VPH Data Editing Software Help

(c) 2014 CKD NIKKI DENSO Co.,LTD.

Ver.4.0


1. 前言

1.1. 为了安全使用

本说明书对“VPH Data Editing Software”的操作步骤、注意事项等进行说明。

为了充分利用VPH系列的性能，请用户在使用前仔细阅读本说明书。

本说明书的正文中将“VPH Data Editing Software”描述为“本软件”。

本说明书中，在标注上将安全注意事项的等级作为“危险”、“注意”来加以区分。

危险

此标注表示，在错误操作时会引起危险的状况，预想有可能导致死亡或重伤的情况。

注意

此标注表示，在错误操作时会引起危险的状况，预想有可能导致中度的障碍或轻伤的情况、以及预想只会发生物理伤害的情况。

附注

表示操作上的注意事项。


1.2. 其他注意事项

·关于本说明书的内容，今后将未经预告而予以变更。

·有关本说明书的内容，我们在制作时以期万全，但是万一用户发现有含糊不清之处或错误等，烦请向本公司联系。

·有关以本软件的运用为理由的损失、利益损失等的请款，本公司概不负责，敬请谅解。

·为了改良产品，今后我们有可能未经预告就变更外观或部分规格。

·Windows为美国Microsoft Corporation（微软公司）在美国以及其他国家的注册商标。

・ENSIS®是株式会社三丰的注册商标。

・LinearScale®是株式会社三丰的注册商标。

・BiSS®是iC-Haus GmbH的注册商标。

・EnDat®是海德汉株式会社的注册商标。


1.3. 软件的使用许可条件

面向ＶＰＨ系列的系统辅助工具

VPH Data Editing Software

使用许可条件

在安装面向ＶＰＨ系列的系统辅助工具之前，请务必阅读以下所载的使用许可条件（下称“使用许可条件”）。在用户安装本软件的时点，即表示用户同意喜开理日机电装株式会社提出的使用许可条件的全部内容。

除了安装本软件的用户外，不管是个人还是法人，使用许可条件适用于使用本软件的全部人员。在不同意使用许可条件的情况下，请勿进行本软件的安装及使用。

１．定义

1.1　“用户”是指喜开理日机电装株式会社进行用户登录，允许本软件的使用并赋予了许可证者。

1.2　“本软件”是指随同使用许可条件一起以从喜开理日机电装株式会社的网站下载的方式进行分发，在用户方的电脑上运行的下述软件。

      品名：面向伺服驱动器ＶＰＨ系列的系统辅助工具

            VPH Data Editing Software

      型号：NPS-VPHDESN3

1.3　“本软件套件”是指包含1.2款所述的本软件和附属于该软件的手册等所有著作物（包含基于ＰＤＦ等格式的电子文件）而成的。

1.4　“许可证”是指喜开理日机电装株式会社按照另行规定的方法及手续对1.1款所述的用户所赋予的、本软件的使用权限。

2．用户登录

2.1　 用户在进行本软件的下载时，必须向喜开理日机电装株式会社进行用户登录申请。用户登录系从喜开理日机电装株式会社的网站通过会员登录或者客户信息的输入而进行，必要项目及其他详情由喜开理日机电装株式会社予以规定。

2.2　 喜开理日机电装株式会社确认2.1款所述的用户登录信息并进行用户登录。另外，喜开理日机电装株式会社除了参照用户登录信息外，还将根据需要参照伺服驱动器ＶＰＨ系列的购买历史等用户信息。

2.3　 用户在用户登录事项发生变更的情况下，应迅速向喜开理日机电装株式会社进行申报。

2.4 　在用户违反使用条件，及因系统被入侵、其他不得已的情由判断为本软件难于进行通常运行的情况下，喜开理日机电装株式会社可能会未经预告就进行用户登录的删除、许可证的停用。

3．使用许可的范围

3.1 喜开理日机电装株式会社以用户同意并遵守本合同所载的使用条件为条件，关于本软件套件，通过赋予许可证允许其使用（包括下载及安装到电脑上）。

3.2　 前款所述的许可的对价为无偿。

3.3　用户不得对第三方允许本软件的再使用。

3.4　只限于备份的目的，用户可制作一份本软件等的复制品。

4．版权的归属

关于本软件套件的版权，归属于喜开理日机电装株式会社。记录有本软件的媒体及其附带的说明书等的转让，并不意味着转让本软件套件的版权。

5．转让、出租、分发等的禁止

不得将本软件套件及许可证用于上述使用目的外，也不得将其转让、分发、出租或发送给第三方用于其他用途。

6．解析和改变等的禁止

用户对于本软件套件的全部或某一部分，不得进行反编译、反向工程、反汇编、修正、改变（也包括源代码的改变）、改编或二次著作的创作。

7．责任的限制

7.1　喜开理日机电装株式会社不保证本软件套件的质量、性能符合用户的使用目的。

7.2 有关本软件套件，即使在与第三方之间发生了关于制造物责任的争议、版权以及其他与知识产权相关的争议的情况下，喜开理日机电装株式会社也不承担责任。

7.3 在喜开理日机电装株式会社改进本软件套件（修正缺陷）时，本公司将根据需要向用户提供修正后的本软件套件及关于修正的信息。但是，有关提供的时期、方法及其他详情，将由喜开理日机电装株式会社斟酌决定。另外，修正后的本软件套件也同样适用此使用许可条件。

7.4　除了7.1款至7.3款的规定外，喜开理日机电装株式会社在法律允许的范围内，对于包括起因于本软件套件的使用或者不可使用或相关的机械、设备、产品、半成品等的损伤、利益损失、数据的丢失、工作的中断或其他财产损害或损失、生命或身体的损害或损失等在内的所有损害等均概不负责。

7.5 在根据7.1款至7.4款及其他本使用许可条款的规定不认可免除喜开理日机电装株式会社责任的情况下，关于用户的所有损害，喜开理日机电装株式会社的赔偿责任总额以本软件套件的出售金额为上限。

8．合同的解除

在用户违反本使用许可条款的任何一项规定的情况下，喜开理日机电装株式会社可立即解除本软件套件的使用许可。这种情况下，用户应承担费用迅速退还本软件套件及其复制品，或者采用无法恢复的方法废弃本软件套件。

9．合同的分离性

不管是在因某种理由而本使用许可条款的某项条款或其部分条款失去效力的情况下，本合同的其他条款或部分依然具有完全的效力。

10．适用法律

本使用许可条款依据日本国法律，应按照日本国法律予以解释。

11．争议的解决

11.1 有关本软件套件及关于本使用许可条件的喜开理日机电装株式会社与用户之间的诉讼，与程序版权相关的诉讼以东京地方法院作为第一审的专属协议管辖法院，其他诉讼则以千叶地方法院为第一审的专属协议管辖法院。

11.2 不管11.1款的规定如何，在用户居住在日本以外国家的情况下，起因于本使用许可条款或者与本使用许可条款相关的、喜开理日机电装株式会社与用户之间发生的任何争议、争论或者意见上的差异，都应按照一般社团法人日本商事仲裁协会的商事仲裁规则，在日本国东京都进行仲裁，谋求最终的解决。


1.4. 概要

本软件是在个人电脑上用来进行VPH驱动器的

① 参数编辑、程序编辑、间接数据编辑

② 示波器数据／频谱数据／频率响应数据的测量和显示

③ 远程运行、运行状态显示

④ 自整定、实时伺服调整、测试运行

⑤ 自诊断／内部控制信息的监控

等的软件。


1.5. 系统环境

要使用本环境，需要具备下列系统构成。

另外，在进行VPH驱动器和数据通信（参数传输等）的情况下，除了个人电脑外还需要USB线缆（市售品）。

※本公司不作为配件提供USB线缆。

个人电脑 | PC/AT兼容机（应可利用USB连接器）
OS | Windows7 32bit/64bit(Ultimate, Professional、Enterprise、Home Premium) Windows 8/8.1 32bit/64bit(无标记、Pro、Enterprise) Windows 10 32bit/64bit(Home、Pro、Enterprise)
CPU | 1GHz以上的处理器
内存 | 1GB(32bit)或2GB(64bit)的RAM以上
硬盘 | 1GB以上
显示器 | XGA（1024×768 pixel）以上
支持的语言 | Japanese, English, Chinese(simplified), Chinese(traditional), Korean
其他 | .NET Framework 4.0以上 Visual C++ 2010 Runtime


1.6. 关于出口管理

在本产品或要提供的技术用途及用户恐会将本产品用于大量杀伤性武器等的开发和常规武器的开发等中的情况下，将会成为《外汇及外国贸易法》中规定的出口限制对象，出口时请严格审核并办理必要的出口手续。


2. 安装／卸载

2.1. 本软件的安装

1) 双击[Setup.exe]文件以开始安装此软件。

2) 尚未安装USB驱动程序时。

显示USB驱动程序的安装画面，请按照画面进行安装。

USB驱动程序的安装方法，请参照“2.3. USB驱动程序的安装”。

3) 尚未安装.NET Framework4.0时。

显示如下画面。请单击[同意]按钮。

4) 进行.Net Framework4.0的安装。

安装完成时，本对话框将会自动关闭。

5) 尚未安装VisualC++ 2010 Runtime程序库时。

显示如下画面。请单击[安装]按钮，按照如下所示方式进行安装。

6) 对[同意]复选框进行勾选，单击[安装]按钮。

7) VisualC++ 2010 Runtime程序库的安装完成时，会显示如下画面。

单击[完成]按钮，进入本软件的安装。

8) 已安装必要组件时。

显示如下画面。单击[下一步]按钮。

9) 同意软件的使用许可时。

请选择[同意软件使用许可合同书]，单击[下一步]按钮。

[不同意]时将无法进行本软件的安装。

10) 变更安装目的地目录时。

请单击[变更]按钮进行变更。接着请单击[下一步]按钮。

11) 安装的确认。

在按照此前所输入的内容进行安装的情况下，请单击[安装]按钮。

12) 显示安装程序的执行经过。

13) 安装完成后，会显示如下画面。

请单击[结束]按钮。


2.2. 本软件的卸载

1) 请单击Windows任务条的[开始]－[控制面板]－[程序和功能]，显示[程序和功能]视窗。

2) 请选择列表框内的[VPH Data Editing Software]，单击[卸载]按钮。

3) 请单击[是]按钮。

4) 显示如下画面，卸载完成。


2.3. USB驱动程序的安装

双击[USB_Driver]文件夹。

用户所使用的PC的OS为32bit时请执行dpinst32.exe，为64bit时请执行dpinst64.exe，并按照以下的向导进行安装。

1) 请从开始画面单击[下一步(N)]。

2) 在以下画面单击[安装(I)]。

3) 开始USB驱动程序的安装。

4) 显示如下画面，USB驱动程序的安装完成。

5) 将VPH驱动器连接到USB端口。

显示以下的弹出窗口，软件的安装完成。


2.4. USB驱动程序的卸载

1) 请单击Windows任务条的[开始]－[控制面板]－[程序和功能]，显示[程序和功能]视窗。

2) 请选择列表框内的[Windows 驱动程序包 - CKD NIKKI DENSO CO.,LTD.(WinUSB)CKD NIKKI DENSO VPH USB Device]，单击[卸载和变更]按钮。

3) 请单击[是]按钮。


3. 功能和操作

3.1. 本软件的启动

要启动本软件，请从Windows 的任务条选择[开始]→[程序(P)]→[NikkiDenso]→[VPH Data Editing Software]→[Nikki VPH DES]，或者从桌面上所创建的[Nikki VPH DES]快捷键执行。

在显示如下标徽后，显示驱动器、马达选择视窗。


3.2. 驱动器马达选择视窗

选择要使用的驱动器马达。


3.2.1. 通过从VPH驱动器选择加载驱动器信息来选择驱动器马达

1) 在本软件与VPH驱动器已相互连接且驱动器的电源已接通的情况下，单击[从驱动器获取设定]按钮，读出登录在驱动器内的信息。

※在画面启动时VPH驱动器已被连接的情况下，自动读出登录在驱动器内的信息

2) 基于已读出的信息，在驱动器信息、马达信息已被选择的状态下在画面上显示信息。

3) 单击[决定]按钮来向主工具条过渡。

本软件与VPH驱动器无法进行USB通信时

请确认所显示的信息内容。

连接有无法在本软件上使用的VPH驱动器时

显示有此信息的情况下，需要更新为与所连接的VPH驱动器相对应的软件。

请向本公司营业担当联系。

VPH驱动器中设定了无法在本软件上使用的马达信息时

请确认马达栏中是否存在要使用的马达。

在找不到希望使用的马达的情况下，需要进行软件的更新。

请向本公司营业担当联系。


3.2.2. 通过手动操作来选择驱动器马达

在本软件与VPH驱动器无法进行USB通信的情况下，直接选择要使用的VPH驱动器和马达。

1) 驱动器的选择

自上而下按照顺序选择驱动器栏的组合框。

2) 马达的选择

自上而下按照顺序选择马达栏的组合框。

根据产品分类，有的情况下要求输入值。

3) 单击[决定]按钮来向主工具条过渡。


3.2.3. 通过拖放文件来选择驱动器马达

通过将文件拖放至本画面，自动地进行驱动器马达选择，并打开参数文件。

※可拖放的文件参照[6.2. 关于文件拖放]

1) 拖曳希望打开的参数文件，将其放至本画面上。

2) 本画面关闭，显示主工具条。

3) 显示已被拖放的参数文件。


3.2.4. 驱动器马达选择的信息

在从驱动器马达选择画面向主工具条过渡之前，有的情况下会显示以下所示的信息。

这种情况下，请按照显示的信息进行操作。

驱动器的选择相匹配，但VPH驱动器内的马达信息尚未设定时

驱动器的选择相匹配，但马达选择与VPH驱动器内的信息不同时

※在变更了马达的情况下必然会显示

需要再启动的参数已被变更时

所选择的驱动器选择、与VPH驱动器的信息不同时

没有找到完全一致的驱动器信息时

在向驱动器发送了马达编码器相关参数时，正在进行网络通信时

试图执行驱动器的自动再启动时，正在进行网络通信时

已将编码器类型变更为BiSS编码器时

已将编码器类型变更为海德汉ABS编码器时


3.2.5. 显示语言切換

切换本软件的显示语言。

1) 变更语言选择组合框(Display language choice)。

2) 变更语言的情况下，显示再启动的确认信息。

3) 若单击“确定”，本软件就会以所选择的语言启动。


3.3. 主工具条视窗

在本软件的主画面上启动各功能的画面。

菜单条

显示选择本软件功能的菜单。

主工具条

显示选择本软件功能的按钮。

状态条

显示驱动器的USB连接状态、参数的反映状态、指令单位、设定单位、驱动器型号、马达型号。

① USB连接状态：

可与驱动器进行通信。

无法与驱动器进行通信。

附注

在连接了与设定不同的驱动器的情况下，会显示以下信息。

请返回驱动器、马达选择画面，进行再设定。

② 参数的反映状态：

无显示 | 参数值为最新的状态。
restart | 为了反映参数值，需要再接通电源。 若予以单击，就会进行电源的再接通。
reset | 为了反映参数值，需要进行RST信号的输入。 若予以单击，就会进行RST信号的输入。

③ 警报、警告状态：

无显示 | 没有发生警报、警告。
 | 警报发生时显示。
 | 警告发生时显示。

④ 网络通信状态：

无显示 | 系网络未使用的驱动器。
 | 驱动器处于维护模式。 若予以单击，就会显示功能模式切换画面。
 | 驱动器处于维护模式。 因MODE开关处于ON，或MTON信号处于ON的状态而无法向通信模式切换。
 | 驱动器处于通信模式。 若予以单击，就会显示功能模式切换画面。
 | 驱动器处于通信模式。 因正在进行网络连接而无法向维护模式切换。

⑤ 单位：

显示选择中的位置单位和位置小数单位。

⑥ 驱动器型号：

显示选择中的驱动器型号。

⑦ 马达型号：

显示选择中的马达型号。

返回驱动器、马达选择视窗

在本软件启动时或任意时点可执行驱动器马达选择。

从菜单条选择

[文件(F)]→[驱动器、马达选择(D)]

就会关闭现在打开中的所有画面。

附注

在存在编辑中途的画面的情况下，确认是否关闭画面。

在关闭所有画面的情况下，返回驱动器马达选择。

在残留有没有关闭的画面的情况下，不会返回驱动器马达选择。

正在执行下述功能的情况下，无法返回驱动器马达选择。

参数、程序、间接数据、成批数据收发中

示波器测量、频谱的测量中

频率响应、自诊断、测试运行、自整定执行中


3.3.1. 电源再接通、RST信号输入

1) 电源再接通

若单击状态条的电源再接通的图标 restart ，就会显示如下所示的确认信息。

再启动驱动器时请单击[确定]，停止驱动器时请单击[取消]。

附注

MTON信号处于ON的情况下，会显示以下信息。

请在伺服关后再次单击电源再接通的图标 restart 。

驱动器正在进行网络通信的情况下，显示以下信息。

请手动进行电源再接通。

2) RST信号输入

若单击状态条的RST信号输入的图标 reset ，就会显示如下所示的确认信息。

输入RST信号时请单击[确定]，停止输入时请单击[取消]。

附注

MTON信号处于ON的情况下，会显示以下信息。

请在伺服关后单击RST信号输入的图标 reset 。

驱动器正在进行网络通信的情况下，显示以下信息。

请手动进行电源再接通。


3.3.2. 功能模式切换

若单击状态条的网络通信状态的图标( [image] 或 [image] )，就会显示功能模式切换视窗。

通信模式时

维护模式时

附注

MODE开关处于ON的情况下，会显示以下信息。

MTON信号处于ON的情况下，会显示以下信息。

请在伺服关后再次单击图标。

驱动器正在进行网络通信的情况下，显示以下信息。

请在切换与网络的连接后再次单击图标。

1)输入所显示的切换代码，按下[Enter]键。

2)由此便可单击功能模式切换按钮。

通信模式时

维护模式时

3)若单击功能模式切换按钮，就会显示如下所示的确认信息。

通信模式时

维护模式时

切换模式时请单击[确定]，停止切换时请单击[取消]。

附注

MTON信号处于ON的情况下，会显示以下信息。

请在伺服关后单击[功能模式切换]按钮。

驱动器正在进行网络通信的情况下，显示以下信息。

请在切换与网络的连接后再次单击[功能模式切换]按钮。

附注

也可通过拖放与本画面对应的文件来打开文件。

※对应的文件请参照[6.2. 关于文件拖放]


3.4. 本软件的结束

通过按驱动器马达选择画面的[×]按钮、主工具条的菜单条选择或[×]按钮来结束本软件。

① 驱动器马达选择画面的[×]按钮

1) 单击驱动器马达选择画面的右上的[×]按钮。

2) 单击结束确认信息的[确定]按钮。

② 主工具条的菜单

1) 从主工具条的菜单条对

[文件(F)]→[结束(X)]

予以单击。

2) 单击结束确认信息的[确定]按钮。

③ 主工具条的[×]按钮

1) 单击主工具条右上的[×]按钮。

2) 单击结束确认信息的[确定]按钮。


3.5. 参数编辑视窗

进行VPH驱动器用的参数编辑。


3.5.1. 视窗的显示

从菜单条选择[文件(F)]→[新建(N)]→[参数(P)]

或者

[文件(F)]→[打开(O)]→[参数(P)]

或者

[文件(F)]→[参数文件变换]

或选择主工具条的[数据编辑]标签→[参数]→[参数菜单选择]


3.5.2. 参数的编辑

① 参数的直接编辑

1) 通过鼠标或键盘操作来选择参数。

2) 通过用鼠标单击所选择的参数，按下 [Enter]、[F2]键来将参数置于编辑状态。

·数值输入项目时：直接从键盘输入数据。

·选择项目时：从列表选择项目。

3) 通过脱离聚焦，按下[Enter]、[Tab]、[F2]键来确定参数。

※无法对灰色显示的参数进行编辑。

② 参数的复制和粘贴

参数编辑视窗间的复制／粘贴

系在显示有多个参数视窗时将特定范围的参数数据复制到其他视窗的便利的功能。

1) 参数数据的复制

在复制参数数据的情况下，在按键盘的[Shift]＋[↑]、[Shift]＋[↓]来指定复制范围，或用鼠标拖曳后，右击鼠标选择[复制]，或用Ctrl＋C进行复制。

2) 参数数据的粘贴

用光标指定参数数据的粘贴目的地，通过右击鼠标来选择[粘贴] ，或用Ctrl＋V进行粘贴。


3.5.3. 参数名称的检索

若在选择了参数的状态下按下[Ｃｔｒｌ] ＋[Ｆ]，

就会显示参数名称检索画面。

①若输入检索字符串，单击[下一步]或[前一步]按钮，

  就会选择与检索字符串一致的参数。

[下一步]按钮的动作，即使按下[Ｅｎｔｅｒ]或[Ｆ３]键也会进行同样的动作。

[前一步]按钮的动作，即使按下[Ｓｈｉｆｔ] ＋ [Ｆ３]键也会进行同样的动作。

附注

在找不到一致的参数的情况下，会显示以下信息。

②若单击[关闭]按钮，就会结束检索画面。

  即使按下[ＥＳＣ]或[×]键也会进行同样的动作。


3.5.4. 单位、电子齿轮设定

设定与单位、电子齿轮相关的参数。

3.5.4.1. 视窗的显示

若从参数编辑视窗

选择[单位、电子齿轮设定]

  或者

    双击对象参数，

就会显示本视窗。

附注

①在已设定[自动设定]的状态下打开本视窗时，有的情况下会显示以下信息。

在[自动设定]中无法选择在参数编辑视窗中设定的位置单位的情况下会显示本信息。

②在本视窗中将“设定模式”变更为[自动设定]时，有的情况下会显示以下信息。

在[自动设定]中无法选择现在所选择的位置单位的情况下会显示本信息。

[确定]：将位置单位变更为适当的值，向自动设定过渡。

[取消]：取消设定模式的变更。

附注

③ 在本视窗中将“设定模式”变更为[自动设定]时，有的情况下会显示以下信息。

在因现在所选择的位置小数单位不正确而无法正常进行机械移动量、旋转体位置范围的自动设定的情况下会显示本信息。

将位置小数单位变更为所显示的值，并向自动设定过渡。

④在本视窗中将“设定模式”变更为[自动设定]时，有的情况下会显示以下信息。

在现在已被设定的、机械移动量、电子齿轮比分子、电子齿轮比分母、旋转体位置范围、旋转体位置范围符号切换位置中设定了无法自动设定的值的情况下会显示本信息。

[确定]：对机械移动量、电子齿轮比分子、电子齿轮比分母、旋转体位置范围、旋转体位置范围符号切换位置设定可自动设定的值。

[取消]：中断自动设定。

3.5.4.2. 单位、电子齿轮的编辑

设定模式的选择

若打开本视窗，就可从[自动设定][手动设定]中选择设定模式。

自动设定

根据所选择的位置单位和位置小数单位，自动计算机械移动量／电子齿轮比分子／电子齿轮比分母／旋转体位置范围／旋转体位置范围符号切换位置并进行设定。

手动设定

在选择了位置单位和位置小数单位的基础上，直接输入机械移动量／电子齿轮比分子／电子齿轮比分母／旋转体位置范围／旋转体位置范围符号切换位置并进行设定。

① 已将“设定模式”设定为[自动设定]时

本视窗按照下图所示方式显示。

①

③

②

在已将“设定模式”设定为[自动设定]的情况下，可以编辑以下项目。

① 位置单位

② 位置小数单位

③ 旋转体位置范围

通过①～③的选择，自动计算机械移动量／电子齿轮比分子／电子齿轮比分母／旋转体位置范围／旋转体位置范围符号切换位置，并进行设定。

各项目的设定方法请参照以下内容。

① 位置单位选择

选择位置单位。

可选择的位置单位根据本软件启动时设定的马达产品分类(参照3.2. 驱动器马达选择视窗)而有所不同。

马达产品类别 | 可选择的位置单位
τDISC | deg、pulse、kpulse
τ直线马达 | m、mm、um、inch、pulse、kpulse

② 位置小数单位选择

选择位置小数单位。

附注

由于本动作，有的情况下会显示以下信息。

在因对①中所选择的位置单位选择了不正确的位置小数单位而无法正常地自动设定机械移动量、旋转体位置范围的情况下会显示本信息。

③ 旋转体位置范围设定

进行旋转体位置范围／旋转体位置范围符号切换位置的设定。

※马达产品类别为“τ直线马达”的情况下，无法设定本参数。

若予以勾选，就会将旋转体位置范围／旋转体位置范围符号切换位置自动地设定为适当的值。

若去掉勾选，就会将旋转体位置范围／旋转体位置范围符号切换位置设定为0。

附注

由于本动作，有的情况下会显示以下信息。

在因位置单位和位置小数单位的组合不正确而无法正常地进行旋转体位置范围的自动设定的情况下会显示本信息。

②已将“设定模式”设定为[手动设定]时

本视窗按照下图所示方式显示。

③

④

①

②

在已将“设定模式”设定为[手动设定]的情况下，可编辑以下项目。

① 位置单位设定

② 位置小数单位设定

③ 机械移动量设定

④ 电子齿轮设定

⑤ 旋转体位置范围

各项目的设定方法请参照以下内容。

① 位置单位选择

选择位置单位。

② 位置小数单位选择

选择位置小数单位。

③ 机械移动量设定

直接输入机械移动量。

④ 电子齿轮设定

直接输入电子齿轮比分子、电子齿轮比分母。

⑤ 旋转体位置范围设定

直接输入旋转体位置范围／旋转体位置范围符号切换位置。

※马达产品类别为“τ直线马达”的情况下，无法设定本参数。

3.5.4.3. 参数的设定

通过单击本视窗的[设定]，本视窗将被关闭，本视窗中编辑的参数将被在参数编辑视窗中设定。

在位置单位和位置小数单位已被变更的情况下，会显示以下信息。

注意

在变更了位置单位和位置小数单位的情况下，请务必在使马达动作之前修改以下设定值。

①速度和移动量的参数值

②程序数据的设定值

③间接数据的设定值

在没有修改设定值就使得马达动作的情况下，有可能导致预料外的动作，请予注意。

3.5.4.4. 视窗关闭

通过单击本视窗的[关闭]来关闭本视窗。

在参数变更后没有单击[设定]就单击[关闭]的情况下，会显示以下信息。

若单击[是]，不应用本视窗中变更的参数就关闭本视窗。

若单击[否]，就会停止关闭。


3.5.5. 组的选择

若单击参数组选择按钮，就可以组为单位进行参数的编辑。如下视窗为选择了[指令设定]组时的显示内容。

在选择了[全部项目显示]时，若单击向指定参数的跳转开关（组合框）设定参数编号，光标就会向所指定的参数移动。

若选择[P100]，画面上就会显示P100的内容，光标移动。


3.5.6. 参数的写入

1) 在将参数编辑视窗上的参数写入驱动器的情况下，单击[写入驱动器]按钮。

2) 显示是否要写入的确认信息，在进行写入时单击[确定]按钮，在停止写入时单击[取消]按钮。

附注

自Version 2.2.0起曾由本软件保持的FB滤波器设定方法选择的值将会被保持在驱动器中，并在参数写入时检查FB滤波器设定方法选择的设定值。

进行写入的参数与驱动器内的FB滤波器设定方法选择不同时，会显示以下信息。

基本上选择“是”，请根据需要在“实时伺服调整画面”上进行FB滤波器设定方法选择的再设定。

此外，在为进行再调整而执行了自整定时也一样，FB滤波器设定方法选择将被再设定。

设定变更后通过进行参数的读出保存在文件中，就可保持FB滤波器设定方法选择的值，下次参数写入时保存的值将被设定在驱动器中。

但是，在写入由Version 2.1.0以前的VPH Data Editing Software所保存的文件时，由于

FB滤波器设定方法选择的值尚未被保存到文件中，因而本信息不予显示，FB滤波器设定方法选择值也不会被设定在驱动器中。

有关自Version 4.0.0起绝对位置补偿数据的设定，在“绝对位置补偿 补偿动作指定”为“无效”时，以下情况下会在参数写入前显示信息。

・编码器类型为“S-ABS2”、“S-ABS3”、“S-ABS4”的任何一种类型，编码器中已登录有绝对位置补偿数据的情形

・编码器类型为“S-ABS2”、“S-ABS3”、“S-ABS4”以外的类型，VPH驱动器中已登录有绝对位置补偿数据的情形

若单击“是”，就会设定为“补偿有效”并发送信息。

单击“否”时，则会在“无效”的状态下发送信息。

测试运行参数与驱动器内的参数不同时，在参数写入前显示以下信息。

若单击“OK”，就会以参数文件的值盖写测试运行的动作参数。

若单击“取消”，写入就会被取消。

3) 进度条显示一直到达右端时写入结束。

4) 写入时，将会向驱动器写入标题上所显示的文件名。

5) 在发送了需要再接通电源或输入RST信号的参数的情况下，会显示如下所示的信息。

发送了需要再接通电源的参数时

发送了需要输入RST信号的参数时

在再接通电源或输入RST信号时请单击[确定]，在停止再接通电源或输入RST信号时请单击[取消]。

附注 | 在发送了需要再接通电源的参数时，MTON信号处于ON的情况下会显示以下信息。 请在伺服关后手动进行电源的再接通，或从主工具条进行电源的再接通。
 | 在试图执行驱动器的电源再接通时，MTON信号处于ON的情况下会显示以下信息。 请在伺服关后手动进行电源的再接通，或从主工具条进行电源的再接通。
 | 在发送了需要再接通电源的参数时，正在进行网络通信的情况下会显示以下信息。 请在切断与网络的连接后手动进行电源的再接通，或从主工具条进行电源的再接通。
 | 在试图执行驱动器的电源再接通时，正在进行网络通信的情况下会显示以下信息。 请在切断与网络的连接后手动进行电源的再接通，或从主工具条进行电源的再接通。
 | 在发送了需要输入RST信号的参数时，MTON信号处于ON的情况下会显示以下信息。 请在伺服关后手动进行电源的再接通，或从主工具条进行RST信号的输入。
 | 在试图执行RST信号的输入时，MTON信号处于ON的情况下会显示以下信息。 请在伺服关后手动进行电源的再接通，或从主工具条进行RST信号的输入。
 | 在发送了需要输入RST信号的参数时，正在进行网络通信的情况下会显示以下信息。 请在切断与网络的连接后手动进行电源的再接通，或从主工具条进行RST信号的输入。
 | 在试图执行RST信号的输入时，正在进行网络通信的情况下会显示以下信息。 请在切断与网络的连接后手动进行电源的再接通，或从主工具条进行RST信号的输入。


3.5.7. 参数的读出

1) 在读出驱动器内的参数的情况下，单击[从驱动器读出]按钮。

2) 显示是否需要读出的确认信息。进行读出时单击[确定]按钮，停止读出时单击[取消]按钮。

3) 进度条显示一直到达右端时读出结束。

4) 读出时，会在画面上显示已被写入驱动器的参数名。

所显示的名称，将成为保存时的初期文件名。

5) 参数读出中，有的情况下会显示以下所示的信息。

在显示有本信息的情况下，有可能驱动器中所设定的参数超过了现在利用本软件正在进行编辑的参数设定范围。

① 若单击[是]，就会继续读出。

“P008(1)=4/P008(2)=3/P028(3-1)=101/P210=-1”系驱动器中所设定的范围外的参数值。()内表示参数的位数范围。

但是，范围外的参数将会强制地设定初期值。

在显示有本信息的情况下，可能是以下原因所致。

内容 | 对策
所使用的参数文件用旧版本制作 | 请用新建参数再次进行参数的读出
驱动器的版本与本软件的版本不一致(本软件的版本为旧版本) | 本软件需要进行版本升级。 请向本公司营业担当联系。
驱动器中所设定的参数值处于范围外(由上位的机器将参数改写为范围外的值等) | 请修正设定了范围外的参数值的部位。

② 若单击[否]，就会停止读出。

附注

在因处于参数范围外而停止了参数读出的情况下，直至成为范围外的参数之前一个参数，读出已完成。


3.5.8. 参数的比较

若单击参数编辑画面的[比较]按钮，就会打开参数的数据比较画面。

比较的种类包括[与初期值比较]、[与驱动器内比较]、[与文件比较]、[对ROM和RAM进行比较]。

若执行比较，就会显示差异点的件数、差异点的一览。

比较结果：差异点的确认

无差异点

有差异点

比较结果：差异的一览

差异的一览自左向右按照参数编号、参数的项目名、比较源设定值、比较目的地设定值、比较源单位的顺序来显示。

附注

对比较目的地的值设定了范围外的值的情况下，显示用红色字符‘()’圈起来的值。

与初期值比较

1) 对参数初期值和现在编辑中的内容进行比较的情况下

单击[比较]→[与初期值比较]按钮。

2) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 参照P161：位置小数单位选择的值的参数为比较对象时

比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了被作为初期值保存的位置小数单位的值。

与驱动器内比较

1) 对驱动器内的参数和现在编辑中的内容进行比较的情况下

单击[比较]→[与驱动器内比较]按钮。

2) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 参照P161：位置小数单位选择的值的参数为比较对象时

比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了驱动器内所设定的位置小数单位的值。

与文件比较

1) 对指定文件和现在编辑中的内容进行比较的情况下

单击[比较]→[与文件比较]按钮。

2) 显示[打开文件]视窗。

3) 选择要进行比较的文件，单击[打开(O)]按钮。

4) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 参照P161：位置小数单位选择的值的参数为比较对象时

比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了保存在文件中的位置小数单位的值。

对ROM和RAM进行比较

1)对驱动器内的RAM区域和ROM区域的内容进行比较的情况下

单击[比较]→[对ROM和RAM进行比较]按钮。

2)比较结果以“比较结果：差异的一览”格式予以显示。

※ 参照P161：位置小数单位选择的值的参数为比较对象时

比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了在执行比较时所设定的位置小数单位的值。

※关于ROM区域和RAM区域

ROM区域是即使切断驱动器的电源数据也不会丢失的区域。可改写的次数限制为10亿次。

RAM区域是一旦切断驱动器的电源数据就会丢失的区域。驱动器的电源接通时或ROM区域的数据被改写时，ROM区域的数据将被复制到RAM区域。驱动器主要使用本区域的数据而动作。改写次数没有限制。

比较结果的输出

① 向文件输出

若单击[CSV输出]按钮，就可向CSV文件输出差异点。

② 打印

若在存在差异点的状态下单击[打印]按钮，就可打印差异点。


3.5.9. 打开文件

打开已被保存的参数时

① 从主工具条打开

1) 单击主工具条的[文件(F)]→[打开]→[参数]

2) 显示打开文件的对话框，选择希望打开的参数文件，单击[打开]按钮。

② 从参数编辑画面打开

1) 单击参数编辑视窗上的[打开]。

2) 显示打开文件的对话框，选择希望打开的参数文件，单击[打开]按钮。

附注

可从文件的种类进行选择的扩展名因驱动器、马达而有所差异。

※详情请参照[6.1. 文件扩展名一览]

通过将参数文件拖放至本画面，也可打开参数文件。

※对应的文件请参照[6.2. 关于文件拖放]


3.5.10. 保存到文件中

在将参数编辑视窗上的参数保存到文件中的情况下，可选择盖写保存在相同文件名上，或者指定新的文件名予以保存。

① 盖写保存在相同文件名的情况下，从菜单条单击
[盖写保存]按钮。

② 指定新的文件名予以保存的情况下，从菜单条单击[另存为]按钮。

附注

自Version 2.2.0起曾由本软件保持的FB滤波器设定方法选择的值将会被保持在驱动器中，也会被保存在参数中。

将被保存的FB滤波器设定方法选择值为从驱动器进行读出时点的值。


3.5.11. 打印

打印参数编辑视窗上的参数的情况下，从菜单条单击[打印]按钮。

① 参数已处于选择状态的情况下，会显示以下信息。

1) 指定打印范围。

① 打印全部范围时

1) 选择[全部打印]。

2) 单击[确定]按钮。

② 指定打印范围进行打印时

1) 选择[打印选择范围内]。

2) 单击[确定]按钮。

2) 显示打印视窗。

① 进行打印的情况下，设定各项目，单击[打印]按钮。

② 中断打印的情况下，单击[取消]按钮。

② 参数已处于选择状态的情况下，打印全部内容。


3.5.12. 视窗关闭

关闭所显示的参数编辑视窗的情况下，单击[关闭]按钮，或单击[×]按钮。

若在已变更参数的状态下进行上述处理，就会显示如下所示的确认信息。

关闭视窗时请单击[确定]，停止处理时请单击[取消]。

※在对参数进行[盖写保存]或[另存为]的情况下，不会显示确认信息


3.6. 间接数据编辑视窗

进行间接数据的编辑。


3.6.1. 视窗的显示

从菜单条选择

[文件(F)]→[新建(N)]→[间接数据(I)]

或者

[文件(F)]→[打开文件(O)]→[间接数据(I)]

或选择主工具条的[数据编辑]标签→[间接数据]→[间接数据菜单选择]，就会显示本视窗。


3.6.2. 间接数据的编辑

① 间接数据的直接编辑

1) 通过鼠标或键盘操作来选择间接数据。

2) 通过用鼠标单击所选择的间接数据，按下[Enter]、[F2]键来将间接数据置于编辑状态。

·数值输入时：从键盘直接输入。

·选择项目时：从列表选择项目。

3) 通过脱离聚焦，按下[Enter]、[Tab]、[F2]键来确定间接数据。

② 间接数据的复制和粘贴

间接数据编辑视窗间的复制／粘贴
系在显示有多个间接数据编辑视窗时将特定范围的间接数据复制到其他视窗的便利的功能。

1) 间接数据的复制

在按键盘的[Shift]＋[↑]、[Shift]＋[↓]来指定复制范围，或用鼠标拖曳后，右击鼠标选择[复制]，或用Ctrl＋C进行复制。

2) 间接数据的粘贴

用光标指定间接数据的粘贴目的地，通过右击鼠标来选择[粘贴] ，或用Ctrl＋V进行粘贴。


3.6.3. 间接数据的写入

1) 在将间接数据编辑视窗上的间接数据写入驱动器的情况下，单击[写入驱动器]按钮。

2) 显示是否要写入的确认信息，进行写入时单击[确定]按钮，停止写入时单击[取消]按钮。

3) 进度条显示一直到达右端时写入结束。

4) 写入时，将会向驱动器写入标题上所显示的文件名。

附注

在间接数据编辑画面上所设定的位置单位、位置小数单位与驱动器中所设定的位置单位、位置小数单位不一致的情况下，无法发送间接数据。

请重新设定间接数据编辑画面上所设定的位置单位、位置小数单位，或者设定驱动器中所设定的位置单位、位置小数单位。

间接数据编辑画面上所设定的位置单位、位置小数单位，通过按下单位变换按钮来进行变换。

将间接数据编辑画面上所设定的位置单位、位置小数单位变换为驱动器中所设定的单位。


3.6.4. 间接数据的读出

1) 在读出驱动器内的参数的情况下，单击[从驱动器读出]按钮。

2) 显示是否要读出的确认信息，进行读出时单击[确定]按钮，停止读出时单击[取消]按钮。

3) 进度条显示一直到达右端时读出结束。

4) 读出时，会在画面上显示已被写入驱动器的间接数据名。

所显示的名称，将成为保存时的初期文件名。

附注

功能类别在本软件与驱动器上不同的情况下，无法收发间接数据。请重新设定本软件的驱动器马达选择。


3.6.5. 间接数据的比较

若单击间接数据编辑视窗的[比较]按钮，就会打开间接数据的数据比较画面。

比较的种类包括[与初期值比较]、[与驱动器内比较]、[与文件比较]。

若执行比较，就会显示差异点的件数、差异点的一览。

比较结果：差异点的确认

无差异点

有差异点

比较结果：差异点的一览

差异点的一览自左向右按照间接数据编号、间接数据的项目名、比较源设定值、比较目的地设定值、比较源单位、比较源注解的顺序来显示。

附注

对比较目的地的值设定了范围外的值的情况下，显示用红色字符‘()’圈起来的值。

与初期值比较

1) 对间接数据初期值和现在编辑中的内容进行比较的情况下

单击[比较]→[与初期值比较]按钮。

2) 比较结果以“比较结果：差异点的一览”格式予以显示。

※ 与比较源设定值、比较目的地设定值一起，显示反映了执行比较时所设定的位置小数单位的值。

与驱动器内比较

1) 对驱动器内的间接数据和现在编辑中的内容进行比较的情况下

单击[比较]→[与驱动器内比较]按钮。

2) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了驱动器内所设定的位置小数单位的值。

与文件比较

1) 对指定文件和现在编辑中的内容进行比较的情况下

单击[比较]→[与文件比较]按钮。

2) 显示[打开文件]视窗。

3) 选择要进行比较的文件，单击[打开(O)]按钮。

4) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了保存在文件中的位置小数单位的值。

比较结果的输出

① 向文件输出

若单击[CSV输出]按钮，就可向CSV文件输出差异点。

② 打印

若在存在差异点的状态下单击[打印]按钮，就可打印差异点。


3.6.6. 打开文件

① 从主工具条打开

1) 单击主工具条的[文件(F)]→[打开]→[间接数据]

2) 显示打开文件的对话框，选择希望打开的间接数据文件，单击[打开]按钮。

② 从间接数据编辑画面打开

1) 单击间接数据编辑视窗上的[打开]

2) 显示打开文件的对话框，选择希望打开的间接数据文件，单击[打开]按钮。

附注

① 可从文件的种类进行选择的扩展名因驱动器而有所差异。

※详情请参照[6.1. 文件扩展名一览]

② 通过将间接数据文件拖放至本画面，也可打开间接数据文件。

※对应的文件请参照[6.2. 关于文件拖放]


3.6.7. 保存到文件中

在将间接数据编辑视窗上的间接数据保存到文件中的情况下，可选择盖写保存在相同文件名上，或者指定新的文件名予以保存。

① 盖写保存在相同文件名的情况下，从菜单条单击[盖写保存]按钮。

② 指定新的文件名予以保存的情况下，从菜单条单击[另存为] 按钮。


3.6.8. 打印

打印间接数据编辑视窗上的参数的情况下，从菜单条单击
[打印]按钮。

① 间接数据已处于选择状态的情况下，会显示以下信息。

1) 指定打印范围。

① 打印全部范围时

1) 选择[全部打印]。

2) 单击[确定]按钮。

②指定打印范围进行打印时

1) 选择[打印选择范围内]。

2) 单击[确定]按钮。

2) 显示打印视窗。

① 进行打印的情况下，选择各项目，单击[打印]按钮。

② 中断打印的情况下，单击[取消]按钮。

② 间接数据已处于选择状态的情况下，打印全部内容。


3.6.9. 视窗关闭

关闭所显示的间接数据编辑视窗的情况下，单击[关闭]按钮，或单击[×]按钮。

若在已变更间接数据的状态下进行上述处理，就会显示如下所示的确认信息。

关闭视窗时请单击[确定]，停止处理时请单击[取消]。

※在对间接数据进行[盖写保存]或[另存为]的情况下，不会显示确认信息


3.7. 程序编辑视窗

进行VPH驱动器用的程序编辑。


3.7.1. 视窗的显示

从菜单条选择

[文件(F)]→[新建(N)]→[程序(R)]

或者

[文件(F)]→[打开文件(O)]→[程序(R)]

或选择主工具条的[数据编辑]标签→[程序]→[程序菜单选择]，就会显示本视窗。


3.7.2. 程序的编辑

① 程序的直接编辑

1) 指定编辑项目时，用鼠标单击所需的程序步骤。

2) 输入程序的情况下，按照如下顺序输入数据。

·通过单击编辑项目的CMD，显示▼。

·通过单击▼，就可选择项目。

·在选择CMD后，选择编辑部位的组合框，或从键盘直接输入数据。

另外，后续的输入项目将会根据CMD的内容而有所不同。（请按照画面的指示进行操作。）

② 程序的复制和粘贴

程序编辑视窗间的复制／粘贴
系显示有多个程序编辑视窗时将特定范围的程序数据复制到其他视窗的便利功能。

1) 程序数据的复制

在复制程序数据的情况下，在按键盘的[Shift]＋[↑]、[Shift]＋[↓]来指定复制范围，或用鼠标拖曳后，右击鼠标选择[复制]，或用Ctrl＋C进行复制。

2) 程序数据的粘贴

用光标指定程序数据的粘贴目的地，通过右击鼠标来选择[粘贴] ，或用Ctrl＋V进行粘贴。

程序步骤按照如下所示方式来粘贴。

③ 行插入

1) 对任意行设定光标。

2) 若单击[行插入]按钮，就会按如下所示方式插入新的行并登录[NOP]命令。

从右击鼠标而显示的、上下文菜单内同样可进行行插入。

最终行为[NOP]命令以外的情况下，显示如下所示的信息而使得行插入无法进行。

在进行行插入的情况下，请将最终行设定为[NOP]以外的命令。

④ 行删除

1) 对任意行设定光标。

2) 若单击[行删除]按钮，就会按如下所示方式删除所指定的行，使得后续的步骤向前靠。

若进行行删除，最终行中将被追加上[NOP]命令。

从右击鼠标而显示的、上下文菜单内同样可进行行删除。


3.7.3. 程序的写入

1) 在将程序编辑视窗上的程序写入驱动器的情况下，单击[写入驱动器]按钮。

2) 显示是否要写入的确认信息，进行写入时单击[确定]按钮，停止写入时单击[取消]按钮。若单击[确定]按钮，就会在进度条上显示写入处理的执行经过。

3) 进度条显示一直到达右端时写入结束。

4) 写入时，将会向驱动器写入标题上所显示的文件名。

附注

在程序编辑画面上所设定的位置单位、位置小数单位与驱动器中所设定的位置单位、位置小数单位不一致的情况下，无法发送程序。

请重新设定程序编辑画面上所设定的位置单位、位置小数单位，或者设定驱动器中所设定的位置单位、位置小数单位。

程序编辑画面上所设定的位置单位、位置小数单位，通过按下单位变换按钮来进行变换。

将程序编辑画面上设定的位置单位、位置小数单位变换为驱动器中所设定的单位。

注意

若在程序运行中写入程序，就会从运行中途切换至新程序数据下的运行，请予注意。

通常，请在结束运行中的程序后写入程序。


3.7.4. 程序的读出

1) 在读出驱动器内的程序的情况下，单击[从驱动器读出]按钮。

2) 显示是否要读出的确认信息，进行读出时单击[确定]按钮，停止读出时单击[取消]按钮。若单击[确定]按钮，就会在进度条上显示读出处理的执行经过。

3) 进度条显示一直到达右端时读出结束。

  4) 读出时，会在画面上显示已被写入驱动器的程序名。

所显示的名称，将成为保存时的初期文件名。


3.7.5. 程序数据的比较

若单击程序编辑画面的[比较]按钮，就会打开程序的数据比较画面。

比较的种类包括[与初期值比较]、[与驱动器内比较]、[与文件比较]。

若执行比较，就会显示差异点的件数、差异点的一览。

比较结果：差异点的确认

无差异点

有差异点

比较结果：差异的一览

差异的一览自左向右按照程序的地址、比较源命令、比较源设定值0～7、比较源注解、比较目的地命令、比较目的地设定值0～7、比较目的地注解的顺序来显示。

附注

对比较目的地的值设定了范围外的值的情况下，显示用红色字符‘()’圈起来的值。

与初期值比较

1) 对程序初期值和现在编辑中的内容进行比较的情况下

单击[比较]→[与初期值比较]按钮。

2) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 参照P161：位置小数单位选择的值的设定值为比较对象时

与比较源设定值、比较目的地设定值一起，显示反映了执行比较时所设定的位置小数单位的值。

与驱动器内比较

1) 对驱动器内的程序和现在编辑中的内容进行比较的情况下

单击[比较]→[与驱动器内比较]按钮。

2) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了驱动器内所设定的位置小数单位的值。

与文件比较

1) 对指定文件和现在编辑中的内容进行比较的情况下

单击[比较]→[与文件比较]按钮。

2) 显示[打开文件]视窗。

3) 选择要进行比较的文件，单击[打开(O)]按钮。

4) 比较结果以“比较结果：差异的一览”格式予以显示。

※ 参照P161：位置小数单位选择的值的程序为比较对象时

比较源设定值显示反映了在执行比较时所设定的位置小数单位的值。

比较目的地设定值显示反映了保存在文件中的位置小数单位的值。

比较结果的输出

① 向文件输出

若单击[CSV输出]按钮，就可向CSV文件输出差异点。

② 打印

若在存在差异点的状态下单击[打印]按钮，就可打印差异点。


3.7.6. 打开文件

打开已被保存的程序时

① 从主工具条打开

1) 单击主工具条的[文件(F)]→[打开]→[程序]

2) 显示打开文件对话框，选择希望打开的程序文件，单击[打开]按钮。

② 从程序编辑画面打开

1) 单击程序编辑视窗上的[打开]

2) 显示打开文件对话框，选择希望打开的程序文件，单击[打开]按钮。

附注

可从文件的种类进行选择的扩展名因驱动器而有所差异。

※详情请参照[6.1. 文件扩展名一览]

通过将程序数据文件拖放至本画面，也可打开程序数据文件。

※对应的文件请参照[6.2. 关于文件拖放]


3.7.7. 保存到文件中

将程序编辑视窗上的程序保存到文件中的情况下，可选择盖写保存在相同文件名上，或者指定新的文件名予以保存。

① 盖写保存在相同文件名的情况下，从菜单条

单击[盖写保存] 按钮。

② 指定新的文件名予以保存的情况下，从菜单条

单击[另存为] 按钮。


3.7.8. 打印

打印程序编辑视窗上的程序的情况下，从菜单条单击[打印]按钮。

① 程序已处于选择状态的情况下，会显示以下信息。

1) 指定打印范围。

① 打印全部范围时

1) 选择[全部打印]。

2) 单击[确定]按钮。

② 指定打印范围进行打印时

1) 选择[打印选择范围内]。

2) 单击[确定]按钮。

2) 显示打印视窗。

① 进行打印的情况下，设定各项目，单击[打印]按钮。

② 中断打印的情况下，单击[取消]按钮。

② 程序已处于选择状态的情况下，打印全部内容。


3.7.9. 视窗关闭

关闭所显示的程序编辑视窗的情况下，单击[关闭]按钮，或单击[×]按钮。

若在已变更程序的状态下进行上述处理，就会显示如下所示的确认信息。

关闭视窗时请单击[确定]，停止处理时请单击[取消]。

※在对程序进行[盖写保存]或[另存为]的情况下，不会显示确认信息


3.8. 成批数据收发

将参数、间接数据、程序数据成批地发送至驱动器，或从驱动器进行接收，作为成批数据予以保存。

① 发送成批数据的情况下，从菜单条选择[文件(F)]→[成批数据]→[发送]。

② 接收成批数据的情况下，从菜单条选择[文件(F)]→[成批数据]→[接收]。

收发文件扩展名为 [*.c*adb]。

详情请参照[6.1. 文件扩展名一览]。

附注

①参数、程序、间接数据的收发中无法进行成批数据的收发。

②显示有主工具条的状态显示、解析功能、调整功能、远程操作标签的视窗的情况下，无法进行成批数据的收发。

③马达尚未设定的情况下，无法进行成批数据的接收。

请在驱动器马达选择画面上，再设定马达后再次重新进行成批数据的接收。

④自Version 2.2.0起开始收发FB滤波器设定方法选择的值。

由此，在保存接收到的数据时，FB滤波器设定方法选择的值将被保持在已保存的文件中，在成批数据发送时将被设定在驱动器中。


3.9. 示波器视窗

实时地图形显示所选择的驱动器数据。


3.9.1. 视窗的显示

测量示波器图形情况下，按下述步骤显示示波器视窗。

若选择主工具条的[解析功能]标签→[示波器]，就会显示本视窗。


3.9.2. 驱动器的状态显示

始终显示以下的驱动器状态。

No | 项目
C012 | 马达热跳脱率
C014 | 驱动器热跳脱率
C018 | 再生超载率

用颜色来表示状态。

颜色 | 状态
绿色 | 正常
黄色 | 注意
红色 | 危险


3.9.3. 示波器设定

若单击示波器视窗的[示波器设定]，就会显示示波器设定视窗。

在示波器设定视窗中，可进行显示对象通道的选择、显示对象的设定、测量设定和触发设定。

① 显示对象通道的选择

勾选希望在[CH有效选择（CH1～4）]复选框中显示的通道。

附注

去掉CH的勾选而测量的数据，全都设定0。

② 控制信息（速度指令、扭矩指令、位置偏差脉冲等）显示时的数据设定

1) 从[CH1设定]～[CH3设定]边框内的[显示项目]组合框中选择希望显示的控制信息（速度指令、扭矩指令、位置偏差脉冲等）项目。

2) 在[显示最大值]的数据输入区域设定图形显示时的Y轴存储器最大值。

3) 在[CH1设定]～[CH3设定]边框内的[显示项目]组合框中选择了[速度反馈][速度指令][模拟速度指令输入][位置指令目标速度]的情况下，可进行速度单位的切换。通过[单位]组合框，向％⇔速度⇔rpm 进行切换。

4) 在[CH1设定]～[CH3设定]边框内的[显示项目]组合框中选择了[实际扭矩指令][模拟扭矩指令输入]的情况下，可进行扭矩单位的切换。通过[单位]组合框，向％⇔Nm(N) 进行切换。

③ 长／字设备监控器时的数据设定

1) 从[CH1选择]～[CH3选择]边框内的[显示项目]组合框中选择长设备监控器或字设备监控器。

2) 从[设备编号]组合框中选择对象设备。

3) 将对象设备设定为D、R。

4) 在[设备编号]的数据输入区域设定设备编号。

5) 在[显示最大值]的数据输入区域设定图形显示时的Y轴存储器最大值。

6) 可在[设备名称]的数据输入区域自由地设定设备名称。

   所设定的设备名称，将会在图形的凡例、打印画面中显示。

④ 状态显示时的数据设定

1)从[CH1选择]～[CH3选择]边框内的[显示项目]组合框中选择希望显示的状态的种类。

2)从[状态项目]组合框中选择希望显示的信号。

⑤ 输入输出信号状态显示时的数据设定

1)从[CH1选择]～[CH4选择]边框内的[显示项目]组合框中选择希望显示的信号的种类。

2)从[信号项目]组合框中选择希望显示的信号。

⑥ 数据解析度的设定

1) 从[数据解析度]组合框中选择时间轴（X轴）的每个数据的采样时间。

2) 数据解析度（msec）根据驱动器和参数设定将在以下范围内变动。

最小测量间隔 | 0.2 | 0.4 | 0.8 | 1.6 | 3.2
最大测量间隔 | 0.4 | 0.8 | 1.6 | 3.2 | 6.4

⑦ 测量时间的设定

1) 从[测量时间]组合框中选择示波器的测量时间。

2) 将对象时间设定为1、2、5、10、20、50、100秒及Infinity。

⑧ 记录的设定

1) 对[记录有效]予以勾选。

2) 显示保存文件的对话框，设定记录文件的保存场所和文件名。

3) 在[记录有效]为ON的情况下，可利用[记录文件名栏][记录文件设定]按钮来进行记录文件的变更。

4) 记录文件的文件扩展名为 [＊.cxlog]。文件将在每60秒钟内被创建，文件名将被赋予序列号。

⑨ 触发设定

在[测量时间]组合框中选择了Inifinity以外的情况下，可进行触发设定。

1) 要使得触发设定有效，对[触发有效]进行勾选。

2) 在连续进行触发的情况下，选择[标准触发]。

   在只进行1次触发的情况下，选择[单触发]。

   若选择[标准触发]，在每次进行触发时，获取测量时间部分的数据，并对图形进行再显示。

   但是，从触发发生后起测量时间内的触发将会无效。

3) 从[触发对象]中选择作为触发对象的通道。

4) 将输入输出信号以外的通道作为触发对象的情况下，在[触发阈值]中设定成为触发的阈值。

5) 在[触发延迟时间]中设定触发发生后的延迟时间（显示触发时机以后的波形的长度）。

设定了[触发延迟时间]时的测量数据显示范围如下所示。

例1) [测量时间]为10sec，[触发延迟时间]为2sec时

显示自触发时机起2sec后的测量时间部分的测量数据(影线部分)。

例2) [测量时间]为10sec，[触发延迟时间]为-2sec时

显示自触发时机起2sec前的测量时间部分的测量数据(影线部分)。

6) 通过[ON]或[OFF]的选择来设定触发检测的边缘。

⑩ 示波器设定的设定

若单击[设定]按钮，就会登录所设定的各信息，并返回示波器视窗。

示波器设定中所设定的内容，将会显示在示波器视窗的下部状态条。

附注

在设定了连接中的驱动器中无法使用的显示项目的情况下，会显示以下信息。

请变更显示项目。

由于来自驱动器的接收数据为16bit数据，所以在对显示最大值设定了超过32767的值时，有的情况下显示数据会呈现阶梯状显示。

例1)

显示项目：位置偏差

显示最大值：16,000,000[pulse]

上述假定下的1数据解析度为

16,000,000/32767≒488[pulse]

驱动器已有1,000,000[pulse]的位置偏差的情况下，显示1,000,031[pulse]。

例2)

显示项目：速度反馈

显示最大值：1,800.000[deg/sec]

上述假定下的1数据解析度为

1,800,000/32767≒55[pulse/sec]

驱动器已在360.000[deg/sec]下动作的情况下，显示359.978 [deg/sec]。


3.9.4. 显示项目

示波器设定中要设定的显示项目如下所示。

显示项目名 | 说明
速度反馈 | 显示马达实际动作速度。
实际扭矩指令 | 显示实际扭矩指令值。
位置偏差 | 显示位置偏差脉冲。
速度指令 | 显示速度指令值。 在速度指令模式、脉冲串指令模式、内置指令模式、来自网络的速度指令和位置指令下有效。 成为包含S字和偏差的速度系最后的指令值。
模拟速度指令 | 显示模拟速度指令值。 只有VPH-HA驱动器显示项目。 没有模拟选项的驱动器，值被固定为0。
模拟扭矩指令 | 显示模拟扭矩指令值。 马达额定扭矩时为100%。 只有VPH-HA驱动器显示项目。 没有模拟选项的驱动器，值被固定为0。
位置指令目标速度 | 显示位置指令的目标速度。 在脉冲串指令模式、内置指令模式、来自网络的位置指令下有效。 成为不包含S字和偏差的指令值。
马达有效值 | 显示马达马达有效值（负载率）。
马达热跳脱率 | 显示马达热跳脱率。 为100%时，检测“马达过负载异常”。
脉冲串指令速度 | 显示脉冲串指令速度。 在脉冲串指令模式、来自网络的位置指令下有效。 显示1ms间隔的原始数值。 成为不包含S字和偏差的指令值。 ※根据VPH驱动器的版本有可能无法进行测量
长设备监控器 | 作为长设备监控器显示所指定的设备值。
字设备监控器 | 作为字设备监控器显示所指定的设备值。
状态显示选择 | 显示所选择的状态显示项目。
输入信号选择 | 显示所选择的输入信号状态。
输出信号选择 | 显示所选择的输出信号状态。


3.9.5. 显示标尺的设定

① 时间(X)轴的设定

1) 从[时间标尺]组合框中选择1个画面上显示的显示时间。

2) 将时间标尺设定为0.05、0.1、0.2、0.5、1、2、5、10、20、50秒。

② 显示数据范围(Y)轴的设定

1) 数值显示项目的情况下，从[标尺]组合框中选择1个画面上显示的数值数据范围。100%时的数值为在示波器设定视窗中设定的显示最大值。

2) 信号显示项目的情况下，从[偏移]组合框中选择信号OFF时的显示位置。偏移0%的显示位置表示Y轴的中央。

3) 将标尺设定为0.1、0.5、1、5、10、25、50、100%。

4) 将偏移设定为-80、 -60、-40、-20、0、20、40、60、80%。


3.9.6. 实时显示的开始／停止

1) 开始示波器的实时显示的情况下、单击[开始]按钮。显示中[开始]按钮会变为[停止]按钮。

2) 若单击[停止]按钮，就会停止显示。

3) 停止显示后，会按如下所示方式显示测量波形。


3.9.7. 图形设定

若在示波器视窗的[标尺][偏移]设定区域内予以右击，就会显示图形设定视窗。

在图形设定视窗中，可进行显示对象通道的颜色选择、显示对象描绘顺序、光标颜色设定和触发阈值线颜色设定。

① 测量图形线色设定

各通道的测量图形的线色，分别以[线色CH1]～[线色CH4] 组合框中所选择的颜色予以显示。

② 描绘顺序设定

从通道选择的列表选择希望变更描绘顺序的通道，通过[向前面移动][向背面移动]来变更顺序。

③ 光标颜色设定

分别以[光标A颜色]组合框、[光标B颜色]组合框中所选择的颜色予以显示。

④ 触发阈值线色设定

以[Trigger] 组合框中所选择的颜色予以显示。


3.9.8. 光标的设定

① 光标的设定

1) 单击按钮[A]或[B]。与所选择的光标（A／B）对应的信息显示栏的显示字符会成为粗体字。[A]或[B]将被唯一选择。

2) 若在选择了光标A的状态下再次单击按钮[A]，光标A的选择就会被解除。对于光标B也相同。

② 通道的设定

1) 选择按钮[CH1]～[CH4]。光标线将被与所选择的通道相互关联起来。

2) 现在所选择的通道，其按钮颜色将被变更。

③ 光标信息的显示

1) 现在显示有光标A或B的位置的时间及CH1～CH4的信息，将会在与光标对应的信息显示栏中显示。

2)在[差异]栏中显示[A]点与[B]点值的差异。

3) 在[A－B Min][A－B Max]栏中显示[A]点与[B]点间的最小值和最大值。

④ 光标的移动

1) 若单击画面上的任意点，就会在该点显示十字光标。

2) 若单击 LeftButton 或 RightButton ，就可对光标位置进行微调整。若持续按住鼠标，光标就会自动移动。

3) 若在显示有光标A及光标B的状态下单击 paraMoveButton ，就会切换至 paraMoveButtonPushed 。在此状态下若单击 LeftButton 或 RightButton ，光标A及光标B就会同时平行移动。

附注

单击开始按钮时，在设定有连接中的驱动器中无法使用的显示项目的情况下，会显示以下信息。

若单击[确定]按钮，就会显示示波器设定画面，请变更显示项目。


3.9.9. 负载率计算

显示负载率的情况下，进行“扭矩指令”的测量，指定光标A、B，并且单击“负载率计算”按钮。

附注

尚未指定光标A或者B的情况下，会显示以下信息。

尚未计测扭矩数据的情况下，会显示以下信息。

在多个通道中测量了“扭矩指令”的情况下，计算编号最小的通道的负载率。

(例:已将CH1～3全都设定为“实际扭矩指令”的情况下，计算CH1的“实际扭矩指令”的负载率)


3.9.10. 示波器显示项目的再设定

在变更显示项目的情况下，单击[示波器设定]来进行通道设定。


3.9.11. 打开文件

显示在本软件的示波器功能下保存的示波器数据。

① 从主工具条打开

1) 单击主工具条的[文件(F)]→[打开文件(O)]→[示波器数据(O)]

2) 显示打开文件的对话框，选择希望打开的示波器数据文件，单击[打开]按钮。

3) 加载中显示以下画面。

附注

可从文件的种类进行选择的扩展名因驱动器而有所差异。

※详情请参照[6.1. 文件扩展名一览]

通过将示波器数据文件拖放至本画面，也可打开示波器数据文件。

※对应的文件请参照[6.2. 关于文件拖放]

图形在已被保存的时间轴上显示。

光标位置和卷动位置被保存在Version 2.2.0以后保存的文件中，若打开文件，光标位置和卷动位置就会被恢复。

在打开由Version 2.1.0以前的VPH Data Editing Software所保存的文件时，光标位置和卷动位置不会被恢复。

关于功能限制

在已显示所保存的示波器数据的情况下，以下功能将会无效。

1.示波器计测

2.示波器设定的CH有效选择和单位变换以外的功能


3.9.12. 保存到文件中

在将本视窗上所显示的示波器数据保存到文件中的情况下，从菜单条

① 单击[另存为]按钮。

② 显示有A和B光标的情况下，可选择保存方法。

附注

可保存的数据至多为300[sec]。

用csv格式保存数据的情况下，输出现在显示中的单位制的数据。

根据显示最大值的设定和计算误差，整数数据可能会成为带小数点的数据。


3.9.13. 打 印

在打印所显示的示波器数据的情况下，从菜单条单击[打印]按钮。

显示打印视窗，设定各项目后单击[确定]按钮。

附注

打印纸尺寸可指定为[Ａ４、Ａ３]，打印方向可指定为[纵、横]，但是实际输出则以[Ａ４]、[纵]格式进行。


3.9.14. 视窗关闭

关闭所显示的示波器视窗的情况下，单击[关闭]按钮，或单击[×]按钮。


3.10. 频谱视窗

进行频谱的测量，实时地进行图形显示。


3.10.1. 测量视窗的显示

若单击主工具条的[解析功能]标签→[频谱测量]，就会显示本视窗。


3.10.2. 测量设定

① 测量对象的设定

1) 从[测量对象]组合框中选择测量对象。

2) 将测量对象设定为速度、扭矩。

② 频率的设定

1) 从[频率]组合框中选择测量频率。

2) 根据驱动器和参数设定，测量频率（Hz）会在以下范围内变动。

最大测量间隔 | 10000 | 5000 | 3333 | 2500 | 2000
最小测量间隔 | 2500 | 1250 | 833 | 625 | 500

附注

根据用户所使用的电脑的动作性能（OS及处理时间），有的情况下无法在所设定的频率下进行测量。这种情况下请调低测量频率。

在[频率]组合框变更时频率与连接中的驱动器不同的情况下，会显示以下信息。

若单击[确定]按钮，图形和频率就会被复位。

若单击[取消]按钮，图形和频率将保持原先的状态。


3.10.3. 画面显示控制的设定

① 振幅的设定

1) 从[振幅]组合框中选择Y轴的测量对象（速度／扭矩）的振幅的显示标尺。

2) 将标尺自动地设定为1、2、3、4、5、10、20、50%（或dB）。

② 线色、背景色、线宽的设定

1) 从[线色]、[背景色]、[线宽]组合框中选择线色、背景色、线宽。

2) 将线色设定为[红色]、[绿色]、[蓝色]、[橙色]、[青色]、[品红]。

3) 将背景色设定为[白色]、[黑色]。

4) 将线宽设定为[细线]、[粗线]、[极粗线]。

③ 显示对象的设定

1) 从[画面切换]组合框中选择测量结果的显示方法。

2) 将显示方法设定为[直线]及[对数]。

3) 设定为直线的情况下，以对应[100%]的形式对额定速度或额定扭矩进行%显示。

4) 设定为对数的情况下，以正规化为[1]的形式对额定速度或额定扭矩进行分贝显示。

将[画面切换]设定为[对数]的情况，显示如下画面。


3.10.4. 频谱的测量开始／停止

1) 开始测量频谱的情况下，单击[开始]按钮。测量中[开始]按钮会变为[停止]按钮。

2) 若单击[停止]按钮，就会停止单击测量。

3) 测量停止后，会按如下所示方式显示测量波形。同时，光标Ａ会被自动设定在[陷波滤波器下限频率]以上的频率区域振幅最大的点。


3.10.5. 光标的设定

① 光标的设定

1) 单击按钮[A]或[B]。与所选择的光标（A/B）对应的信息显示栏的显示字符会成为粗体字。[A]或[B]将被唯一选择。

2) 若在选择了光标A的状态下再次单击按钮[A]，光标A的选择就会被解除。对于光标B也相同。

3) 在 [image] 中设定了光标设定方法时，单击位置前后的频率中会显示橙色的线条。光标会被设定在此橙色线条的范围内最高的频率处。

光标已被设定的时画面如下所示。

4) 在 [image] 中设定了光标设定方法时，光标就会被设定在所单击的频率处。

光标已被设定的时画面如下所示。

② 光标的移动

1) 若单击画面上的任意点，就会在该点显示十字光标。光标A时以[绿色]予以显示，光标Ｂ时以[青色]予以显示。（但是，若光标彼此相互重叠，或与显示波形、轴线等重叠，颜色会暂时变化。）

2) 若单击 LeftButton 或 RightButton ，就可对光标位置进行微调整。若持续按住鼠标，光标就会自动移动。

③ 光标信息的显示

1) 现在显示有光标A或B的位置的频率及速度或扭矩的信息，将会在与光标对应的信息显示栏中显示。

2) 在[差异]栏中显示[A]点与[B]点值的差异。

设定了光标时的画面如下所示。


3.10.6. 陷波滤波器的设定

本视窗上的陷波滤波器的设定与前一节所述的光标设定联动。

① 陷波滤波器的设定值读出

1) 在显示有本视窗的时点显示在所连接的驱动器内设定的陷波滤波器的信息。

2) 若单击陷波滤波器边框内的[接收]按钮，就会读出并显示在所连接的驱动器内设定的陷波滤波器的信息。

② 陷波滤波器的计算

计算陷波滤波器包括以下两种方式。

1) 只设定了光标A或光标B时

中心频率：将光标位置的频率作为中心频率予以设定。

带宽率：将对陷波滤波器带宽率设定的值作为带宽率予以设定。

2) 设定了光标A及光标B时

中心频率：[A]及[B]中所显示的频率的积的平方根（ [image] ）将被设定为中心频率。

带宽率：设定将带宽除以中心频率时的商变换为百分率的值。

※超过100%时，将钳制在100%上。

设定光标A、B时的中心频率、带宽率设定例

光标 | A | B | 差异
频率[Hz] | 500 | 1000 | -500

计算式 | 例
中心频率 = | 707 [Hz] =
带宽= ABS(A-B) | 500 [Hz] =
带宽率= 带宽 ÷ 中心频率 | 0.707107 = 500÷707.1068
带宽率[%] = 带宽率 × 100 | 70 [%] = 0.707107×100

③ 陷波滤波器的设定

1) 设定光标A、B。

2) 单击与进行滤波处理的对象的参数对应的[设定]按钮。

3) 将通过光标的设定计算出的结果设定为中心频率、带宽率。

4) 在设定的同时，该设定值也将被写入驱动器内。

5) 对应深度的装置上，通过在设定了值的状态下单击[设定]按钮就可设定深度。

注意

此时，若设定内容与系统不匹配，马达就会剧烈振动。请按下与设定了陷波滤波器的位置相对应的[清除]按钮来紧急解除陷波滤波器的设定。

6) 试图在[陷波滤波器下限频率]中设定的值以下的频率区域进行陷波滤波器的设定的情况下，会显示如下信息。

单击[是]的情况下，将强行设定。

※本判断将由客户作出。请客户在充分确认驱动器安全性的基础上作出判断。

单击[否]的情况下，将停止设定。

通常选择[否]。

7) 可通过从键盘输入[数值＋Enter]来设定[陷波滤波器下限频率]、[陷波滤波器带宽率]。

（例１）若将光标Ａ指向下图位置并单击各中心频率的[设定]按钮，就会按下图所示方式设定陷波滤波器。

（例2）若将光标Ａ及光标Ｂ指向下图位置并单击各中心频率的[设定]按钮，就会按下图所示方式设定陷波滤波器。


3.10.7. 打开文件

从主工具条打开

1) 单击主工具条的[文件(F)]→[打开文件(O)]→[频谱 (S)] 。

2) 显示打开文件的对话框，选择希望打开的频谱数据文件，单击[打开]按钮。

附注

可从文件的种类进行选择的扩展名因驱动器而有所差异。

※详情请参照[6.1. 文件扩展名一览]

通过将频谱数据文件拖放至本画面，也可打开频谱数据文件。

※对应的文件请参照[6.2. 关于文件拖放]

关于功能限制

在已显示所保存的频谱数据的情况下，以下功能将会无效。

1.频谱计测

2.陷波滤波器的设定

3.测量设定的变更


3.10.8. 保存到文件中

在将本视窗上所显示的频谱数据保存到文件中的情况下，从菜单条选择[另存为] 。


3.10.9. 打 印

在打印所显示的频谱数据的情况下，从菜单条单击[打印]按钮。

显示打印视窗，设定各项目后单击[确定(A)]按钮。

附注

打印纸尺寸可指定为[Ａ４、Ａ３]，打印方向可指定为[纵、横]，但是实际输出则以[Ａ４]、[纵]格式进行。


3.10.10. 视窗关闭

关闭所显示的频谱视窗的情况下，单击[关闭]按钮，或单击[×]按钮。


3.10.11. 向导信息

频谱测量时显示如下信息。请按照指示进行操作。

示波器执行中无法进行频谱的测量。

在单击[开始]按钮时频率与连接中的驱动器不同的情况下，会显示此信息。

试图在陷波滤波器下限频率以下（上面的画面中为100Hz）的区域设定陷波滤波器时会显示此信息。

本判断将由客户作出。请客户在充分确认驱动器安全性的基础上作出判断。

对于不对应陷波滤波器深度的装置，在试图设定深度时会显示此信息。

在从驱动器接收频谱数据时没有来得及进行数据的加载时会显示此信息。

依赖于测量频率和用户所使用的电脑的动作性能（OS及处理时间）。使用相同电脑的情况下，请调低测量频率进行测量。


3.11. 频率响应视窗

此窗口用来测量并显示测量驱动器的频率响应，显示所保存的频率响应数据。


3.11.1. 测量视窗的显示

若单击主工具条的[解析功能]标签→[频率响应]，就会显示本视窗。


3.11.2. 测量设定

① 测量增益编号的设定

选择测量增益编号。

② 测量频率的设定

1) 从[测量频率]组合框中选择测量频率。

2) 根据驱动器和参数设定，测量频率（Hz）会在以下范围内变动。

最大测量间隔 | 10000 | 5000 | 3333 | 2500 | 2000
最小测量间隔 | 2500 | 1250 | 833 | 625 | 500

附注

根据用户所使用的电脑的动作性能（OS及处理时间），有的情况下无法在所设定的频率下进行测量。这种情况下请调低测量频率。

在[测量频率]组合框变更时测量频率与连接中的驱动器不同的情况下，会显示以下信息。

若单击[确定]按钮，图形和测量频率就会被复位。

若单击[取消]按钮，图形和测量频率将保持原先的状态。

③ 励振宽幅（速度指令量／偏移量）的设定

1) 从键盘直接输入励振时的励振宽幅。

2) 若右击[%]的部分，就会显示可输入的数据区域。

注意

请根据客户的驱动器，在安全的范围内进行设定。

④ 励振时间的设定

从键盘直接输入励振的时间。在从1Hz至上面所设定的测量频率的范围内进行设定。

⑤ 允许最大振动量的设定

从键盘直接输入允许最大振动量。

注意

请根据客户的驱动器，在安全的范围内进行设定。

特别是τ直线马达的情况下，要注意避免超过有效行程。

⑥ 计测次数的设定

将从1Hz至上面所设定的测量频率的励振作为1次，从键盘直接输入总计测次数。


3.11.3. 显示设定

① 振幅的设定

1) [振幅]组合框中选择Y轴的振幅的显示标尺。

2) 将标尺设定为自动、1、2、3、4、5、10、20、50dB。

3) 刚测量完后被设定为[自动]，从而可在整个画面上显示波形。

② 相位的设定

1) 从[相位]组合框中选择Y轴的相位的显示标尺。

2) 将标尺设定为自动、15、30、45、60、75、90deg。

3) 刚测量完后被设定为[自动]，从而可在整个画面上显示波形。

③ 线色、背景色、线宽的设定

1) 从[线色]、[背景色]、[线宽]组合框中选择线色、背景色、线宽。

2) 将线色设定为[红色]、[绿色]、[蓝色]、[橙色]、[青色]、[品红]。

3) 将背景色设定为[白色]、[黑色]。

4) 将线宽设定为[细线]、[粗线]、[极粗线]。

④ 显示对象的设定

1) 从[画面切换]组合框中选择测量结果的显示方法。

2) 将显示方法设定为[振幅相位]及[振幅]。

3) 设定为振幅相位的情况下，在显示区域的上半部分显示振幅，下半部分显示相位。

4) 设定为振幅的情况下，在整个显示区域显示振幅的画面。


3.11.4. 频率响应的测量开始／停止

1) 开始测量频率响应的情况下，单击[开始]按钮。测量中[开始]按钮会变为[停止]按钮。

→

2) 显示如下画面。

3) 进行所设定的计测次数部分的测量而结束后，自动完成测量，[停止]按钮会变回到[开始]按钮。

4) 在测量完成的同时，光标Ａ会被自动设定在[陷波滤波器下限频率]以上的频率区域中之前点与当前点处的振幅变化量最大的点。

5) 测量中希望紧急停止动作的情况下，再次单击[停止]按钮。测量会紧急停止。

6) 测量完成时成为如下画面。


3.11.5. 光标的设定

① 光标的设定

1) 单击按钮[A]或[B]。与所选择的光标（A/B）对应的信息显示栏的显示字符会成为红色。[A]或[B]将被唯一选择。

2) 若在选择了光标A的状态下再次单击按钮[A]，光标A的选择就会被解除。对于光标B也相同。

3) 在 [image] 中设定了光标设定方法时，单击位置前后的频率中会显示橙色的线条。光标会被设定在此橙色线条的范围内最高的频率处。

光标已被设定的时画面如下所示。

4) 在 [image] 中设定了光标设定方法时，光标就会被设定在所单击的频率处。

光标已被设定的时画面如下所示。

② 光标的移动

1) 若单击画面上的任意点，就会在该点显示十字光标。光标A时以[绿色]予以显示，光标B时以[青色]予以显示。（但是，若光标彼此相互重叠，或与显示波形、轴线等重叠，颜色会暂时变化。）

2) 若单击 LeftButton 或 RightButton ，就可对光标位置进行微调整。若持续按住鼠标，光标就会自动移动。

③ 光标信息的显示

1) 现在显示有光标A或B的位置的频率及振幅或相位的信息，将会在与光标对应的信息显示栏中显示。

2) 在[差异]栏中显示[A]点与[B]点值的差异。

设定了光标时的画面如下所示。


3.11.6. 陷波滤波器的设定

本视窗上的陷波滤波器的设定与前一节所述的光标设定联动。

① 陷波滤波器的设定值读出

1) 在显示有本视窗的时点显示在所连接的驱动器内设定的陷波滤波器的信息。

2) 若单击陷波滤波器边框内的[接收]按钮，就会读出并显示在所连接的驱动器内设定的陷波滤波器的信息。

② 陷波滤波器的计算

计算陷波滤波器包括以下两种方式。

① 只设定了光标A或光标B时

中心频率：将光标位置的频率作为中心频率予以设定。

带宽率：将对陷波滤波器带宽率设定的值作为带宽率予以设定。

② 设定了光标A及光标B时

中心频率：[A]及[B]中所显示的频率的积的平方根（ [image] ）将被设定为中心频率。

带宽率：设定将带宽除以中心频率时的商变换为百分率的值。

※超过100%时，将钳制在100%上。

设定光标A、B时的中心频率、带宽率设定例

光标 | A | B | 差异
频率[Hz] | 500 | 1000 | -500

计算式 | 例
中心频率 = | 707 [Hz] =
带宽= ABS(A-B) | 500[Hz] =
带宽率= 带宽 ÷ 中心频率 | 0.707107 = 500÷707.1068
带宽率[%] = 带宽率 × 100 | 70 [%] = 0.707107×100

③ 陷波滤波器的设定

1) 设定光标A、B。

2) 单击与进行滤波处理的对象的参数对应的[设定]按钮。

3) 将通过光标的设定计算出的结果设定为中心频率、带宽率。

4) 在设定的同时，该设定值也将被写入驱动器内。

5) 对应深度的装置上，通过在设定了值的状态下单击[设定]按钮就可设定深度。

注意

此时，若设定内容与系统不匹配，马达就会剧烈振动。请按下与设定了陷波滤波器的位置相对应的[清除]按钮来紧急解除陷波滤波器的设定。

6) 试图在[陷波滤波器下限频率]中设定的值以下的频率区域进行陷波滤波器的设定的情况下，会显示如下信息。

单击[是]的情况下，将强行设定。

※本判断将由客户作出。请客户在充分确认驱动器安全性的基础上作出判断。

单击[否]的情况下，将停止设定。

通常选择[否]。

7) 可通过从键盘输入[数值＋Enter]来设定[陷波滤波器下限频率]、[陷波滤波器带宽率]。

（例１）若将光标A指向下图位置并单击各中心频率的[设定]按钮，就会按下图所示方式设定陷波滤波器。

（例2）若将光标Ａ及光标Ｂ指向右图位置并单击各中心频率的[设定]按钮，就会按下图所示方式设定陷波滤波器。


3.11.7. 打开文件

从主工具条打开

1) 单击主工具条的[文件(F)]→[打开文件(O)]→[频率响应(R)] 。

2) 显示打开文件的对话框，选择希望打开的频率响应数据文件，单击[打开]按钮。

附注

可从文件的种类进行选择的扩展名因驱动器而有所差异。

※详情请参照[6.1. 文件扩展名一览]

通过将频率响应数据文件拖放至本画面，也可打开频率响应数据文件。

※对应的文件请参照[6.2. 关于文件拖放]

关于功能限制

在已显示所保存的频率响应数据的情况下，以下功能将会无效。

1.频率响应计测

2.陷波滤波器的设定

3.测量条件的变更


3.11.8. 保存到文件中

在将本视窗上所显示的频率响应数据保存到文件中的情况下，从菜单条单击[另存为]按钮。


3.11.9. 打 印

1) 在打印所显示的频率响应数据的情况下，从菜单条单击[打印]按钮。

2) 显示打印视窗，设定各项目后单击[打印]按钮。

附注

打印纸尺寸可指定为[Ａ４、Ａ３]，打印方向可指定为[纵、横]，但是实际输出则以[Ａ４]、[纵]格式进行。


3.11.10. 视窗关闭

关闭所显示的频率响应视窗的情况下，单击[关闭]按钮，或单击[×]按钮。

此时，有的情况下会以下画面。


3.11.11. 向导信息

频率响应测量时显示如下信息。请按照指示进行操作。

在从驱动器接收频率响应数据时没有来得及进行数据的加载时会显示此信息。

根据用户所使用的电脑的动作性能（OS及处理时间），有的情况下无法在所设定的频率下进行测量。这种情况下请调低测量频率。

在驱动器内执行励振时发生错误时会显示此信息。

请在变更励振宽幅、允许最大振动量等后进行再测量。

在单击[开始]按钮时测量频率与连接中的驱动器不同的情况下，会显示此信息。

从驱动器接收陷波滤波器的值的情况下发生异常时会显示此信息。

请确认是否处在可进行USB通信的状态。

在尚未设定光标的状态下试图进行陷波滤波器的设定时会显示出此信息。请设定光标。

对于不对应陷波滤波器深度的装置，在试图设定深度时会显示此信息。


3.12. 状态显示视窗

此视窗显示警报履历、驱动器状态、驱动器信息、编码器信息、马达信息等。


3.12.1. 状态显示视窗的显示

若单击主工具条的[状态显示]标签→[状态显示]，就会显示本视窗。


3.12.2. 状态信息

① 若选择状态显示标签，就会显示运行信息。

② 项目的现在值在[数据]显示栏中显示。

③ 项目的现在的单位在[单位]显示栏中显示。

④ 单击清除按钮的情况下，会显示如下确认信息。

若单击[确定]按钮，就会清除对象项目的数据。

若单击[取消]按钮，就会停止清除而返回原先的画面。

⑤ 若单击状态组选择按钮，就可在组单位下进行状态的显示。

如下视窗为选择了[位置]组时的显示内容。

⑥ 选择[用户定制]组，就可调换显示项目的顺序，或将不需要的项目隐藏起来。

向下移动项目时，选择希望移动的项目后单击[ [image] ]按钮。

向上移动项目时，选择希望移动的项目后单击[ [image]]按钮。

要隐藏项目，选择希望使其隐藏的项目后单击[隐藏]按钮。

返回初期状态时，单击[初期显示]按钮。


3.12.3. 警报信息

① 若选择警报标签，就会显示警报信息。

② 各项目的现在值在[Data]显示栏中显示。

③ 若单击[一览显示]按钮，就会显示警报警告一览画面。

若单击所显示的警报，就会在警报警告一览画面中显示警报的详细。

④ 若单击[警报清除]按钮，就会显示如下确认信息。

若单击[确定]按钮，就会清除警报信息。

若单击[取消]按钮，就会停止清除而返回原先的画面。


3.12.4. 驱动器信息显示

① 若选择驱动器信息标签，就会显示驱动器信息。

② 项目的现在值在[Data]显示栏中显示。

③ 项目的现在的单位在[单位]显示栏中显示。


3.12.5. 编码器信息显示

  ① 若选择编码器信息标签，就会显示编码器信息。

  ② 项目的现在值在[Data]显示栏中显示。

③ 项目的现在的单位在[单位]显示栏中显示。

附注

在连接了与编码器信息的显示不对应的驱动器的情况下，会显示以下信息，并将编码器信息标签隐藏起来。

在连接了与编码器信息对应的驱动器的情况下，会显示以下信息，并显示编码器信息标签。


3.12.6. 马达信息显示

  ① 若选择马达信息标签，就会显示马达信息。

  ② 项目的现在值在[Data]显示栏中显示。

③ 项目的现在的单位在[单位]显示栏中显示。

※有的马达没有信息，因此马达信息标签中有可能没有显示项目。

附注

在连接了与马达信息的显示不对应的驱动器的情况下，会显示以下信息，并将马达信息标签隐藏起来。

在连接了与马达信息对应的驱动器的情况下，会显示以下信息，并显示马达信息标签。


3.12.7. 视窗关闭

关闭所显示的状态显示视窗的情况下，单击[关闭]按钮，或单击[×]按钮。


3.13. 输入输出信号状态显示视窗

显示输入输出信号状态。


3.13.1. 输入输出信号状态显示视窗的显示

若单击主工具条的[状态显示]标签→[输入输出显示]，就会显示本视窗。


3.13.2. 输入输出信号状态显示

① 显示输入输出信号的现在的状态。

② 在信号为[ON]的状态下成为蓝色显示。

③ 标光标指向信号记号，就会显示信号名。


3.13.3. 视窗关闭

关闭所显示的状态显示视窗的情况下，单击[×]按钮。


3.14. 远程运行视窗

从本软件上操作输入输出信号，进行远程运行。


3.14.1. 开关箱视窗的显示

若单击主工具条的[远程操作]标签→[开关箱] ，就会显示本视窗。

有关视窗内的各信号内容，请参照驱动器的使用说明书。


3.14.2. 输出信号状态的显示

实时显示输出信号的状态。

（信号ON时：绿色、红色 ／ 信号OFF时：背景色）


3.14.3. 输入信号的ON／OFF操作

在对输入信号进行ON／OFF操作的情况下，对各按钮、标签（速度控制模式等）、列表框（SS1-3）进行操作

① 通常输入信号按钮

SwitchBoxButton | 显示 | 通常的字体
 | 动作 | 单击：ON/OFF切换 右击：ON/OFF切换

② 瞬时输入信号按钮

SwitchBoxButton | 显示 | 斜体
 | 动作 | 按钮按下状态：ON 按钮松开状态：OFF 右击：ON/OFF切换

注意

马达将会根据输入信号的操作而动作，所以要在充分确认安全的基础上进行操作。


3.14.4. 视窗关闭

关闭所显示的远程运行视窗的情况下，单击[关闭]按钮，或单击[×]按钮。


3.15. 实时伺服调整视窗

实时变更自整定后的水平调整和速度／位置回路增益及伺服调整参数。


3.15.1. 实时伺服调整视窗的显示

若单击主工具条的[调整功能]标签→[实时伺服调整]，就会显示本视窗。

附注

自Version 2.2.0起曾由本软件保持的FB滤波器设定方法选择的值被保存在驱动器中。

本画面启动时驱动器内的FB滤波器设定方法选择未设定时，会显示以下信息。

此外，USB连接时也会进行FB滤波器设定方法选择的检查，未设定时则显示本信息。


3.15.2. 调整对象增益的选择

1) 从[调整增益选择]组合框中选择调整对象项目。

2) 与所选择的调整对象项目相关的参数会在相关参数显示／设定区域中显示。


3.15.3. 参数调整

① 通过按钮进行调整

1) 在相关参数显示／设定区域单击各项目的调整按钮[▲][▼]。

2) 若单击[▲]，参数的设定值就会递增，并被实时更新。

3) 若单击[▼]，参数的设定值就会递减，并被实时更新。

4) 可通过递增量调整单选按钮来变更单击[▲][▼]时的递增／递减量。

② 通过键盘进行调整

通过键盘直接设定值。

设定值在按下[Enter]键时被确定。

在对设定值输入了非法值的情况下，将会显示信息，并将设定值恢复为操作之前的值。

输入了范围外的值时

输入了数值以外的值时

附注

在持续按下增益调整按钮[▲][▼]期间，持续递增或递减。

在尚未确定设定值的状态下，以红色字符予以显示。

要确定设定值，按下[Enter]键。

③ 低速增益(Step3)联动

① 对与低速增益(Step3)联动的复选框予以勾选。

② 若确定Step1(联动源参数)，就会变更Step3(联动目的地参数)。

Step1 | Step3
速度回路比例增益 | 速度回路比例增益／低速增益
速度回路积分时间常数 | 速度回路积分时间常数／低速增益
速度回路微分时间常数 | 速度回路微分时间常数／低速增益
速度回路比例增益分配率 | 速度回路比例增益分配率／低速增益
位置回路增益 | 位置回路增益／低速增益
位置回路微分时间常数 | 位置回路微分时间常数／低速增益


3.15.4. 惯量的设定

若变更[惯量]的值，就会显示如下确认信息。

若单击[确定]，就会对驱动器内的参数设定现在的惯量定值。

若单击[取消]，就会停止参数的设定。


3.15.5. 粘性摩擦的设定

若变更[粘性摩擦]的值，就会显示如下确认信息。

若单击[确定]，就会对驱动器内的参数设定现在的粘性摩擦。

若单击[取消]，就会停止参数的设定。


3.15.6. FB滤波器设定

1)显示本视窗时，在USB连接时，按下[ [image] ]时会接收驱动器内的FB滤波器设定方法选择的值，并反映到FB滤波器设定方法选择中。

2)若将[FB滤波器设定方法选择]组合框设定为[手动]，就可手动设定[FB滤波器次数]、[FB滤波器频率]。

3)若将[FB滤波器设定方法选择]组合框设定为[手动]以外，就会进行FB滤波器处理，[FB滤波器次数]、[FB滤波器频率]会自动更新。

此外，在此状态下进行自整定水平调整的情况下，也会同样被更新。

4)若单击[更新]按钮，就会向驱动器发送FB滤波器设定方法选择的值。


3.15.7. 恢复为调整前的参数

若单击[ [image] ]，就会显示如下确认信息。

若单击[是]，就会将参数和FB滤波器设定方法选择恢复为调整前的设定。

若单击[否]，就会停止参数恢复为调整前的设定。


3.15.8. 参数的更新

若单击[更新]按钮，就会显示如下确认信息。

所有的设定值都已被确定时

若单击[确定]，就会向驱动器发送现在的增益设定值和FB滤波器设定方法选择值。

若单击[取消]，就会停止参数的设定。

有未确定（红字）的设定值时

对红字的设定值予以确定（Enter键），再次单击[更新]按钮。


3.15.9. 视窗关闭

关闭所显示的实时增益调整视窗的情况下，单击[关闭]按钮，或单击[×]按钮。

在关闭画面时尚未进行[更新]的情况下，会显示如下信息。

※即使不单击[更新]按钮而予以关闭，也会被记录到驱动器的RAM区域中，所以直至切断驱动器的电源为止显示本视窗时将保持编辑状态。


3.16. 自整定视窗

进行自整定，设定增益参数。


3.16.1. 视窗的显示

若从主工具条单击[调整功能]标签→[自整定]，就会显示本视窗。

附注

自Version 2.2.0起曾由本软件保持的FB滤波器设定方法选择的值被保存在驱动器中。

本画面启动时驱动器内的FB滤波器设定方法选择未设定时，会显示以下信息。

此外，USB连接时也会进行FB滤波器设定方法选择的检查，未设定时则显示本信息。


3.16.2. 动作参数的接收

若单击动作参数接收按钮，就会接收驱动器的动作参数，并将该值也反映到动作参数设定项目中。

附注

自Version 2.2.0起曾由本软件保持的FB滤波器设定方法选择的值被保存在驱动器中。

接收动作参数时驱动器内的FB滤波器设定方法选择未设定时，会显示以下信息。

此外，USB连接时也会进行FB滤波器设定方法选择的检查，未设定时则显示本信息。


3.16.3. 动作参数的设定

设定整定增益、动作方向、运行比率、最大扭矩、惯量倍率。


3.16.4. FB滤波器的设定

在FB滤波器设定方法选择被设定为[手动]的情况下，会以FB滤波器次数、FB滤波器频率中所设定的值进行FB滤波器处理。

在FB滤波器设定方法选择被设定为[手动]以外的情况下，会自动地进行FB滤波器处理。


3.16.5. 自整定的开始

若单击开始按钮，就会以对动作参数所设定的参数开始自整定。

自整定的结果将会在状态中显示。


3.16.6. 详细的显示

若单击视窗的右上的 [image] ，就会显示马达动作预想值和自整定结果。

VPH-HB驱动器、VPH-HD驱动器、VPH-HE驱动器的情况下，追加显示deg单位或者mm单位的马达动作预想值。

无法与VPH驱动器通信的情况下，马达动作预想值成为“---”。

VPH-HA驱动器、VPH-HC驱动器

VPH-HB驱动器、VPH-HD驱动器、VPH-HE驱动器


3.16.7. 视窗关闭

关闭所显示的定位自整定视窗的情况下，单击[关闭]按钮，或单击[×]按钮。

自整定执行后，显示以下信息。


3.17. 测试运行视窗

进行测试运行。


3.17.1. 测试运行视窗的显示

若从主工具条选择[调整功能]标签→[测试运行]，就会显示本视窗。


3.17.2. 动作的设定

项目名 | 设定范围 | 说明
开始位置指定 | 无效、ABS、INC | 可选择动作开始位置的方法。
HCP限制 | HCP限制、无限制 | 只有在[开始位置指定]为“ABS”的情况下才会显示。 在[开始位置指定]为“HCP限制”的情况下，在原点恢复尚未完成的状态下无法执行测试运行。 在[开始位置指定]为“无限制”的情况下，即使在尚未完成原点恢复的状态也会执行测试运行。
动作开始位置 | -2147483648～2147483647 [P161] | 指定马达的动作开始位置。 单位和小数点位置依照P161的设定值。
开始位置移动速度 | 0～300000000[P161/sec] | 设定直至动作开始位置的马达的移动速度。 单位和小数点位置依照P161的设定值。
动作方向 | ＋方向、－方向、往返 | 可选择马达的动作方向。
移动量 | -2147483648～2147483647 [P161] | 设定马达的移动量。 单位和小数点位置依照P161的设定值。
速度 | 0～300000000[P161/sec] | 设定马达的动作速度。 单位和小数点位置依照P161的设定值。
停止时间 | 0.000～999.999[s] | 设定自定位完成后直至后续定位开始的停止时间。
SEL选择 | SEL.0、SEL.1、SEL.2、SEL.3、SEL.4、SEL.5、SEL.6、SEL.7 | 马达在所选择的SEL的加减速时间内动作。
加速时间 | -9.9～99999.9[ms] | 设定所选择的SEL的马达加速时间。
减速时间 | -9.9～99999.9[ms] | 设定所选择的SEL的马达减速时间。
S字时间1 | -9.9～1000.0[ms] | 设定所选择的SEL的马达S字时间1。 若对复选框予以勾选，就会对脉冲串指令的S字时间1设定相同的值。
S字时间2 | -9.9～1000.0[ms] | 对马达加减速时间及S字时间1进一步设定S字时间2。

附注

若在S字时间1的同时设定复选框处于OFF的状态下执行了测试运行的情况下变更SEL选择，就会显示以下信息。

若单击“是”按钮，就会在驱动器中设定S字时间1的值。

若单击“否”按钮，就会变更SEL选择。

若在[开始位置指定]为“ABS”，[HCP限制]为“HCP限制”，原点恢复尚未完成的状态下执行测试运行，就会显示以下信息。


3.17.3. 停止设定

项目名 | ON/OFF | 说明
USB通信切断时马达停止 | ON | 即使在测试运行动作中切断了USB通信的情况下，也会继续进行测试运行动作。
 | OFF | 在测试运行动作中切断了USB通信的情况下，将会停止测试运行动作。
循环停止 | ON | 返回动作开始位置，结束测试运行动作。
 | OFF | 在现在位置结束测试运行动作。


3.17.4. 测试运行的开始／停止

注意

若执行本功能，马达就会动作，所以要在充分确认安全的基础上进行操作。

1) 若单击[开始]按钮，就会显示以下信息。

2) 动作中以一定间隔更新状态。

动作中的状态在状态中显示。

状态 | 状态
RUNNING[执行次数] | 执行中
CYCLE STOP RUNNING[执行次数] | 循环停止执行中
STOP[执行次数] | 中途停止
ALARM STOP[执行次数] 警报名 | 警报停止 警报的名称
WARNING STOP[执行次数] | 警告停止
FORCED STOP[执行次数] | 强制停止
USB CLOSE | 无法与驱动器进行USB通信

3) 停止运行时

① 单击了[循环停止]按钮的情况下，通过循环停止来停止测试运行。(只限于[停止设定]的[循环停止]为ON的情形)

② 单击了[减速停止]按钮的情况下，通过减速停止来停止测试运行。

③ 单击了[急速停止]按钮的情况下，通过急速停止来停止测试运行。

④ 按下了[Esc]键的情况下，通过急停止来停止测试运行。


3.17.5. 动作状态的显示

若单击视窗的右上的 [image] ，就会显示动作状态。

若单击 [image] ，就可隐藏动作状态。

动作状态的显示内容如下所示。

项目名 | 说明
现在位置 | 显示马达的现在位置(C021)。
定位目标位置1 | 显示后续的定位目标位置。
定位目标位置2 | 显示定位目标位置1后续的定位目标位置。
速度 | 显示马达的实际动作速度(C001)。

动作方向配合马达的动作方向显示黄色箭头。

状态 | τDISC |  |  | τ直线马达
 | 往返 | ＋方向 | －方向 | 往返 | ＋方向 | －方向
未执行 |  |  |  |
停止中 |  |  |  |  |  |
＋方向动作中 |  |  |  |  |  |
－方向动作中 |  |  |  |  |  |

附注

马达动作中、停止中的判断，通过SZ信号来作出判断。

不管是否在马达动作中，在没有显示黄色箭头的情况下，请将SZ信号速度范围(P651)设定为未满马达动作速度。

动作方向的显示，可通过以下设定来设定为相反方向。

项目名 | 说明
通常设定 | 显示马达的动作方向。
特殊设定 | 反相显示马达的动作方向。


3.17.6. 基于VPH驱动器的追加显示

VPH-HB驱动器、VPH-HD驱动器、VPH-HE驱动器的情况下，追加显示将单位换算为“deg”或者“mm”的项目。

有关追加显示部分，在与VPH驱动器无法通信的情况下，动作参数设定会成为空白，动作状态成为“0.00”。

换算后追加显示的项目如下所示。

动作参数设定 | 动作显示
动作开始位置 | 现在位置
开始位置移动速度 | 定位目标位置1
移动量 | 定位目标位置2
速度 | 速度


3.17.7. 视窗关闭

关闭所显示的定位测试运行视窗的情况下，单击[关闭]按钮，或单击[×]按钮。

测试运行执行后的情况下，显示以下信息。

附注

在S字时间1的同时设定复选框处于OFF的状态下执行了测试运行的情况下，会显示以下信息。

若单击“是”按钮，就会在驱动器中设定S字时间1的值。

若单击“否”按钮，就会直接结束画面。


3.18. 自诊断视窗

从电脑上执行驱动器的自诊断。

注意

根据自诊断的项目内容将伴有伺服动作，所以要在充分确认安全的基础上进行操作。


3.18.1. 视窗的显示

若从主工具条单击[调整功能]标签→[自诊断]，就会显示本视窗。


3.18.2. 自诊断项目的选择

从[诊断项目选择(DG No.)]组合框中选择自诊断项目。


3.18.3. 自诊断的开始／结束

① 开始自诊断的情况下，单击[诊断开始]按钮。
开始诊断后，[诊断开始]按钮将变为[诊断结束]按钮。

② 结束自诊断情况下，单击[诊断结束]按钮。
结束诊断后，[诊断结束]按钮将变为[诊断开始]按钮。


3.18.4. 诊断结果的显示

自诊断中／诊断结束时的诊断结果，将会在[诊断内容的设定／显示]框内显示。


3.18.5. 视窗关闭

关闭所显示的自诊断视窗的情况下，单击[×]按钮。

自诊断执行后的情况下，会显示如下信息。


3.19. 设备监控器视窗

对驱动器内的设备内容进行监控。


3.19.1. 视窗的显示

若从主工具条单击[状态显示]标签→[设备监控器]，就会显示本视窗。

视窗的概要

① [Bit]项目：可进行Bit单位（0/1）的读出/写入。

② [Word]项目：可进行Word单位（-32768～32767）的读出／写入。

③ [Long]项目：可进行Long单位（-2147483648～2147483647）的读出／写入。

④ [IX Device]、[R Device]、[D Device] 、[X Device]的情况下，可在相应的边框内直接进行数据的操作。

⑤ 其他的设备（X/R/D/IX）的情况下，可在[ Device][Word]／[Long]边框内指定设备的类别来进行数据的操作。

⑥ 可利用[R]按钮从驱动器读出数据。

⑦ 可利用[W]按钮向驱动器写入数据。


3.19.2. 数据的读出

1) 向各边框内的设备编号输入区域(①)输入设备编号。

通过单击[▲][▼]按钮(②)也会使得设备编号增减。

可利用递增调整组合框(③)来指定增减量。

2) 单击[R]按钮(④)。

3) 在各边框内的数据区域(⑤)中显示读出的数据。

浮动小数值显示区域(⑥)浮动显示读出的32bit数据。

4) 在状态显示框(⑦)中显示读出时的处理结果。

（正常结束时：显示OK／异常结束时：显示ＮＧ。）


3.19.3. 数据的写入操作

1) 向各边框内的设备编号输入区域(①)输入设备编号。

通过单击[▲][▼]按钮(②)也会使得设备编号增减。

可利用递增调整组合框(③)来指定增减量。

2) 向数据区域(④)输入要写入的值。

3) 单击[W]按钮(⑤)。

4) 在状态显示框(⑥)中显示写入时的处理结果。

正常结束时：显示OK／异常结束时：显示NG。）


3.19.4. 实时更新

1) 对[实时更新]复选框予以勾选。

2) [R][W]按钮将会无效。

3) 在数据区域显示所指定的设备编号的数据，实时地进行更新。


3.19.5. 视窗关闭

关闭所显示的自诊断视窗的情况下，单击[关闭]按钮，或单击[×]按钮。


3.20. 版本视窗

显示本软件的版本信息。

从菜单条单击[帮助(H)] →[版本信息(V)]。


4. 通信错误

4.1. 错误内容

执行USB通信时显示有如下信息的情况下，请确认信息中所显示的内容。


5. 数据导入

5.1. 关于数据导入

本功能是导入驱动器马达信息，在没有软件的版本升级下可使用新追加的驱动器及马达的功能。

附注

数据导入功能与VPH Data Editing Software Version 1.0.0或更新版对应。


5.2. 数据导入方法

1) 单击驱动器、马达的选择视窗的[数据导入]按钮。

2) 显示再启动软件的信息，单击[确定]。

3) 在显示UAC(用户帐号控制)的确认信息后，请单击[是]。

4) 单击已被再启动的驱动器、马达的选择视窗的[数据导入]按钮。

5) 显示打开文件的对话框，选择导入文件，单击[打开]按钮。

6) 导入处理中显示表示进度状况的进度条。

7) 显示以下信息，数据导入完成。

附注

在数据导入没有正常结束的情况下，会显示以下信息。


6. 附录

6.1. 文件扩展名一览

本软件中使用的文件扩展名如下所示。

名称 | 驱动器类别 | 马达类别 | 扩展名 | 打开 | 保存
参数 | VPH-HA | τDISC | *.c0pa0 | ○ | ○
 | VPH-HA | τ直线马达 | *.c0pa1 | ○ | ○
 | VPH-HB | τDISC | *.c1pa0 | ○ | ○
 | VPH-HB | τ直线马达 | *.c1pa1 | ○ | ○
 | VPH-HC | τDISC | *.c2pa0 | ○ | ○
 | VPH-HC | τ直线马达 | *.c2pa1 | ○ | ○
 | VPH-HD | τDISC | *.c3pa0 | ○ | ○
 | VPH-HD | τ直线马达 | *.c3pa1 | ○ | ○
 | VPH-HE | τDISC | *.c4pa0 | ○ | ○
 | VPH-HE | τ直线马达 | *.c4pa1 | ○ | ○
 | ALL | ALL | *.csv | × | ○
程序数据 | VPH-HA | ALL | *.c0pro | ○ | ○
 | VPH-HB | ALL | *.c1pro | ○ | ○
 | VPH-HC | ALL | *.c2pro | ○ | ○
 | VPH-HD | ALL | *.c3pro | ○ | ○
 | VPH-HE | ALL | *.c4pro | ○ | ○
间接数据 | VPH-HA | ALL | *.c0ind | ○ | ○
 | VPH-HB | ALL | *.c1ind | ○ | ○
 | VPH-HC | ALL | *.c2ind | ○ | ○
 | VPH-HD | ALL | *.c3ind | ○ | ○
 | VPH-HE | ALL | *.c4ind | ○ | ○
示波器数据 | ALL | ALL | *.cxosc | ○ | ○
 | ALL | ALL | *.cxlog | ○ | ○
 | ALL | ALL | *.csv | × | ○
频谱数据 | ALL | ALL | *.cxfrs | ○ | ○
频率响应数据 | ALL | ALL | *.cxfrr | ○ | ○
成批数据 | VPH-HA | ALL | *.c0adb | ○ | ○
 | VPH-HB | ALL | *.c1adb | ○ | ○
 | VPH-HC | ALL | *.c2adb | ○ | ○
 | VPH-HD | ALL | *.c3adb | ○ | ○
 | VPH-HE | ALL | *.c4adb | ○ | ○

※ALL对应全部类别


6.2. 关于文件拖放

通过将文件拖放至支持本软件的视窗来打开拖放来的文件。


6.2.1. 对应视窗、文件一览

 |  | 对象视窗
 |  | 驱动器 | 主 | 参数 | 程序 | 间接 | 示波器 | 频谱 | 频率响应
拖放的文件 | 参数(*.c*pa**) | ○ | ○ | ○ | × | × | × | × | ×
 | 参数(*.csv) | × | × | × | × | × | × | × | ×
 | 程序(*.c*pro*) | ○ | ○ | × | ○ | × | × | × | ×
 | 间接数据(*.c*ind*) | ○ | ○ | × | × | ○ | × | × | ×
 | 示波器数据(*.cxosc*, *.cxlog) | ○ | ○ | × | × | × | ○ | × | ×
 | 示波器数据(*.csv) | × | × | × | × | × | × | × | ×
 | 频谱数据(*.cxfrs*) | ○ | ○ | × | × | × | × | ○ | ×
 | 频率响应数据(*.cxfrr*) | ○ | ○ | × | × | × | × | × | ○
 | 频率响应数据(*.csv) | × | × | × | × | × | × | × | ×
 | 成批数据(*.c*adb*) | × | × | × | × | × | × | × | ×

※视窗简称：正式名称

驱动器：驱动器马达选择视窗、主：主工具条视窗、参数：参数编辑视窗、程序：程序编辑视窗

间接：间接数据编辑视窗、示波器：示波器视窗、频谱：频谱视窗、频率响应：频率响应测量视窗


6.2.2. 不对应拖放的视窗

下述视窗不对应通过拖放来打开文件。

视窗名称

状态显示视窗

输入输出信号状态显示视窗

设备监控器视窗

自诊断视窗

自整定视窗

实时伺服调整视窗

测试运行视窗

开关箱视窗

版本显示视窗

数据比较视窗

打印视窗


6.3. csv文件的数据结构

这里列出以csv文件保存数据时的数据结构。

注意

以csv文件格式保存的文件，无法利用本软件来打开。

参数数据csv文件结构

NAME | 文件名 |  |  |  |  |  |  |
DEF | 参数编号 | 设备编号 | 参数名称 | 单位 | 设定范围 | 设定值 | 初期值 | 显示状态

示波器数据csv文件结构

NAME | 文件名 |  |  |  |
DEF | 15 |  |  | 通道设定 |
DEF | 0 | CH1显示最大值 | CH1显示偏移量 |  | CH1: CH1的名称
DEF | 1 | CH2显示最大值 | CH2显示偏移量 |  | CH2: CH2的名称
DEF | 2 | CH3显示最大值 | CH3显示偏移量 |  | CH3: CH3的名称
DEF | 205 |  | CH4显示偏移量 |  | CH4: CH4的名称
DEF | 数据解析度[msec] |  |  | 数据解析度 |
DEF | 290 |  | 2 |  | 2
DEF | 291 |  | 1 |  | 0
DEF | 292 |  | 3 |  | 0
DEF | 293 |  | 0 |  | 0
DEF | 294 |  | 7 |  | 6
DAT | 数据获取时间[sec] | CH1数据 | CH2数据 | CH3数据 | CH4数据

附注

CH*显示偏移量，只输出测量项目中设定了信号的CH。

速度系统的数据，输出所显示的单位制的数据。

信号数据为0时OFF，为1时ON。

频率响应数据csv文件结构

NAME | 文件名 |  |
 | 【测量条件】 | 设定值 | 单位
DEF | 测量增益编号 | 0 |
DEF | 测量频率 | 4000 | [Hz]
DEF | 励振宽幅(速度指令量) | 1 | [%]
DEF | 励振宽幅(偏移量) | 0 | [%]
DEF | 励振时间 | 3000 | [msec]
DEF | 允许最大振动量 | 0 | [pulse]
DEF | 计测次数 | 3 | 【次】
 | 【陷波滤波器】 | 设定值 | 单位
DEF | 中心频率1 | 0 | [Hz]
DEF | 带宽率1 | 0 | [%]
DEF | 深度1 | 0 | [-dB]
DEF | 中心频率2 | 0 | [Hz]
DEF | 带宽率2 | 0 | [%]
DEF | 深度2 | 0 | [-dB]
DEF | 中心频率3 | 0 | [Hz]
DEF | 带宽率3 | 0 | [%]
DEF | 深度3 | 0 | [-dB]
DEF | 中心频率4 | 0 | [Hz]
DEF | 带宽率4 | 0 | [%]
DEF | 深度4 | 0 | [-dB]
DEF | 中心频率 | 0 | [Hz]
DEF | 带宽率 | 0 | [%]
DEF | 深度 | 0 | [-dB]
 | 【频率响应】 |  |
 | 频率[Hz] | 振幅[dB] | 相位[deg]
DAT | 0.244110826 | -0.3161 | 0
DAT | 0.488221653 | -0.3032 | -0.2199
DAT | 0.732332479 | -0.2988 | -0.1022
DAT | ～ | ～ | ～
DAT | 3999.511778 | -11.7789 | 17.4333
DAT | 3999.755889 | -11.8517 | -153.2895
DAT | 4000 | -13.3143 | 22.0282