VPH Data Editing Software Help

(c) 2014 CKD NIKKI DENSO CO., LTD.

Ver. 4.0


1. はじめに

1.1. 安全にご使用いただくために

本書は「VPH Data Editing Software」の操作手順、注意事項などを説明したものです。

VPHシリーズの性能を十分にご利用いただく為に、ご使用になる前によくお読み下さい。

本書の本文中において「VPH Data Editing Software」を「本ソフトウェア」と表記します。

本書では、安全注意事項のランクを『危険』、『注意』として表示区分してあります。

危険

この表示は取り扱いを誤った場合に、危険な状況が起こりえて、死亡または重症を受ける可能性が想定されることを示しています。

注意

この表示は取り扱いを誤った場合に、危険な状況が起こりえて、中程度の障害や軽症を受ける可能性が想定される場合および、物的傷害のみの発生が想定されることを示しています。

注記

操作の注意点を示しています。


1.2. その他のご注意

・本書の内容に関して、将来予告なしに変更することがあります。

・本書の内容につきましては万全を期して作成しておりますが、万一不審な点や誤りなどお気づきになりましたらご連絡をお願い申し上げます。

・本ソフトウェアの運用を理由とする損失、逸失利益などの請求につきましては、いかなる責任も負いかねますので、予めご了承ください。

・製品改良のため、将来予告なく概観または仕様の一部を変更する場合があります。

・Windows は米国 Microsoft Corporation の米国およびその他の国における登録商標です。

・ENSIS®は、株式会社ミツトヨの登録商標です。

・リニヤスケール®は、株式会社ミツトヨの登録商標です。

・BiSS®は、iC-Haus GmbHの登録商標です。

・EnDat®は、ハイデンハイン株式会社の登録商標です。


1.3. ソフトウェアの使用許諾条件

ＶＰＨシリーズ向けシステム支援ツール

VPH Data Editing Software

使用許諾条件

ＶＰＨシリーズ向けシステム支援ツールをインストールする前に、以下に記載する使用許諾条件（以下「使用許諾条件」といいます）を必ずお読み下さい。ユーザが本ソフトウェアをインストールした時点で、ユーザはＣＫＤ日機電装株式会社の提示する使用許諾条件の内容全てに同意されたものとさせて頂きます。

使用許諾条件は、インストールしたユーザの他、個人、法人を問わず、本ソフトウェアを使用する全ての者に適用されます。同意いただけない場合は、本ソフトウェアのインストール、及び使用をしないでください。

１．定義

1.1　「ユーザ」とは、ＣＫＤ日機電装株式会社がユーザ登録を行って、本ソフトウェアの使用を認め、ライセンスを与えた者をいいます。

1.2　「本ソフトウェア」とは、使用許諾条件とともにＣＫＤ日機電装株式会社のウェブサイトからダウンロードする方式で配布され、ユーザ側のコンピュータで動作する下記のソフトウェアをいいます。

      品名：サーボドライバＶＰＨシリーズ向けシステム支援ツール

            VPH Data Editing Software

      型式：NPS-VPHDESN3

1.3　「本ソフトウェア一式」とは1.2項の本ソフトウェアとそれに付属するマニュアル等一切の著作物（ＰＤＦ等による電子文書を含む）を包含したものをいいます。

1.4　「ライセンス」とは、1.1項のユーザに対しＣＫＤ日機電装株式会社が別途定める方法及び手続によって付与した、本ソフトウェアの使用権限をいいます。

２．ユーザ登録

2.1　 ユーザは、本ソフトウェアのダウンロードに当たり、ＣＫＤ日機電装株式会社にユーザ登録申請を行うことが必要です。ユーザ登録はＣＫＤ日機電装株式会社ウェブサイトから会員登録又はお客様情報の入力によって行うこととし、必要項目その他の詳細はＣＫＤ日機電装株式会社が定めるものとします。

2.2　 ＣＫＤ日機電装株式会社は、2.1項のユーザ登録情報を確認しユーザ登録を行います。なお、ＣＫＤ日機電装株式会社は、ユーザ登録情報のほか、必要に応じサーボドライバＶＰＨシリーズの購買履歴等のユーザ情報を参照するものとします。

2.3　 ユーザは、ユーザ登録事項に変更がある場合は、速やかにＣＫＤ日機電装株式会社に届けるものとします。

2.4 　ＣＫＤ日機電装株式会社は、ユーザによる使用条件の違反があった場合、及びハッキング、その他やむを得ない事情により本ソフトウェアの通常稼働が困難と判断した場合は予告なしにユーザ登録の削除、ライセンスの停止を行うことがあります。

３．使用許諾の範囲

3.1 ＣＫＤ日機電装株式会社は、ユーザが本契約記載の使用条件を承諾し順守することを条件として、本ソフトウェア一式に関して、ライセンスを付与することによって使用（ダウンロード及びコンピュータへのインストールを含みます）を許諾するものとします。

3.2　 前項の許諾の対価は、無償とします。

3.3　ユーザは第三者に対し本ソフトウェアの再使用を許諾することはできません。

3.4　ユーザはバックアップの目的に限り、本ソフトウェア等の複製物を１部のみ作成することができるものとします。

４．著作権の帰属

本ソフトウェア一式に関する著作権は、ＣＫＤ日機電装株式会社に帰属します。本ソフトウェアが記録された媒体及びそれに付属するマニュアル等の譲渡は、本ソフトウェア一式の著作権を譲渡するものではありません。

５．譲渡、貸与、頒布等の禁止

本ソフトウェア一式及びライセンスは、上記目的以外で使用すること、及び第三者へ譲渡・頒布・貸与・送信その他の使用をすることはできません。

６．解析・改変等の禁止

ユーザは、本ソフトウェア一式の全部または一部に対し、逆コンパイル、リバースエンジニアリング、逆アセンブル、修正、改変（ソースコードの改変も含む）、翻案または二次的著作物の創作を行うことはできません。

７．責任の制限

7.1　ＣＫＤ日機電装株式会社は、本ソフトウェア一式の品質、性能がユーザの使用目的に適合することを保証しません。

7.2 本ソフトウェア一式について、第三者との間で製造物責任に関する紛争、及び著作権その他知的財産権に関連する紛争が生じた場合もＣＫＤ日機電装株式会社は責任を負いません。

7.3 ＣＫＤ日機電装株式会社が本ソフトウェア一式を改良（バグ修正）したときは、必要に応じユーザに対して修正後の本ソフトウェア一式及び修正に関する情報を提供します。但し、提供の時期、方法その他の詳細についてはＣＫＤ日機電装株式会社の裁量によって決定するものとします。なお、修正後の本ソフトウェア一式にもこの使用許諾条件が適用されるものとします。

7.4　7.1項乃至7.3項に定めるほか、ＣＫＤ日機電装株式会社は、法が禁じない範囲において、本ソフトウェア一式の使用もしくは使用不可に起因するかもしくは関連する、機械・設備・製品・半製品等の損傷、逸失利益、データの消失、仕事の中断またはその他の財産的損害または損失、生命・身体的損害または損失等を含む一切の損害等についていかなる責任も負いません。

7.5 7.1項乃至7.4項その他この使用許諾条件の規定によってもＣＫＤ日機電装株式会社の免責が認められない場合、ユーザに生じた全ての損害に関するＣＫＤ日機電装株式会社の賠償責任総額は本ソフトウェア一式の代金額を上限とします。

８．契約の解除

ユーザが本使用許諾条項の規定のいずれかに違反した場合、ＣＫＤ日機電装株式会社は、直ちに、本ソフトウェア一式の使用許諾を解除することができます。その場合、ユーザは、その費用負担により、本ソフトウェア一式及びその複製物を速やかに返還するか、または回復不可能な方法により破棄して頂くこととします。

９．契約の分離性

何らかの理由により、本使用許諾条項のいずれかの条項またはその一部について効力がないものとされた場合であっても、本契約の他の条項または部分は、依然として完全な効力を有するものとします。

１０．準拠法

本使用許諾条項は日本法に準拠し、日本法に従って解釈されるものとします。

１１．紛争解決

11.1 本ソフトウェア一式及びこの使用許諾条件に関するＣＫＤ日機電装株式会社とユーザとの間の訴訟については、プログラム著作権に関連するものについては東京地方裁判所を第一審の専属的合意管轄裁判所とし、その他の訴訟については千葉地方裁判所を第一審の専属的合意管轄裁判所とします。

11.2 11.1項の規定に関わらず、ユーザが日本国外に所在する場合は、本使用許諾条項から又は本使用許諾条項に関連して、ＣＫＤ日機電装株式会社とユーザとの間に生ずることがあるすべての紛争、論争又は意見の相違は、一般社団法人日本商事仲裁協会の商事仲裁規則に従って、日本国東京都において仲裁により最終的に解決されるものとします。


1.4. 概要

本ソフトウェアは、パーソナルコンピュータ上からVPH装置の

① パラメータ編集、プログラム編集、間接データ編集

② オシロデータ／周波数スペクトルデータ／周波数応答データの測定と表示

③ リモート運転、運転状態表示

④ オートチューニング、リアルタイムサーボ調整、テスト運転

⑤ 自己診断／内部制御情報のモニタ等を行うためのソフトウェアです。


1.5. システム環境

本ソフトを使用するには、下記のシステム構成が必要です。

尚、VPH装置とデータ通信（パラメータ転送他）を行う場合は、パーソナルコンピュータ以外にUSBケーブル（市販品）が必要になります。

※弊社ではUSBケーブルをオプションとして用意しておりません。

パーソナルコンピュータ | PC/AT互換機（USBコネクタが利用可能であること）
OS | Windows7 32bit/64bit(Ultimate, Professional,Enterprise, Home Premium) Windows 8/8.1 32bit/64bit(無印, Pro, Enterprise) Windows 10 32bit/64bit(Home, Pro, Enterprise)
CPU | 1GHz以上のプロセッサ
メモリ | 1GB(32bit)または2GB(64bit)のRAM以上
ハードディスク | 1GB以上
ディスプレイ | XGA（1024×768 pixel）以上
対応言語 | Japanese, English, Chinese(simplified), Chinese(traditional), Korean
その他 | .NET Framework 4.0以上 Visual C++ 2010 ランタイム


1.6. 輸出管理について

本製品や提供しようとする技術の用途及び需要者が、大量破壊兵器等の開発等や通常兵器の開発等に使用されるおそれがある場合は、「外国為替及び外国貿易法」の定める輸出規制の対象となることがありますので、輸出される際には十分な審査及び必要な輸出手続きをお取りください。


2. インストール／アンインストール

2.1. 本ソフトウェアのインストール

1) [Setup.exe]をダブルクリックしてし、本ソフトウェアのインストールを開始します。

2) USBドライバがインストールされていない場合。

USBドライバのインストール画面が表示されますので、画面に従いインストールを行ってください。

USBドライバのインストール方法は「2.3. USBドライバのインストール」を参照してください。

3) .NET Framework4.0がインストールされていない場合。

次の画面が表示されます。[同意する]ボタンをクリックして下さい。

4) .Net Framework4.0のインストールが行われます。

インストール完了時に本ダイアログは、自動的に閉じられます。

5) VisualC++ 2010ランタイムライブラリがインストールされていない場合。

次の画面が表示されます。[インストール]ボタンをクリックし、以下の通りにインストールを行って下さい。

6) [同意する]チェックボックスにチェックを入れ、[インストール]ボタンを

クリックします。

7) VisualC++ 2010ランタイムライブラリのインストールが完了すると次の画面が表示されます。

[完了]ボタンをクリックし、本ソフトウェアのインストールに進みます。

8) 必要なコンポーネントがインストールされている場合。

次の画面が表示されます。[次へ]ボタンをクリックして下さい。

9) ソフトウェアの使用許諾に同意される場合。

[ソフトウェア使用許諾契約書に同意します]を選択し [次へ]ボタンをクリックして下さい。

[同意しない]場合本ソフトウェアのインストールを行えません。

10) インストール先のディレクトリを変更する場合。

[変更]ボタンをクリックして変更して下さい。続いて[次へ]ボタンをクリックして下さい。

11) インストールの確認。

これまで入力した内容でインストールを行う場合、[インストール]ボタンをクリックして下さい。

12) インストールプログラムの実行経過が表示されます。

13) インストールが完了すると次の画面が表示されます。

[終了]ボタンをクリックして下さい。


2.2. 本ソフトウェアのアンインストール

1) Windowsタスクバーの[スタート]－[コントロールパネル]－[プログラムと機能]をクリックして、[プログラムと機能]ウィンドウを表示して下さい。

2) リストボックス内の[VPH Data Editing Software]を選択して、[アンインストール]ボタンをクリックして下さい。

3) [はい]ボタンをクリックして下さい。

4) 次の画面が表示されアンインストールが完了します。


2.3. USBドライバのインストール

[USB_Driver]フォルダをダブルクリックします。

お使いのPCのOSが32bitの場合dpinst32.exeを、64bitの場合dpinst64.exeを実行し、以下のウィザードに従ってインストールを行って下さい。

1) 開始画面から[次へ(N)]ボタンをクリックしてください。

2) 以下の画面で[インストール(I)]をクリックします。

3) USBドライバのインストールが開始されます。

4) 次の画面が表示されUSBドライバのインストールが完了します。

5) VPH装置をUSBポートに接続します。

以下のポップアップが表示され、ソフトウェアのインストールが完了します。


2.4. USBドライバのアンインストール

1) Windowsタスクバーの[スタート] - [コントロールパネル] - [プログラムと機能]をクリックして、[プログラムと機能]ウィンドウを表示して下さい。

2) リストボックス内の[Windows ドライバパッケージ – CKD NIKKI DENSO CO.,LTD.(WinUSB)CKD NIKKI DENSO VPH USB Device]を選択して、[アンインストールと変更]ボタンをクリックして下さい。

3) [はい]ボタンをクリックして下さい。


3. 機能と操作

3.1. 本ソフトウェアの起動

本ソフトウェアを起動するには、Windows のタスクバーから

[スタート]→[プログラム(P)]→

[NikkiDenso]→[VPH Data Editing Software]→[Nikki VPH DES]

を選択するか、デスクトップに作成された[Nikki VPH DES]ショートカットより実行してください。

次のロゴマークが表示された後、装置・モータ選択ウィンドウが表示されます。


3.2. 装置モータ選択ウィンドウ

使用する装置モータを選択します。


3.2.1. VPH装置からの装置情報の読込みによる装置モータ選択

1) 本ソフトウェアとVPH装置が接続されていてかつ装置の電源がオンの場合は、[装置から設定を取得する]ボタンをクリックして装置内に登録されている情報を読出します。

※画面起動時にVPH装置が接続されていた場合、自動的に装置内に登録されている情報を読み出します

2) 読出した情報を基に装置情報、モータ情報が選択された状態で画面に表示されます。

3) [決定]ボタンをクリックしてメインツールバーに移行します。

本ソフトウェアとVPH装置がUSB通信できない場合

表示されたメッセージの内容を確認してください。

本ソフトウェアで使用できないVPH装置が接続されている場合

このメッセージが表示された場合、接続しているVPH装置に適応したソフトウェアにアップデートする必要があります。

弊社担当営業までご連絡下さい。

本ソフトウェアで使用できないモータ情報がVPH装置に設定されている場合

使用するモータがモータ欄に存在するか確認して下さい。

使用したいモータが見つからない場合、ソフトウェアのアップデートが必要です。

弊社担当営業までご連絡下さい。


3.2.2. 手動による装置モータ選択

本ソフトウェアとVPH装置がUSB通信できない場合、直接使用するVPH装置とモータを選択します。

1) 装置の選択

装置欄のコンボボックスを上から順に選択します。

2) モータの選択

モータ欄のコンボボックスを上から順に選択します。

製品分類によっては値の入力を求められることがあります。

3) [決定]ボタンをクリックしてメインツールバーへ移行します。


3.2.3. ファイルドロップによる装置モータ選択

本画面にファイルをドロップすることで、自動的に装置モータ選択を行いパラメータファイルを開きます。

※ドロップ可能なファイルは[6.2. ファイルドロップについて]を参照

1) 開きたいパラメータファイルをドラッグし、本画面上にドロップします。

2) 本画面が閉じられメインツールバーが表示されます。

3) ドロップしたパラメータファイルが表示されます。


3.2.4. 装置モータ選択のメッセージ

装置モータ選択画面からメインツールバーに移行する前に以下のようなメッセージが表示されることがあります。

その場合メッセージに従い操作してください。

装置の選択は合っているが、VPH装置内のモータ情報が未設定の場合 |
装置の選択は合っているが、モータ選択がVPH装置内の情報と異なる場合 ※モータを変更した場合必ず表示されます |
再起動が必要なパラメータが変更された場合 |
選択されている装置選択と、VPH装置の情報が異なる場合 | DeviceDifferenceAlart
完全に一致する装置情報が見つからなかった場合 |
モータエンコーダ関連パラメータを装置に送信したときに、ネットワーク通信中の場合 |
装置の自動再起動を実行しようとしたときに、ネットワーク通信中の場合 |
エンコーダタイプをBiSSエンコーダに変更した場合 |
エンコーダタイプをハイデンハインABSエンコーダに変更した場合 |


3.2.5. 表示言語切換

本ソフトウェアの表示言語を切り替えます。

1) 言語選択コンボボックス(Display language choice)を変更します。

2) 言語を変更した場合、再起動の確認メッセージを表示します。

3) 「OK」をクリックすると選択した言語で本ソフトウェアが起動します。


3.3. メインツールバーウィンドウ

本ソフトウェアのメイン画面で、各機能の画面を起動します。

メニューバー

本ソフトウェアの機能を選択するメニューが表示されます。

メインツールバー

本ソフトウェアの機能を選択するボタンが表示されます。

ステータスバー

装置のUSB接続状態、パラメータの反映状態、指令単位、設定単位、装置形式、モータ型式が表示されます。

① USB接続状態：

装置と通信可能です。

装置と通信できません。

注記

設定と異なる装置が接続された場合、以下のメッセージが表示されます。

装置・モータ選択画面に戻り、再設定してください。

② パラメータの反映状態：

表示なし | パラメータ値は最新の状態です。
restart | パラメータ値を反映する為に電源再投入が必要です。 クリックすると、電源の再投入を行います。
reset | パラメータ値を反映する為にRST信号の入力が必要です。 クリックすると、RST信号の入力を行います。

③ アラーム、ワーニング状態：

表示なし | アラーム、ワーニングの発生はありません。
 | アラーム発生時に表示します。
 | ワーニング発生時に表示します。

④ ネットワーク通信状態：

表示なし | ネットワーク未使用の装置です。
 | 装置がメンテナンスモードです。 クリックすると、機能モード切替画面を表示します。
 | 装置がメンテナンスモードです。 MODEスイッチがONか、MTON信号がONの状態の為、通信モードに切り替えられません。
 | 装置が通信モードです。 クリックすると、機能モード切替画面を表示します。
 | 装置が通信モードです。 ネットワーク接続中の為、メンテナンスモードに切り替えられません。

⑤ 単位：

選択中の位置単位と位置小数単位を表示します。

⑥ 装置形式：

選択中の装置形式を表示します。

⑦ モータ型式：

選択中のモータ型式を表示します。

装置・モータ選択ウィンドウへ戻る

本ソフトウェアが起動された時または任意の時点で装置モータ選択の実行が可能です。

メニューバーから

[ファイル(F)]→[装置・モータ選択(D)]

を選択すると現在開いている画面全てを閉じます。

注記

編集途中の画面が存在する場合、画面を閉じるかを確認します。

全ての画面を閉じる場合は、装置モータ選択に戻ります。

閉じない画面が残る場合は、装置モータ選択に戻りません。

下記機能が実行中の場合、装置モータ選択に戻れません。

パラメータ、プログラム、間接データ、一括データ送受信中

オシロ測定、周波数スペクトルの測定中

周波数応答、自己診断、テスト運転、オートチューニング実行中


3.3.1. 電源再投入、RST信号入力

1) 電源再投入

ステータスバーの電源再投入のアイコン restart をクリックすると、下記のような確認メッセージが表示されます。

装置を再起動する場合は[OK]をクリックし、中止する場合は[キャンセル]をクリックしてください。

注記

MTON信号がONの場合、以下のメッセージが表示されます。

サーボオフ後、再度電源再投入のアイコン restart をクリックしてください。

装置がネットワーク通信中の場合、以下のメッセージが表示されます。

電源再投入を手動で行ってください。

2) RST信号入力

ステータスバーのRST信号入力のアイコン reset をクリックすると、下記のような確認メッセージが表示されます。

RST信号を入力する場合は[OK]をクリックし、中止する場合は[キャンセル]をクリックしてください。

注記

MTON信号がONの場合、以下のメッセージが表示されます。

サーボオフ後、RST信号入力のアイコン reset をクリックしてください。

装置がネットワーク通信中の場合、以下のメッセージが表示されます。

電源再投入を手動で行ってください。


3.3.2. 機能モード切替

ステータスバーのネットワーク通信状態のアイコン( [image] 又は [image] )をクリックすると、機能モード切替ウィンドウが表示されます。

通信モードの場合

メンテナンスモードの場合

注記

MODEスイッチがONの場合、以下のメッセージが表示されます。

MTON信号がONの場合、以下のメッセージが表示されます。

サーボオフ後、再度アイコンをクリックしてください。

装置がネットワーク通信中の場合、以下のメッセージが表示されます。

ネットワークと切り離してから再度アイコンをクリックしてください。

1)表示されている切替コードを入力し、[Enter]キーを押下します。

2)機能モード切替ボタンがクリック可能になります。

通信モードの場合

メンテナンスモードの場合

3)機能モード切替ボタンをクリックすると、下記のような確認メッセージが表示されます。

通信モードの場合

メンテナンスモードの場合

モードを切り替える場合は[OK]をクリックし、中止する場合は[キャンセル]をクリックしてください。

注記

MTON信号がONの場合、以下のメッセージが表示されます。

サーボオフ後、[機能モード切替]ボタンをクリックしてください。

装置がネットワーク通信中の場合、以下のメッセージが表示されます。

ネットワークと切り離してから再度[機能モード切替]ボタンをクリックしてください。

注記

本画面に対応するファイルをドロップすることで、ファイルを開くこともできます。

※対応するファイルは[6.2. ファイルドロップについて]を参照


3.4. 本ソフトウェアの終了

本ソフトウェアは、装置モータ選択画面の[×]ボタン、メインツールバーのメニューバー選択又は[×]ボタンより終了します。

① 装置モータ選択画面の[×]ボタン

1) 装置モータ選択画面の右上の[×]ボタンをクリックします。

2) 終了確認メッセージの[OK]ボタンをクリックします。

② メインツールバーのメニュー

1) メインツールバーのメニューバーから

[ファイル(F)]→[終了(X)]

をクリックします。

2) 終了確認メッセージの[OK]ボタンをクリックします。

③ メインツールバーの[×]ボタン

1) メインツールバーの右上の[×]ボタンをクリックします。

2) 終了確認メッセージの[OK]ボタンをクリックします。


3.5. パラメータ編集ウィンドウ

VPH装置用のパラメータ編集を行います。


3.5.1. ウィンドウの表示

メニューバーから

[ファイル(F)]→[新規作成(N)]→[パラメータ(P)]

または

[ファイル(F)]→[開く(O)]→[パラメータ(P)]

または

[ファイル(F)]→[パラメータファイル変換]

メインツールバーの

[データ編集]タブ→[パラメータ]→[パラメータメニュー選択]


3.5.2. パラメータの編集

① パラメータの直接編集

1) マウスまたは、キーボード操作によって、パラメータを選択します。

2) 選択したパラメータをマウスでクリック、 [Enter]、[F2]キーを押下することでパラメータを編集状態にします。

・数値入力項目の場合：キーボードからデータを直接入力します。

・選択項目の場合：リストから項目を選択します。

3) フォーカスを外す、[Enter]、[Tab]、[F2]キーを押下することで、パラメータを確定します。

※グレーアウトしているパラメータは編集できません。

② パラメータのコピーと貼り付け

パラメータ編集ウィンドウ間のコピー／貼り付け

複数のパラメータウィンドウを表示している際に特定範囲のパラメータデータを他のウィンドウにコピーするのに便利な機能です。

1) パラメータデータのコピー

パラメータデータをコピーする場合は、コピー範囲をキーボードの[Shift]＋[↑]、[Shift]＋[↓]を押して指定するか、又はマウスでドラッグした後、マウス右クリック[コピー] を選ぶか、またはCtrl＋Cでコピーします。

2) パラメータデータの貼り付け

パラメータデータの貼り付け先をカーソルで指定し、マウス右クリックから[ペースト] を選ぶか、またはCtrl＋Vで貼り付けます。


3.5.3. パラメータ名称の検索

パラメータを選択した状態で、[Ｃｔｒｌ] ＋[Ｆ]を押すと、

パラメータ名称検索画面が表示されます。

①検索文字列を入力して、[次へ]又は[前へ]ボタンをクリックすると、

  検索文字列と一致するパラメータを選択します。

[次へ]ボタンの動作は、[Ｅｎｔｅｒ]又は[Ｆ３]キーを押しても同様の動作を行います。

[前へ]ボタンの動作は、[Ｓｈｉｆｔ] ＋ [Ｆ３]キーを押しても同様の動作を行います。

注記

一致するパラメータが見つからない場合、以下のメッセージが表示されます。

②[閉じる]ボタンをクリックすると、検索画面を終了します。

  [ＥＳＣ]又は[×]キーを押しても同様の動作を行います。


3.5.4. 単位・電子ギア設定

単位、電子ギア関連のパラメータを設定します。

3.5.4.1. ウィンドウの表示

パラメータ編集ウィンドウから

[単位、電子ギア設定] を選択する

  または

    対象のパラメータをダブルクリックする

と、本ウィンドウが表示されます。

注記

①既に[自動設定]が設定されている状態で本ウィンドウをオープンする際、以下のメッセージが表示されることがあります。

本メッセージは[自動設定]ではパラメータ編集ウィンドウで設定した位置単位が選択できない場合に表示されます。

②本ウィンドウで「設定モード」を[自動設定]に変更する際、以下のメッセージが表示されることがあります。

本メッセージは[自動設定]では現在選択されている位置単位が選択できない場合に表示されます。

[OK]：位置単位を適切な値に変更し、自動設定に移行します。

[キャンセル]：設定モードの変更をキャンセルします。

注記

③本ウィンドウで「設定モード」を[自動設定]に変更する際、以下のメッセージが表示されることがあります。

本メッセージは現在選択されている位置小数単位が不正であるため、正常に機械移動量・回転体位置範囲の自動設定ができない場合に表示されます。

位置小数単位を表示されている値に変更し、自動設定に移行します。

④本ウィンドウで「設定モード」を[自動設定]に変更する際、以下のメッセージが表示されることがあります。

本メッセージは現在設定されている、機械移動量、電子ギア比分子、電子ギア比分母、回転体位置範囲、回転体位置範囲符号切替位置の中に自動設定できない値が設定されている場合に表示されます。

[OK]：機械移動量、電子ギア比分子、電子ギア比分母、回転体位置範囲、回転体位置範囲符号切替位置に自動設定可能な値を設定します。

[キャンセル]：自動設定を中断します。

3.5.4.2. 単位、電子ギアの編集

設定モードの選択

本ウィンドウをオープンすると、設定モードを[自動設定][手動設定]から選択することができます。

自動設定

選択された位置単位と位置小数単位から、機械移動量／電子ギア比分子／電子ギア比分母／回転体位置範囲／回転体位置範囲符号切替位置を自動計算して設定します。

手動設定

位置単位と位置小数単位を選択したうえで、機械移動量／電子ギア比分子／電子ギア比分母／回転体位置範囲／回転体位置範囲符号切替位置を直接入力して設定します。

① 「設定モード」を[自動設定]にした場合

本ウィンドウが下図のように表示されます。

「設定モード」を[自動設定]にした場合は、以下の項目を編集することができます。

① 位置単位

② 位置小数単位

③ 回転体位置範囲

①～③の選択により、機械移動量／電子ギア比分子／電子ギア比分母／回転体位置範囲／回転体位置範囲符号切替位置を自動計算し、設定されます。

各項目の設定方法は以下を参照してください。

① 位置単位選択

位置単位を選択します。

本ソフトウェア起動時に設定したモータ製品分類(3.2. 装置モータ選択ウィンドウを参照)により、選択できる位置単位が異なります。

モータ製品種別 | 選択可能な位置単位
τDISC | deg、pulse、kpulse
τリニア | m、mm、um、inch、pulse、kpulse

② 位置小数単位選択

位置小数単位を選択します。

注記

本動作により以下のメッセージが表示されることがあります。

本メッセージは①で選択した位置単位に対し、不正な位置小数単位が選択されたことによって、正常に機械移動量・回転体位置範囲の自動設定ができない場合に表示されます。

③ 回転体位置範囲設定

回転体位置範囲／回転体位置範囲符号切替位置の設定を行います。

※モータ製品種別が「τリニア」の場合、本パラメータは設定することができません。

チェックを入れると、回転体位置範囲／回転体位置範囲符号切替位置を自動で適切な値に設定します。

チェックを外すと、回転体位置範囲／回転体位置範囲符号切替位置は0に設定されます。

注記

本動作により以下のメッセージが表示されることがあります。

本メッセージは位置単位と位置小数単位の組み合わせが不正なために、正常に回転体位置範囲の自動設定ができない場合に表示されます。

②「設定モード」を[手動設定]にした場合

本ウィンドウが下図のように表示されます。

「設定モード」を[手動動設定]にした場合は、以下の項目を編集することができます。

① 位置単位設定

② 位置小数単位設定

③ 機械移動量設定

④ 電子ギア設定

⑤ 回転体位置範囲

各項目の設定方法は以下を参照してください。

① 位置単位選択

位置単位を選択します。

② 位置小数単位選択

位置小数単位を選択します。

③ 機械移動量設定

機械移動量を直接入力します。

④ 電子ギア設定

電子ギア比分子、電子ギア比分母を直接入力します。

⑤ 回転体位置範囲設定

回転体位置範囲／回転体位置範囲符号切替位置を直接入力します。

※モータ製品種別が「τリニア」の場合、本パラメータは設定することができません。

3.5.4.3. パラメータの設定

本ウィンドウの[設定]をクリックすることで、本ウィンドウがクローズされ、本ウィンドウで編集したパラメータがパラメータ編集ウィンドウに設定されます。

位置単位と位置小数単位が変更されている場合、以下のメッセージが表示されます。

注意

位置単位と位置小数単位を変更した場合、モータを動作させる前に以下の設定値を必ず見直してください。

①速度や移動量のパラメータ値

②プログラムデータの設定値

③間接データの設定値

設定値を見直さずにモータを動作させた場合、意図しない動作をする可能性があるため注意してください。

3.5.4.4. ウインドウクローズ

本ウィンドウの[閉じる]をクリックすることで、本ウィンドウをクローズします。

パラメータ変更後[設定]をクリックせずに[閉じる]をクリックした場合、以下のメッセージが表示されます。

[はい]をクリックすると、本ウィンドウで変更したパラメータを適用せずに、本ウィンドウをクローズします。

[いいえ]をクリックすると、閉じるのを中止します。


3.5.5. グループの選択

パラメータグループ選択ボタンをクリックするとグループ単位でパラメータの編集を行うことができます。次のウィンドウは[指令設定]グループを選択した時の表示内容です。

[全項目表示]を選択している時に、指定パラメータへのジャンプスイッチ（コンボボックス）をクリックしてパラメータ番号を設定すると指定したパラメータにカーソルが移動します。

[P100]を選択すると画面にP100の内容が表示されてカーソルが移動します。


3.5.6. パラメータの書き込み

1) パラメータ編集ウィンドウ上のパラメータを装置に書き込む場合は[装置に書き込む]ボタンをクリックします。

2) 書き込みして良いか確認メッセージが表示されますので書き込みを行う場合は[OK]ボタンを、中止する場合は[キャンセル]タンをクリックします。

注記

Version 2.2.0から本ソフトウェアで保持していたFBフィルタ設定方法選択の値が、装置に保持されるようになり、パラメータ書き込み時にFBフィルタ設定方法選択の設定値をチェックするようなりました。

書き込みを行うパラメータと装置内のFBフィルタ設定方法選択が異なる場合、以下のメッセージが表示されます。

基本的には「はい」を選択し、必要に応じて「リアルタイムサーボ調整画面」にてFBフィルタ設定方法選択の再設定を行ってください。

また、再調整の為オートチューニングを実行した場合も同様にFBフィルタ設定方法選択が再設定されます。

設定変更後はパラメータの読み出しを行いファイルに保存することで、FBフィルタ設定方法選択の値を保持することができ、次回パラメータ書き込み時に保存された値が装置に設定されます。

但し、Version 2.1.0以前のVPH Data Editing Softwareにて保存されたファイルを書き込む場合は、FBフィルタ設定方法選択の値がファイルに保存されていないため、本メッセージは表示されず、FBフィルタ設定方法選択値も装置に設定されません。

Version 4.0.0から絶対位置補正データの設定について「絶対位置補正 補正動作指定」が「無効」のとき、以下の場合にパラメータ書き込み前にメッセージが表示されるようになります。

・エンコーダタイプが「S-ABS2」、「S-ABS3」、「S-ABS4」のいずれかであり、エンコーダに絶対位置補正データが登録されている場合

・エンコーダタイプが「S-ABS2」、「S-ABS3」、「S-ABS4」以外であり、VPH装置に絶対位置補正データが登録されている場合

「はい」をクリックすると「補正有効」にし送信します。

「いいえ」をクリックした場合は「無効」のまま送信します。

テスト運転パラメータが装置内と異なっている場合、パラメータ書き込み前に以下のメッセージが表示されます。

「OK」をクリックすると、テスト運転の動作パラメータを、パラメータファイルの値で上書きします。

「キャンセル」をクリックすると、書き込みがキャンセルされます。

3) バー表示が右端まで達すると書き込み終了です。

4) 書き込み時にタイトルに表示されているファイル名を装置に書き込みます。

5) 電源再投入またはRST信号入力が必要なパラメータが送信された場合には、次のようなメッセージが表示されます。

電源再投入が必要なパラメータが送信された場合

RST信号入力が必要なパラメータが送信された場合

電源再投入またはRST信号入力する場合は[OK]をクリックし、中止する場合は[キャンセル]をクリックしてください。

注記 | 電源再投入が必要なパラメータが送信されたとき、MTON信号がONの場合以下のメッセージが表示されます。 サーボオフ後、電源の再投入を手動で行うか、メインツールバーから電源の再投入を行ってください。
 | 装置の電源再投入を実行しようとしたときに、MTON信号がONの場合以下のメッセージが表示されます。 サーボオフ後、電源の再投入を手動で行うか、メインツールバーから電源の再投入を行ってください。
 | 電源再投入が必要なパラメータが送信されたとき、ネットワーク通信中の場合以下のメッセージが表示されます。 ネットワークと切り離した後、電源の再投入を手動で行うか、メインツールバーから電源の再投入を行ってください。
 | 装置の電源再投入を実行しようとしたときに、ネットワーク通信中の場合以下のメッセージが表示されます。 ネットワークと切り離した後、電源の再投入を手動で行うか、メインツールバーから電源の再投入を行ってください。
 | RST信号入力が必要なパラメータが送信されたとき、MTON信号がONの場合以下のメッセージが表示されます。 サーボオフ後、電源の再投入を手動で行うか、メインツールバーからRST信号の入力を行ってください。
 | RST信号入力を実行しようとしたときに、MTON信号がONの場合以下のメッセージが表示されます。 サーボオフ後、電源の再投入を手動で行うか、メインツールバーからRST信号の入力を行ってください。
 | RST信号入力が必要なパラメータが送信されたとき、ネットワーク通信中の場合以下のメッセージが表示されます。 ネットワークと切り離した後、電源の再投入を手動で行うか、メインツールバーからRST信号入力を行ってください。
 | RST信号入力を実行しようとしたときに、ネットワーク通信中の場合以下のメッセージが表示されます。 ネットワークと切り離した後、電源の再投入を手動で行うか、メインツールバーからRST信号入力を行ってください。


3.5.7. パラメータの読み出し

1) 装置内のパラメータを読み出す場合は[装置から読み出す]ボタンをクリックします。

2) 読み出して良いか確認メッセージが表示されます。ので、読み出しを行う場合は[OK]ボタンを、中止する場合は[キャンセル]ボタンをクリックします。

3) バー表示が右端まで達すると読み出し終了です。

4) 読み出し時に、装置に書き込まれているパラメータ名を画面に表示します。

表示された名前は、保存時の初期ファイル名となります。

5) パラメータ読み出し中に以下のようなメッセージが表示される場合があります。

本メッセージが表示された場合、装置に設定されているパラメータが現在本ソフトウェアにて編集しているパラメータの設定範囲を超えていることが考えられます。

① [はい]をクリックすると、読み出しを継続します。

「P008(1)=4/P008(2)=3/P028(3-1)=101/P210=-1」は装置に設定されている範囲外のパラメータ値です。()内はパラメータの桁範囲を表しています。

但し範囲外のパラメータは強制的に初期値を設定します。

本メッセージが表示された場合以下のことが考えられます。

内容 | 対策
使用しているパラメータファイルが古いバージョンで作成された | 新規作成パラメータにて再度パラメータの読み出しを行って下さい
装置のバージョンと本ソフトウェアのバージョンが合っていない(本ソフトウェアのバージョンが古い) | 本ソフトウェアのバージョンアップが必要です。 弊社担当営業にお問合せ下さい。
装置に設定されたパラメータ値が範囲外となっている(上位の機器よりパラメータを範囲外の値に書き換えた等) | 範囲外のパラメータ値を設定している箇所を修正してください。

② [いいえ]をクリックすると、読み出しを中止します。

注記

パラメータ範囲外によりパラメータ読み出しを中止した場合、範囲外となったパラメータの一つ前のパラメータまでは読み出しが完了しています。


3.5.8. パラメータの比較

パラメータ編集画面の[比較]ボタンをクリックすると、パラメータのデータ比較画面が開かれます。

比較の種類は、[初期値と比較]、[装置内と比較]、[ファイルと比較]、[ROMとRAMを比較]です。

比較を実行すると、相違点の件数、相違点の一覧が表示されます。

比較結果：相違点の確認

相違点無し | indirectSettingCompareResultFalse
相違点あり |

比較結果：相違の一覧

相違の一覧は左から、パラメータ番号、パラメータの項目名、比較元設定値、比較先設定値、比較元単位の順に表示されます。

注記

比較先の値に範囲外の値が設定されている場合、赤文字で’()’でくくられた値が表示されます。

初期値と比較

1) パラメータ初期値と現在編集中の内容を比較する場合は

[比較]→[初期値と比較]ボタンをクリックします。

2) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ P161：位置小数単位選択の値を参照しているパラメータが比較対象の場合

比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、初期値として保存されている位置小数単位を反映した値を表示します。

装置内と比較

1) 装置内のパラメータと現在編集中の内容を比較する場合は

[比較]→[装置内と比較]ボタンをクリックします。

2) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ P161：位置小数単位選択の値を参照しているパラメータが比較対象の場合

比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、装置内に設定されている位置小数単位を反映した値を表示します。

ファイルと比較

1) 指定ファイルと現在編集中の内容を比較する場合は

[比較]→[ファイルと比較]ボタンをクリックします。

2) [ファイルを開く]ウィンドウが表示されます。

3) 比較するファイルを選択し[開く(O)]ボタンをクリックします。

4) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ P161：位置小数単位選択の値を参照しているパラメータが比較対象の場合

比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、ファイルに保存されている位置小数単位を反映した値を表示します。

ROMとRAMを比較

1)装置内のRAMエリアとROMエリアの内容を比較する場合は

[比較]→[ROMとRAMを比較]ボタンをクリックします。

2)比較結果は「比較結果：相違の一覧」形式で表示されます。

※ P161：位置小数単位選択の値を参照しているパラメータが比較対象の場合

比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

※ROMエリアとRAMエリアについて

ROMエリアは、装置の電源を落としてもデータが消えないエリアです。書き換え可能回数10億回の制限があります。

RAMエリアは、装置の電源を落とすとデータが消失するエリアです。装置の電源投入時又はROMエリアのデータが書き換えられると、ROMエリアのデータがRAMエリアにコピーされます。主に本エリアのデータを使用して装置が動作します。書き換え回数に制限はありません。

比較結果の出力

① ファイルに出力

[CSV出力]ボタンをクリックすると相違点をCSVファイルに出力することができます。

② 印刷

相違点が存在する状態で[印刷]ボタンをクリックすると相違点を印刷することができます。


3.5.9. ファイルを開く

保存されたパラメータを開く場合

① メインツールバーから開く

1) メインツールバーの[ファイル(F)]→[開く]→[パラメータ]をクリック

2) ファイルを開くダイアログが表示されるので、開きたいパラメータファイルを選択し[開く]ボタンをクリックします。

② パラメータ編集画面から開く

1) パラメータ編集ウィンドウ上の[開く]をクリックします。

2) ファイルを開くダイアログが表示されるので、開きたいパラメータファイルを選択し[開く]ボタンをクリックします。

注記

ファイルの種類より選択できる拡張子は装置、モータにより異なります。

※詳しくは[6.1. ファイル拡張子一覧]を参照

本画面にパラメータファイルをドロップすることで、パラメータファイルを開くこともできます。

※対応するファイルは[6.2. ファイルドロップについて]を参照


3.5.10. ファイルに保存

パラメータ編集ウィンドウ上のパラメータをファイルに保存する場合は、同ファイル名に上書き保存するか、新しいファイル名を指定して保存するか選択できます。

① 同ファイル名に上書き保存する場合は、メニューバーから
[上書き保存]ボタンをクリックします。

② 新しいファイル名を指定して保存する場合は、メニューバーから

[名前を付けて保存]ボタンをクリックします。

注記

Version 2.2.0から本ソフトウェアで保持していたFBフィルタ設定方法選択の値が、装置に保持されるようになり、パラメータにも保存されるようになりました。

保存されるFBフィルタ設定方法選択値は、装置から読み出しを行った時点の値となります。


3.5.11. 印刷

パラメータ編集ウィンドウ上のパラメータを印刷する場合は、メニューバーから

[印刷]ボタンをクリックします。

① パラメータが選択状態になっている場合、以下のメッセージが表示されます。

1) 印刷範囲を指定します。

① 全範囲を印刷する場合

1) [全体を印刷]を選択します。

2) [OK]ボタンをクリックします。

② 印刷範囲を指定して印刷する場合

1) [選択範囲内を印刷]を選択します。

2) [OK]ボタンをクリックします。

2) 印刷ウィンドウが表示されます。

① 印刷をする場合、各項目を設定し[印刷]ボタンをクリックします。

② 印刷を中断する場合は、[キャンセル]ボタンをクリックします。

② パラメータが選択状態になっていない場合、全体を印刷します。


3.5.12. ウィンドウクローズ

表示されているパラメータ編集ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。

パラメータが変更されたまま上記の処理をすると下記のような確認メッセージが表示されます。

ウィンドウを閉じる場合は[OK]をクリックし、中止する場合は[キャンセル]をクリックしてください。

※パラメータを[上書き保存]、又は[名前を付けて保存]した場合確認メッセージは表示されません


3.6. 間接データ編集ウィンドウ

間接データの編集を行います。


3.6.1. ウィンドウの表示

メニューバーから

[ファイル(F)]→[新規作成(N)]→[間接データ(I)]

または

[ファイル(F)]→[ファイルを開く(O)]→[間接データ(I)]

メインツールバーの

[データ編集]タブ→[間接データ]→[間接データメニュー選択]

を選択すると、本ウィンドウが表示されます。


3.6.2. 間接データの編集

① 間接データの直接編集

1) マウスまたは、キーボード操作によって、間接データを選択します。

2) 選択した間接データをマウスでクリック、[Enter]、[F2]キーを押下することで間接データを編集状態にします。

・数値入力の場合：キーボードから直接入力します。

・選択項目の場合：リストから項目を選択します。

3) フォーカスを外す、[Enter]、[Tab]、[F2]キーを押下することで、間接データを確定します。

② 間接データのコピーと貼り付け

間接データ編集ウィンドウ間のコピー／貼り付け
複数の間接データ編集ウィンドウを表示している際に特定範囲の間接データを他のウィンドウにコピーするのに便利な機能です。

1) 間接データのコピー

コピー範囲をキーボードの[Shift]＋[↑]、[Shift]＋[↓]を押して指定するか、又はマウスでドラッグした後、マウス右クリック[コピー] を選ぶか、またはCtrl＋Cでコピーします。

2) 間接データの貼り付け

間接データの貼り付け間接データの貼り付け先をカーソルで指定し、マウス右クリックから[ペースト]を選ぶか、またはCtrl＋Vで貼り付けます。


3.6.3. 間接データの書き込み

1) 間接データ編集ウィンドウ上の間接データを装置へ書き込む場合は[装置に書き込む]ボタンをクリックします。

2) 書き込みして良いか確認メッセージが表示されますので書き込みを行う場合は[OK]ボタンを、中止する場合は[キャンセル]ボタンをクリックします。

3) バー表示が右端まで達すると書き込み終了です。

4) 書き込み時にタイトルに表示されているファイル名を装置に書き込みます。

注記

間接データ編集画面に設定されている位置単位、位置小数単位と装置に設定されている位置単位、位置小数単位が一致しない場合は、間接データを送信できません。

間接データ編集画面に設定されている位置単位、位置小数単位か、装置に設定されている位置単位、位置小数単位を設定しなおして下さい。

間接データ編集画面に設定されている位置単位、位置小数単位は、単位変換ボタンを押下することによって行います。

間接データ編集画面に設定されている位置単位、位置小数単位を装置に設定されている単位に変換を行います。


3.6.4. 間接データの読み出し

1) 装置内のパラメータを読み出す場合は[装置から読み出す]ボタンをクリックします。

2) 読み出して良いか確認メッセージが表示されますので読み出しを行う場合は[OK]ボタンを、中止する場合は[キャンセル]ボタンをクリックします。

3) バー表示が右端まで達すると読み出し終了です。

4) 読み出し時に、装置に書き込まれている間接データ名を画面に表示します。

表示された名前は、保存時の初期ファイル名となります。

注記

機能種別が本ソフトウェアと装置で異なる場合は、間接データを送受信できません。本ソフトウェアの装置モータ選択を設定しなおして下さい。


3.6.5. 間接データの比較

間接データ編集ウィンドウの[比較]ボタンをクリックすると、間接データのデータ比較画面が開かれます。

比較の種類は、[初期値と比較]、[装置内と比較]、[ファイルと比較]です。

比較を実行すると、相違点の件数、相違点の一覧が表示されます。

比較結果：相違点の確認

相違点無し | indirectSettingCompareResultFalse
相違点あり | IndirectDataSettintCompareResult

比較結果：相違点の一覧

相違点の一覧は左から、間接データ番号、間接データの項目名、比較元設定値、比較先設定値、比較元単位、比較元コメントの順に表示されます。

注記

比較先の値に範囲外の値が設定されている場合、赤文字で’()’でくくられた値が表示されます。

初期値と比較

1) 間接データ初期値と現在編集中の内容を比較する場合は

[比較]→[初期値と比較]ボタンをクリックします。

2) 比較結果は「比較結果：相違点の一覧」形式で表示されます。

※ 比較元設定値、比較先設定値共に、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

装置内と比較

1) 装置内の間接データと現在編集中の内容を比較する場合は

[比較]→[装置内と比較]ボタンをクリックします。

2) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ 比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、装置内に設定されている位置小数単位を反映した値を表示します。

ファイルと比較

1) 指定ファイルと現在編集中の内容を比較する場合は

[比較]→[ファイルと比較]ボタンをクリックします。

2) [ファイルを開く]ウィンドウが表示されます。

3) 比較するファイルを選択し[開く(O)]ボタンをクリックします。

4) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ 比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、ファイルに保存されている位置小数単位を反映した値を表示します。

比較結果の出力

① ファイルに出力

[CSV出力]ボタンをクリックすると相違点をCSVファイルに出力することができます。

② 印刷

相違点が存在する状態で[印刷]ボタンをクリックすると相違点を印刷することができます。


3.6.6. ファイルを開く

① メインツールバーから開く

1) メインツールバーの[ファイル(F)]→[開く]→[間接データ]をクリック

2) ファイルを開くダイアログが表示されるので、開きたい間接データファイルを選択し[開く]ボタンをクリックします。

② 間接データ編集画面から開く

1) 間接データ編集ウィンドウ上の[開く]をクリック

2) ファイルを開くダイアログが表示されるので、開きたい間接データファイルを選択し[開く]ボタンをクリックします。

注記

① ファイルの種類より選択できる拡張子は装置により異なります。

※詳しくは[6.1. ファイル拡張子一覧]を参照

② 本画面に間接データファイルをドロップすることで、間接データファイルを開くこともできます。

※対応するファイルは[6.2. ファイルドロップについて]を参照


3.6.7. ファイルに保存

間接データ編集ウィンドウ上の間接データをファイルに保存する場合は、同ファイル名に上書き保存するか、新しいファイル名を指定して保存するか選択できます。

① 同ファイル名に上書き保存する場合は、メニューバーから

[上書き保存]ボタンをクリックします。

② 新しいファイル名を指定して保存する場合は、メニューバーから

[名前を付けて保存] ボタンをクリックします。


3.6.8. 印刷

間接データ編集ウィンドウ上のパラメータを印刷する場合は、メニューバーから
[印刷]ボタンをクリックします。

① 間接データが選択状態になっている場合、以下のメッセージが表示されます。

1) 印刷範囲を指定します。

① 全範囲を印刷する場合

1) [全体を印刷]を選択します。

2) [OK]ボタンをクリックします。

②印刷範囲を指定して印刷する場合

1) [選択範囲内を印刷]を選択します。

2) [OK]ボタンをクリックします。

2) 印刷ウィンドウが表示されます。

① 印刷する場合、各項目を選択肢[印刷]ボタンをクリックします。

② 印刷を中断する場合は、[キャンセル]ボタンをクリックします。

② 間接データが選択状態になっていない場合、全体を印刷します。


3.6.9. ウィンドウクローズ

表示されている間接データ編集ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。

間接データが変更されたまま上記の処理をすると下記のような確認メッセージが表示されます。

ウィンドウを閉じる場合は[OK]をクリックし、中止する場合は[キャンセル]をクリックしてください。

※間接データを[上書き保存]、又は[名前を付けて保存]した場合確認メッセージは表示されません


3.7. プログラム編集ウィンドウ

VPH装置用のプログラム編集を行います。


3.7.1. ウィンドウの表示

メニューバーから

[ファイル(F)]→[新規作成(N)]→[プログラム(R)]

または

[ファイル(F)]→[ファイルを開く(O)]→[プログラム(R)]

メインツールバーの

[データ編集]タブ→[プログラム]→[プログラムメニュー選択]

を選択すると、本ウィンドウが表示されます。


3.7.2. プログラムの編集

① プログラムの直接編集

1) 編集項目の指定は目的のプログラムステップをマウスでクリックします。

2) プログラムを入力する場合は次の順でデータを入力します。

・編集項目のCMDをクリックすることで▼が表示されます。

・▼をクリックすることで項目が選択可能になります。

・CMDを選択した後、編集箇所のコンボボックスを選択するか、キーボードからデータを直接入力します。

尚、CMDの内容により後続する入力項目が異なります。（画面の指示に従って下さい。）

② プログラムのコピーと貼り付け

プログラム編集ウィンドウ間のコピー／貼り付け
複数のプログラム編集ウィンドウを表示している際に特定範囲のプログラムデータを他のウィンドウにコピーするのに便利な機能です。

1) プログラムデータのコピー

プログラムデータをコピーする場合は、コピー範囲をキーボードの[Shift]＋[↑]、[Shift]＋[↓]を押して指定するか、又はマウスでドラッグした後、マウス右クリック[コピー] を選ぶか、またはCtrl＋Cでコピーします。

2) プログラムデータの貼り付け

プログラムデータの貼り付け先をカーソルで指定し、マウス右クリックから[ペースト] を選ぶか、またはCtrl＋Vで貼り付けます。

プログラムステップが次のように貼り付けられます。

③ 行挿入

1) カーソルを任意の行に設定します。

2) [行挿入]ボタンをクリックすると次のように新しい行が挿入されて[NOP]命令が登録されます。

マウスを右クリックすることで表示される、コントキストメニュー内からも同様に、行挿入を行うことができます。

最終行が[NOP]命令以外の場合、次のようなメッセージが表示されて行挿入を行えません。

行挿入を行う場合は、最終行を[NOP]以外のコマンドに設定してください。

④ 行削除

1) カーソルを任意の行に設定します。

2) [行削除]ボタンをクリックすると次のように指定された行が削除され、後続のステップが前に詰められます。

行削除を行うと最終行に[NOP]命令が追加されます。

マウスを右クリックすることで表示される、コントキストメニュー内からも同様に、行削除を行うことができます。


3.7.3. プログラムの書き込み

1) プログラム編集ウィンドウ上のプログラムを装置へ書き込む場合は[装置に書き込む]ボタンをクリックします。

2) 書き込みして良いか確認メッセージが表示されますので書き込みを行う場合は[OK]ボタンを、中止する場合は[キャンセル]ボタンをクリックします。[OK]ボタンをクリックすると、書き込み処理の実行経過がバー表示されます。

3) バー表示が右端まで達すると書き込み終了です。

4) 書き込み時にタイトルに表示されているファイル名を装置に書き込みます。

注記

プログラム編集画面に設定されている位置単位、位置小数単位と装置に設定されている位置単位、位置小数単位が一致しない場合は、プログラムを送信できません。

プログラム編集画面に設定されている位置単位、位置小数単位か、装置に設定されている位置単位、位置小数単位を設定しなおして下さい。

プログラム編集画面に設定されている位置単位、位置小数単位は、単位変換ボタンを押下することによって行います。

プログラム編集画面に設定されている位置単位、位置小数単位を装置に設定されている単位に変換を行います。

注意

プログラム運転中にプログラムを書き込むと運転途中から新しいプログラムデータでの運転に切り替わりますので注意して下さい。

通常は、運転中のプログラムを終了してから書き込んで下さい。


3.7.4. プログラムの読み出し

1) 装置内のプログラムを読み出す場合は[装置から読み出す]ボタンをクリックします。

2) 読み出して良いか確認メッセージが表示されますので読み出しを行う場合は[OK]ボタンを、中止する場合は[キャンセル]ボタンをクリックします。[OK]ボタンをクリックすると、読み出し処理の実行経過がバー表示されます。

3) バー表示が右端まで達すると読み出し終了です。

4) 読み出し時に、装置に書き込まれているプログラム名を画面に表示します。

表示された名前は、保存時の初期ファイル名となります。


3.7.5. プログラムデータの比較

プログラム編集画面の[比較]ボタンをクリックすると、プログラムのデータ比較画面が開かれます。

比較の種類は、[初期値と比較]、[装置内と比較]、[ファイルと比較]です。

比較を実行すると、相違点の件数、相違点の一覧が表示されます。

比較結果：相違点の確認

相違点無し | indirectSettingCompareResultFalse
相違点あり |

比較結果：相違の一覧

相違の一覧は左から、プログラムのアドレス、比較元コマンド、比較元設定値0～7、比較元コメント、比較先コマンド、比較先設定値0～7、比較先コメントの順に表示されます。

注記

比較先の値に範囲外の値が設定されている場合、赤文字で’()’でくくられた値が表示されます。

初期値と比較

1) プログラム初期値と現在編集中の内容を比較する場合は

[比較]→[初期値と比較]ボタンをクリックします。

2) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ P161：位置小数単位選択の値を参照している設定値が比較対象の場合

比較元設定値、比較先設定値共に、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

装置内と比較

1) 装置内のプログラムと現在編集中の内容を比較する場合は

[比較]→[装置内と比較]ボタンをクリックします。

2) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ 比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、装置内に設定されている位置小数単位を反映した値を表示します。

ファイルと比較

1) 指定ファイルと現在編集中の内容を比較する場合は

[比較]→[ファイルと比較]ボタンをクリックします。

2) [ファイルを開く]ウィンドウが表示されます。

3) 比較するファイルを選択し[開く(O)]ボタンをクリックします。

4) 比較結果は「比較結果：相違の一覧」形式で表示されます。

※ P161：位置小数単位選択の値を参照しているプログラムが比較対象の場合

比較元設定値は、比較を実行した際に設定されている位置小数単位を反映した値を表示します。

比較先設定値は、ファイルに保存されている位置小数単位を反映した値を表示します。

比較結果の出力

① ファイルに出力

[CSV出力]ボタンをクリックすると相違点をCSVファイルに出力することができます。

② 印刷

相違点が存在する状態で[印刷]ボタンをクリックすると相違点を印刷することができます。


3.7.6. ファイルを開く

保存されたプログラムを開く場合

① メインツールバーから開く

1) メインツールバーの[ファイル(F)]→[開く]→[プログラム]をクリック

2) ファイルを開くダイアログが表示されるので、開きたいプログラムファイルを選択し[開く」ボタンをクリックします。

② プログラム編集画面から開く

1) プログラム編集ウィンドウ上の[開く]をクリック

2) ファイルを開くダイアログが表示されるので、開きたいプログラムファイルを選択し[開く]ボタンをクリックします。

注記

ファイルの種類より選択できる拡張子は装置により異なります。

※詳しくは[6.1. ファイル拡張子一覧]を参照

本画面にプログラムデータファイルをドロップすることで、プログラムデータファイルを開くこともできます。

※対応するファイルは[6.2. ファイルドロップについて]を参照


3.7.7. ファイルに保存

プログラム編集ウィンドウ上のプログラムをファイルに保存する場合は、同ファイル名に上書き保存するか、新しいファイル名を指定して保存するか選択できます。

① 同ファイル名に上書き保存する場合は、メニューバーから

[上書き保存] ボタンをクリックします。

② 新しいファイル名を指定して保存する場合は、メニューバーから

[名前を付けて保存] ボタンをクリックします。


3.7.8. 印刷

プログラム編集ウィンドウ上のプログラムを印刷する場合は、メニューバーから

[印刷]ボタンをクリックします。

① プログラムが選択状態になっている場合、以下のメッセージが表示されます。

1) 印刷範囲を指定します。

① 全範囲を印刷する場合

1) [全体を印刷]を選択します。

2) [OK]ボタンをクリックします。

② 印刷範囲を指定して印刷する場合

1) [選択範囲内を印刷]を選択します。

2) [OK]ボタンをクリックします。

2) 印刷ウィンドウが表示されます。

① 印刷をする場合、各項目を設定し[印刷]ボタンをクリックします。

② 印刷を中断する場合は、[キャンセル]ボタンをクリックします。

② プログラムが選択されていない場合、全体を印刷します。


3.7.9. ウィンドウクローズ

表示されているプログラム編集ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。

プログラムが変更されたまま上記の処理をすると下記のような確認メッセージが表示されます。

ウィンドウを閉じる場合は[OK]をクリックし、中止する場合は[キャンセル]をクリックしてください。

※プログラムを[上書き保存]、又は[名前を付けて保存]した場合確認メッセージは表示されません


3.8. 一括データ送受信

パラメータ、間接データ、プログラムデータを一括して、装置に送信または装置から受信し、一括データとして保存します。

① 送信する場合は、メニューバーから

[ファイル(F)]→[一括データ]→[送信]

を選びます。

② 受信する場合は、メニューバーから

[ファイル(F)]→[一括データ]→[受信]

を選びます。

送受信ファイル拡張子は [*.c*adb]となります。

詳しくは[6.1. ファイル拡張子一覧]を参照。

注記

①パラメータ、プログラム、間接データの送受信中は一括データの送受信を行えません。

②メインツールバーの状態表示、解析機能、調整機能、リモート操作タブのウィンドウが表示されている場合は、一括データの送受信を行えません。

③モータが未設定の場合、一括データの受信は行えません。

装置モータ選択画面で、モータを再設定後再度、一括データの受信をやり直してください。

④Version 2.2.0よりFBフィルタ設定方法選択の値が送受信されるようになりました。

これにより受信したデータを保存した場合、保存したファイルにはFBフィルタ設定方法選択の値が保持され、一括データ送信時に装置に設定されます。


3.9. オシロスコープウィンドウ

選択した装置データをリアルタイムにグラフ表示します。


3.9.1. ウィンドウの表示

オシログラフを測定する場合は、下記の手順でオシロスコープウィンドウを表示します。

メインツールバーの

[解析機能]タブ→[オシロスコープ]

を選択すると、本ウィンドウが表示されます。


3.9.2. 装置の状態表示

以下の装置状態を常に表示します。

No | 項目
C012 | モータサーマルトリップ率
C014 | 装置サーマルトリップ率
C018 | 回生過負荷率

色で状態を表しています。

色 | 状態
緑 | 正常
黄 | 注意
赤 | 危険


3.9.3. オシロ設定

オシロスコープウィンドウの[オシロ設定]をクリックすると、オシロ設定ウィンドウが表示されます。

オシロ設定ウィンドウでは、表示対象チャンネルの選択・表示対象の設定・測定設定・トリガ設定が行えます。

① 表示対象チャンネルの選択

[CH有効選択（CH1～4）]チェックボックスに表示したいチャンネルをチェックします。

注記

CHのチェックを外して測定したデータは、全て0が設定されます。

② 制御情報（速度指令、トルク指令、位置偏差パルス等）表示時のデータ設定

1) [CH1設定]～[CH3設定]枠内の[表示項目]コンボボックスから表示したい制御情報（速度指令、トルク指令、位置偏差パルス等）項目を選択します。

2) [表示最大値]のデータ入力エリアにグラフ表示する際のY軸メモリ最大値を設定します。

3) [CH1設定]～[CH3設定]枠内の[表示項目]コンボボックスで[速度フィードバック][速度指令][アナログ速度指令入力][位置指令目標速度]が選択されている場合、速度単位の切り替えが可能です。[単位]コンボボックスにより　％⇔速度⇔rpm　に切り替えを行います。

4) [CH1設定]～[CH3設定]枠内の[表示項目]コンボボックスで[実トルク指令][アナログトルク指令入力]が選択されている場合、トルク単位の切り替えが可能です。[単位]コンボボックスにより　％⇔Nm(N)　に切り替えを行います。

③ ロング／ワードデバイスモニタ時のデータ設定

1) [CH1選択]～[CH3選択]枠内の[表示項目]コンボボックスからロングデバイスモニタまたはワードデバイスモニタを選択します。

2) [デバイス番号]コンボボックスから対象デバイスを選択します。

3) 対象デバイスはD,Rとします。

4) [デバイス番号]のデータ入力エリアにデバイス番号を設定します。

5) [表示最大値]のデータ入力エリアにグラフ表示する際のY軸メモリ最大値を設定します。

6) [デバイス名称]のデータ入力エリアに自由にデバイス名称を設定することが可能です。

   設定したデバイス名称は、グラフの凡例、印刷画面に表示されます。

④ 状態表示時のデータ設定

1)[CH1選択]～[CH3選択]枠内の[表示項目]コンボボックスから表示したい状態の種類を選択します。

2)[状態項目]コンボボックスから表示したい信号を選択します。

⑤ 入出力信号状態表示時のデータ設定

1)[CH1選択]～[CH4選択]枠内の[表示項目]コンボボックスから表示したい信号の種類を選択します。

2)[信号項目]コンボボックスから表示したい信号を選択します。

⑥ データ分解能の設定

1) [データ分解能]コンボボックスから時間軸（X軸）の1データあたりのサンプリング時間を選択します。

2) データ分解能（msec）は装置とパラメータ設定により以下の範囲で変動します。

最小測定間隔 | 0.2 | 0.4 | 0.8 | 1.6 | 3.2
最大測定間隔 | 0.4 | 0.8 | 1.6 | 3.2 | 6.4

⑦ 測定時間の設定

1) [測定時間]コンボボックスからオシロスコープの測定時間を選択します。

2) 対象時間は1, 2, 5, 10, 20, 50, 100秒及びInfinityとします。

⑧ ロギングの設定

1) [ロギング有効]にチェックを入れます。

2) ファイルを保存するダイアログが表示されるので、ロギングファイルの保存場所とファイル名を設定します。

3) [ロギング有効]がONの場合、[ログファイル名欄][ログファイル設定]ボタンにて、ログファイルの変更ができます。

4) ログファイルのファイル拡張子は [＊.cxlog]となります。ファイルは60秒毎にファイルが作成され、ファイル名に連番が振られます。

⑨ トリガ設定

[測定時間]コンボボックスでInifinity以外を選択した場合、トリガ設定が可能です。

1) トリガ設定を有効にするには、[トリガ有効]のチェックを入れます。

2) 連続的にトリガをかける場合は、[ノーマルトリガ]を選択します。

   1回だけトリガをかける場合は、[シングルトリガ]を選択します。

   [ノーマルトリガ]を選択すると、トリガがかかる度に、測定時間分データを取得し、グラフを再表示します。

   ただし、トリガ発生後から測定時間内のトリガは無効になります。

3) トリガ対象とするチャンネルを[トリガ対象]から選択します。

4) 入出力信号以外のチャンネルをトリガ対象とした場合、[トリガ閾値]にトリガとなる閾値を設定します。

5) トリガが発生してからの遅延時間（トリガタイミング以降の波形を表示する長さ）を[トリガ遅延時間]で設定します。

[トリガ遅延時間]を設定した時の測定データ表示範囲は以下の様になります。

例1) [測定時間]を10sec、[トリガ遅延時間]を2secの時

トリガタイミングから、2sec後の測定時間分の測定データ(網掛け部分)が表示されます。

例2) [測定時間]を10sec、[トリガ遅延時間]を-2secの時

トリガタイミングから、2sec前の測定時間分の測定データ(網掛け部分)が表示されます。

6) [ON]又は[OFF]の選択により、トリガ検出のエッジを設定します。

⑩ オシロ設定の設定

[設定]ボタンをクリックすると設定した各情報を登録し、オシロスコープウィンドウに戻ります。

オシロ設定にて設定した内容は、オシロスコープウィンドウの下部ステータスバーに表示します。

注記

接続中の装置で使用できない表示項目が設定されている場合、以下のメッセージが表示されます。

表示項目を変更してください。

装置からの受信データは16bitデータの為、表示最大値に32767を超える値を設定した場合、表示データが階段状に表示されることがあります。

例1)

表示項目：位置偏差

表示最大値：16,000,000[pulse]

とした場合の1データ分解能は

16,000,000/32767≒488[pulse]

となり、装置が1,000,000[pulse]の位置偏差を持っていた場合、1,000,031[pulse]と表示します。

例2)

表示項目：速度フィードバック

表示最大値：1,800.000[deg/sec]

とした場合の1データ分解能は

1,800,000/32767≒55[pulse/sec]

となり、装置が360.000[deg/sec]で動作していた場合、359.978 [deg/sec]と表示します。


3.9.4. 表示項目

オシロ設定で設定する表示項目は以下の通りです。

表示項目名 | 説明
速度フィードバック | モータ実動作速度を表示します。
実トルク指令 | 実トルク指令値を表示します。
位置偏差 | 位置偏差パルスを表示します。
速度指令 | 速度指令値を表示します。 速度指令モード、パルス列指令モード、内蔵指令モード、ネットワークからの速度指令と位置指令で有効です。 S字や偏差を含む速度系最後の指令値となります。
アナログ速度指令 | アナログ速度指令値を表示します。 VPH-HA装置のみ項目が表示されます。 アナログオプションが無い装置は、値が0固定となります。
アナログトルク指令 | アナログトルク指令値を表示します。 モータ定格トルク時に100%となります。 VPH-HA装置のみ項目が表示されます。 アナログオプションが無い装置は、値が0固定となります。
位置指令目標速度 | 位置指令における目標速度を表示します。 パルス列指令モード、内蔵指令モード、ネットワークからの位置指令で有効です。 S字や偏差を含まない指令値となります。
モータ実効値 | モータ実効値（負荷率）を表示します。
モータサーマルトリップ率 | モータサーマルトリップ率を表示します。 100%になると「モータ過負荷異常」を検出します。
パルス列指令速度 | パルス列指令速度を表示します。 パルス列指令モード、ネットワークからの位置指令で有効です。 1ms間隔の生値を表示します。 S字や偏差を含まない指令値となります。 ※VPH装置のバージョンによって測定を行えない場合があります
ロングデバイスモニタ | 指定したデバイス値をロングデバイスとして表示します。
ワードデバイスモニタ | 指定したデバイス値をワードデバイスとして表示します。
状態表示選択 | 選択した状態表示項目を表示します。
入力信号選択 | 選択した入力信号状態を表示します。
出力信号選択 | 選択した出力信号状態を表示します。


3.9.5. 表示スケールの設定

① 時間(X)軸の設定

1) 1画面に表示する表示時間を[時間スケール]コンボボックスから選択します。

2) 時間スケールは0.05, 0.1, 0.2, 0.5, 1,2, 5, 10, 20, 50秒とします。

② 表示データ範囲(Y)軸の設定

1) 数値表示項目の場合は、1画面に表示する数値データ範囲を、[スケール]コンボボックスから選択します。100%時の数値とは、オシロスコープ設定ウィンドウで設定した表示最大値となります。

2) 信号表示項目の場合は、信号OFF時の表示位置を、[オフセット]コンボボックスから選択します。オフセット0%の表示位置とは、Y軸の中央を意味します。

3) スケールは0.1, 0.5, 1,5, 10, 25, 50, 100%とします。

4) オフセットは-80 , -60, -40, -20, 0,20, 40, 60, 80%とします。


3.9.6 リアルタイム表示の開始／停止

1) オシロスコープのリアルタイム表示を開始する場合は、[開始]ボタンをクリックします。表示中は[開始]ボタンが[停止]ボタンになります。

2) [停止]ボタンをクリックすると表示を停止します。

3) 表示を停止すると次のように測定波形が表示されます。


3.9.7. グラフ設定

オシロスコープウィンドウの[スケール][オフセット]設定エリア内で右クリックすると、グラフ設定ウィンドウが表示されます。

グラフ設定ウィンドウでは、表示対象チャンネルの色選択・表示対象描画順・カーソル色設定・トリガ閾値線色設定を行うことができます。

① 測定グラフ線色設定

各チャンネルの測定グラフの線色は[線色CH1]～[線色CH4] コンボボックスで選択した色でそれぞれ表示されます。

② 描画順設定

チャンネル選択のリストから描画順を変更したいチャンネルを選択し、[前面へ移動][背面へ移動]にて順序を変更します。

③ カーソル色設定

[カーソルA色]コンボボックス、[カーソルB色]コンボボックスで選択した色でそれぞれ表示されます。

④ トリガ閾値線色設定

[Trigger] コンボボックスで選択した色で表示されます。


3.9.8. カーソルの設定

① カーソルの設定

1) ボタン[A]または[B]をクリックします。選択したカーソル（A／B）に対応する情報表示欄の表示文字が太字になります。[A]または[B]は排他的に選択されます。

2) カーソルAが選択されている状態で再度ボタン[A]をクリックするとカーソルAの選択が解除されます。カーソルBについても同様です。

② チャンネルの設定

1) ボタン[CH1]～[CH4]を選択します。選択したチャンネルにカーソル線が対応付けられます。

2) 現在選択されているチャンネルはボタン色が変更されます。

③ カーソル情報の表示

1) 現在カーソルAまたはBが表示されている位置の時間及びCH1～CH4の情報がカーソルに対応する情報表示欄に表示されます。

2)[差異]の欄には[A]点と[B]点の値の差を表示します。

3) [A－B Min][A－B Max]の欄には、[A]点と[B]点の間の最小値・最大値を表示します。

④ カーソルの移動

1) 画面上の任意の点をクリックするとその点に十字カーソルが表示されます。

2) LeftButton または RightButton をクリックするとカーソル位置の微調整が可能です。マウスを押し続けるとカーソルが自動的に移動します。

3) カーソルA及びカーソルBが表示されている状態で paraMoveButton をクリックすると paraMoveButtonPushed に切替わります。この状態で LeftButton または RightButton をクリックするとカーソルA及びカーソルBが同時に平行移動します。

注記

開始ボタンクリック時に、接続中の装置で使用できない表示項目が設定されている場合、以下のメッセージが表示されます。

[OK]ボタンをクリックすると、オシロ設定画面が表示されるので、表示項目を変更してください。


3.9.9. 負荷率計算

負荷率を表示する場合は、「トルク指令」の測定を行います、カーソルA、Bを指定します、そして「負荷率計算」ボタンをクリックします。

注記

カーソルAまたはBが指定されていない場合、以下のメッセージが表示されます。

トルクデータが計測されていない場合、以下のメッセージが表示されます。

複数のチャンネルで「トルク指令」を測定した場合、一番番号の小さいチャンネルの負荷率を計算します。

(例:CH1～3を全て「実トルク指令」にした場合、CH1の「実トルク指令」の負荷率を計算)


3.9.10. オシロスコープ表示項目の再設定

表示項目の変更を行う場合は[オシロ設定]をクリックしてチャンネル設定を行います。


3.9.11. ファイルを開く

本ソフトウェアのオシロスコープ機能で保存したオシロデータを表示します。

① メインツールバーから開く

1) メインツールバーの[ファイル(F)]→[ファイルを開く(O)]→[オシロデータ(O)] をクリック

2) ファイルを開くダイアログが表示されるので、開きたいオシロデータファイルを選択し[開く]ボタンをクリックします。

3) 読み込み中は、以下の画面が表示されます。

注記

ファイルの種類より選択できる拡張子は装置により異なります。

※詳しくは[6.1. ファイル拡張子一覧]を参照

本画面にオシロデータファイルをドロップすることで、オシロデータファイルを開くこともできます。

※対応するファイルは[6.2. ファイルドロップについて]を参照

グラフは保存されている時間軸で表示されます。

Version 2.2.0以降で保存したファイルには、カーソル位置とスクロール位置が保存され、ファイルを開くとカーソル位置とスクロール位置が復元されます。

Version 2.1.0以前のVPH Data Editing Softwareにて保存したファイルを開いた場合は、カーソル位置とスクロール位置は復元されません。

機能制限について

保存したオシロデータを表示した場合は以下の機能が無効となります。

1.オシロ計測

2.オシロ設定のCH有効選択と単位変換以外の機能


3.9.12. ファイルに保存

本ウィンドウ上で表示しているオシロデータをファイルに保存する場合は、メニューバーから

①[名前を付けて保存]ボタンをクリックします。

②AとBのカーソルが表示されている場合、保存方法を選択できます。

注記

保存できるデータは300[sec]までとなります。

csv形式でデータを保存した場合、現在表示している単位系のデータを出力します。

表示最大値の設定や計算誤差により整数データが小数点付きのデータとなることがあります。


3.9.13. 印 刷

表示されているオシロデータを印刷する場合は、メニューバーから

[印刷]ボタンをクリックします。

印刷ウィンドウが表示さますので、各項目を設定して[OK]ボタンをクリックします。

注記

用紙サイズは[Ａ４、Ａ３]，印刷向きは[縦、横]の指定が可能ですが、実際の出力は[Ａ４]，[縦]形式で行われます。


3.9.14. ウィンドウクローズ

表示されているオシロスコープウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。


3.10. 周波数スペクトルウィンドウ

周波数スペクトルの測定を行いリアルタイムにグラフ表示します。


3.10.1. 測定ウィンドウの表示

メインツールバーの

[解析機能]タブ→[周波数スペクトル測定]をクリックすると、本ウィンドウが表示されます。


3.10.2. 測定設定

① 測定対象の設定

1) [測定対象]コンボボックスから測定対象を選択します。

2) 測定対象は速度，トルクとします。

② 周波数の設定

1) [周波数]コンボボックスから測定周波数を選択します。

2) 測定周波数（Hz）は装置とパラメータ設定により以下の範囲で変動します。

最大測定間隔 | 10000 | 5000 | 3333 | 2500 | 2000
最小測定間隔 | 2500 | 1250 | 833 | 625 | 500

注記

ご使用になるパソコンの動作性能（OS及び処理時間）によっては設定した周波数で測定ができない場合があります。この場合は測定周波数を下げて下さい。

[周波数]コンボボックス変更時に、接続中の装置と周波数が異なる場合、以下のメッセージが表示されます。

[OK]ボタンをクリックすると、グラフと周波数がリセットされます。

[キャンセル]ボタンをクリックすると、グラフと周波数はそのままの状態になります。


3.10.3. 画面の表示制御の設定

① 振幅の設定

1) Y軸の測定対象（速度／トルク）の振幅の表示スケールを[振幅]コンボボックスから選択します。

2) スケールは、自動, 1, 2, 3, 4, 5, 10, 20, 50%（又はdB）とします。

② 線色、背景色、線幅の設定

1) 線色、背景色、線幅を[線色]、[背景色]、[線幅]コンボボックスから選択します。

2) 線色は、[赤]、[緑]、[青]、[橙]、[シアン]、[マゼンタ]とします。

3) 背景色は、[白]、[黒]とします。

4) 線幅は、[細線]、[太線]、[極太線]とします。

③ 表示対象の設定

1) 測定結果の表示方法を[画面切替]コンボボックスから選択します。

2) 表示方法は、[リニア]及び[対数]とします。

3) リニアの場合は、定格速度または定格トルクを[100%]に対応させた形で%表示されます。

4) 対数の場合は、定格速度または定格トルクを[1]に正規化した形でデシベル表示されます。

[画面切替]を[対数]にした場合、次の画面が表示されます。


3.10.4. 周波数スペクトルの測定開始／停止

1) 周波数スペクトルの測定を開始する場合は、[開始]ボタンをクリックします。測定中は[開始]ボタンが[停止]ボタンになります。

2) [停止]ボタンをクリックすると測定を停止します。

3) 測定が停止されると次のように測定波形が表示されます。同時に、[ノッチフィルタ下限周波数]以上の周波数領域で振幅が最高になる点にカーソルＡが自動設定されます。


3.10.5. カーソルの設定

① カーソルの設定

1) ボタン[A]または[B]をクリックします。選択したカーソル（A/B）に対応する情報表示欄の表示文字が太文字になります。[A]または[B]は排他的に選択されます。

2) カーソルAが選択されている状態で再度ボタン[A]をクリックするとカーソルAの選択が解除されます。カーソルBについても同様です。

3) カーソル設定方法を [image] に設定した場合、クリック位置の前後の周波数にオレンジの線が表示されます。このオレンジの線の範囲内で最も高い周波数にカーソルが設定されます。

カーソルが設定された場合の画面を次に示します。

4) カーソル設定方法を [image] に設定した場合、クリックした周波数にカーソルが設定されます。

カーソルが設定された場合の画面を次に示します。

② カーソルの移動

1) 画面上の任意の点をクリックするとその点に十字カーソルが表示されます。カーソルAの場合は[緑]、カーソルＢの場合は[シアン]で表示されます。（但しカーソル同士が重なる、表示波形、軸線等と重なると一次的に色が変わります。）

2) LeftButton または RightButton をクリックするとカーソル位置の微調整が可能です。マウスを押し続けるとカーソルが自動的に移動します。

③ カーソル情報の表示

1) 現在カーソルAまたはBが表示されている位置の周波数及び速度またはトルクの情報がカーソルに対応する情報表示欄に表示されます。

2) [差異]の欄には[A]点と[B]点の値の差を表示します。

カーソルが設定された場合の画面を次に示します。


3.10.6. ノッチフィルタの設定

本ウィンドウでのノッチフィルタの設定は前節のカーソルの設定と連動しています。

① ノッチフィルタの設定値読出し

1) 本ウィンドウが表示された時点で接続されている装置内に設定されているノッチフィルタの情報が表示されます。

2) ノッチフィルタ枠内の[受信]ボタンをクリックすると接続されている装置内に設定されているノッチフィルタの情報を読出して表示します。

② ノッチフィルタの算出

ノッチフィルタの算出には以下の2方式があります。

1) カーソルAまたはカーソルBのみを設定した場合

中心周波数：カーソル位置の周波数を中心周波数として設定します。

バンド幅率：ノッチフィルタバンド幅率に設定された値をバンド幅率として設定します。

2) カーソルAおよびカーソルBを設定した場合

中心周波数：[A]及び[B]に表示されている周波数の積の平方根（ [image] ）が中心周波数に設定されます。

バンド幅率：バンド幅を中心周波数で割った時の商を百分率に変換した値を設定します。

※100%を超える場合は、100%でクランプします。

カーソルA,B設定時の中心周波数、バンド幅率設定例

カーソル | A | B | 差異
周波数[Hz] | 500 | 1000 | -500

計算式 | 例
中心周波数 = | 707 [Hz] =
バンド幅= ABS(A-B) | 500 [Hz] =
バンド幅率= バンド幅 ÷ 中心周波数 | 0.707107 = 500÷707.1068
バンド幅率[%] = バンド幅率 × 100 | 70 [%] = 0.707107×100

③ ノッチフィルタの設定

1) カーソルA, Bを設定します。

2) フィルタをかける対象のパラメータに対応する[設定]ボタンをクリックします。

3) カーソルの設定により算出した結果を、中心周波数、バンド幅率に設定します。

4) 設定と同時に当該設定値が装置内にも書込まれます。

5) 深さに対応した装置では、値を設定した状態で[設定]ボタンをクリックすることで深さを設定することができます。

注意

この時、設定された内容がシステムにマッチングしないとモータが激振します。ノッチフィルタを設定した位置に対応する[クリア]ボタンを押してノッチフィルタの設定を至急解除して下さい。

6) [ノッチフィルタ下限周波数]に設定した値以下の周波数領域にノッチフィルタの設定をしようとした場合は次のメッセージが表示されます。

[はい]をクリックした場合、設定を強行します。

※本判断はお客様が行います。お客様の装置の安全性を十分に確認した上で判断して下さい。

[いいえ]をクリックした場合、設定を中止します。

通常はこちらを選択します。

7) [ノッチフィルタ下限周波数]、[ノッチフィルタバンド幅率]は、キーボードから[数値＋Enter]を入力することによって設定できます。

（例１）カーソルＡを下図の位置に合わせて各中心周波数の[設定]ボタンをクリックすると下図のようにノッチフィルタが設定されます。

（例２）カーソルＡ及びカーソルＢを下図の位置に合わせて各中心周波数の[設定]ボタンをクリックすると下図のようにノッチフィルタが設定されます。


3.10.7. ファイルを開く

メインツールバーから開く

1) メインツールバーの[ファイル(F)]→[ファイルを開く(O)]→[周波数スペクトル (S)] をクリックします。

2) ファイルを開くダイアログが表示されるので、開きたい周波数スペクトルデータファイルを選択し[開く]ボタンをクリックします。

注記

ファイルの種類より選択できる拡張子は装置により異なります。

※詳しくは[6.1. ファイル拡張子一覧]を参照

本画面に周波数スペクトルデータファイルをドロップすることで、周波数スペクトルデータファイルを開くこともできます。

※対応するファイルは[6.2. ファイルドロップについて]を参照

機能制限について

保存した周波数スペクトルデータを表示した場合は、以下の機能が無効となります。

1.周波数スペクトル計測

2.ノッチフィルタの設定

3.測定設定の変更


3.10.8. ファイルに保存

本ウィンドウ上で表示してる周波数スペクトルデータをファイルに保存する場合は、メニューバーから

[名前を付けて保存] を選びます。


3.10.9. 印 刷

表示されている周波数スペクトルデータを印刷する場合は、メニューバーから

[印刷]ボタンをクリックします。

印刷ウィンドウが表示さますので、各項目を設定して[OK(A)]ボタンをクリックします。

注記

用紙サイズは[Ａ４、Ａ３]，印刷向きは[縦、横]の指定が可能ですが、実際の出力は[Ａ４]，[縦]形式で行われます。


3.10.10. ウィンドウクローズ

表示されている周波数スペクトルウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。


3.10.11. ガイドメッセージ

周波数スペクトルの測定時に次のメッセージが表示されます。指示に従って下さい。

オシロスコープ実行中は周波数スペクトルの測定はできません。

[開始]ボタンをクリックしたときに、接続中の装置と周波数が異なる場合、表示されます。

ノッチフィルタ下限周波数以下（上画面では、100Hz）の領域にノッチフィルタを設定しようとした時に表示されます。

本判断はお客様が行います。お客様の装置の安全性を十分に確認した上で判断して下さい。

ノッチフィルタ深さに対応していない装置に対して、深さを設定しようとした時に表示されます。

周波数スペクトルデータを装置から受信している際にデータの取込みが間に合わなかった時に表示されます。

測定周波数とご使用になるパソコンの動作性能（OS及び処理時間）に依存します。同じパソコンを使用される場合は、測定周波数を下げて測定して下さい。


3.11. 周波数応答ウィンドウ

装置の周波数応答を測定し表示、保存した周波数応答データを表示します。


3.11.1. 測定ウィンドウの表示

メインツールバーの

[解析機能]タブ→[周波数応答]をクリックすると、本ウィンドウが表示されます。


3.11.2. 測定設定

① 測定ゲイン番号の設定

測定ゲイン番号を選択します。

② 測定周波数の設定

1) [測定周波数]コンボボックスから測定周波数を選択します。

2) 測定周波数（Hz）は装置とパラメータ設定により以下の範囲で変動します。

最大測定間隔 | 10000 | 5000 | 3333 | 2500 | 2000
最小測定間隔 | 2500 | 1250 | 833 | 625 | 500

注記

ご使用になるパソコンの動作性能（OS及び処理時間）によっては設定した周波数で測定ができない場合があります。この場合は測定周波数を下げて下さい。

[測定周波数]コンボボックス変更時に、接続中の装置と測定周波数が異なる場合、以下のメッセージが表示されます。

[OK]ボタンをクリックすると、グラフと測定周波数がリセットされます。

[キャンセル]ボタンをクリックすると、グラフと測定周波数はそのままの状態になります。

③ 加振幅（速度指令量／オフセット量）の設定

1) 加振時の加振幅をキーボードから直接入力します。

2) [%]の部分を右クリックすると入力可能なデータ領域が表示されます。

注意

お客様の装置に合わせて安全な範囲内で設定して下さい。

④ 加振時間の設定

加振する時間をキーボードから直接入力します。1Hzから上で設定した測定周波数までの範囲で設定します。

⑤ 許容最大振れ量の設定

許容最大振れ量をキーボードから直接入力します。

注意

お客様の装置に合わせて安全な範囲内で設定して下さい。

特にτリニアモータの場合は有効ストロークをオーバーしないように注意して下さい。

⑥ 計測回数の設定

１Hzから上で設定した測定周波数までの加振を1回として総計測回数をキーボードから直接入力します。


3.11.3. 表示設定

① 振幅の設定

1) Y軸の振幅の表示スケールを[振幅]コンボボックスから選択します。

2) スケールは、自動, 1, 2, 3, 4, 5, 10, 20, 50dBとします。

3) 測定直後は[自動]が設定され、画面全体に波形が表示可能となるようにしています。

② 位相の設定

1) Y軸の位相の表示スケールを[位相]コンボボックスから選択します。

2) スケールは、自動, 15, 30, 45, 60, 75, 90degとします。

3) 測定直後は[自動]が設定され、画面全体に波形が表示可能となるようにしています。

③ 線色、背景色、線幅の設定

1) 線色、背景色、線幅を[線色]、[背景色]、[線幅]コンボボックスから選択します。

2) 線色は、[赤]、[緑]、[青]、[橙]、[シアン]、[マゼンタ]とします。

3) 背景色は、[白]、[黒]とします。

4) 線幅は、[細線]、[太線]、[極太線]とします。

④ 表示対象の設定

1) 測定結果の表示方法を[画面切替]コンボボックスから選択します。

2) 表示方法は、[振幅位相]及び[振幅]とします。

3) 振幅位相の場合は、表示領域の上半分に振幅を、下半分に位相表示します。

4) 振幅の場合は、振幅の画面が表示領域全体に表示されます。


3.11.4. 周波数応答の測定開始／停止

1) 周波数応答の測定を開始する場合は[開始]ボタンをクリックします。測定中は[開始]ボタンが[停止]ボタンになります。

responseStartButton → responseStopButton

2) 次の画面が表示されます。

3) 設定された計測回数分の測定が行われ終了すると自動的に測定を完了し[停止]ボタンが[開始]ボタンに戻ります。

4) 測定が完了すると同時に、[ノッチフィルタ下限周波数]以上の周波数領域で前ポイントと現ポイトでの振幅の変化量が最高になる点にカーソルAが自動設定されます。

5) 測定中に緊急に動作を停止させたい場合は再度[停止]ボタンをクリックします。測定が緊急停止します。

6) 測定完了時は次の画面になります。


3.11.5. カーソルの設定

① カーソルの設定

1) ボタン[A]または[B]をクリックします。選択したカーソル（A/B）に対応する情報表示欄の表示文字が赤になります。[A]または[B]は排他的に選択されます。

2) カーソルAが選択されている状態で再度ボタン[A]をクリックするとカーソルAの選択が解除されます。カーソルBについても同様です。

3) カーソル設定方法を [image] に設定した場合、クリック位置の前後の周波数にオレンジの線が表示されます。このオレンジの線の範囲内で最も高い周波数にカーソルが設定されます。

カーソルが設定された場合の画面を次に示します。

4) カーソル設定方法を [image] にした場合、クリックした周波数にカーソルが設定されます。

カーソルが設定された場合の画面を次に示します。

② カーソルの移動

1) 画面上の任意の点をクリックするとその点に十字カーソルが表示されます。カーソルAの場合は[緑]、カーソルBの場合は[シアン]で表示されます。（但しカーソルが重なったり、表示波形、軸線等と重なったりすると一次的に色が変わります。）

2) LeftButton または RightButton をクリックするとカーソル位置の微調整が可能です。マウスを押し続けるとカーソルが自動的に移動します。

③ カーソル情報の表示

1) 現在カーソルAまたはBが表示されている位置の周波数及び振幅または位相の情報がカーソルに対応する情報表示欄に表示されます。

2) [差異]の欄には[A]点と[B]点の値の差を表示します。


3.11.6. ノッチフィルタの設定

本ウィンドウでのノッチフィルタの設定は前節のカーソルの設定と連動しています。

① ノッチフィルタの設定値読出し

1) 本ウィンドウが表示された時点で接続されている装置内に設定されているノッチフィルタの情報が表示されます。

2) ノッチフィルタ枠内の[受信]ボタンをクリックすると接続されている装置内に設定されているノッチフィルタの情報を読出して表示します。

② ノッチフィルタの算出

ノッチフィルタの算出には以下の2方式があります。

① カーソルAまたはカーソルBのみを設定した場合

中心周波数：カーソル位置の周波数を中心周波数として設定します。

バンド幅率：ノッチフィルタバンド幅率に設定された値をバンド幅率として設定します。

② カーソルAおよびカーソルBを設定した場合

中心周波数：[A]及び[B]に表示されている周波数の積の平方根（ [image] ）が中心周波数に設定されます。

バンド幅率：バンド幅を中心周波数で割った時の商を百分率に変換した値を設定します。

※100%を超える場合は、100%でクランプします。

カーソルA,B設定時の中心周波数、バンド幅率設定例

カーソル | A | B | 差異
周波数[Hz] | 500 | 1000 | -500

計算式 | 例
中心周波数 = | 707 [Hz] =
バンド幅= ABS(A-B) | 500[Hz] =
バンド幅率= バンド幅 ÷ 中心周波数 | 0.707107 = 500÷707.1068
バンド幅率[%] = バンド幅率 × 100 | 70 [%] = 0.707107×100

③ ノッチフィルタの設定

1) カーソルA, Bを設定します。

2) フィルタをかける対象のパラメータに対応する[設定]ボタンをクリックします。

3) カーソルの設定により算出した結果を、中心周波数、バンド幅率に設定します。

4) 設定と同時に当該設定値が装置内にも書込まれます。

5) 深さに対応した装置では、値を設定した状態で[設定]ボタンをクリックすることで深さを設定することができます。

注意

この時、設定された内容がシステムにマッチングしないとモータが激振します。ノッチフィルタを設定した位置に対応する[クリア]ボタンを押してノッチフィルタの設定を至急解除して下さい。

6) [ノッチフィルタ下限周波数]に設定した値以下の周波数領域にノッチフィルタの設定をしようとした場合は次のメッセージが表示されます。

[はい]をクリックした場合、設定を強行します。

※本判断はお客様が行います。お客様の装置の安全性を十分に確認した上で判断して下さい。

[いいえ]をクリックした場合、設定を中止します。

通常はこちらを選択します。

7) [ノッチフィルタ下限周波数]、[ノッチフィルタバンド幅率]はキーボードから[数値＋Enter]を入力することによって設定できます。

（例１）カーソルAを下図の位置に合わせて各中心周波数の[設定]ボタンをクリックすると下図のようにノッチフィルタが設定されます。

（例２）カーソルＡ及びカーソルＢを右図の位置に合わせて各中心周波数の[設定]ボタンをクリックすると下図のようにノッチフィルタが設定されます。


3.11.7. ファイルを開く

メインツールバーから開く

1) メインツールバーの[ファイル(F)]→[ファイルを開く(O)]→[周波数応答(R)] をクリックします。

2) ファイルを開くダイアログが表示されるので、開きたい周波数応答データファイルを選択し[開く]ボタンをクリックします。

注記

ファイルの種類より選択できる拡張子は装置により異なります。

※詳しくは[6.1. ファイル拡張子一覧]を参照

本画面に周波数応答データファイルをドロップすることで、周波数応答データファイルを開くこともできます。

※対応するファイルは[6.2. ファイルドロップについて]を参照

機能制限について

保存した周波数応答データを表示した場合は、以下の機能が無効となります。

1.周波数応答計測

2.ノッチフィルタの設定

3.測定条件の変更


3.11.8. ファイルに保存

本ウィンドウ上で表示している周波数応答データをファイルに保存する場合は、メニューバーから

[名前を付けて保存]ボタンをクリックします。


3.11.9. 印 刷

1) 表示されている周波数応答データを印刷する場合は、メニューバーから

[印刷]ボタンをクリックします。

2) 印刷ウィンドウが表示さますので、各項目を設定して[印刷]ボタンをクリックします。

注記

用紙サイズは[Ａ４、Ａ３]，印刷向きは[縦、横]の指定が可能ですが、実際の出力は[Ａ４]，[縦]形式で行われます。


3.11.10. ウィンドウクローズ

表示されている周波数応答ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。

その際以下の画面が表示されることがあります。


3.11.11. ガイドメッセージ

周波数応答の測定時に次のメッセージが表示されます。指示に従って下さい。

周波数応答データを装置から受信している際にデータの取込みが間に合わなかった時に表示されます。

ご使用になるパソコンの動作性能（OS及び処理時間）によっては設定した周波数で測定ができない場合があります。この場合は測定周波数を下げて下さい。

装置内で加振を実行している際にエラーが発生した時に表示されます。

加振幅、許容最大振れ量等を変更後再測定して下さい。

[開始]ボタンをクリックしたときに、接続中の装置と測定周波数が異なる場合、表示されます。

装置からノッチフィルタの値を受信する場合に異常が発生した時に表示されます。

USB通信できる状態になっているか確認してください。

カーソルが設定されていない状態でノッチフィルタの設定を行おうとした時に表示されます。 カーソルを設定して下さい。

ノッチフィルタ深さに対応していない装置に対して、深さを設定しようとした時に表示されます。


3.12. 状態表示ウィンドウ

アラーム履歴、装置状態、装置情報、エンコーダ情報、モータ情報等を表示します。


3.12.1. 状態表示ウィンドウの表示

メインツールバーの

[状態表示]タブ→[状態表示]をクリックすると、本ウィンドウが表示されます。


3.12.2. 状態情報

① 状態表示タブを選択すると運転情報が表示されます。

② 項目の現在値が[データ]表示欄に表示されます。

③ 項目の現在の単位が[単位]表示欄に表示されます。

④クリアボタンをクリックした場合、次の確認メッセージが表示されます。

[OK]ボタンをクリックすると、対象の項目のデータがクリアされます。

[キャンセル]ボタンをクリックすると、クリアを中止して元の画面に戻ります。

⑤状態グループ選択ボタンをクリックするとグループ単位で状態の表示を行うことができます。

次のウィンドウは[位置]グループを選択した時の表示内容 です。

⑥[ユーザカスタム]グループを選択すると、表示項目の順番を入れ替えたり、不要な項目を非表示にすることができます。

項目を下へ移動する際は、移動したい項目を選択して、[ [image] ]ボタンをクリックします。

項目を上へ移動する際は、移動したい項目を選択して、[ [image]]ボタンをクリックします。

項目を非表示にするには、非表示にしたい項目を選択して、[非表示]ボタンをクリックします。

初期状態に戻す際は、[初期表示]ボタンをクリックします。


3.12.3. アラーム情報

① アラームタブを選択するとアラーム情報が表示されます。

② 各項目の現在値が[Data]表示欄に表示されます。

③ [一覧表示]ボタンをクリックすると、アラームワーニング一覧画面が表示されます。

表示されているアラームを右クリックすると、アラームワーニング一覧画面でアラームの詳細が表示されます。

④ [アラームクリア]ボタンをクリックすると次の確認メッセージが表示されます。

[OK]ボタンをクリックするとアラーム情報がクリアされます。

[キャンセル]ボタンをクリックするとクリアを中止して元の画面に戻ります。


3.12.4. 装置情報表示

① 装置情報タブを選択すると装置情報が表示されます。

② 項目の現在値が[Data]表示欄に表示されます。

③ 項目の現在の単位が[単位]表示欄に表示されます。


3.12.5. エンコーダ情報表示

  ① エンコーダ情報タブを選択すると、エンコーダ情報が表示されます。

  ② 項目の現在値が[Data]表示欄に表示されます。

③ 項目の現在の単位が[単位]表示欄に表示されます。

注記

エンコーダ情報の表示に対応していない装置を接続した場合、以下のメッセージが表示され、エンコーダ情報タブが非表示になります。

エンコーダ情報に対応している装置を接続した場合、以下のメッセージが表示され、エンコーダ情報タブが表示されます。


3.12.6. モータ情報表示

  ① モータ情報タブを選択すると、モータ情報が表示されます。

  ② 項目の現在値が[Data]表示欄に表示されます。

③ 項目の現在の単位が[単位]表示欄に表示されます。

※モータによっては情報がないため、モータ情報タブに項目が表示されない場合があります。

注記

モータ情報の表示に対応していない装置を接続した場合、以下のメッセージが表示され、モータ情報タブが非表示になります。

モータ情報に対応している装置を接続した場合、以下のメッセージが表示され、モータ情報タブが表示されます。


3.12.7. ウィンドウクローズ

表示されている状態表示ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。


3.13. 入出力信号状態表示ウィンドウ

入出力信号状態を表示します。


3.13.1. 入出力信号状態表示ウィンドウの表示

メインツールバーの

[状態表示]タブ→[入出力表示]をクリックすると、本ウィンドウが表示されます。


3.13.2. 入出力信号状態表示

① 入出力信号の現在の状態が表示されます。

② 信号が[オン]の状態で青色表示になります。

③ 信号記号上にマウスカーソルを移動すると信号名が表示されます。


3.13.3. ウィンドウクローズ

表示されている状態表示ウィンドウを閉じる場合は、[×]ボタンをクリックします。


3.14. リモート運転ウィンドウ

本ソフトウェア上から入出力信号を操作してリモート運転を行います。


3.14.1. スイッチBOXウィンドウの表示

メインツールバーの

[リモート操作]タブ→[スイッチボックス] をクリックすると、本ウィンドウが表示されます。

ウィンドウ内の各信号内容については装置の取扱説明書を参照して下さい。


3.14.2. 出力信号状態の表示

出力信号の状態をリアルタイムに表示します。

（信号ON時：緑色，赤色 ／ 信号OFF時：背景色）


3.14.3. 入力信号のON／OFF操作

入力信号をON／OFFする場合は、各ボタン,タブ（速度制御モード他），リストボックス（SS1-3）を操作します。

① 通常入力信号ボタン

SwitchBoxButton | 表示 | 通常のフォント
 | 動作 | クリック：ON/OFF切替 右クリック：ON/OFF切替

② モーメンタリー入力信号ボタン

SwitchBoxButton | 表示 | イタリックのフォント
 | 動作 | ボタンプレス状態：ON ボタンリリース状態：OFF 右クリック：ON/OFF切替

注意

入力信号の操作によってはモータが動作しますので、十分安全を確認した上で行って下さい。


3.14.4. ウィンドウクローズ

表示されているリモート運転ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。


3.15. リアルタイムサーボ調整ウィンドウ

オートチューニング後のレベル調整と速度／位置ループゲイン及びサーボ調整パラメータをリアルタイムに変更します。


3.15.1. リアルタイムサーボ調整ウィンドウの表示

メインツールバーの

[調整機能]タブ→[リアルタイムサーボ調整]をクリックすると、本ウィンドウが表示されます。

注記

Version 2.2.0から本ソフトウェアで保持していたFBフィルタ設定方法選択の値が、装置に保持されるようになりました。

本画面起動時に装置内のFBフィルタ設定方法選択が未設定の場合、以下のメッセージが表示されます。

また、USB接続時もFBフィルタ設定方法選択のチェックを行い、未設定の場合は本メッセージが表示されます。


3.15.2. 調整対象ゲインの選択

1) 調整対象項目を[調整ゲイン選択]コンボボックスから選択します。

2) 選択された調整対象項目に関連するパラメータが関連パラメータ表示／設定領域に表示されます。


3.15.3. パラメータ調整

① ボタンによる調整

1) 関連パラメータ表示／設定領域で各項目の調整ボタン[▲][▼]をクリックします。

2) [▲]をクリックするとパラメータの設定値がインクリメントされ、リアルタイムに更新されます。

3) [▼]をクリックするとパラメータの設定値がデクリメントされ、リアルタイムに更新されます。

4) インクリメント量調整ラジオボタンで、[▲][▼]をクリックしたときのインクリメント／デクリメント量を変更することができます。

② キーボードによる調整

キーボードで直接値を設定します。

設定値は、[Enter]キーを押下したときに確定します。

設定値に不正な値を入力した場合、メッセージを表示し設定値を直前の値に戻します。

範囲外の値を入力した場合

数値以外の値を入力した場合

注記

ゲイン調整ボタン[▲][▼]を押下し続けている間は、インクリメント、又はデクリメメントし続けます。

設定値が確定されない状態では、赤文字で表示されます。

設定値を確定するためには、[Enter]キーを押下します。

③ 低速ゲイン(Step3)と連動

① 低速ゲイン(Step3)と連動チェックボックスにチェックを入れます。

② Step1(連動元パラメータ)を確定すると、Step3(連動先パラメータ)を変更します。

Step1 | Step3
速度ループ比例ゲイン | 速度ループ比例ゲイン／低速ゲイン
速度ループ積分時定数 | 速度ループ積分時定数／低速ゲイン
速度ループ微分時定数 | 速度ループ微分時定数／低速ゲイン
速度ループ比例ゲイン分配率 | 速度ループ比例ゲイン分配率／低速ゲイン
位置ループゲイン | 位置ループゲイン／低速ゲイン
位置ループ微分時定数 | 位置ループ微分時定数／低速ゲイン


3.15.4. イナーシャの設定

[イナーシャ]の値を変更すると次の確認メッセージが表示されます。

[OK]をクリックすると現在のイナーシャ定値を装置内のパラメータに設定します。

[キャンセル]をクリックするとパラメータの設定を中止します。


3.15.5. 粘性摩擦の設定

[粘性摩擦]の値を変更すると次の確認メッセージが表示されます。

[OK]をクリックすると現在の粘性摩擦値を装置内のパラメータに設定します。

[キャンセル]をクリックするとパラメータの設定を中止します。


3.15.6. FBフィルタ設定

1)本ウィンドウの表示時、USB接続時、[ [image]]の押下時に装置内のFBフィルタ設定方法選択の値を受信し、FBフィルタ設定方法選択に反映します。

2)[FBフィルタ設定方法選択]コンボボックスを[手動]に設定すると、[FBフィルタ次数]、[FBフィルタ周波数]を手動で設定可能になります。

3)[FBフィルタ設定方法選択]コンボボックスを[手動]以外に設定すると、FBフィルタ処理を行い、[FBフィルタ次数]、[FBフィルタ周波数]が自動で更新されます。

また、この状態で、オートチューニングレベル調整を行う場合も、同様に更新されます。

4)[更新]ボタンをクリックすると、FBフィルタ設定方法選択の値を装置へ送信します。


3.15.7. 調整前のパラメータに戻す

[ [image]]をクリックすると次の確認メッセージが表示されます。

[はい]をクリックすると、パラメータとFBフィルタ設定方法選択を調整前の設定に戻します。

[いいえ]をクリックするとパラメータを元に戻すを中止します。


3.15.8. パラメータの更新

[更新]ボタンをクリックすると次の確認メッセージが表示されます。

全ての設定値が確定されている場合 [OK]をクリックすると現在のゲイン設定値とFBフィルタ設定方法選択値を装置に送信します。 [キャンセル]をクリックするとパラメータの設定を中止します。 | realTimeGainRegist
未確定（赤字）の設定値がある場合 赤字の設定値を確定（Enterキー）し、再度[更新]ボタンをクリックします。 |


3.15.9. ウィンドウクローズ

表示されているリアルタイムゲイン調整ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。

画面を閉じる際に、[更新]が行われていない場合、次のメッセージが表示されます。

※[更新]ボタンをクリックしないで閉じても装置のRAM領域に記録されているため、装置の電源を切るまで本ウィンドウ表示時に編集状態が保持されます。


3.16. オートチューニングウィンドウ

オートチューニングを行い、ゲインパラメータを設定します。


3.16.1. ウィンドウの表示

メインツールバーから[調整機能]タブ→[オートチューニング] をクリックすると、本ウィンドウが表示されます。

注記

Version 2.2.0から本ソフトウェアで保持していたFBフィルタ設定方法選択の値が、装置に保持されるようになりました。

本画面起動時に装置内のFBフィルタ設定方法選択が未設定の場合、以下のメッセージが表示されます。

また、USB接続時もFBフィルタ設定方法選択のチェックを行い、未設定の場合は本メッセージが表示されます。


3.16.2. 動作パラメータの受信

動作パラメータ受信ボタンをクリックすると、装置の動作パラメータを受信し、動作パラメータ設定項目にその値を反映します。

注記

Version 2.2.0から本ソフトウェアで保持していたFBフィルタ設定方法選択の値が、装置に保持されるようになりました。

動作パラメータの受信時に装置内のFBフィルタ設定方法選択が未設定の場合、以下のメッセージが表示されます。

また、USB接続時もFBフィルタ設定方法選択のチェックを行い、未設定の場合は本メッセージが表示されます。


3.16.3. 動作パラメータの設定

チューニングゲイン、動作方向、運転比率、最大トルク、イナーシャ倍率を設定します。


3.16.4. FBフィルタの設定

本ウィンドウの表示時、USB接続時、動作パラメータの受信時に、装置内のFBフィルタ設定方法選択を受信し、FBフィルタ設定方法選択に反映します。

FBフィルタ設定方法選択が[手動]の場合、FBフィルタ次数、FBフィルタ周波数に設定した値でFBフィルタ処理を行います。

FBフィルタ設定方法選択が[手動]以外の場合、自動でFBフィルタ処理を行います。


3.16.5. オートチューニングの開始

開始ボタンをクリックすると、動作パラメータに設定したパラメータでオートチューングを開始します。

オートチューニングの結果はステータスに表示されます。


3.16.6. 詳細の表示

ウィンドウの右上にある [image] をクリックすると、モータ動作予想値とオートチューニング結果を表示します。

VPH-HB装置・VPH-HD装置・VPH-HE装置の場合、deg単位もしくはmm単位のモータ動作予想値が追加表示されます。

VPH装置と通信できない場合、モータ動作予想値は「---」となります。

VPH-HA装置・VPH-HC装置

VPH-HB装置・VPH-HD装置・VPH-HE装置


3.16.7. ウィンドウクローズ

表示されている位置決めオートチューニングウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。

オートチューニング実行後の場合、以下のメッセージを表示します。


3.17. テスト運転ウィンドウ

テスト運転を行います。


3.17.1. テスト運転ウィンドウの表示

メインツールバーから[調整機能]タブ→[テスト運転]を選択すると、本ウィンドウが表示されます。


3.17.2. 動作の設定

項目名 | 設定範囲 | 説明
開始位置指定 | 無効、ABS、INC | 動作開始位置の方法を選択できます。
HCP制限 | HCP制限、制限無 | [開始位置指定]が「ABS」の場合のみ表示されます。 「HCP制限」の場合、原点復帰完了していない状態ではテスト運転を実行できません。 「制限無」の場合、原点復帰完了していない状態でもテスト運転を実行します。
動作開始位置 | -2147483648～2147483647 [P161] | モータの動作開始位置を指定します。 単位と小数点位置はP161の設定値に従います。
開始位置移動速度 | 0～300000000[P161/sec] | 動作開始位置までのモータの移動速度を設定します。 単位と小数点位置はP161の設定値に従います。
動作方向 | ＋方向、－方向、往復 | モータの動作方向を選択できます。
移動量 | -2147483648～2147483647 [P161] | モータの移動量を設定します。 単位と小数点位置はP161の設定値に従います。
速度 | 0～300000000[P161/sec] | モータの動作速度を設定します。 単位と小数点位置はP161の設定値に従います。
停止時間 | 0.000～999.999[s] | 位置決め完了後から次の位置決め開始までの停止時間を設定します。
SEL選択 | SEL.0、SEL.1、SEL.2、SEL.3、SEL.4、SEL.5、SEL.6、SEL.7 | 選択したSELの加減速時間でモータが動作します。
加速時間 | -9.9～99999.9[ms] | 選択したSELのモータ加速時間を設定します。
減速時間 | -9.9～99999.9[ms] | 選択したSELのモータ減速時間を設定します。
S字時間1 | -9.9～1000.0[ms] | 選択したSELのモータS字時間1を設定します。 チェックボックスにチェックを入れると、パルス列指令のS字時間1に同じ値を設定します。
S字時間2 | -9.9～1000.0[ms] | モータ加減速時間及びS字時間1にさらにS字時間2を設定します。

注記

S字時間1の同時設定チェックボックスがOFFの状態でテスト運転を実行していた場合、SEL選択を変更すると以下のメッセージが表示されます。

「はい」ボタンをクリックすると、S字時間1の値を装置に設定します。

「いいえ」ボタンをクリックすると、SEL選択を変更します。

[開始位置指定]が「ABS」、[HCP制限]が「HCP制限」で、原点復帰完了していない状態で、テスト運転を実行すると、以下のメッセージが表示されます。


3.17.3. 停止設定

項目名 | ON/OFF | 説明
USB通信時切断時モータ停止 | ON | テスト運転動作中にUSB通信を切断した場合でも、テスト運転動作を継続します。
 | OFF | テスト運転動作中にUSB通信を切断した場合、テスト運転動作を停止します。
サイクル停止 | ON | 動作開始位置に戻って、テスト運転動作を終了します。
 | OFF | 現在位置で、テスト運転動作を終了します。


3.17.4. テスト運転の開始／停止

注意

本機能を実行するとモータが動作しますので、十分安全を確認した上で行って下さい。

1) [開始]ボタンをクリックすると、以下のメッセージを表示します。

2) 動作中は一定間隔でステータスを更新します。

動作中の状態はステータスに表示されます。

ステータス | 状態
RUNNING[実行回数] | 実行中
CYCLE STOP RUNNING[実行回数] | サイクル停止実行中
STOP[実行回数] | 途中停止
ALARM STOP[実行回数] アラーム名 | アラーム停止 アラームの名称
WARNING STOP[実行回数] | ワーニング停止
FORCED STOP[実行回数] | 強制停止
USB CLOSE | 装置とUSB通信できない

3) 運転を停止する場合

① [サイクル停止]ボタンをクリックした場合、テスト運転をサイクル停止で停止します。([停止設定]の[サイクル停止]がONの場合のみ)

② [減速停止]ボタンをクリックした場合、テスト運転を減速停止で停止します。

③ [急停止]ボタンをクリックした場合、テスト運転を急停止で停止します。

④ [Esc]キーを押下した場合、テスト運転を急停止で停止します。


3.17.5. 動作状態の表示

ウィンドウの右上にある [image] をクリックすると、動作状態を表示します。

をクリックすると動作状態を非表示にできます。

動作状態の表示内容は以下の通りです。

項目名 | 説明
現在位置 | モータの現在位置(C021)を表示します。
位置決め目標位置1 | 次の位置決め目標位置を表示します。
位置決め目標位置2 | 位置決め目標位置1の次の位置決め目標位置を表示します。
速度 | モータの実動作速度(C001)を表示します。

動作方向はモータの動作方向に合わせて黄色矢印が表示されます。

状態 | τDISC |  |  | τリニア
 | 往復 | ＋方向 | －方向 | 往復 | ＋方向 | －方向
未実行 |  |  |  |
停止中 |  |  |  |  |  |
＋方向動作中 |  |  |  |  |  |
－方向動作中 |  |  |  |  |  |

注記

モータ動作中、停止中の判断はSZ信号により判断します。

モータ動作中にも関わらず黄色矢印が表示されない場合、SZ信号速度範囲(P651)をモータ動作速度未満に設定してください。

動作方向の表示は以下の設定で逆方向とすることが可能です。

項目名 | 説明
通常設定 | モータの動作方向を表示します。
特殊設定 | モータの動作方向を反転表示します。


3.17.6. VPH装置による追加表示

VPH-HB装置・VPH-HD装置・VPH-HE装置の場合、単位を「deg」もしくは「mm」に換算された項目が追加表示されます。

追加表示部分についてVPH装置と通信できない場合、動作パラメータ設定は空白になり、動作状態は「0.00」となります。

換算されて追加表示される項目は以下の通りです。

動作パラメータ設定 | 動作表示
動作開始位置 | 現在位置
開始位置移動速度 | 位置決め目標位置1
移動量 | 位置決め目標位置2
速度 | 速度


3.17.7. ウィンドウクローズ

表示されている位置決めテスト運転ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。

テスト運転実行後の場合、以下のメッセージを表示します。

注記

S字時間1の同時設定チェックボックスがOFFの状態でテスト運転を実行していた場合、以下のメッセージが表示されます。

「はい」ボタンをクリックすると、S字時間1の値を装置に設定します。

「いいえ」ボタンをクリックすると、そのまま画面を終了します。


3.18. 自己診断ウィンドウ

パソコン上から装置の自己診断を実行します。

注意

自己診断の項目内容によりサーボ動作を伴いますので、十分安全を確認した上で行って下さい。


3.18.1. ウィンドウの表示

メインツールバーから

[調整機能]タブ→[自己診断]をクリックすると、本ウィンドウが表示されます。


3.18.2. 自己診断項目の選択

[診断項目選択(DG No.)]コンボボックスから自己診断項目を選択します。


3.18.3. 自己診断の開始／終了

① 自己診断を開始する場合は、[診断開始]ボタンをクリックします。
診断を開始すると、[診断開始]ボタンが[診断終了]ボタンに変わります。

② 自己診断を終了する場合は、[診断終了]ボタンをクリックします。
診断を終了すると、[診断終了]ボタンが[診断開始]ボタンに変わります。


3.18.4. 診断結果の表示

自己診断中／診断終了時の診断結果は、[診断内容の設定／表示]ボックス内に表示されます。


3.18.5. ウィンドウクローズ

表示されている自己診断ウィンドウを閉じる場合は、[×]ボタンをクリックします。

自己診断実行後の場合、次のメッセージが表示されます。


3.19. デバイスモニタウィンドウ

装置内のデバイス内容をモニタリングします。


3.19.1. ウィンドウの表示

メインツールバーから

[状態表示]タブ→[デバイスモニタ] をクリックすると、本ウィンドウが表示されます。

ウィンドウの概要

① [Bit]項目：Bit単位（0/1）の読出し/書込みができます。

② [Word]項目：Word単位（-32768～32767）の読出し／書込みができます。

③ [Long]項目：Long単位（-2147483648～2147483647）の読出し／書込みができます。

④ [IX Device]、[R Device]、[D Device] 、[X Device]の場合は、該当する枠内で直接データの操作ができます。

⑤ その他のデバイス（X/R/D/IX）の場合は[ Device][Word]／[Long]枠内でデバイスの種別を指定してデータの操作ができます。

⑥ [R]ボタンで装置からのデータ読出しができます。

⑦ [W]ボタンで装置へのデータ書込みができます。


3.19.2. データの読出し

1) 各枠内のデバイス番号入力エリア(①)にデバイス番号を入力します。

デバイス番号は[▲][▼]ボタン(②)をクリックすることでも増減します。

増減量は、インクリメント量調整コンボボックス(③)で指定することができます。

2) [R]ボタン(④)をクリックします。

3) 読出したデータは各枠内のデータエリア(⑤)に表示されます。

浮動小数地表示エリア(⑥)は読み出した32bitデータをフロート表示します。

4) 読出した際の処理結果は状態表示ボックス(⑦)に表示します。

（正常終了時：OK／異常終了時：ＮＧが表示されます。）


3.19.3. データの書込み操作

1) 各枠内のデバイス番号入力エリア(①)にデバイス番号を入力します。

デバイス番号は[▲][▼]ボタン(②)をクリックすることでも増減します。

増減量は、インクリメント量調整コンボボックス(③)で指定することができます。

2) データエリア(④)に書き込む値を入力します。

3) [W]ボタン(⑤)をクリックします。

4) 書き込んだ際の処理結果は状態表示ボックス(⑥)に表示します。

正常終了時：OK／異常終了時：NGが表示されます。）


3.19.4. リアルタイム更新

1) [リアルタイム更新]チェックボックスをONにします。

2) [R][W]ボタンが無効になります。

3) 指定されたデバイス番号のデータをデータエリアに表示してリアルタイムに更新されます。


3.19.5. ウィンドウクローズ

表示されている自己診断ウィンドウを閉じる場合は、[閉じる]ボタンをクリックするか、または[×]ボタンをクリックします。


3.20. バージョンウィンドウ

本ソフトウェアのバージョン情報が表示されます。

メニューバーから

[ヘルプ(H)] →[バージョン情報(V)]をクリックします。


4. 通信エラー

4.1. エラー内容

USB通信を実行している時に次のメッセージが表示された場合メッセージに表示された内容を確認して下さい。


5. データインポート

5.1. データインポートについて

本機能は装置モータ情報をインポートし、新しく追加された装置及びモータをソフトウェアのバージョンアップ無しで使用できるようにする機能です。

注記

データインポート機能はVPH Data Editing Software Version 1.0.0より対応します。


5.2. データインポート方法

1) 装置・モータの選択ウィンドウの[データインポート]ボタンをクリックします。

2) ソフトウェアを再起動するメッセージが表示されるので、[OK]をクリックします。

3) UAC(ユーザーアカウント制御)の確認メッセージが表示されたら、[はい]をクリックしてください。

4) 再起動された装置・モータの選択ウィンドウの[データインポート]ボタンをクリックします。

5) ファイルを開くダイアログが表示されるので、インポートファイルを選択し[開く]ボタンをクリックします。

6) インポート処理中は進捗状況を表すバーが表示されます。

7) 以下のメッセージが表示されデータインポート完了です。

注記

データインポートが正常に終了しなかった場合、以下のメッセージが表示されます。


6. 付録

6.1. ファイル拡張子一覧

本ソフトウェアにて使用するファイル拡張子は以下の通りです。

名称 | 装置種別 | モータ種別 | 拡張子 | 開く | 保存
パラメータ | VPH-HA | τDISC | *.c0pa0 | ○ | ○
 | VPH-HA | τリニア | *.c0pa1 | ○ | ○
 | VPH-HB | τDISC | *.c1pa0 | ○ | ○
 | VPH-HB | τリニア | *.c1pa1 | ○ | ○
 | VPH-HC | τDISC | *.c2pa0 | ○ | ○
 | VPH-HC | τリニア | *.c2pa1 | ○ | ○
 | VPH-HD | τDISC | *.c3pa0 | ○ | ○
 | VPH-HD | τリニア | *.c3pa1 | ○ | ○
 | VPH-HE | τDISC | *.c4pa0 | ○ | ○
 | VPH-HE | τリニア | *.c4pa1 | ○ | ○
 | ALL | ALL | *.csv | × | ○
プログラムデータ | VPH-HA | ALL | *.c0pro | ○ | ○
 | VPH-HB | ALL | *.c1pro | ○ | ○
 | VPH-HC | ALL | *.c2pro | ○ | ○
 | VPH-HD | ALL | *.c3pro | ○ | ○
 | VPH-HE | ALL | *.c4pro | ○ | ○
間接データ | VPH-HA | ALL | *.c0ind | ○ | ○
 | VPH-HB | ALL | *.c1ind | ○ | ○
 | VPH-HC | ALL | *.c2ind | ○ | ○
 | VPH-HD | ALL | *.c3ind | ○ | ○
 | VPH-HE | ALL | *.c4ind | ○ | ○
オシロデータ | ALL | ALL | *.cxosc | ○ | ○
 | ALL | ALL | *.cxlog | ○ | ○
 | ALL | ALL | *.csv | × | ○
周波数スペクトルデータ | ALL | ALL | *.cxfrs | ○ | ○
周波数応答データ | ALL | ALL | *.cxfrr | ○ | ○
一括データ | VPH-HA | ALL | *.c0adb | ○ | ○
 | VPH-HB | ALL | *.c1adb | ○ | ○
 | VPH-HC | ALL | *.c2adb | ○ | ○
 | VPH-HD | ALL | *.c3adb | ○ | ○
 | VPH-HE | ALL | *.c4adb | ○ | ○

※ALLは全ての種別に対応


6.2. ファイルドロップについて

本ソフトウェアの対応するウィンドウにファイルをドロップすることで、ドロップしたファイルを開きます。


6.2.1. 対応ウィンドウ、ファイル一覧

 |  | 対象ウィンドウ
 |  | 装置 | メイン | パラ | プロ | 間接 | オシロ | スペ | 周応
ドロップファイル | パラメータ(*.c*pa**) | ○ | ○ | ○ | × | × | × | × | ×
 | パラメータ(*.csv) | × | × | × | × | × | × | × | ×
 | プログラム(*.c*pro*) | ○ | ○ | × | ○ | × | × | × | ×
 | 間接データ(*.c*ind*) | ○ | ○ | × | × | ○ | × | × | ×
 | オシロデータ(*.cxosc*, *.cxlog) | ○ | ○ | × | × | × | ○ | × | ×
 | オシロデータ(*.csv) | × | × | × | × | × | × | × | ×
 | 周波数スペクトルデータ(*.cxfrs*) | ○ | ○ | × | × | × | × | ○ | ×
 | 周波数応答データ(*.cxfrr*) | ○ | ○ | × | × | × | × | × | ○
 | 周波数応答データ(*.csv) | × | × | × | × | × | × | × | ×
 | 一括データ(*.c*adb*) | × | × | × | × | × | × | × | ×

※ウィンドウ略称：正式名称

装置：装置モータ選択ウィンドウ、メイン：メインツールバーウィンドウ、パラ：パラメータ編集ウィンドウ、プロ：プログラム編集ウィンドウ

間接：間接データ編集ウィンドウ、オシロ：オシロスコープウィンドウ、スペ：周波数スペクトルウィンドウ、周応：周波数応答測定ウィンドウ


6.2.2. ドロップ非対応ウィンドウ

下記ウィンドウは、ドロップによるファイルオープンに対応していません。

ウィンドウ名称

状態表示ウィンドウ

入出力信号状態表示ウィンドウ

デバイスモニタウィンドウ

自己診断ウィンドウ

オートチューニングウィンドウ

リアルタイムサーボ調整ウィンドウ

テスト運転ウィンドウ

スイッチBOXウィンドウ

バージョン表示ウィンドウ

データ比較ウィンドウ

印刷ウィンドウ


6.3. csvファイルのデータ構造

csvファイルにてデータを保存した場合のデータ構造を示します。

注意

csvファイル形式にて保存したファイルは、本ソフトウェアで開くことはできません。

パラメータデータcsvファイル構造

NAME | ファイル名 |  |  |  |  |  |  |
DEF | パラメータ番号 | デバイス番号 | パラメータ名称 | 単位 | 設定範囲 | 設定値 | 初期値 | 表示状態

オシロデータcsvファイル構造

NAME | ファイル名 |  |  |  |
DEF | 15 |  |  | チャンネル設定 |
DEF | 0 | CH1表示最大値 | CH1表示オフセット量 |  | CH1: CH1の名称
DEF | 1 | CH2表示最大値 | CH2表示オフセット量 |  | CH2: CH2の名称
DEF | 2 | CH3表示最大値 | CH3表示オフセット量 |  | CH3: CH3の名称
DEF | 205 |  | CH4表示オフセット量 |  | CH4: CH4の名称
DEF | データ分解能[msec] |  |  | データ分解能 |
DEF | 290 |  | 2 |  | 2
DEF | 291 |  | 1 |  | 0
DEF | 292 |  | 3 |  | 0
DEF | 293 |  | 0 |  | 0
DEF | 294 |  | 7 |  | 6
DAT | データ取得時間[sec] | CH1データ | CH2データ | CH3データ | CH4データ

注記

CH*表示オフセット量は測定項目に信号が設定されているCHのみ出力されます。

速度系のデータは、示されている単位系のデータを出力します。

信号データは0でOFF、1でONとなります。

周波数応答データcsvファイル構造

NAME | ファイル名 |  |
 | 【測定条件】 | 設定値 | 単位
DEF | 測定ゲイン番号 | 0 |
DEF | 測定周波数 | 4000 | [Hz]
DEF | 加振幅(速度指令量) | 1.00 | [%]
DEF | 加振幅(オフセット量) | 0.00 | [%]
DEF | 加振時間 | 3000 | [msec]
DEF | 許容最大振れ量 | 0 | [pulse]
DEF | 計測回数 | 3 | [回]
 | 【ノッチフィルタ】 | 設定値 | 単位
DEF | P331：中心周波数1 | 0 | [Hz]
DEF | P331：バンド幅率1 | 0 | [%]
DEF | P331：深さ1 | 0 | [-dB]
DEF | P332：中心周波数2 | 0 | [Hz]
DEF | P332：バンド幅率2 | 0 | [%]
DEF | P332：深さ2 | 0 | [-dB]
DEF | P333：中心周波数3 | 0 | [Hz]
DEF | P333：バンド幅率3 | 0 | [%]
DEF | P333：深さ3 | 0 | [-dB]
DEF | P334：中心周波数4 | 0 | [Hz]
DEF | P334：バンド幅率4 | 0 | [%]
DEF | P334：深さ4 | 0 | [-dB]
DEF | P236：中心周波数 | 0 | [Hz]
DEF | P236：バンド幅率 | 0 | [%]
DEF | P236：深さ | 0 | [-dB]
 | 【周波数応答】 |  |
 | 周波数[Hz] | 振幅[dB] | 位相[deg]
DAT | 0.244110826 | -0.3161 | 0
DAT | 0.488221653 | -0.3032 | -0.2199
DAT | 0.732332479 | -0.2988 | -0.1022
DAT | ～ | ～ | ～
DAT | 3999.511778 | -11.7789 | 17.4333
DAT | 3999.755889 | -11.8517 | -153.2895
DAT | 4000 | -13.3143 | 22.0282