VPH Data Editing Software Help

(c) 2014 CKD NIKKI DENSO Co.,LTD.

Ver. 4.0


1. 前言

1.1. 為了安全使用

本說明書對「VPH Data Editing Software」的操作步驟、注意事項等進行說明。

為了充分利用VPH系列的性能，請用戶在使用前仔細閱讀本說明書。

本說明書的正文中將「VPH Data Editing Software」描述為「本軟體」。

本說明書中，在標注上將安全注意事項的等級作為「危險」、「注意」來加以區分。

危險

此標注表示，在錯誤操作時會引起危險的狀況，預想有可能導致死亡或重傷的情況。

注意

此標注表示，在錯誤操作時會引起危險的狀況，預想有可能導致中度的障礙或輕傷的情況、以及預想只會發生物理傷害的情況。

附註

表示操作上的注意事項。


1.2. 其他注意事項

· 關於本說明書的內容，今後將未經預告而予以變更。

· 有關本說明書的內容，我們在製作時以期萬全，但是萬一用戶發現有含糊不清之處或錯誤等，煩請向本公司聯繫。

· 有關以本軟體的運用為理由的損失、利益損失等的請款，本公司概不負責，敬請諒解。

· 為了改良產品，今後我們有可能未經預告就變更外觀或部分規格。

· Windows為美國Microsoft Corporation（微軟公司）在美國以及其他國家的註冊商標。

・ENSIS®為株式會社三豐的註冊商標。

・LinearScale®為株式會社三豐的註冊商標。

・BiSS®為iC-Haus GmbH的註冊商標。

・EnDat®為海德漢株式會社的註冊商標。


1.3. 軟體的使用許可條件

面向ＶＰＨ系列的系統輔助工具

VPH Data Editing Software

使用許可條件

在安裝面向ＶＰＨ系列的系統輔助工具之前，請務必閱讀以下所載的使用許可條件（下稱「使用許可條件」）。在用戶安裝本軟體的時點，即表示用戶同意喜開理日機電裝株式會社提出的使用許可條件的全部內容。

除了安裝本軟體的用戶外，不管是個人還是法人，使用許可條件適用於使用本軟體的全部人員。在不同意使用許可條件的情況下，請勿進行本軟體的安裝及使用。

１．定義

1.1　「用戶」是指喜開理日機電裝株式會社進行用戶登錄，允許本軟體的使用並賦予了許可證者。

1.2　「本軟體」是指隨同使用許可條件一起以從喜開理日機電裝株式會社的網站下載的方式進行分發，在用戶方的電腦上運行的下述軟體。

      品名：面向伺服驅動器ＶＰＨ系列的系統輔助工具

            VPH Data Editing Software

      型號：NPS-VPHDESN3

1.3　「本軟體套件」是指包含1.2款所述的本軟體和附屬於該軟體的手冊等所有著作物（包含ＰＤＦ等格式的電子文檔）而成的內容。

1.4　「許可證」是指喜開理日機電裝株式會社按照另行規定的方法及手續對1.1款所述的用戶所賦予的、本軟體的使用權限。

2．用戶登錄

2.1　 用戶在進行本軟體的下載時，必須向喜開理日機電裝株式會社進行用戶登錄申請。用戶登錄係從喜開理日機電裝株式會社的網站透過會員登錄或者客戶資訊的輸入而進行，必要項目及其他詳情由喜開理日機電裝株式會社予以規定。

2.2　 喜開理日機電裝株式會社確認2.1款所述的用戶登錄資訊並進行用戶登錄。另外，喜開理日機電裝株式會社除了參照用戶登錄資訊外，還根據需要參照伺服驅動器ＶＰＨ系列的購買履歷等用戶資訊。

2.3　 用戶在用戶登錄事項發生變更的情況下，應迅速向喜開理日機電裝株式會社進行申報。

2.4 　在用戶違反使用條件，及因系統被入侵、其他不得已的情由判斷為本軟體難於進行通常運行的情況下，喜開理日機電裝株式會社可能會未經預告就進行用戶登錄的刪除、許可證的停用。

3．使用許可的範圍

3.1 喜開理日機電裝株式會社以用戶同意並遵守本合約所載的使用條件為條件，透過賦予許可證允許其使用關於本軟體套件（包括下載及安裝到電腦上）。

3.2　 前款所述的許可的對價為無償。

3.3　用戶不得對第三方允許本軟體的再使用。

3.4　只限於備份的目的，用戶可製作一份本軟體等的複製品。

4．著作權的歸屬

關於本軟體套件的著作權，歸屬於喜開理日機電裝株式會社。記錄有本軟體的媒體及其附帶的說明書等的轉讓，並不意味著轉讓本軟體套件的著作權。

5．轉讓、出租、分發等的禁止

不得將本軟體套件及許可證用於上述使用目的外，也不得將其轉讓、分發、出租或發送給第三方用於其他用途。

6．解析和改變等的禁止

用戶對於本軟體套件的全部或某一部分，不得進行反編譯、反向工程、反彙編、修正、改變（也包括原始程式碼的改變）、改編或二次著作的創作。

7．責任的限制

7.1　喜開理日機電裝株式會社不保證本軟體套件的品質、性能符合用戶的使用目的。

7.2 有關本軟體套件，即使在與第三方之間發生了關於製造物責任的爭議、著作權以及其他與智慧財產權相關的爭議的情況下，喜開理日機電裝株式會社也不承擔責任。

7.3 在喜開理日機電裝株式會社改進本軟體套件（修正缺陷）時，本公司將根據需要向用戶提供修正後的本軟體套件及關於修正的資訊。但是，有關提供的時期、方法及其他詳情，將由喜開理日機電裝株式會社斟酌決定。另外，修正後的本軟體套件也同樣適用本使用許可條件。

7.4　除了7.1款至7.3款的規定外，喜開理日機電裝株式會社在法律允許的範圍內，對於包括起因於本軟體套件的使用或者不可使用或相關的機台、設備、產品、半成品等的損傷、利益損失、數據的丟失、工作的中斷或其他財產損害或損失、生命或身體的損害或損失等在內的所有損害等均概不負責。

7.5 在根據7.1款至7.4款及其他本使用許可條款的規定不認可免除喜開理日機電裝株式會社責任的情況下，關於用戶的所有損害，喜開理日機電裝株式會社的賠償責任總額以本軟體套件的出售金額為上限。

8．合約的解除

在用戶違反本使用許可條款的任何一項規定的情況下，喜開理日機電裝株式會社可立即解除本軟體套件的使用許可。這種情況下，用戶應承擔費用迅速退還本軟體套件及其複製品，或者採用無法恢復的方法廢棄本軟體套件。

9．合約的分離性

不管是在因某種理由而本使用許可條款的某項條款或其部分條款失去效力的情況下，本合約的其他條款或部分依然具有完全的效力。

10．適用法律

本使用許可條款依據日本國法律，應按照日本國法律予以解釋。

11．爭議的解決

11.1 有關本軟體套件及關於本使用許可條件的喜開理日機電裝株式會社與用戶之間的訴訟，與程式著作權相關的訴訟以東京地方法院作為第一審的專屬協議管轄法院，其他訴訟則以千葉地方法院為第一審的專屬協議管轄法院。

11.2 無論11.1款的規定如何，在用戶居住在日本以外國家的情況下，起因於本使用許可條款或者與本使用許可條款相關的、喜開理日機電裝株式會社與用戶之間發生的任何爭議、爭論或者意見上的差異，都應按照一般社團法人日本商事仲裁協會的商事仲裁規則，在日本國東京都進行仲裁，謀求最終的解決。


1.4. 概要

本軟體是在個人電腦上用來進行VPH裝置的

① 參數編輯、程式編輯、間接數據編輯

② 示波器數據／頻譜數據／頻率應答數據的測量和顯示

③ 遠距離運轉、運轉狀態顯示

④ 自動調諧、實時伺服調整、測試運轉

⑤ 自我診斷／內部控制資訊的監控

等的軟體。


1.5. 系統環境

要使用本環境，需要具備下列系統構成。

另外，在進行VPH裝置和數據通信（參數傳輸等）的情況下，除了個人電腦外還需要USB線纜（市售品）。

※本公司在選配上未提供USB線纜。

個人電腦 | PC/AT相容機（應可利用USB連接器）
OS | Windows7 32bit/64bit(Ultimate, Professional、Enterprise、Home Premium) Windows 8/8.1 32bit/64bit(無標記、Pro、Enterprise) Windows 10 32bit/64bit(Home、Pro、Enterprise)
CPU | 1GHz以上的處理器
記憶體 | 1GB(32bit)或2GB(64bit)的RAM以上
硬碟 | 1GB以上
顯示器 | XGA（1024×768 pixel）以上
支持的語言 | Japanese, English, Chinese(simplified), Chinese(traditional), Korean
其他 | .NET Framework 4.0以上 Visual C++ 2010 Runtime


1.6. 關於出口管理

在本產品或要提供的技術用途及使用者恐會將本產品用於大量殺傷性武器等的開發和常規武器的開發等中的情況下，將會成為《外匯及外國貿易法》中規定的出口限制對象，出口時請嚴格審核並辦理必要的出口手續。


2. 安裝／卸載

2.1. 本軟體的安裝

1) 雙擊[Setup.exe]文件以開始安裝此軟件。

2) 尚未安裝USB驅動程式時。

顯示USB驅動程式的安裝畫面，請按照畫面進行安裝。

USB驅動程式的安裝方法，請參照「2.3. USB驅動程式的安裝」。

3) 尚未安裝.NET Framework4.0時。

顯示如下畫面。請單擊[同意]按鈕。

4) 進行.Net Framework4.0的安裝。

安裝完成時，本對話方塊將會自動關閉。

5) 尚未安裝VisualC++ 2010 Runtime程式庫時。

顯示如下畫面。請單擊[安裝]按鈕，按照如下所示方式進行安裝。

6) 對[同意]核取方塊進行勾選，單擊[安裝]按鈕。

7) VisualC++ 2010 Runtime程式庫的安裝完成時，會顯示如下畫面。

單擊[完成]按鈕，進入本軟體的安裝。

8) 已安裝必要組件時。

顯示如下畫面。請單擊[下一步]按鈕。

9) 同意軟體的使用許可時。

請選擇[同意軟體使用許可合約書]，單擊[下一步]按鈕。

[不同意]時將無法進行本軟體的安裝。

10) 變更安裝目的地目錄時。

請單擊[變更]按鈕進行變更。接著請單擊[下一步]按鈕。

11) 安裝的確認。

在按照此前所輸入的內容進行安裝的情況下，請單擊[安裝]按鈕。

12) 顯示安裝程式的執行經過。

13) 安裝完成後，會顯示如下畫面。

請單擊[結束]按鈕。


2.2. 本軟體的卸載

1) 請單擊Windows任務欄的[開始]－[控制台]－[程式和功能]，顯示[程式和功能]視窗。

2) 請選擇清單方塊內的[VPH Data Editing Software]，單擊[卸載]按鈕。

3) 請單擊[是]按鈕。

4) 顯示如下畫面，卸載完成。


2.3. USB驅動程式的安裝

雙擊[USB_Driver]文件夾。

用戶所使用的PC的OS為32bit時請執行dpinst32.exe，為64bit時請執行dpinst64.exe，並按照以下的嚮導進行安裝。

1) 請從開始畫面單擊[下一步(N)]。

2) 在以下畫面單擊[安裝(I)]。

3) 開始USB驅動程式的安裝。

4) 顯示如下畫面，USB驅動程式的安裝完成。

5) 將VPH裝置連接到USB埠。

顯示以下的快顯視窗，軟體的安裝完成。


2.4. USB驅動程式的卸載

1) 請單擊Windows任務條的[開始]－[控制台]－[程式和功能]，顯示[程式和功能]視窗。

2) 請選擇清單方塊內的[Windows 驅動程式封裝 - CKD NIKKI DENSO CO.,LTD.(WinUSB)CKD NIKKI DENSO VPH USB Device]，單擊[卸載和變更]按鈕。

3) 請單擊[是]按鈕。


3. 功能和操作

3.1. 本軟體的啟動

要啟動本軟體，請從Windows 的任務條選擇[開始]→[程式(P)]→[NikkiDenso]→[VPH Data Editing Software]→[Nikki VPH DES]，或者從桌面上所創建的[Nikki VPH DES]快速鍵執行。

在顯示如下標徽後，顯示裝置、馬達選擇視窗。


3.2. 裝置馬達選擇視窗

選擇要使用的裝置馬達。


3.2.1. 通過從VPH裝置選擇載入裝置資訊來選擇裝置馬達

1) 在本軟體與VPH裝置已相互連接且裝置的電源已接通的情況下，單擊[從裝置獲取設定]按鈕，讀出登錄在裝置內的資訊。

※在畫面啟動時VPH裝置已被連接的情況下，自動讀出登錄在裝置內的資訊

2) 基於已讀出的資訊，在裝置資訊、馬達資訊已被選擇的狀態下在畫面上顯示資訊。

3) 單擊[決定]按鈕來向主工具欄移行。

本軟體與VPH裝置無法進行USB通信時

請確認所顯示的訊息內容。

連接有無法在本軟體上使用的VPH裝置時

顯示有此訊息的情況下，需要更新為與所連接的VPH裝置相對應的軟體。

請向本公司營業擔當聯繫。

VPH裝置中設定了無法在本軟體上使用的馬達資訊時

請確認馬達欄中是否存在要使用的馬達。

在找不到希望使用的馬達的情況下，需要進行軟體的更新。

請向本公司營業擔當聯繫。


3.2.2. 通過手動操作來選擇裝置馬達

在本軟體與VPH裝置無法進行USB通信的情況下，直接選擇要使用的VPH裝置和馬達。

1) 裝置的選擇

自上而下按照順序選擇裝置欄的下拉式列示方塊。

2) 馬達的選擇

自上而下按照順序選擇馬達欄的下拉式列示方塊。

根據產品分類，有的情況下要求輸入值。

3) 單擊[決定]按鈕來向主工具欄移行。


3.2.3. 通過拖放文檔來選擇裝置馬達

通過將文檔拖放至本畫面，自動地進行裝置馬達選擇，並打開參數文檔。

※可拖放的文檔請參照[6.2. 關於文檔拖放]

1) 拖曳希望打開的參數文檔，將其放至本畫面上。

2) 本畫面關閉，顯示主工具欄。

3) 顯示已被拖放的參數文檔。


3.2.4. 裝置馬達選擇的訊息

在從裝置馬達選擇畫面向主工具欄移行之前，有的情況下會顯示以下所示的訊息。

這種情況下，請按照顯示的訊息進行操作。

裝置的選擇相匹配，但VPH裝置內的馬達資訊尚未設定時

裝置的選擇相匹配，但馬達選擇與VPH裝置內的資訊不同時

※在變更了馬達的情況下必然會顯示

需要再啟動的參數已被變更時

所選擇的裝置選擇、與VPH裝置的資訊不同時

沒有找到完全一致的裝置資訊時

在向裝置傳送了馬達編碼器相關參數時，正在進行網路通信時

試圖執行裝置的自動再啟動時，正在進行網路通信時

已將編碼器類型變更為BiSS編碼器時

已將編碼器類型變更為海德漢ABS編碼器時


3.2.5. 顯示語言切換

切換本軟體的顯示語言。

1) 變更語言選擇下拉式列示方塊(Display language choice)。

2) 變更語言的情況下，顯示再啟動的確認訊息。

3) 若單擊「確定」，本軟體就會以所選擇的語言啟動。


3.3. 主工具欄視窗

在本軟體的主畫面上啟動各功能的畫面。

選單欄

顯示選擇本軟體功能的選單。

主工具欄

顯示選擇本軟體功能的按鈕。

狀態欄

顯示裝置的USB連接狀態、參數的反映狀態、指令單位、設定單位、裝置型號、馬達型號。

① USB連接狀態：

可與裝置進行通信。

無法與裝置進行通信。

附註

在連接了與設定不同的裝置的情況下，會顯示以下訊息。

請返回裝置、馬達選擇畫面，進行再設定。

② 參數的反映狀態：

無顯示 | 參數值為最新的狀態。
restart | 為了反映參數值，需要再開啟電源。 若予以單擊，就會進行電源的再開啟。
reset | 為了反映參數值，需要進行RST信號的輸入。 若予以單擊，就會進行RST信號的輸入。

③ 警報、警告狀態：

無顯示 | 沒有發生警報、警告。
 | 警報發生時顯示。
 | 警告發生時顯示。

④ 網路通信狀態：

無顯示 | 系網路未使用的裝置。
 | 裝置處於維護模式。 若予以單擊，就會顯示功能模式切換畫面。
 | 裝置處於維護模式。 因MODE開關處於ON，或MTON信號處於ON的狀態而無法向通信模式切換。
 | 裝置處於通信模式。 若予以單擊，就會顯示功能模式切換畫面。
 | 裝置處於通信模式。 因正在進行網路連接而無法向維護模式切換。

⑤ 單位：

顯示選擇中的位置單位和位置小數單位。

⑥ 裝置型號：

顯示選擇中的裝置型號。

⑦ 馬達型號：

顯示選擇中的裝置型號。

返回裝置、馬達選擇視窗

在本軟體啟動時或任意時點可執行裝置馬達選擇。

從選單欄選擇

[文檔(F)]→[裝置、馬達選擇(D)]

就會關閉現在打開中的所有畫面。

附註

在存在編輯中途的畫面的情況下，確認是否關閉畫面。

在關閉所有畫面的情況下，返回裝置馬達選擇。

在殘留有沒有關閉的畫面的情況下，不會返回裝置馬達選擇。

正在執行下述功能的情況下，無法返回裝置馬達選擇。

參數、程式、間接數據、成批數據傳送接收中

示波器測量、頻譜的測量中

頻率應答、自我診斷、測試運轉、自動調諧執行中


3.3.1. 電源再開啟、RST信號輸入

1) 電源再開啟

若單擊狀態欄的電源再開啟的圖示 restart ，就會顯示如下所示的確認訊息。

再啟動裝置時請單擊[確定]，停止裝置時請單擊[取消]。

附註

MTON信號處於ON的情況下，會顯示以下訊息。

請在伺服OFF後再次單擊電源再開啟的圖示 restart 。

裝置正在進行網路通信的情況下，顯示以下訊息。

請手動進行電源再開啟。

2) RST信號輸入

若單擊狀態欄的RST信號輸入的圖示 reset ，就會顯示如下所示的確認訊息。

輸入RST信號時請單擊[確定]，停止輸入時請單擊[取消]。

附註

MTON信號處於ON的情況下，會顯示以下訊息。

請在伺服OFF後單擊RST信號輸入的圖示 reset 。

裝置正在進行網路通信的情況下，顯示以下訊息。

請手動進行電源再開啟。


3.3.2. 功能模式切換

若單擊狀態欄的網路通信狀態的圖示( [image] 或 [image] )，就會顯示功能模式切換視窗。

通信模式時

維護模式時

附註

MODE開關處於ON的情況下，會顯示以下訊息。

MTON信號處於ON的情況下，會顯示以下訊息。

請在伺服OFF後再次單擊圖示。

裝置正在進行網路通信的情況下，顯示以下訊息。

請在切換與網路的連接後再次單擊圖示。

1)輸入所顯示的切換代碼，按下[Enter]鍵。

2)由此便可單擊功能模式切換按鈕。

通信模式時

維護模式時

3)若單擊功能模式切換按鈕，就會顯示如下所示的確認訊息。

通信模式時

維護模式時

切換模式時請單擊[確定]，停止切換時請單擊[取消]。

附註

MTON信號處於ON的情況下，會顯示以下訊息。

請在伺服OFF後單擊[功能模式切換]按鈕。

裝置正在進行網路通信的情況下，顯示以下訊息。

請在切換與網路的連接後再次單擊[功能模式切換]按鈕。

附註

也可通過拖放與本畫面對應的文檔來打開文檔。

※對應的文檔請參照[6.2. 關於文檔拖放]


3.4. 本軟體的結束

通過按裝置馬達選擇畫面的[×]按鈕、主工具欄的選單欄選擇或[×]按鈕來結束本軟體。

① 裝置馬達選擇畫面的[×]按鈕

1) 單擊裝置馬達選擇畫面的右上的[×]按鈕。

2) 單擊結束確認訊息的[確定]按鈕。

② 主工具欄的選單

1) 從主工具欄的選單欄對

[文檔(F)]→[結束(X)]

予以單擊。

2) 單擊結束確認訊息的[確定]按鈕。

③ 主工具欄的[×]按鈕

1) 單擊主工具欄右上的[×]按鈕。

2) 單擊結束確認訊息的[確定]按鈕。


3.5. 參數編輯視窗

進行VPH裝置用的參數編輯。


3.5.1. 視窗的顯示

從選單欄選擇[文檔(F)]→[新增(N)]→[參數(P)]

或者

[文檔(F)]→[打開(O)]→[參數(P)]

或者

[文檔(F)]→[參數文檔變換]

或選擇主工具欄的[數據編輯]頁籤→[參數]→[參數選單選擇]


3.5.2. 參數的編輯

① 參數的直接編輯

1) 通過滑鼠或鍵盤操作來選擇參數。

2) 通過用滑鼠單擊所選擇的參數，按下 [Enter]、[F2]鍵來將參數置於編輯狀態。

· 數值輸入項目時：直接從鍵盤輸入數據。

· 選擇項目時：從列表選擇項目。

3) 通過脫離聚焦，按下[Enter]、[Tab]、[F2]鍵來確定參數。

※無法對灰色顯示的參數進行編輯。

② 參數的複製和貼上

參數編輯視窗間的複製／貼上

系在顯示有多個參數視窗時將特定範圍的參數數據複製到其他視窗的便利的功能。

1) 參數數據的複製

在複製參數數據的情況下，在按鍵盤的[Shift]＋[↑]、[Shift]＋[↓]來指定複製範圍，或用滑鼠拖曳後，右擊滑鼠選擇[複製]，或用Ctrl＋C進行複製。

2) 參數數據的貼上

用游標指定參數數據的貼上目的地，通過右擊滑鼠來選擇[貼上] ，或用Ctrl＋V進行貼上。


3.5.3. 參數名稱的檢索

若在選擇了參數的狀態下按下[Ｃｔｒｌ] ＋[Ｆ]，

就會顯示參數名稱檢索畫面。

①若輸入檢索字串，單擊[下一步]或[前一步]按鈕，

  就會選擇與檢索字串一致的參數。

[下一步]按鈕的動作，即使按下[Ｅｎｔｅｒ]或[Ｆ３]鍵也會進行同樣的動作。

[前一步]按鈕的動作，即使按下[Ｓｈｉｆｔ] ＋ [Ｆ３]鍵也會進行同樣的動作。

附註

在找不到一致的參數的情況下，會顯示以下訊息。

②若單擊[關閉]按鈕，就會結束檢索畫面。

  即使按下[ＥＳＣ]或[×]鍵也會進行同樣的動作。


3.5.4. 單位、電子齒輪設定

設定與單位、電子齒輪相關的參數。

3.5.4.1. 視窗的顯示

若從參數編輯視窗

選擇[單位、電子齒輪設定]

  或者

    雙擊對象參數

就會顯示本視窗。

附註

① 在已設定[自動設定]的狀態下打開本視窗時，有的情況下會顯示以下訊息。

在[自動設定]中無法選擇在參數編輯視窗中設定的位置單位的情況下會顯示本訊息。

② 在本視窗中將「設定模式」變更為[自動設定]時，有的情況下會顯示以下訊息。

在[自動設定]中無法選擇現在所選擇的位置單位的情況下會顯示本訊息。

[確定]：將位置單位變更為適當的值，向自動設定移行。

[取消]：取消設定模式的變更。

附註

③ 在本視窗中將「設定模式」變更為[自動設定]時，有的情況下會顯示以下訊息。

在因現在所選擇的位置小數單位不正確而無法正常進行機台移動量、回轉體位置範圍的自動設定的情況下會顯示本訊息。

將位置小數單位變更為所顯示的值，並向自動設定移行。

④ 在本視窗中將「設定模式」變更為[自動設定]，有的情況下會顯示以下訊息。

在現在已被設定的、機台移動量、電子齒輪比分子、電子齒輪比分母、回轉體位置範圍、回轉體位置範圍符號切換位置中設定了無法自動設定的值的情況下會顯示本訊息。

[確定]：對機台移動量、電子齒輪比分子、電子齒輪比分母、回轉體位置範圍、回轉體位置範圍符號切換位置設定可自動設定的值。

[取消]：中斷自動設定。

3.5.4.2. 單位、電子齒輪的編輯

設定模式的選擇

若打開本視窗，就可從[自動設定][手動設定]中選擇設定模式。

自動設定

根據所選擇的位置單位和位置小數單位，自動計算機台移動量／電子齒輪比分子／電子齒輪比分母／回轉體位置範圍／回轉體位置範圍符號切換位置並進行設定。

手動設定

在選擇了位置單位和位置小數單位的基礎上，直接輸入機台移動量／電子齒輪比分子／電子齒輪比分母／回轉體位置範圍／回轉體位置範圍符號切換位置並進行設定。

① 已將「設定模式」設定為[自動設定]時

本視窗按照下圖所示方式顯示。

③

②

①

在已將「設定模式」設定為[自動設定]的情況下，可以編輯以下項目。

① 位置單位

② 位置小數單位

③ 回轉體位置範圍

通過①∼③的選擇，自動計算機台移動量／電子齒輪比分子／電子齒輪比分母／回轉體位置範圍／回轉體位置範圍符號切換位置，並進行設定。

各項目的設定方法請參照以下內容。

① 位置單位選擇

選擇位置單位。

可選擇的位置單位根據本軟體啟動時設定的馬達產品分（參照3.2. )而有所差異。

馬達產品類別 | 可選擇的位置單位
τDISC | deg、pulse、kpulse
τ線性馬達 | m、mm、um、inch、pulse、kpulse

② 位置小數單位選擇

選擇位置小數單位。

附註

由於本動作，有的情況下會顯示以下訊息。

在因對①中所選擇的位置單位選擇了不正確的位置小數單位而無法正常地自動設定機台移動量、回轉體位置範圍的情況下會顯示本訊息。

③ 回轉體位置範圍設定

進行回轉體位置範圍／回轉體位置範圍符號切換位置的設定。

※馬達產品類別為「τ線性馬達」的情況下，無法設定本參數。

若予以勾選，就會將回轉體位置範圍／回轉體位置範圍符號切換位置自動地設定為適當的值。

若去掉勾選，就會將回轉體位置範圍／回轉體位置範圍符號切換位置設定為0。

附註

由於本動作，有的情況下會顯示以下訊息。

在因位置單位和位置小數單位的組合不正確而無法正常地進行回轉體位置範圍的自動設定的情況下會顯示本訊息。

②已將「設定模式」設定為[手動設定]時

本視窗按照下圖所示方式顯示。

⑤

④

③

①

②

在已將「設定模式」設定為[手動設定]的情況下，可編輯以下項目。

① 位置單位設定

② 位置小數單位設定

③ 機台移動量設定

④ 電子齒輪設定

⑤ 回轉體位置範圍

各項目的設定方法請參照以下內容。

① 位置單位選擇

選擇位置單位。

② 位置小數單位選擇

選擇位置小數單位。

③ 機台移動量設定

直接輸入機台移動量。

④ 電子齒輪設定

直接輸入電子齒輪比分子、電子齒輪比分母。

⑤ 回轉體位置範圍設定

直接輸入回轉體位置範圍／回轉體位置範圍符號切換位置。

※馬達產品類別為「τ線性馬達」的情況下，無法設定本參數。

3.5.4.3. 參數的設定

通過單擊本視窗的[設定]，本視窗將被關閉，本視窗中編輯的參數將被在參數編輯視窗中設定。

在位置單位和位置小數單位已被變更的情況下，會顯示以下訊息。

注意

在變更了位置單位和位置小數單位的情況下，請務必在使馬達動作之前修改以下設定值。

①速度和移動量的參數值

②程式數據的設定值

③間接數據的設定值

在沒有修改設定值就使得馬達動作的情況下，有可能導致預料外的動作，請予注意。

3.5.4.4. 視窗關閉

通過單擊本視窗的[關閉]來關閉本視窗。

在參數變更後沒有單擊[設定]就單擊[關閉]的情況下，會顯示以下訊息。

若單擊[是]，不應用本視窗中變更的參數就關閉本視窗。

若單擊[否]，就會停止關閉。


3.5.5. 組的選擇

若單擊參數組選擇按鈕，就可以組為單位進行參數的編輯。如下視窗為選擇了[指令設定]組時的顯示內容。

在選擇了[全部項目顯示]時，若單擊向指定參數的跳轉開關（下拉式列示方塊）設定參數編號，游標就會向所指定的參數移動。

若選擇[P100]，畫面上就會顯示P100的內容，游標移動。


3.5.6. 參數的寫入

1) 在將參數編輯視窗上的參數寫入裝置的情況下，單擊[寫入裝置]按鈕。

2) 顯示是否要寫入的確認訊息，在進行寫入時單擊[確定]按鈕，在停止寫入時單擊[取消]按鈕。

附註

自Version 2.2.0起曾由本軟體保持的FB濾波器設定方法選擇的值將會被保持在裝置中，並在參數寫入時檢查FB濾波器設定方法選擇的設定值。

進行寫入的參數與裝置內的FB濾波器設定方法選擇不同時，會顯示以下訊息。

基本上選擇「是」，請根據需要在「實時伺服調整畫面」上進行FB濾波器設定方法選擇的再設定。

此外，在為進行再調整而執行了自動調諧時也一樣，FB濾波器設定方法選擇將被再設定。

設定變更後通過進行參數的讀出保存在文檔中，就可保持FB濾波器設定方法選擇的值，下次參數寫入時保存的值將被設定在裝置中。

但是，在寫入由Version 2.2.0以前的VPH Data Editing Software所保存的文檔時，由於FB濾波器設定方法選擇的值尚未被保存到文檔中，因而本訊息不予顯示，FB濾波器設定方法選擇值也不會被設定在裝置中。

有關自Version 4.0.0起絕對置校正數據的設定，在「絕對位置校正 校正動作指定」為「無效」時，以下情況下會在參數寫入前顯示訊息。

・編碼器類型為「S-ABS2」、「S-ABS3」、「S-ABS4」的任何一種類型，編碼器中登錄有絕對位置校正數據的情形

・編碼器類型為「S-ABS2」、「S-ABS3」、「S-ABS4」以外的類型，VPH裝置中登錄有絕對位置校正數據的情形

若單擊「是」，則會設定為「校正有效」並傳送訊息。

單擊「否」的情況下會在「無效」的狀態下傳送訊息。

測試運轉參數與裝置內的參數不同時，在參數寫入前顯示以下訊息。

若單擊「OK」，就會以參數文檔的值蓋寫測試運轉的動作參數。

若單擊「取消」，寫入就會被取消。

3) 進度條顯示一直到達右端時寫入結束。

4) 寫入時，將會向裝置寫入標題上所顯示的文檔名。

5) 在傳送了需要再開啟電源或輸入RST信號的參數的情況下，會顯示如下所示的訊息。
傳送了需要再開啟電源的參數時

傳送了需要輸入RST信號的參數時

在再開啟電源或輸入RST信號時請單擊[確定]，在停止再開啟電源或輸入RST信號時請單擊[取消]。

附註 | 在傳送了需要再開啟電源的參數時，MTON信號處於ON的情況下會顯示以下訊息。 請在伺服OFF後手動進行電源的再開啟，或從主工具欄進行電源的再開啟。
 | 在試圖執行裝置的電源再開啟時，MTON信號處於ON的情況下會顯示以下訊息。 請在伺服OFF後手動進行電源的再開啟，或從主工具欄進行電源的再開啟。
 | 在傳送了需要再開啟電源的參數時，正在進行網路通信的情況下會顯示以下訊息。 請在切斷與網路的連接後手動進行電源的再開啟，或從主工具欄進行電源的再開啟。
 | 在試圖執行裝置的電源再開啟時，正在進行網路通信的情況下會顯示以下訊息。 請在切斷與網路的連接後手動進行電源的再開啟，或從主工具欄進行電源的再開啟。
 | 在傳送了需要輸入RST信號的參數時，MTON信號處於ON的情況下會顯示以下訊息。 請在伺服OFF後手動進行電源的再開啟，或從主工具欄進行RST信號的輸入。
 | 在試圖執行RST信號的輸入時，MTON信號處於ON的情況下會顯示以下訊息。 請在伺服OFF後手動進行電源的再開啟，或從主工具欄進行RST信號的輸入。
 | 在傳送了需要輸入RST信號的參數時，正在進行網路通信的情況下會顯示以下訊息。 請在切斷與網路的連接後手動進行電源的再開啟，或從主工具欄進行RST信號的輸入。
 | 在試圖執行RST信號的輸入時，正在進行網路通信的情況下會顯示以下訊息。 請在切斷與網路的連接後手動進行電源的再開啟，或從主工具欄進行RST信號的輸入。


3.5.7. 參數的讀出

1) 在讀出裝置內的參數的情況下，單擊[從裝置讀出]按鈕。

2) 顯示是否需要讀出的確認訊息。進行讀出時單擊[確定]按鈕，停止讀出時單擊[取消]按鈕。

3) 進度條顯示一直到達右端時讀出結束。

4) 讀出時，會在畫面上顯示已被寫入裝置的參數名。

所顯示的名稱，將成為保存時的初期文檔名。

5) 參數讀出中，有的情況下會顯示以下所示的訊息。

在顯示有本訊息的情況下，有可能裝置中所設定的參數超過了現在利用本軟體正在進行編輯的參數設定範圍。

① 若單擊[是]，就會繼續讀出。

「P008(1)=4/P008(2)=3/P028(3-1)=101/P210=-1」系裝置中所設定的範圍外的參數值。()內表示參數的位數範圍。

但是，範圍外的參數將會強制地設定初期值。

在顯示有本訊息的情況下，可能是以下原因所致。

內容 | 對策
所使用的參數文檔用舊版本製作 | 請用新增參數再次進行參數的讀出
裝置的版本與本軟體的版本不一致(本軟體的版本為舊版本) | 本軟體需要進行版本升級。 請向本公司營業擔當聯繫。
裝置中所設定的參數值處於範圍外(由上位的機器將參數改寫為範圍外的值等) | 請修正設定了範圍外的參數值的部位。

② 若單擊[否]，就會停止讀出。

附註

在因處於參數範圍外而停止了參數讀出的情況下，直至成為範圍外的參數之前一個參數，讀出已完成。


3.5.8. 參數的比較

若單擊參數編輯畫面的[比較]按鈕，就會打開參數的數據比較畫面。

比較的種類包括[與初期值比較]、[與裝置內比較]、[與文檔比較]、[比較ROM和RAM]。

若執行比較，就會顯示差異點的件數、差異點的一覽。

比較結果：差異點的確認

無差異點

有差異點

比較結果：差異的一覽

差異的一覽自左向右按照參數編號、參數的項目名、比較源設定值、比較目的地設定值、比較源單位的順序來顯示。

附註

對比較目的地的值設定了範圍外的值的情況下，顯示用紅色字元‘()’圈起來的值。

與初期值比較

1) 對參數初期值和現在編輯中的內容進行比較的情況下

單擊[比較]→[與初期值比較]按鈕。

2) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 參照P161：位置小數單位選擇的值的參數為比較對象時

比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了被作為初期值保存的位置小數單位的值。

與裝置內比較

1) 對裝置內的參數和現在編輯中的內容進行比較的情況下

單擊[比較]→[與裝置內比較]按鈕。

2) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 參照P161：位置小數單位選擇的值的參數為比較對象時

比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了裝置內所設定的位置小數單位的值。

與文檔比較

1) 對指定文檔和現在編輯中的內容進行比較的情況下

單擊[比較]→[與文檔比較]按鈕。

2) 顯示[打開文檔]視窗。

3) 選擇要進行比較的文檔，單擊[打開(O)]按鈕。

4) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 參照P161：位置小數單位選擇的值的參數為比較對象時

比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了保存在文檔中的位置小數單位的值。

比較ROM和RAM

1)對裝置內的RAM區域和ROM區域的內容進行比較的情況下

單擊[比較]→[比較ROM和RAM]按鈕。

2)比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 參照P161：位置小數單位選擇的值的參數為比較對象時

比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了在執行比較時所設定的位置小數單位的值。

※關於ROM區域和RAM區域

ROM區域是即使切斷裝置的電源數據也不會丟失的區域。可改寫的次數限制為10億次。

RAM區域是一旦切斷裝置的電源數據就會丟失的區域。裝置的電源開啟時或ROM區域的數據被改寫時，ROM區域的數據將被複製到RAM區域。裝置主要使用本區域的數據而動作。改寫次數沒有限制。

比較結果的輸出

① 向文檔輸出

若單擊[CSV輸出]按鈕，就可向CSV文檔輸出差異點。

② 列印

若在存在差異點的狀態下單擊[列印]按鈕，就可列印差異點。


3.5.9. 打開文檔

打開已被保存的參數時

① 從主工具欄打開

1) 單擊主工具欄的[文檔(F)]→[打開]→[參數]

2) 顯示打開文檔的對話方塊，選擇希望打開的參數文檔，單擊[打開]按鈕。

② 從參數編輯畫面打開

1) 單擊參數編輯視窗上的[打開]。

2) 顯示打開文檔的對話方塊，選擇希望打開的參數文檔，單擊[打開]按鈕。

附註

可從文檔的種類進行選擇的副檔名因裝置、馬達而有所差異。

※詳情請參照[6.1. 文檔副檔名一覽]

通過將參數文檔拖放至本畫面，也可打開參數文檔。

※對應的文檔請參照[6.2. 關於文檔拖放]


3.5.10. 保存到文檔中

在將參數編輯視窗上的參數保存到文檔中的情況下，可選擇蓋寫保存在相同文檔名上，或者指定新的文檔名予以保存。

① 蓋寫保存在相同文檔名的情況下，從選單欄單擊
[蓋寫保存]按鈕。

② 指定新的文檔名予以保存的情況下，從選單欄

單擊[另存新檔] 按鈕。

附註

自Version 2.2.0起曾由本軟體保持的FB濾波器設定方法選擇的值將會被保持在裝置中，也會被保存在參數中。

將被保存的FB濾波器設定方法選擇值為從裝置進行讀出時點的值。


3.5.11. 列印

列印參數編輯視窗上的參數的情況下，從選單欄單擊[列印]按鈕。

① 參數已處於選擇狀態的情況下，會顯示以下訊息。

1) 指定列印範圍。

① 列印全部範圍時

1) 選擇[全部列印]。

2) 單擊[確定]按鈕。

② 指定列印範圍進行列印時

1) 選擇[列印選擇範圍內]。

2) 單擊[確定]按鈕。

2) 顯示列印視窗。

① 進行列印的情況下，設定各項目，單擊[列印]按鈕。

② 中斷列印的情況下，單擊[取消]按鈕。

② 參數已處於選擇狀態的情況下，列印全部內容。


3.5.12. 視窗關閉

關閉所顯示的參數編輯視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。

若在已變更參數的狀態下進行上述處理，就會顯示如下所示的確認訊息。

關閉視窗時請單擊[確定]，停止處理時請單擊[取消]。

※在對參數進行[蓋寫保存]或[另存新檔]的情況下，不會顯示確認訊息


3.6. 間接數據編輯視窗

進行間接數據的編輯。


3.6.1. 視窗的顯示

從選單欄選擇

[文檔(F)]→[新增(N)]→[間接數據(I)]

或者

[文檔(F)]→[打開文檔(O)]→[間接數據(I)]

或選擇主工具欄的[數據編輯]頁籤→[間接數據]→[間接數據選單選擇]，就會顯示本視窗。


3.6.2. 間接數據的編輯

① 間接數據的直接編輯

1) 通過滑鼠或鍵盤操作來選擇間接數據。

2) 通過用滑鼠單擊所選擇的間接數據，按下[Enter]、[F2]鍵來將間接數據置於編輯狀態。

· 數值輸入時：從鍵盤直接輸入。

· 選擇項目時：從列表選擇項目。

3) 通過脫離聚焦，按下[Enter]、[Tab]、[F2]鍵來確定間接數據。

② 間接數據的複製和貼上

間接數據編輯視窗間的複製／貼上
系在顯示有多個間接數據編輯視窗時將特定範圍的間接數據複製到其他視窗的便利的功能。

1) 間接數據的複製

在按鍵盤的[Shift]＋[↑]、[Shift]＋[↓]來指定複製範圍，或用滑鼠拖曳後，右擊滑鼠選擇[複製]，或用Ctrl＋C進行複製。

2) 間接數據的貼上

用游標指定間接數據的貼上目的地，通過右擊滑鼠來選擇[貼上] ，或用Ctrl＋V進行貼上。


3.6.3. 間接數據的寫入

1) 在將間接數據編輯視窗上的間接數據寫入裝置的情況下，單擊[寫入裝置]按鈕。

2) 顯示是否要寫入的確認訊息，進行寫入時單擊[確定]按鈕，停止寫入時單擊[取消]按鈕。

3) 進度條顯示一直到達右端時寫入結束。

4) 寫入時，將會向裝置寫入標題上所顯示的文檔名。

附註

在間接數據編輯畫面上所設定的位置單位、位置小數單位與裝置中所設定的位置單位、位置小數單位不一致的情況下，無法傳送間接數據。

請重新設定間接數據編輯畫面上所設定的位置單位、位置小數單位，或者設定裝置中所設定的位置單位、位置小數單位。

間接數據編輯畫面上所設定的位置單位、位置小數單位，透過按下單位變換按鈕來進行變換。

將間接數據編輯畫面上所設定的位置單位、位置小數單位變換為裝置中所設定的單位。


3.6.4. 間接數據的讀出

1) 在讀出裝置內的參數的情況下，單擊[從裝置讀出]按鈕。

2) 顯示是否要讀出的確認訊息，進行讀出時單擊[確定]按鈕，停止讀出時單擊[取消]按鈕。

3) 進度條顯示一直到達右端時讀出結束。

4) 讀出時，會在畫面上顯示已被寫入裝置的間接數據名。

所顯示的名稱，將成為保存時的初期文檔名。

附註

功能類別在本軟體與裝置上不同的情況下，無法傳送接收間接數據。請重新設定本軟體的裝置馬達選擇。


3.6.5. 間接數據的比較

若單擊間接數據編輯視窗的[比較]按鈕，就會打開間接數據的數據比較畫面。

比較的種類包括[與初期值比較]、[與裝置內比較]、[與文檔比較]。

若執行比較，就會顯示差異點的件數、差異點的一覽。

比較結果：差異點的確認

無差異點

有差異點

比較結果：差異點的一覽

差異點的一覽自左向右按照間接數據編號、間接數據的項目名、比較源設定值、比較目的地設定值、比較源單位、比較源注解的順序來顯示。

附註

對比較目的地的值設定了範圍外的值的情況下，顯示用紅色字元‘()’圈起來的值。

與初期值比較

1) 對間接數據初期值和現在編輯中的內容進行比較的情況下

單擊[比較]→[與初期值比較]按鈕。

2) 比較結果以「比較結果：差異點的一覽」格式予以顯示。

※ 與比較源設定值、比較目的地設定值一起，顯示反映了執行比較時所設定的位置小數單位的值。

與裝置內比較

1) 對裝置內的間接數據和現在編輯中的內容進行比較的情況下

單擊[比較]→[與裝置內比較]按鈕。

2) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了裝置內所設定的位置小數單位的值。

與文檔比較

1) 對指定文檔和現在編輯中的內容進行比較的情況下

單擊[比較]→[與文檔比較]按鈕。

2) 顯示[打開文檔]視窗。

3) 選擇要進行比較的文檔，單擊[打開(O)]按鈕。

4) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了保存在文檔中的位置小數單位的值。

比較結果的輸出

① 向文檔輸出

若單擊[CSV輸出]按鈕，就可向CSV文檔輸出差異點。

② 列印

若在存在差異點的狀態下單擊[列印]按鈕，就可列印差異點。


3.6.6. 打開文檔

① 從主工具欄打開

1) 單擊主工具欄的[文檔(F)]→[打開]→[間接數據]

2) 顯示打開文檔的對話方塊，選擇希望打開的間接數據文檔，單擊[打開]按鈕。

② 從間接數據編輯畫面打開

1) 單擊間接數據編輯視窗上的[打開]

2) 顯示打開文檔的對話方塊，選擇希望打開的間接數據文檔，單擊[打開]按鈕。

附註

① 可從文檔的種類進行選擇的副檔名因裝置而有所差異。

※詳情請參照[6.1. 文檔副檔名一覽]

② 通過將間接數據文檔拖放至本畫面，也可打開間接數據文檔。

※對應的文檔請參照[6.2. 關於文檔拖放]


3.6.7. 保存到文檔中

在將間接數據編輯視窗上的間接數據保存到文檔中的情況下，可選擇蓋寫保存在相同文檔名上，或者指定新的文檔名予以保存。

① 蓋寫保存在相同文檔名的情況下，從選單欄

單擊[蓋寫保存] 按鈕。

② 指定新的文檔名予以保存的情況下，從選單欄

單擊[另存新檔] 按鈕。


3.6.8. 列印

列印間接數據編輯視窗上的參數的情況下，從選單欄單擊
[列印]按鈕。

① 間接數據已處於選擇狀態的情況下，會顯示以下訊息。

1) 指定列印範圍。

① 列印全部範圍時

1) 選擇[全部列印]。

2) 單擊[確定]按鈕。

② 指定列印範圍進行列印時

1) 選擇[列印選擇範圍內]。

2) 單擊[確定]按鈕。

2) 顯示列印視窗。

① 進行列印的情況下，選擇各項目，單擊[列印]按鈕。

② 中斷列印的情況下，單擊[取消]按鈕。

② 間接數據已處於選擇狀態的情況下，列印全部內容。


3.6.9. 視窗關閉

表關閉所顯示的間接數據編輯視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。

若在已變更間接數據的狀態下進行上述處理，就會顯示如下所示的確認訊息。

關閉視窗時請單擊[確定]，停止處理時請單擊[取消]。

※在對間接數據進行[蓋寫保存]或[另存新檔]的情況下，不會顯示確認訊息


3.7. 程式編輯視窗

進行VPH裝置用的程式編輯。


3.7.1. 視窗的顯示

從選單欄選擇

[文檔(F)]→[新增(N)]→[程式(R)]

或者

[文檔(F)]→[打開文檔(O)]→[程式(R)]

或選擇主工具欄的[數據編輯]頁籤→[程式]→[程式選單選擇]，就會顯示本視窗。


3.7.2. 程式的編輯

① 程式的直接編輯

1) 指定編輯項目時，用滑鼠單擊所需的程式步驟。

2) 輸入程式的情況下，按照如下順序輸入數據。

· 通過單擊編輯項目的CMD，顯示▼。

· 通過單擊▼，就可選擇項目。

· 在選擇CMD後，選擇編輯部位的下拉式列示方塊，或從鍵盤直接輸入數據。

另外，後續的輸入項目將會根據CMD的內容而有所差異。（請按照畫面的指示進行操作。）

② 程式的複製和貼上

程式編輯視窗間的複製／貼上
系顯示有多個程式編輯視窗時將特定範圍的程式數據複製到其他視窗的便利功能。

1) 程式數據的複製

在複製程式數據的情況下，在按鍵盤的[Shift]＋[↑]、[Shift]＋[↓]來指定複製範圍，或用滑鼠拖曳後，右擊滑鼠選擇[複製]，或用Ctrl＋C進行複製。

2) 程式數據的貼上

用游標指定程式數據的貼上目的地，通過右擊滑鼠來選擇[貼上] ，或用Ctrl＋V進行貼上。

程式步驟按照如下所示方式來貼上。

③ 行插入

1) 對任意行設定游標。

2) 若單擊[行插入]按鈕，就會按如下所示方式插入新的行並登錄[NOP]命令。

從右擊滑鼠而顯示的、上下文選單內同樣可進行行插入。

最終行為[NOP]命令以外的情況下，顯示如下所示的訊息而使得行插入無法進行。

在進行行插入的情況下，請將最終行設定為[NOP]以外的命令。

④ 行刪除

1) 對任意行設定游標。

2) 若單擊[行刪除]按鈕，就會按如下所示方式刪除所指定的行，使得後續的步驟向前靠。

若進行行刪除，最終行中將被追加上[NOP]命令。

從右擊滑鼠而顯示的、上下文選單內同樣可進行行刪除。


3.7.3. 程式的寫入

1) 在將程式編輯視窗上的程式寫入裝置的情況下，單擊[寫入裝置]按鈕。

2) 顯示是否要寫入的確認訊息，進行寫入時單擊[確定]按鈕，停止寫入時單擊[取消]按鈕。若單擊[確定]按鈕，就會在進度條上顯示寫入處理的執行經過。

3) 進度條顯示一直到達右端時寫入結束。

4) 寫入時，將會向裝置寫入標題上所顯示的文檔名。

附註

在程式編輯畫面上所設定的位置單位、位置小數單位與裝置中所設定的位置單位、位置小數單位不一致的情況下，無法傳送程式。

請重新設定程式編輯畫面上所設定的位置單位、位置小數單位，或者設定裝置中所設定的位置單位、位置小數單位。

程式編輯畫面上所設定的位置單位、位置小數單位，透過按下單位變換按鈕來進行變換。

將程式編輯畫面上所設定的位置單位、位置小數單位變換為裝置中所設定的單位。

注意

若在程式運轉中寫入程式，就會從運轉中途切換至新程式數據下的運轉，請予注意。

通常，請在結束運轉中的程式後寫入程式。


3.7.4. 程式的讀出

1) 在讀出裝置內的程式的情況下，單擊[從裝置讀出]按鈕。

2) 顯示是否要讀出的確認訊息，進行讀出時單擊[確定]按鈕，停止讀出時單擊[取消]按鈕。若單擊[確定]按鈕，就會在進度條上顯示讀出處理的執行經過。

3) 進度條顯示一直到達右端時讀出結束。

  4) 讀出時，會在畫面上顯示已被寫入裝置的程式名。

所顯示的名稱，將成為保存時的初期文檔名。


3.7.5. 程式數據的比較

若單擊程式編輯畫面的[比較]按鈕，就會打開程式的數據比較畫面。

比較的種類包括[與初期值比較]、[與裝置內比較]、[與文檔比較]。

若執行比較，就會顯示差異點的件數、差異點的一覽。

比較結果：差異點的確認

無差異點

有差異點

比較結果：差異的一覽

差異的一覽自左向右按照程式的位址、比較源命令、比較源設定值0∼7、比較源注解、比較目的地命令、比較目的地設定值0∼7、比較目的地注解的順序來顯示。

附註

對比較目的地的值設定了範圍外的值的情況下，顯示用紅色字元‘()’圈起來的值。

與初期值比較

1) 對程式初期值和現在編輯中的內容進行比較的情況下

單擊[比較]→[與初期值比較]按鈕。

2) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 參照P161：位置小數單位選擇的值的設定值為比較對象時

與比較源設定值、比較目的地設定值一起，顯示反映了執行比較時所設定的位置小數單位的值。

與裝置內比較

1) 對裝置內的程式和現在編輯中的內容進行比較的情況下

單擊[比較]→[與裝置內比較]按鈕。

2) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了裝置內所設定的位置小數單位的值。

與文檔比較

1) 對指定文檔和現在編輯中的內容進行比較的情況下

單擊[比較]→[與文檔比較]按鈕。

2) 顯示[打開文檔]視窗。

3) 選擇要進行比較的文檔，單擊[打開(O)]按鈕。

4) 比較結果以「比較結果：差異的一覽」格式予以顯示。

※ 參照P161：位置小數單位選擇的值的程式為比較對象時

比較源設定值顯示反映了在執行比較時所設定的位置小數單位的值。

比較目的地設定值顯示反映了保存在文檔中的位置小數單位的值。

比較結果的輸出

① 向文檔輸出

若單擊[CSV輸出]按鈕，就可向CSV文檔輸出差異點。

② 列印

若在存在差異點的狀態下單擊[列印]按鈕，就可列印差異點。


3.7.6. 打開文檔

打開已被保存的程式時

① 從主工具欄打開

1) 單擊主工具欄的[文檔(F)]→[打開]→[程式]

2) 顯示打開文檔對話方塊，選擇希望打開的程式文檔，單擊[打開]按鈕。

② 從程式編輯畫面打開

1) 單擊程式編輯視窗上的[打開]

2) 顯示打開文檔對話方塊，選擇希望打開的程式文檔，單擊[打開]按鈕。

附註

可從文檔的種類進行選擇的副檔名因裝置而有所差異。

※詳情請參照[6.1. 文檔副檔名一覽]

通過將程式數據文檔拖放至本畫面，也可打開程式數據文檔。

※對應的文檔請參照[6.2. 關於文檔拖放]


3.7.7. 保存到文檔中

將程式編輯視窗上的程式保存到文檔中的情況下，可選擇蓋寫保存在相同文檔名上，或者指定新的文檔名予以保存。

① 蓋寫保存在相同文檔名的情況下，從選單欄

單擊[蓋寫保存] 按鈕。

② 指定新的文檔名予以保存的情況下，從選單欄

單擊[另存新檔] 按鈕。


3.7.8. 列印

列印程式編輯視窗上的程式的情況下，從選單欄單擊[列印]按鈕。

① 程式已處於選擇狀態的情況下，會顯示以下訊息。

1) 指定列印範圍。

① 列印全部範圍時

1) 選擇[全部列印]。

2) 單擊[確定]按鈕。

② 指定列印範圍進行列印時

1) 選擇[列印選擇範圍內]。

2) 單擊[確定]按鈕。

2) 顯示列印視窗。

① 進行列印的情況下，設定各項目，單擊[列印]按鈕。

② 中斷列印的情況下，單擊[取消]按鈕。

② 程式已處於選擇狀態的情況下，列印全部內容。


3.7.9. 視窗關閉

關閉所顯示的程式編輯視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。

若在已變更程式的狀態下進行上述處理，就會顯示如下所示的確認訊息。

關閉視窗時請單擊[確定]，停止處理時請單擊[取消]。

※在對程式進行[蓋寫保存]或[另存新檔]的情況下，不會顯示確認訊息


3.8. 成批數據傳送接收

將參數、間接數據、程式數據成批地傳送至裝置，或從裝置進行接收，作為成批數據予以保存。

① 傳送成批數據的情況下，從選單欄選擇[文檔(F)]→[成批數據]→[傳送]。

② 接收成批數據的情況下，從選單欄選擇[文檔(F)]→[成批數據]→[接收]。

傳送接收文檔的副檔名為 [*.c*adb]。

詳情請參照[6.1. 文檔副檔名一覽]。

附註

①參數、程式、間接數據的傳送接收中無法進行成批數據的傳送接收。

②顯示有主工具欄的狀態顯示、解析功能、調整功能、遠距離操作頁籤的視窗的情況下，無法進行成批數據的傳送接收。

③馬達尚未設定的情況下，無法進行成批數據的接收。

請在裝置馬達選擇畫面上，再設定馬達後再次重新進行成批數據的接收。

④自Version 2.2.0起開始傳送接收FB濾波器設定方法選擇的值。

由此，在保存接收到的數據時，FB濾波器設定方法選擇的值將被保持在已保存的文檔中，在成批數據傳送時將被設定在裝置中。


3.9. 示波器視窗

實時地圖形顯示所選擇的裝置數據。


3.9.1. 視窗的顯示

測量示波器圖形情況下，按下述步驟顯示示波器視窗。

若選擇主工具欄的[解析功能]頁籤→[示波器]，就會顯示本視窗。


3.9.2. 裝置的狀態顯示

始終顯示以下的裝置狀態。

No | 項目
C012 | 馬達熱跳脫率
C014 | 裝置熱跳脫率
C018 | 回生過載率

用顏色來表示狀態。

顏色 | 狀態
綠色 | 正常
黃色 | 注意
紅色 | 危險


3.9.3. 示波器設定

若單擊示波器視窗的[示波器設定]，就會顯示示波器設定視窗。

在示波器設定視窗中，可進行顯示對象通道的選擇、顯示對象的設定、測量設定和觸發設定。

① 顯示對象通道的選擇

勾選希望在[CH有效選擇（CH1∼4）]核取方塊中顯示的通道。

附註

去掉CH的勾選而測量的數據，全都設定0。

② 控制資訊（速度指令、轉矩指令、位置偏差脈衝等）顯示時的數據設定

1) 從[CH1設定]∼[CH3設定]邊框內的[顯示項目]下拉式列示方塊中選擇希望顯示的控制資訊（速度指令、轉矩指令、位置偏差脈衝等）項目。

2) 在[顯示最大值]的數據登錄區域設定圖形顯示時的Y軸記憶體最大值。

3) 在[CH1設定]∼[CH3設定]邊框內的[顯示項目]下拉式列示方塊中選擇了[速度反饋][速度指令][類比速度指令輸入][位置指令目標速度]的情況下，可進行速度單位的切換。通過[單位]下拉式列示方塊，向％⇔速度⇔rpm 進行切換。

4) 在[CH1設定]∼[CH3設定]邊框內的[顯示項目]下拉式列示方塊中選擇了[實際轉矩指令][類比轉矩指令輸入]的情況下，可進行轉矩單位的切換。通過[單位]下拉式列示方塊，向％⇔Nm(N) 進行切換。

③ 長／字設備監控器時的數據設定

1) 從[CH1選擇]∼[CH3選擇]邊框內的[顯示項目]下拉式列示方塊中選擇長設備監控器或字設備監控器。

2) 從[設備編號]下拉式列示方塊中選擇對象設備。

3) 將對象設備設定為D、R。

4) 在[設備編號]的數據登錄區域設定設備編號。

5) 在[顯示最大值]的數據登錄區域設定圖形顯示時的Y軸記憶體最大值。

6) 可在[設備名稱]的數據登錄區域自由地設定設備名稱。

   所設定的設備名稱，將會在圖形的凡例、列印畫面中顯示。

④ 狀態顯示時的數據設定

1)從[CH1選擇]∼[CH3選擇]邊框內的[顯示項目]下拉式列示方塊中選擇希望顯示的狀態的種類。

2)從[狀態項目]下拉式列示方塊中選擇希望顯示的信號。

⑤ 輸入輸出信號狀態顯示時的數據設定

1)從[CH1選擇]∼[CH4選擇]邊框內的[顯示項目]下拉式列示方塊中選擇希望顯示的信號的種類。

2)從[信號項目]下拉式列示方塊中選擇希望顯示的信號。

⑥ 數據解析度的設定

1) 從[數據解析度]下拉式列示方塊中選擇時間軸（X軸）的每個數據的採樣時間。

2) 數據解析度（msec）根據裝置和參數設定將在以下範圍內變動。

最小測量間隔 | 0.2 | 0.4 | 0.8 | 1.6 | 3.2
最大測量間隔 | 0.4 | 0.8 | 1.6 | 3.2 | 6.4

⑦ 測量時間的設定

1) 從[測量時間]下拉式列示方塊中選擇示波器的測量時間。

2) 將對象時間設定為1、2、5、10、20、50、100秒及Infinity。

⑧ 記錄的設定

1) 對[記錄有效]予以勾選。

2) 顯示保存文檔的對話方塊，設定記錄文檔的保存場所和文檔名。

3) 在[記錄有效]為ON的情況下，可利用[記錄文檔名欄][記錄文檔設定]按鈕來進行記錄文檔的變更。

4) 記錄文檔的文檔副檔名為 [＊.cxlog]。文檔將在每60秒鐘內被創建，文檔名將被賦予序號。

⑨ 觸發設定

在[測量時間]下拉式列示方塊中選擇了Inifinity以外的情況下，可進行觸發設定。

1) 要使得觸發設定有效，對[觸發有效]進行勾選。

2) 在連續進行觸發的情況下，選擇[標準觸發]。

   在只進行1次觸發的情況下，選擇[單觸發]。

   若選擇[標準觸發]，在每次進行觸發時，獲取測量時間部分的數據，並對圖形進行再顯示。

   但是，從觸發發生後起測量時間內的觸發將會無效。

3) 從[觸發對象]中選擇作為觸發對象的通道。

4) 將輸入輸出信號以外的通道作為觸發對象的情況下，在[觸發閾值]中設定成為觸發的閾值。

5) 在[觸發延遲時間]中設定觸發發生後的延遲時間（顯示觸發時機以後的波形的長度）。

設定了[觸發延遲時間]時的測量數據顯示範圍如下所示。

例1) [測量時間]為10sec，[觸發延遲時間]為2sec時

顯示自觸發時機起2sec後的測量時間部分的測量數據(影線部分)。

例2) [測量時間]為10sec，[觸發延遲時間]為-2sec時

顯示自觸發時機起2sec前的測量時間部分的測量數據(影線部分)。

6) 通過[ON]或[OFF]的選擇來設定觸發檢測的邊緣。

⑩ 示波器設定的設定

若單擊[設定]按鈕，就會登錄所設定的各資訊，並返回示波器視窗。

示波器設定中所設定的內容，將會顯示在示波器視窗的下部狀態欄。

附註

在設定了連接中的裝置中無法使用的顯示項目的情況下，會顯示以下訊息。

請變更顯示項目。

由於來自裝置的接收數據為16bit數據，所以在對顯示最大值設定了超過32767的值時，有的情況下顯示數據會呈現階梯狀顯示。

例1)

顯示項目：位置偏差

顯示最大值：16,000,000[pulse]

上述假定下的1數據解析度為

16,000,000/32767≒488[pulse]

裝置已有1,000,000[pulse]的位置偏差的情況下，顯示1,000,031[pulse]。

例2)

顯示項目：速度反饋

顯示最大值：1,800.000[deg/sec]

上述假定下的1數據解析度為

1,800,000/32767≒55[pulse/sec]

裝置已在360.000[deg/sec]下動作的情況下，顯示359.978 [deg/sec]。


3.9.4. 顯示項目

示波器設定中要設定的顯示項目如下所示。

顯示項目名 | 說明
速度反饋 | 顯示馬達實際動作速度。
實際轉矩指令 | 顯示實際轉矩指令值。
位置偏差 | 顯示位置偏差脈衝。
速度指令 | 顯示速度指令值。 在速度指令模式、脈衝列指令模式、內建指令模式、來自網路的速度指令和位置指令下有效。 成為包含S字和偏差的速度系最後的指令值。
類比速度指令 | 顯示類比速度指令值。 只有VPH-HA裝置才會顯示項目。 沒有類比選項的裝置，值被固定為0。
類比轉矩指令 | 顯示類比轉矩指令值。 馬達額定轉矩時為100%。 只有VPH-HA裝置才會顯示項目。 沒有類比選項的裝置，值被固定為0。
位置指令目標速度 | 顯示位置指令的目標速度。 在速度指令模式、內建指令模式、來自網路的位置指令下有效。 成為不包含S字和偏差的指令值。
馬達有效值 | 顯示馬達有效值（負載率）。
馬達熱跳脫率 | 顯示馬達熱跳脫率。 為100%時，檢測「馬達超載異常」。
脈衝列指令速度 | 顯示脈衝列指令速度。 在脈衝列指令模式、來自網路的位置指令下有效。 顯示1ms間隔的原始數值。 成為不包含S字和偏差的指令值。 ※根據VPH裝置的版本有可能無法進行測量
長設備監控器 | 作為長設備顯示所指定的設備值。
字設備監控器 | 作為字設備顯示所指定的設備值。
狀態顯示選擇 | 顯示所選擇的狀態顯示項目。
輸入信號選擇 | 顯示所選擇的輸入信號狀態。
輸出信號選擇 | 顯示所選擇的輸出信號狀態。


3.9.5. 顯示標尺的設定

① 時間(X)軸的設定

1) 從[時間標尺]下拉式列示方塊中選擇1個畫面上顯示的顯示時間。

2) 將時間標尺設定為0.05、0.1、0.2、0.5、1、2、5、10、20、50秒。

② 顯示數據範圍(Y)軸的設定

1) 數值顯示項目的情況下，從[標尺]下拉式列示方塊中選擇1個畫面上顯示的數值數據範圍。100%時的數值為在示波器設定視窗中設定的顯示最大值。

2) 信號顯示項目的情況下，從[偏位]下拉式列示方塊中選擇信號OFF時的顯示位置。偏位0%的顯示位置表示Y軸的中央。

3) 將標尺設定為0.1、0.5、1、5、10、25、50、100%。

4) 將偏位設定為-80、 -60、-40、-20、0、20、40、60、80%。


3.9.6. 實時顯示的開始／停止

1) 開始示波器的實時顯示的情況下、單擊[開始]按鈕。顯示中[開始]按鈕會變為[停止]按鈕。

2) 若單擊[停止]按鈕，就會停止顯示。

3) 停止顯示後，會按如下所示方式顯示測量波形。


3.9.7. 圖形設定

若在示波器視窗的[標尺][偏位]設定區域內予以右擊，就會顯示圖形設定視窗。

在圖形設定視窗中，可進行顯示對象通道的顏色選擇、顯示對象描繪順序、游標顏色設定和觸發閾值線顏色設定。

① 測量圖形線色設定

各通道的測量圖形的線色，分別以[線色CH1]∼[線色CH4] 下拉式列示方塊中所選擇的顏色予以顯示。

② 描繪順序設定

從通道選擇的清單選擇希望變更描繪順序的通道，通過[向前面移動][向背面移動]來變更順序。

③ 游標顏色設定

分別以[游標A顏色]下拉式列示方塊、[游標B顏色]下拉式列示方塊中所選擇的顏色予以顯示。

④ 觸發閾值線色設定

以[Trigger] 下拉式列示方塊中所選擇的顏色予以顯示。


3.9.8. 游標的設定

① 游標的設定

1) 單擊按鈕[A]或[B]。與所選擇的游標（A／B）對應的資訊顯示欄的顯示字元會成為粗體字。[A]或[B]將被唯一選擇。

2) 若在選擇了游標A的狀態下再次單擊按鈕[A]，游標A的選擇就會被解除。對於游標B也相同。

② 通道的設定

1) 選擇按鈕[CH1]∼[CH4]。游標線將被與所選擇的通道相互關聯起來。

2) 現在所選擇的通道，其按鈕顏色將被變更。

③ 游標資訊的顯示

1) 現在顯示有游標A或B的位置的時間及CH1∼CH4的資訊，將會在與游標對應的資訊顯示欄中顯示。

2)在[差異]欄中顯示[A]點與[B]點值的差異。

3) 在[A－B Min][A－B Max]欄中顯示[A]點與[B]點間的最小值和最大值。

④ 游標的移動

1) 若單擊畫面上的任意點，就會在該點顯示十字游標。

2) 若單擊 LeftButton 或者 RightButton ，就可對游標位置進行微調整。若持續按住滑鼠，游標就會自動移動。

3) 若在顯示有游標A及游標B的狀態下單擊 paraMoveButton ，就會切換至 paraMoveButtonPushed 。在此狀態下若單擊 LeftButton 或者 RightButton ，游標A及游標B就會同時平行移動。

附註

單擊開始按鈕時，在設定有連接中的裝置中無法使用的顯示項目的情況下，會顯示以下訊息

若單擊[確定]按鈕，就會顯示示波器設定畫面，請變更顯示項目。


3.9.9. 負載率計算

顯示負載率的情況下，進行「轉矩指令」的測量，指定游標A、B，並且單擊「負載率計算」按鈕。

附註

尚未指定游標A或B的情況下，顯示以下訊息。

尚未計測轉矩數據的情況下，顯示以下訊息。

在多個通道中測量了「轉矩指令」的情況下，計算編號最小的通道的負載率。

(例:已將CH1∼3全都設定為「實際轉矩指令」的情況下，計算CH1的「實際轉矩指令」的負載率)


3.9.10. 示波器顯示項目的再設定

在變更顯示項目的情況下，單擊[示波器設定]來進行通道設定。


3.9.11. 打開文檔

顯示在本軟體的示波器功能下保存的示波器數據。

① 從主工具欄打開

1) 單擊主工具欄的[文檔(F)]→[打開文檔(O)]→[示波器數據(O)]

2) 顯示打開文檔的對話方塊，選擇希望打開的示波器數據文檔，單擊[打開]按鈕。

3) 載入中顯示以下畫面。

附註

可從文檔的種類進行選擇的副檔名因裝置而有所差異。

※詳情請參照[6.1. 文檔副檔名一覽]

通過將示波器數據文檔拖放至本畫面，也可打開示波器數據文檔。

※對應的文檔請參照[6.2. 關於文檔拖放]

圖形在已被保存的時間軸上顯示。

游標位置和捲動位置被保存在Version 2.2.0以後保存的文檔中，若打開文檔，游標位置和捲動位置就會被恢復。

在打開由Version 2.1.0以前的VPH Data Editing Software所保存的文檔時，游標位置和捲動位置不會被恢復。

關於功能限制

在已顯示所保存的示波器數據的情況下，以下功能將會無效。

1.示波器計測

2.示波器設定的CH有效選擇和單位變換以外的功能


3.9.12. 保存到文檔中

在將本視窗上所顯示的示波器數據保存到文檔中的情況下，從選單欄

① 單擊[另存新檔]按鈕。

②顯示有A和B游標的情況下，可選擇保存方法。

附註

可保存的數據至多為300[sec]。

在用csv格式保存數據的情況下，輸出現在顯示中的單位制的數據。

根據顯示最大值的設定和計算誤差，整數數據可能會成為帶小數點的數據。


3.9.13. 列印

在列印所顯示的示波器數據的情況下，從選單欄單擊[列印]按鈕。

顯示列印視窗，設定各項目後單擊[確定]按鈕。

附註

列印紙尺寸可指定為[Ａ４、Ａ３]，列印方向可指定為[縱、橫]，但是實際輸出則以[Ａ４]、[縱]格式進行。


3.9.14. 視窗關閉

關閉所顯示的示波器視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。


3.10. 頻譜視窗

進行頻譜的測量，實時地進行圖形顯示。


3.10.1. 測量視窗的顯示

若單擊主工具欄的[解析功能]頁籤→[頻譜測量]，就會顯示本視窗。


3.10.2. 測量設定

① 測量對象的設定

1) 從[測量對象]下拉式列示方塊中選擇測量對象。

2) 將測量對象設定為速度、轉矩。

② 頻率的設定

1) 從[頻率]下拉式列示方塊中選擇測量頻率。

2) 根據裝置和參數設定，測量頻率（Hz）會在以下範圍內變動。

最大測量間隔 | 10000 | 5000 | 3333 | 2500 | 2000
最小測量間隔 | 2500 | 1250 | 833 | 625 | 500

附註

根據用戶所使用的電腦的動作性能（OS及處理時間），有的情況下無法在所設定的頻率下進行測量。這種情況下請調低測量頻率。

在[頻率]下拉式列示方塊變更時頻率與連接中的裝置不同的情況下，會顯示以下訊息。

若單擊[確定]按鈕，圖形和頻率就會被重置。

若單擊[取消]按鈕，圖形和頻率將保持原先的狀態。


3.10.3. 畫面顯示控制的設定

① 振幅的設定

1) 從[振幅]下拉式列示方塊中選擇Y軸的測量對象（速度／轉矩）的振幅的顯示標尺。

2) 將標尺自動地設定為1、2、3、4、5、10、20、50%（或dB）。

② 線色、背景色、線幅的設定

1) 從[線色]、[背景色]、[線幅]下拉式列示方塊中選擇線色、背景色、線幅。

2) 將線色設定為[紅色]、[綠色]、[藍色]、[橙色]、[青色]、[品紅]。

3) 將背景色設定為[白色]、[黑色]。

4) 將線幅設定為[細線]、[粗線]、[極粗線]。

③ 顯示對象的設定

1) 從[畫面切換]下拉式列示方塊中選擇測量結果的顯示方法。

2) 將顯示方法設定為[線性]及[對數]。

3) 設定為線性的情況下，以對應[100%]的形式對額定速度或額定轉矩進行%顯示。

4) 設定為對數的情況下，以正規化為[1]的形式對額定速度或額定轉矩進行分貝顯示。

將[畫面切換]設定為[對數]的情況，顯示如下畫面。


3.10.4. 頻譜的測量開始／停止

1) 開始測量頻譜的情況下，單擊[開始]按鈕。測量中[開始]按鈕會變為[停止]按鈕。

2) 若單擊[停止]按鈕，就會停止單擊測量。

3) 測量停止後，會按如下所示方式顯示測量波形。同時，游標Ａ會被自動設定在[陷波濾波器下限頻率]以上的頻率區域振幅最大的點。


3.10.5. 游標的設定

① 游標的設定

1) 單擊按鈕[A]或[B]。與所選擇的游標（A/B）對應的資訊顯示欄的顯示字元會成為粗體字。[A]或[B]將被唯一選擇。

2) 若在選擇了游標A的狀態下再次單擊按鈕[A]，游標A的選擇就會被解除。對於游標B也相同。

3) 在 [image] 中設定了游標設定方法時，單擊位置前後的頻率中會顯示橙色的線條。游標會被設定在此橙色線條的範圍內最高的頻率處。

游標已被設定的時畫面如下所示。

4) 在 [image] 中設定了游標設定方法時，游標就會被設定在所單擊的頻率處。

游標已被設定的時畫面如下所示。

② 游標的移動

1) 若單擊畫面上的任意點，就會在該點顯示十字游標。游標A時以[綠色]予以顯示，游標Ｂ時以[青色]予以顯示。（但是，若游標彼此相互重疊，或與顯示波形、軸線等重疊，顏色會暫時變化。）

2) 若單擊 LeftButton 或者 RightButton ，就可對游標位置進行微調整。若持續按住滑鼠，游標就會自動移動。

③ 游標資訊的顯示

1) 現在顯示有游標A或B的位置的頻率及速度或轉矩的資訊，將會在與游標對應的資訊顯示欄中顯示。

2) 在[差異]欄中顯示[A]點與[B]點值的差異。

設定了游標時的畫面如下所示。


3.10.6. 陷波濾波器的設定

本視窗上的陷波濾波器的設定與前一節所述的游標設定聯動。

① 陷波濾波器的設定值讀出

1) 在顯示有本視窗的時點顯示在所連接的裝置內設定的陷波濾波器的資訊。

2) 若單擊陷波濾波器邊框內的[接收]按鈕，就會讀出並顯示在所連接的裝置內設定的陷波濾波器的資訊。

② 陷波濾波器的計算

計算陷波濾波器包括以下兩種方式。

1) 只設定了游標A或游標B時

中心頻率：將游標位置的頻率作為中心頻率予以設定。

頻寬率：將對陷波濾波器頻寬率設定的值作為頻寬率予以設定。

2) 設定了游標A及游標B時

中心頻率：[A]及[B]中所顯示的頻率的積的平方根（ [image] ）將被設定為中心頻率。

頻寬率：設定將頻寬除以中心頻率時的商變換為百分率的值。

※超過100%時，將鉗制在100%上。

設定游標A、B時的中心頻率、頻寬率設定例

游標 | A | B | 差異
頻率[Hz] | 500 | 1000 | -500

計算式 | 例
中心頻率 = | 707 [Hz] =
頻寬= ABS(A-B) | 500 [Hz] =
頻寬率= 頻寬 ÷ 中心頻率 | 0.707107 = 500÷707.1068
頻寬率[%] = 頻寬率 × 100 | 70 [%] = 0.707107×100

③ 陷波濾波器的設定

1) 設定游標A、B。

2) 單擊與進行濾波處理的對象的參數對應的[設定]按鈕。

3) 將通過游標的設定計算出的結果設定為中心頻率、頻寬率。

4) 在設定的同時，該設定值也將被寫入裝置內。

5) 對應深度的裝置上，通過在設定了值的狀態下單擊[設定]按鈕就可設定深度。

注意

此時，若設定內容與系統不匹配，馬達就會劇烈振動。請按下與設定了陷波濾波器的位置相對應的[清除]按鈕來緊急解除陷波濾波器的設定。

6) 試圖在[陷波濾波器下限頻率]中設定的值以下的頻率區域進行陷波濾波器的設定的情況下，會顯示如下訊息。

單擊[是]的情況下，將強行設定。

※本判斷將由客戶作出。請客戶在充分確認裝置安全性的基礎上作出判斷。

單擊[否]的情況下，將停止設定。

通常選擇[否]。

7) 可通過從鍵盤輸入[數值＋Enter]來設定[陷波濾波器下限頻率]、[陷波濾波器頻寬率]。

（例１）若將游標Ａ指向下圖位置並單擊各中心頻率的[設定]按鈕，就會按下圖所示方式設定陷波濾波器。

（例2）若將游標Ａ及游標Ｂ指向下圖位置並單擊各中心頻率的[設定]按鈕，就會按下圖所示方式設定陷波濾波器。


3.10.7. 打開文檔

從主工具欄打開

1) 單擊主工具欄的[文檔(F)]→[打開文檔(O)]→[頻譜 (S)]。

2) 顯示打開文檔的對話方塊，選擇希望打開的頻譜數據文檔，單擊[打開]按鈕。

附註

可從文檔的種類進行選擇的副檔名因裝置而有所差異。

※詳情請參照[6.1. 文檔副檔名一覽]

通過將頻譜數據文檔拖放至本畫面，也可打開頻譜數據文檔。

※對應的文檔請參照[6.2. 關於文檔拖放]

關於功能限制

在已顯示所保存的頻譜數據的情況下，以下功能將會無效。

1.頻譜計測

2.陷波濾波器的設定

3.測量設定的變更


3.10.8. 保存到文檔中

在將本視窗上所顯示的頻譜數據保存到文檔中的情況下，從選單欄選擇[另存新檔] 。


3.10.9. 列印

在列印所顯示的頻譜數據的情況下，從選單欄單擊[列印]按鈕。

顯示列印視窗，設定各項目後單擊[確定(A)]按鈕。

附註

列印紙尺寸可指定為[Ａ４、Ａ３]，列印方向可指定為[縱、橫]，但是實際輸出則以[Ａ４]、[縱]格式進行。


3.10.10. 視窗關閉

關閉所顯示的頻譜視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。


3.10.11. 嚮導訊息

頻譜測量時顯示如下訊息。請按照指示進行操作。

示波器執行中無法進行頻譜的測量。

在單擊[開始]按鈕時頻率與連接中的裝置不同的情況下，會顯示此訊息。

試圖在陷波濾波器下限頻率以下（上面的畫面中為100Hz）的區域設定陷波濾波器時會顯示此訊息。

本判斷將由客戶作出。請客戶在充分確認裝置安全性的基礎上作出判斷。

對於不對應陷波濾波器深度的裝置，在試圖設定深度時會顯示此訊息。

在從裝置接收頻譜數據時沒有來得及進行數據的載入時會顯示此訊息。

依賴於測量頻率和用戶所使用的電腦的動作性能（OS及處理時間）。使用相同電腦的情況下，請調低測量頻率進行測量。


3.11. 頻率應答視窗

此視窗用來測量並顯示測量裝置的頻率應答，顯示所保存的頻率應答數據。


3.11.1. 測量視窗的顯示

若單擊主工具欄的[解析功能]頁籤→[頻率應答]，就會顯示本視窗。


3.11.2. 測量設定

① 測量增益編號的設定

選擇測量增益編號。

② 測量頻率的設定

1) 從[測量頻率]下拉式列示方塊中選擇測量頻率。

2) 根據裝置和參數設定，測量頻率（Hz）會在以下範圍內變動。

最大測量間隔 | 10000 | 5000 | 3333 | 2500 | 2000
最小測量間隔 | 2500 | 1250 | 833 | 625 | 500

附註

根據用戶所使用的電腦的動作性能（OS及處理時間），有的情況下無法在所設定的頻率下進行測量。這種情況下請調低測量頻率。

在[測量頻率]下拉式列示方塊變更時測量頻率與連接中的裝置不同的情況下，會顯示以下訊息。

若單擊[確定]按鈕，圖形和測量頻率就會被重置。

若單擊[取消]按鈕，圖形和測量頻率將保持原先的狀態。

③ 勵振寬幅（速度指令量／偏位量）的設定

1) 從鍵盤直接輸入勵振時的勵振寬幅。

2) 若右擊[%]的部分，就會顯示可輸入的數據區域。

注意

請根據客戶的裝置，在安全的範圍內進行設定。

④ 勵振時間的設定

從鍵盤直接輸入勵振的時間。在從1Hz至上面所設定的測量頻率的範圍內進行設定。

⑤ 容許最大振動量的設定

從鍵盤直接輸入容許最大振動量。

注意

請根據客戶的裝置，在安全的範圍內進行設定。

特別是τ線性馬達的情況下，要注意避免超過有效行程。

⑥ 計測次數的設定

將從1Hz至上面所設定的測量頻率的勵振作為1次，從鍵盤直接輸入總計測次數。


3.11.3. 顯示設定

① 振幅的設定

1) [振幅]下拉式列示方塊中選擇Y軸的振幅的顯示標尺。

2) 將標尺設定為自動、1、2、3、4、5、10、20、50dB。

3) 剛測量完後被設定為[自動]，從而可在整個畫面上顯示波形。

② 相位的設定

1) 從[相位]下拉式列示方塊中選擇Y軸的相位的顯示標尺。

2) 將標尺設定為自動、15、30、45、60、75、90deg。

3) 剛測量完後被設定為[自動]，從而可在整個畫面上顯示波形。

③ 線色、背景色、線幅的設定

1) 從[線色]、[背景色]、[線幅]下拉式列示方塊中選擇線色、背景色、線幅。

2) 將線色設定為[紅色]、[綠色]、[藍色]、[橙色]、[青色]、[品紅]。

3) 將背景色設定為[白色]、[黑色]。

4) 將線幅設定為[細線]、[粗線]、[極粗線]。

④ 顯示對象的設定

1) 從[畫面切換]下拉式列示方塊中選擇測量結果的顯示方法。

2) 將顯示方法設定為[振幅相位]及[振幅]。

3) 設定為振幅相位的情況下，在顯示區域的上半部分顯示振幅，下半部分顯示相位。

4) 設定為振幅的情況下，在整個顯示區域顯示振幅的畫面。


3.11.4. 頻率應答的測量開始／停止

1) 開始測量頻率應答的情況下，單擊[開始]按鈕。測量中[開始]按鈕會變為[停止]按鈕。

→

2) 顯示如下畫面。

3) 進行所設定的計測次數部分的測量而結束後，自動完成測量，[停止]按鈕會變回到[開始]按鈕。

4) 在測量完成的同時，游標Ａ會被自動設定在[陷波濾波器下限頻率]以上的頻率區域中之前點與當前點處的振幅變化量最大的點。

5) 測量中希望緊急停止動作的情況下，再次單擊[停止]按鈕。測量會緊急停止。

6) 測量完成時成為如下畫面。


3.11.5. 游標的設定

① 游標的設定

1) 單擊按鈕[A]或[B]。與所選擇的游標（A/B）對應的資訊顯示欄的顯示字元會成為紅色。[A]或[B]將被唯一選擇。

2) 若在選擇了游標A的狀態下再次單擊按鈕[A]，游標A的選擇就會被解除。對於游標B也相同。

3) 在 [image] 中設定了游標設定方法時，單擊位置前後的頻率中會顯示橙色的線條。游標會被設定在此橙色線條的範圍內最高的頻率處。

游標已被設定的時畫面如下所示。

4) 在 [image] 中設定了游標設定方法時，游標就會被設定在所單擊的頻率處。

游標已被設定的時畫面如下所示。

② 游標的移動

1) 若單擊畫面上的任意點，就會在該點顯示十字游標。游標A時以[綠色]予以顯示，游標B時以[青色]予以顯示。（但是，若游標彼此相互重疊，或與顯示波形、軸線等重疊，顏色會暫時變化。）

2) 若單擊 LeftButton 或者 RightButton ，就可對游標位置進行微調整。若持續按住滑鼠，游標就會自動移動。

③ 游標資訊的顯示

1) 現在顯示有游標A或B的位置的頻率及振幅或相位的資訊，將會在與游標對應的資訊顯示欄中顯示。

2) 在[差異]欄中顯示[A]點與[B]點值的差異。

設定了游標時的畫面如下所示。


3.11.6. 陷波濾波器的設定

本視窗上的陷波濾波器的設定與前一節所述的游標設定聯動。

① 陷波濾波器的設定值讀出

1) 在顯示有本視窗的時點顯示在所連接的裝置內設定的陷波濾波器的資訊。

2) 若單擊陷波濾波器邊框內的[接收]按鈕，就會讀出並顯示在所連接的裝置內設定的陷波濾波器的資訊。

② 陷波濾波器的計算

計算陷波濾波器包括以下兩種方式。

① 只設定了游標A或游標B時

中心頻率：將游標位置的頻率作為中心頻率予以設定。

頻寬率：將對陷波濾波器頻寬率設定的值作為頻寬率予以設定。

② 設定了游標A及游標B時

中心頻率：[A]及[B]中所顯示的頻率的積的平方根（ [image] ）將被設定為中心頻率。

頻寬率：設定將頻寬除以中心頻率時的商變換為百分率的值。

※超過100%時，將鉗制在100%上。

設定游標A、B時的中心頻率、頻寬率設定例

游標 | A | B | 差異
頻率[Hz] | 500 | 1000 | -500

計算式 | 例
中心頻率 = | 707 [Hz] =
頻寬= ABS(A-B) | 500[Hz] =
頻寬率= 頻寬 ÷ 中心頻率 | 0.707107 = 500÷707.1068
頻寬率[%] = 頻寬率 × 100 | 70 [%] = 0.707107×100

③ 陷波濾波器的設定

1) 設定游標A、B。

2) 單擊與進行濾波處理的對象的參數對應的[設定]按鈕。

3) 將通過游標的設定計算出的結果設定為中心頻率、頻寬率。

4) 在設定的同時，該設定值也將被寫入裝置內。

5) 對應深度的裝置上，通過在設定了值的狀態下單擊[設定]按鈕就可設定深度。

注意

此時，若設定內容與系統不匹配，馬達就會劇烈振動。請按下與設定了陷波濾波器的位置相對應的[清除]按鈕來緊急解除陷波濾波器的設定。

6) 試圖在[陷波濾波器下限頻率]中設定的值以下的頻率區域進行陷波濾波器的設定的情況下，會顯示如下訊息。

單擊[是]的情況下，將強行設定。

※本判斷將由客戶作出。請客戶在充分確認裝置安全性的基礎上作出判斷。

單擊[否]的情況下，將停止設定。

通常選擇[否]。

7) 可通過從鍵盤輸入[數值＋Enter]來設定[陷波濾波器下限頻率]、[陷波濾波器頻寬率]。

（例１）若將游標A指向下圖位置並單擊各中心頻率的[設定]按鈕，就會按下圖所示方式設定陷波濾波器。

（例2）若將游標Ａ及游標Ｂ指向右圖位置並單擊各中心頻率的[設定]按鈕，就會按下圖所示方式設定陷波濾波器。


3.11.7. 打開文檔

從主工具欄打開

1) 單擊主工具欄的[文檔(F)]→[打開文檔(O)]→[頻率應答(R)] 。

2) 顯示打開文檔的對話方塊，選擇希望打開的頻率應答數據文檔，單擊[打開]按鈕。

附註

可從文檔的種類進行選擇的副檔名因裝置而有所差異。

※詳情請參照[6.1. 文檔副檔名一覽]

通過將頻率應答數據文檔拖放至本畫面，也可打開頻率應答數據文檔。

※對應的文檔請參照[6.2. 關於文檔拖放]

關於功能限制

在已顯示所保存的頻率應答數據的情況下，以下功能將會無效。

1.頻率應答計測

2.陷波濾波器的設定

3.測量條件的變更


3.11.8. 保存到文檔中

在將本視窗上所顯示的頻率應答數據保存到文檔中的情況下，從選單欄單擊[另存新檔]按鈕。


3.11.9. 列印

1) 在列印所顯示的頻率應答數據的情況下，從選單欄單擊[列印]按鈕。

2) 顯示列印視窗，設定各項目後單擊[列印]按鈕。

附註

列印紙尺寸可指定為[Ａ４、Ａ３]，列印方向可指定為[縱、橫]，但是實際輸出則以[Ａ４]、[縱]格式進行。


3.11.10. 視窗關閉

關閉所顯示的頻率應答視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。

此時，有的情況下會以下畫面。


3.11.11. 嚮導訊息

頻率應答測量時顯示如下訊息。請按照指示進行操作。

在從裝置接收頻率應答數據時沒有來得及進行數據的載入時會顯示此訊息。

根據用戶所使用的電腦的動作性能（OS及處理時間），有的情況下無法在所設定的頻率下進行測量。這種情況下請調低測量頻率。

在裝置內執行勵振時發生錯誤時會顯示此訊息。

請在變更勵振寬幅、容許最大振動量等後進行再測量。

在單擊[開始]按鈕時測量頻率與連接中的裝置不同的情況下，會顯示此訊息。

從裝置接收陷波濾波器的值的情況下發生異常時會顯示此訊息。

請確認是否處在可進行USB通信的狀態。

在尚未設定游標的狀態下試圖進行陷波濾波器的設定時會顯示出此訊息。請設定游標。

對於不對應陷波濾波器深度的裝置，在試圖設定深度時會顯示此訊息。


3.12. 狀態顯示視窗

此視窗顯示警報履歷、裝置狀態、裝置資訊、編碼器資訊、馬達資訊等。


3.12.1. 狀態顯示視窗的顯示

若單擊主工具欄的[狀態顯示]頁籤→[狀態顯示]，就會顯示本視窗。


3.12.2. 狀態資訊

① 若選擇狀態顯示頁籤，就會顯示運轉資訊。

② 項目的現在值在[數據]顯示欄中顯示。

③ 項目的現在的單位在[單位]顯示欄中顯示。

④ 單擊清除按鈕的情況下，會顯示如下確認訊息。

若單擊[確定]按鈕，就會清除對象項目的數據。

若單擊[取消]按鈕，就會停止清除而返回原先的畫面。

⑤ 若單擊狀態組選擇按鈕，就可在組單位下進行狀態的顯示。

如下視窗為選擇了[位置]組時的顯示內容。

⑥ 若選擇[用戶自訂]組，就可調換顯示項目的順序，或將不需要的項目隱藏起來。

向下移動項目時，選擇希望移動的項目後單擊[ [image] ]按鈕。

向上移動項目時，選擇希望移動的項目後單擊[ [image]]按鈕。

要隱藏項目，選擇希望使其隱藏的項目後單擊[隱藏]按鈕。

返回初期狀態時，單擊[初期顯示]按鈕。


3.12.3. 警報資訊

① 若選擇警報頁籤，就會顯示警報資訊。

② 各項目的現在值在[Data]顯示欄中顯示。

③ 若單擊[一覽顯示]按鈕，就會顯示警報警告一覽畫面。

若單擊所顯示的警報，就會在警報警告一覽畫面中顯示警報的詳細。

④ 若單擊[警報清除]按鈕，就會顯示如下確認訊息。

若單擊[確定]按鈕，就會清除警報資訊。

若單擊[取消]按鈕，就會停止清除而返回原先的畫面。


3.12.4. 裝置資訊顯示

① 若選擇裝置資訊頁籤，就會顯示裝置資訊。

② 項目的現在值在[Data]顯示欄中顯示。

③ 項目的現在的單位在[單位]顯示欄中顯示。


3.12.5. 編碼器資訊顯示

  ① 若選擇編碼器資訊頁籤，就會顯示編碼器資訊。

  ② 項目的現在值在[Data]顯示欄中顯示。

③ 項目的現在的單位在[單位]顯示欄中顯示。

附註

在連接了與編碼器資訊的顯示不對應的裝置的情況下，會顯示以下許晉西，並將編碼器資訊頁籤隱藏起來。

在連接了與編碼器資訊對應的裝置的情況下，會顯示以下訊息，並顯示編碼器資訊頁籤。


3.12.6. 馬達資訊顯示

  ① 若選擇馬達資訊頁簽，就會顯示馬達資訊。

  ② 項目的現在值在[Data]顯示欄中顯示。

③ 項目的現在的單位在[單位]顯示欄中顯示。

※有的馬達沒有資訊，因此馬達資訊頁簽中有可能沒有顯示項目。

附註

在連接了與馬達資訊的顯示不對應的裝置的情況下，會顯示以下訊息，並將馬達資訊頁籤隱藏起來。

在連接了與馬達資訊對應的裝置的情況下，會顯示以下訊息，並顯示馬達資訊頁籤。


3.12.7. 視窗關閉

關閉所顯示的狀態顯示視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。


3.13. 輸入輸出信號狀態顯示視窗

顯示輸入輸出信號狀態。


3.13.1. 輸入輸出信號狀態顯示視窗的顯示

若單擊主工具欄的[狀態顯示]頁籤→[輸入輸出顯示]，就會顯示本視窗。


3.13.2. 輸入輸出信號狀態顯示

① 顯示輸入輸出信號的現在的狀態。

② 在信號為[ON]的狀態下成為藍色顯示。

③ 若將滑鼠游標指向信號記號，就會顯示信號名。


3.13.3. 視窗關閉

關閉所顯示的狀態顯示視窗的情況下，單擊[×]按鈕。


3.14. 遠距離運轉視窗

從本軟體上操作輸入輸出信號，進行遠距離運轉。


3.14.1. 開關箱視窗的顯示

若單擊主工具欄的[遠距離操作]頁籤→[開關箱] ，就會顯示本視窗。

有關視窗內的各信號內容，請參照裝置的使用說明書。


3.14.2. 輸出信號狀態的顯示

實時顯示輸出信號的狀態。

（信號ON時：綠色、紅色 ／ 信號OFF時：背景色）


3.14.3. 輸入信號的ON／OFF操作

在對輸入信號進行ON／OFF操作的情況下，對各按鈕、頁籤（速度控制模式等）、清單方塊（SS1-3）進行操作。

① 通常輸入信號按鈕

SwitchBoxButton | 顯示 | 通常的字體
 | 動作 | 單擊：ON/OFF切換 右擊：ON/OFF切換

② 暫態輸入信號按鈕

SwitchBoxButton | 顯示 | 斜體
 | 動作 | 按鈕按下狀態：ON 按鈕鬆開狀態：OFF 右擊：ON/OFF切換

注意

馬達將會根據輸入信號的操作而動作，所以要在充分確認安全的基礎上進行操作。


3.14.4. 視窗關閉

關閉所顯示的遠距離運轉視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。


3.15. 實時伺服調整視窗

實時變更自動調諧後的位準調整和速度／位置迴圈增益及伺服調整參數。


3.15.1. 實時伺服調整視窗的顯示

若單擊主工具欄的[調整功能]頁籤→[實時伺服調整]，就會顯示本視窗。

附註

自Version 2.2.0起曾由本軟體保持的FB濾波器設定方法選擇的值被保存在裝置中。

本畫面啟動時裝置內的FB濾波器設定方法選擇未設定時，會顯示以下訊息。

此外，USB連接時也會進行FB濾波器設定方法選擇的檢查，未設定時則顯示本訊息。


3.15.2. 調整對象增益的選擇

1) 從[調整增益選擇]下拉式列示方塊中選擇調整對象項目。

2) 與所選擇的調整對象項目相關的參數會在相關參數顯示／設定區域中顯示。


3.15.3. 參數調整

① 通過按鈕進行調整

1) 在相關參數顯示／設定區域單擊各項目的調整按鈕[▲][▼]。

2) 若單擊[▲]，參數的設定值就會遞增，並被實時更新。

3) 若單擊[▼]，參數的設定值就會遞減，並被實時更新。

4) 可通過遞增量調整選項按鈕來變更單擊[▲][▼]時的遞增／遞減量。

② 通過鍵盤進行調整

通過鍵盤直接設定值。

設定值在按下[Enter]鍵時被確定。

在對設定值輸入了非法值的情況下，將會顯示訊息，並將設定值恢復為操作之前的值。

輸入了範圍外的值時

輸入了數值以外的值時

附註

在持續按下增益調整按鈕[▲][▼]期間，持續遞增或遞減。

在尚未確定設定值的狀態下，以紅色字元予以顯示。

要確定設定值，按下[Enter]鍵。

③ 與低速增益(Step3)聯動

① 對與低速增益(Step3)聯動的核取方塊予以勾選。

② 若確定Step1(聯動源參數)，就會變更Step3(聯動目的地參數)。

Step1 | Step3
速度迴圈比例增益 | 速度迴圈比例增益／低速增益
速度迴圈積分時間常數 | 速度迴圈積分時間常數／低速增益
速度迴圈微分時間常數 | 速度迴圈微分時間常數／低速增益
速度迴圈比例增益分配率 | 速度迴圈比例增益分配率／低速增益
位置迴圈增益 | 位置迴圈增益／低速增益
位置迴圈微分時間常數 | 位置迴圈微分時間常數／低速增益


3.15.4. 慣性的設定

若變更[慣性]的值，就會顯示如下確認訊息。

若單擊[確定]，就會對裝置內的參數設定現在的慣性定值。

若單擊[取消]，就會停止參數的設定。


3.15.5. 黏性摩擦的設定

若變更[黏性摩擦]的值，就會顯示如下確認訊息。

若單擊[確定]，就會對裝置內的參數設定現在的黏性摩擦。

若單擊[取消]，就會停止參數的設定。


3.15.6. FB濾波器設定

1)顯示本視窗時，在USB連接時，按下[ [image] ]時會接收裝置內的FB濾波器設定方法選擇的值，並反映到FB濾波器設定方法選擇中。

2)若將[FB濾波器設定方法選擇]下拉式列示方塊設定為[手動]，就可手動設定[FB濾波器次數]、[FB濾波器頻率]。

3)若將[FB濾波器設定方法選擇]下拉式列示方塊設定為[手動]以外，就會進行FB濾波器處理，[FB濾波器次數]、[FB濾波器頻率]會自動更新。

此外，在此狀態下進行自動調諧位準調整的情況下，也會同樣被更新。

4)若單擊[更新]按鈕，就會向裝置傳送FB濾波器設定方法選擇的值。


3.15.7. 恢復為調整前的參數

若單擊[ [image] ]，就會顯示如下確認訊息。

若單擊[是]，就會將參數恢復為調整前的設定。

若單擊[是]，就會將參數和FB濾波器設定方法選擇恢復為調整前的設定。

若單擊[否]，就會停止參數恢復為調整前的設定。


3.15.8. 參數的更新

若單擊[更新]按鈕，就會顯示如下確認訊息。

所有的設定值都已被確定時

若單擊[確定]，就會向裝置傳送現在的增益設定值和FB濾波器設定方法選擇值。

若單擊[取消]，就會停止參數的設定。

有未確定（紅字）的設定值時

對紅字的設定值予以確定（Enter鍵），再次單擊[更新]按鈕。


3.15.9. 視窗關閉

關閉所顯示的實時增益調整視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。

在關閉畫面時尚未進行[更新]的情況下，會顯示如下訊息。

※即使不單擊[更新]按鈕而予以關閉，也會被記錄到裝置的RAM區域中，所以直至切斷裝置的電源為止顯示本視窗時將保持編輯狀態。


3.16. 自動調諧視窗

進行自動調諧，設定增益參數。


3.16.1. 視窗的顯示

若從主工具欄單擊[調整功能]頁籤→[自動調諧]，就會顯示本視窗。

附註

自Version 2.2.0起曾由本軟體保持的FB濾波器設定方法選擇的值被保存在裝置中。

本畫面啟動時裝置內的FB濾波器設定方法選擇未設定時，會顯示以下訊息。

此外，USB連接時也會進行FB濾波器設定方法選擇的檢查，未設定時則顯示本訊息。


3.16.2. 動作參數的接收

若單擊動作參數接收按鈕，就會接收裝置的動作參數，並將該值也反映到動作參數設定項目中。

附註

自Version 2.2.0起曾由本軟體保持的FB濾波器設定方法選擇的值被保存在裝置中。

接收動作參數時裝置內的FB濾波器設定方法選擇未設定時，會顯示以下訊息。

此外，USB連接時也會進行FB濾波器設定方法選擇的檢查，未設定時則顯示本訊息。


3.16.3. 動作參數的設定

設定調諧增益、動作方向、運轉比率、最大轉矩、慣性倍率。


3.16.4. FB濾波器的設定

在FB濾波器設定方法選擇被設定為[手動]的情況下，會以FB濾波器次數、FB濾波器頻率中所設定的值進行FB濾波器處理。

在FB濾波器設定方法選擇被設定為[手動]以外的情況下，會自動地進行FB濾波器處理。


3.16.5. 自動調諧的開始

若單擊開始按鈕，就會以對動作參數所設定的參數開始自動調諧。

自動調諧的結果將會在狀態中顯示。


3.16.6. 詳細的顯示

若單擊視窗的右上的 [image] ，就會顯示馬達動作預想值和自動調諧結果。

VPH-HB裝置、VPH-HD裝置、VPH-HE裝置的情況下，追加顯示deg單位或mm單位的馬達動作預想值。

無法與VPH裝置通信的情況下，馬達動作預想值成為「---」。

VPH-HA裝置、VPH-HC裝置

VPH-HB裝置、VPH-HD裝置、VPH-HE裝置


3.16.7. 視窗關閉

關閉所顯示的定位自動調諧視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。

自動調諧執行後的情況下，顯示以下訊息。


3.17. 測試運轉視窗

進行測試運轉。


3.17.1. 測試運轉視窗的顯示

若從主工具欄選擇[調整功能]頁籤→[測試運轉]，就會顯示本視窗。


3.17.2. 動作的設定

項目名 | 設定範圍 | 說明
開始位置指定 | 無效、ABS、INC | 可選擇動作開始位置的方法。
HCP限制 | HCP限制、無限制 | 只有在[開始位置指定]為「ABS」的情況下才會顯示。 在[開始位置指定]為「HCP限制」的情況下，在原點復歸尚未完成的狀態下無法執行測試運轉。 在[開始位置指定]為「無限制」的情況下，即使在尚未完成原點復歸的狀態也會執行測試運轉。
動作開始位置 | -2147483648∼2147483647 [P161] | 指定馬達的動作開始位置。 單位和小數點位置依照P161的設定值。
開始位置移動速度 | 0∼300000000[P161/sec] | 設定直至動作開始位置的馬達的移動速度。 單位和小數點位置依照P161的設定值。
動作方向 | ＋方向、－方向、往返 | 可選擇馬達的動作方向。
移動量 | -2147483648∼2147483647 [P161] | 設定馬達的移動量。 單位和小數點位置依照P161的設定值。
速度 | 0∼300000000[P161/sec] | 設定馬達的動作速度。 單位和小數點位置依照P161的設定值。
停止時間 | 0.000∼999.999[s] | 設定自定位完成後直至後續定位開始的停止時間。
SEL選擇 | SEL.0、SEL.1、SEL.2、SEL.3、SEL.4、SEL.5、SEL.6、SEL.7 | 馬達在所選擇的SEL的加減速時間內動作。
加速時間 | -9.9∼99999.9[ms] | 設定所選擇的SEL的馬達加速時間。
減速時間 | -9.9∼99999.9[ms] | 設定所選擇的SEL的馬達減速時間。
S型時間1 | -9.9∼1000.0[ms] | 設定所選擇的SEL的馬達S型時間1。 若對核取方塊予以勾選，就會對脈衝列指令的S型時間1設定相同的值
S型時間2 | -9.9∼1000.0[ms] | 對馬達加減速時間及S型時間1進一步設定S型時間2。

附註

若在S型時間1的同時設定核取方塊處於OFF的狀態下執行了測試運轉的情況下變更SEL選擇，就會顯示以下訊息。

若單擊「是」按鈕，就會在裝置中設定S型時間1的值。

若單擊「否」按鈕，就會變更SEL選擇。

若在[開始位置指定]為「ABS」，[HCP限制]為「HCP限制」，原點復歸尚未完成的狀態下執行測試運轉，就會顯示以下訊息。


3.17.3. 停止設定

項目名 | ON/OFF | 說明
USB通信時切斷時馬達停止 | ON | 即使在測試運轉動作中切斷了USB通信的情況下，也會繼續進行測試運轉動作。
 | OFF | 在測試運轉動作中切斷了USB通信的情況下，將會停止測試運轉動作。
週期停止 | ON | 返回動作開始位置，結束測試運轉動作。
 | OFF | 在現在位置結束測試運轉動作。


3.17.4. 測試運轉的開始／停止

注意

若執行本功能，馬達就會動作，所以要在充分確認安全的基礎上進行操作。

1) 若單擊[開始]按鈕，就會顯示以下訊息。

2) 動作中以一定間隔更新狀態。

動作中的狀態在狀態中顯示。

狀態 | 狀態
RUNNING[執行次數] | 執行中
CYCLE STOP RUNNING[執行次數] | 週期停止執行中
STOP[執行次數] | 中途停止
ALARM STOP[執行次數] 警報名 | 警報停止 警報的名稱
WARNING STOP[執行次數] | 警告停止
FORCED STOP[執行次數] | 強制停止
USB CLOSE | 無法與裝置進行USB通信

3) 停止運轉時

① 單擊了[週期停止]按鈕的情況下，通過週期停止來停止測試運轉。(只限於[停止設定]的[週期停止]為ON的情形)

② 單擊了[減速停止]按鈕的情況下，通過減速停止來停止測試運轉。

③ 單擊了[急速停止]按鈕的情況下，通過急速停止來停止測試運轉。

④ 按下了[Esc]鍵的情況下，通過急停止來停止測試運轉。


3.17.5. 動作狀態的顯示

若單擊視窗的右上的 [image] ，就會顯示動作狀態。

若單擊 [image] ，就可隱藏動作狀態。

動作狀態的顯示內容如下所示。

項目名 | 說明
現在位置 | 顯示馬達的現在位置(C021)。
定位目標位置1 | 顯示後續的定位目標位置。
定位目標位置2 | 顯示定位目標位置1後續的定位目標位置。
速度 | 顯示馬達的實際動作速度(C001)。

動作方向配合馬達的動作方向顯示黃色箭頭。

狀態 | τDISC |  |  | τ線性馬達
 | 往返 | ＋方向 | －方向 | 往返 | ＋方向 | －方向
未執行 |  |  |  |
停止中 |  |  |  |  |  |
＋方向動作中 |  |  |  |  |  |
－方向動作中 |  |  |  |  |  |

附註

馬達動作中、停止中的判斷，通過SZ信號來作出判斷。

不管是否在馬達動作中，在沒有顯示黃色箭頭的情況下，請將SZ信號速度範圍(P651)設定為未滿馬達動作速度。

動作方向的顯示，可通過以下設定來設定為相反方向。

項目名 | 說明
通常設定 | 顯示馬達的動作方向。
特殊設定 | 反相顯示馬達的動作方向。


3.17.6. 基於VPH裝置的追加顯示

VPH-HB裝置、VPH-HD裝置、VPH-HE裝置的情況下，追加顯示將單位換算成「deg」或「mm」的項目。

有關追加顯示部分，在無法與VPH裝置通信的情況下，動作參數設定會成為空白，動作狀態成為「0.00」。

換算後追加顯示的項目如下所示。

動作參數設定 | 動作顯示
動作開始位置 | 現在位置
開始位置移動速度 | 定位目標位置1
移動量 | 定位目標位置2
速度 | 速度


3.17.7. 視窗關閉

關閉所顯示的定位測試運轉視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。

測試運轉執行後的情況下，顯示以下訊息。

附註

在S型時間1的同時設定核取方塊處於OFF的狀態下執行了測試運轉的情況下，會顯示以下訊息。

若單擊「是」按鈕，就會在裝置中設定S型時間1的值。

若單擊「否」按鈕，就會直接結束畫面。


3.18. 自我診斷視窗

從電腦上執行裝置的自我診斷。

注意

根據自我診斷的項目內容將伴有伺服動作，所以要在充分確認安全的基礎上進行操作


3.18.1. 視窗的顯示

若從主工具欄單擊[調整功能]頁籤→[自我診斷]，就會顯示本視窗。


3.18.2. 自我診斷項目的選擇

從[診斷項目選擇(DG No.)]下拉式列示方塊中選擇自我診斷項目。


3.18.3. 自我診斷的開始／結束

① 開始自我診斷的情況下，單擊[診斷開始]按鈕。
開始診斷後，[診斷開始]按鈕將變為[診斷結束]按鈕。

② 結束自我診斷情況下，單擊[診斷結束]按鈕。
結束診斷後，[診斷結束]按鈕將變為[診斷開始]按鈕。


3.18.4. 診斷結果的顯示

自我診斷中／診斷結束時的診斷結果，將會在[診斷內容的設定／顯示]方塊內顯示。


3.18.5. 視窗關閉

關閉所顯示的自我診斷視窗的情況下，單擊[×]按鈕。

自我診斷執行後的情況下，會顯示如下訊息。


3.19. 設備監控器視窗

對裝置內的設備內容進行監控。


3.19.1. 視窗的顯示

若從主工具欄單擊[狀態顯示]頁籤→[設備監控器]，就會顯示本視窗。

視窗的概要

① [Bit]項目：可進行Bit單位（0/1）的讀出/寫入。

② [Word]項目：可進行Word單位（-32768∼32767）的讀出／寫入。

③ [Long]項目：可進行Long單位（-2147483648∼2147483647）的讀出／寫入。

④ [IX Device]、[R Device]、[D Device] 、[X Device]的情況下，可在相應的邊框內直接進行數據的操作。

⑤ 其他設備（X/R/D/IX）的情況下，可在[ Device][Word]／[Long]邊框內指定設備的類別來進行數據的操作。

⑥ 可利用[R]按鈕從裝置讀出數據。

⑦ 可利用[W]按鈕向裝置寫入數據。


3.19.2. 數據的讀出

1) 向各邊框內的設備編號輸入區域(①)輸入裝置編號。

通過單擊[▲][▼]按鈕(②)也會使得設備編號增減。

可利用遞增調整下拉式列示方塊(③)來指定增減量。

2) 單擊[R]按鈕(④)。

3) 在各邊框內的數據區域(⑤)中顯示讀出的數據。

浮動小數值顯示區域(⑥)浮動顯示讀出的32bit數據。

4) 在狀態顯示方塊(⑦)中顯示讀出時的處理結果。

（正常結束時：顯示OK／異常結束時：顯示ＮＧ。）


3.19.3. 數據的寫入操作

1) 向各邊框內的設備編號輸入區域(①)輸入裝置編號。

通過單擊[▲][▼]按鈕(②)也會使得設備編號增減。

可利用遞增調整下拉式列示方塊(③)來指定增減量。

2) 向數據區域(④)輸入要寫入的值。

3) 單擊[W]按鈕(⑤)。

4) 在狀態顯示方塊(⑥)中顯示寫入時的處理結果。

正常結束時：顯示OK／異常結束時：顯示NG。）


3.19.4. 實時更新

1) 對[實時更新]核取方塊予以勾選。

2) [R][W]按鈕將會無效。

3) 在數據區域顯示所指定的設備編號的數據，實時地進行更新。


3.19.5. 視窗關閉

關閉所顯示的自我診斷視窗的情況下，單擊[關閉]按鈕，或單擊[×]按鈕。


3.20. 版本視窗

顯示本軟體的版本資訊。

從選單欄單擊[幫助(H)] →[版本資訊(V)]。


4. 通信錯誤

4.1. 錯誤內容

執行USB通信時顯示有如下訊息的情況下，請確認訊息中所顯示的內容。


5. 數據導入

5.1. 關於數據導入

本功能是導入裝置馬達資訊，在沒有軟體的版本升級下可使用新追加的裝置及馬達的功能。

附註

數據導入功能與VPH Data Editing Software Version 1.0.0或更新版對應。


5.2. 數據導入方法

1) 單擊裝置、馬達的選擇視窗的[數據導入]按鈕。

2) 顯示再啟動軟體的訊息，單擊[確定]。

3) 在顯示UAC(用戶帳號控制)的確認訊息後，請單擊[是]。

4) 單擊已被再啟動的裝置、馬達的選擇視窗的[數據導入]按鈕。

5) 顯示打開文檔的對話方塊，選擇導入文檔，單擊[打開]按鈕。

6) 導入處理中顯示表示進度狀況的進度條。

7) 顯示以下訊息，數據導入完成。

附註

在數據導入沒有正常結束的情況下，會顯示以下訊息。


6. 附錄

6.1. 文檔副檔名一覽

本軟體中使用的文檔副檔名如下所示。

名稱 | 裝置類別 | 馬達類別 | 副檔名 | 打開 | 保存
參數 | VPH-HA | τDISC | *.c0pa0 | ○ | ○
 | VPH-HA | τ線性馬達 | *.c0pa1 | ○ | ○
 | VPH-HB | τDISC | *.c1pa0 | ○ | ○
 | VPH-HB | τ線性馬達 | *.c1pa1 | ○ | ○
 | VPH-HC | τDISC | *.c2pa0 | ○ | ○
 | VPH-HC | τ線性馬達 | *.c2pa1 | ○ | ○
 | VPH-HD | τDISC | *.c3pa0 | ○ | ○
 | VPH-HD | τ線性馬達 | *.c3pa1 | ○ | ○
 | VPH-HE | τDISC | *.c4pa0 | ○ | ○
 | VPH-HE | τ線性馬達 | *.c4pa1 | ○ | ○
 | ALL | ALL | *.csv | × | ○
程式數據 | VPH-HA | ALL | *.c0pro | ○ | ○
 | VPH-HB | ALL | *.c1pro | ○ | ○
 | VPH-HC | ALL | *.c2pro | ○ | ○
 | VPH-HD | ALL | *.c3pro | ○ | ○
 | VPH-HE | ALL | *.c4pro | ○ | ○
間接數據 | VPH-HA | ALL | *.c0ind | ○ | ○
 | VPH-HB | ALL | *.c1ind | ○ | ○
 | VPH-HC | ALL | *.c2ind | ○ | ○
 | VPH-HD | ALL | *.c3ind | ○ | ○
 | VPH-HE | ALL | *.c4ind | ○ | ○
示波器數據 | ALL | ALL | *.cxosc | ○ | ○
 | ALL | ALL | *.cxlog | ○ | ○
 | ALL | ALL | *.csv | × | ○
頻譜數據 | ALL | ALL | *.cxfrs | ○ | ○
頻率應答數據 | ALL | ALL | *.cxfrr | ○ | ○
成批數據 | VPH-HA | ALL | *.c0adb | ○ | ○
 | VPH-HB | ALL | *.c1adb | ○ | ○
 | VPH-HC | ALL | *.c2adb | ○ | ○
 | VPH-HD | ALL | *.c3adb | ○ | ○
 | VPH-HE | ALL | *.c4adb | ○ | ○

※ALL對應全部類別


6.2. 關於文檔拖放

通過將文檔拖放至支援本軟體的視窗來打開拖放來的文檔。


6.2.1. 對應視窗、文檔一覽

 |  | 對象視窗
 |  | 裝置 | 主 | 參數 | 程式 | 間接 | 示波器 | 頻譜 | 頻率應答
拖放的文檔 | 參數(*.c*pa**) | ○ | ○ | ○ | × | × | × | × | ×
 | 參數(*.csv) | × | × | × | × | × | × | × | ×
 | 程式(*.c*pro*) | ○ | ○ | × | ○ | × | × | × | ×
 | 間接數據(*.c*ind*) | ○ | ○ | × | × | ○ | × | × | ×
 | 示波器數據(*.cxosc*, *.cxlog) | ○ | ○ | × | × | × | ○ | × | ×
 | 示波器數據(*.csv) | × | × | × | × | × | × | × | ×
 | 頻譜數據(*.cxfrs*) | ○ | ○ | × | × | × | × | ○ | ×
 | 頻率應答數據(*.cxfrr*) | ○ | ○ | × | × | × | × | × | ○
 | 頻率應答數據(*.csv) | × | × | × | × | × | × | × | ×
 | 成批數據(*.c*adb*) | × | × | × | × | × | × | × | ×

※視窗簡称：正式名稱

裝置：裝置馬達選擇視窗、主：主工具欄視窗、參數：參數編輯視窗、程式：程式編輯視窗

間接：間接數據編輯視窗、示波器：示波器視窗、頻譜：頻譜視窗、頻率應答：頻率應答測量視窗


6.2.2. 不對應拖放的視窗

下述視窗不對應通過拖放來打開文檔。

視窗名稱

狀態顯示視窗

輸入輸出信號狀態顯示視窗

設備監控器視窗

自我診斷視窗

自動調諧視窗

實時伺服調整視窗

測試運轉視窗

開關箱視窗

版本顯示視窗

數據比較視窗

列印視窗


6.3. csv文檔的數據結構

這裡列出以csv文檔保存數據時的數據結構。

注意

以csv文檔格式保存的文檔，無法利用本軟體來打開。

參數數據csv文檔結構

NAME | 文檔名 |  |  |  |  |  |  |
DEF | 參數編號 | 設備編號 | 參數名稱 | 單位 | 設定範圍 | 設定值 | 初期值 | 顯示狀態

示波器數據csv文檔結構

NAME | 文檔名 |  |  |  |
DEF | 15 |  |  | 通道設定 |
DEF | 0 | CH1顯示最大值 | CH1顯示偏位量 |  | CH1: CH1的名稱
DEF | 1 | CH2顯示最大值 | CH2顯示偏位量 |  | CH2: CH2的名稱
DEF | 2 | CH3顯示最大值 | CH3顯示偏位量 |  | CH3: CH3的名稱
DEF | 205 |  | CH4顯示偏位量 |  | CH4: CH4的名稱
DEF | 數據解析度[msec] |  |  | 數據解析度 |
DEF | 290 |  | 2 |  | 2
DEF | 291 |  | 1 |  | 0
DEF | 292 |  | 3 |  | 0
DEF | 293 |  | 0 |  | 0
DEF | 294 |  | 7 |  | 6
DAT | 數據獲取時間[sec] | CH1數據 | CH2數據 | CH3數據 | CH4數據

附註

CH*顯示偏位量，只輸出測量項目中設定了信號的CH。

速度系統的數據，輸出所顯示的單位制的數據。

信號數據為0時OFF，為1時ON。

頻率應答csv文檔結構

NAME | 文檔名 |  |
 | 【測量條件】 | 設定值 | 單位
DEF | 測量增益編號 | 0 |
DEF | 測量頻率 | 4000 | [Hz]
DEF | 勵振幅度(速度指令量) | 1 | [%]
DEF | 勵振幅度(偏位量) | 0 | [%]
DEF | 勵振時間 | 3000 | [msec]
DEF | 許可最大振動量 | 0 | [pulse]
DEF | 計測次數 | 3 | 【次】
 | 【陷波濾波器】 | 設定值 | 單位
DEF | 中心頻率1 | 0 | [Hz]
DEF | 頻寬率1 | 0 | [%]
DEF | 深度1 | 0 | [-dB]
DEF | 中心頻率2 | 0 | [Hz]
DEF | 頻寬率2 | 0 | [%]
DEF | 深度2 | 0 | [-dB]
DEF | 中心頻率3 | 0 | [Hz]
DEF | 頻寬率3 | 0 | [%]
DEF | 深度3 | 0 | [-dB]
DEF | 中心頻率4 | 0 | [Hz]
DEF | 頻寬率4 | 0 | [%]
DEF | 深度4 | 0 | [-dB]
DEF | 中心頻率 | 0 | [Hz]
DEF | 頻寬率 | 0 | [%]
DEF | 深度 | 0 | [-dB]
 | 【頻率應答】 |  |
 | 頻率[Hz] | 振幅[dB] | 相位[deg]
DAT | 0.244110826 | -0.3161 | 0
DAT | 0.488221653 | -0.3032 | -0.2199
DAT | 0.732332479 | -0.2988 | -0.1022
DAT | ∼ | ∼ | ∼
DAT | 3999.511778 | -11.7789 | 17.4333
DAT | 3999.755889 | -11.8517 | -153.2895
DAT | 4000 | -13.3143 | 22.0282