VPH Data Editing Software Help

(c) 2014 CKD NIKKI DENSO CO., LTD.

Ver. 4.0


1. 머리말

1.1. 안전하게 사용하기 위하여

본 설명서는 ‘VPH Data Editing Software’의 조작 순서, 주의 사항 등을 설명한 것입니다.

VPH 시리즈의 성능을 충분히 이용하기 위해 사용하기 전에 잘 읽으십시오.

본 설명서의 본문에서 ‘VPH Data Editing Software’를 ‘본 소프트웨어’라고 표기합니다.

본 설명서에서는 안전 주의 사항의 등급을 “위험”, “주의”로 표시하여 구분하고 있습니다.

위험

이 표시는 잘못 취급한 경우에 위험 상황이 발생할 수 있어 사망 또는 중상을 입을 가능성이 예상됨을 나타냅니다.

주의

이 표시는 잘못 취급한 경우에 위험 상황이 발생할 수 있어 중간 정도의 장애나 경상을 입을 가능성이 예상되는 경우 및 물적 상해만의 발생이 예상됨을 나타냅니다.

주기

조작의 주의점을 나타냅니다.


1.2. 기타 주의 사항

ㆍ본 설명서의 내용은 예고 없이 변경될 수 있습니다.

ㆍ본 설명서의 내용은 만전을 기해 작성했습니다만, 만일 의심스러운 점이나 잘못된 점 등이 있으면 연락 주시기를 부탁드립니다.

ㆍ본 소프트웨어의 운용을 이유로 하는 손실, 일실 이익 등의 청구에 대해서는 그 어떤 책임도 지지 않으므로 미리 양해 부탁드립니다.

ㆍ제품 개량을 위해 예고 없이 개관 또는 사양의 일부를 변경하는 경우가 있습니다.

ㆍWindows는 미국 Microsoft Corporation의 미국 및 기타 국가에서의 등록 상표입니다.

ㆍENSIS®는 주식회사 미츠토요의 등록 상표입니다.

ㆍ리니어 스케일®은 주식회사 미츠토요의 등록 상표입니다.

ㆍBiSS®는 iC-Haus GmbH의 등록 상표입니다.

ㆍEnDat®는 하이덴하인 주식회사의 등록 상표입니다.


1.3. 소프트웨어의 사용 허가 조건

VPH 시리즈용 시스템 지원 툴

VPH Data Editing Software

사용 허가 조건

VPH 시리즈용 시스템 지원 툴을 설치하기 전에 다음에 기재되어 있는 사용 허가 조건(이하 ‘사용 허가 조건’이라 한다)을 반드시 읽으십시오. 사용자가 본 소프트웨어를 설치한 시점에서 사용자는 CKD 니키덴소 주식회사가 제시하는 사용 허가 조건의 내용 전부에 동의한 것으로 간주합니다.

사용 허가 조건은 설치한 사용자 외에 개인, 법인을 불문하고 본 소프트웨어를 사용하는 모든 사람에게 적용됩니다. 동의하지 않는 경우에는 본 소프트웨어의 설치 및 사용을 하지 마십시오.

1. 정의

1.1 ‘사용자’란 CKD 니키덴소 주식회사가 사용자 등록을 하여 본 소프트웨어의 사용을 인정하고 라이선스를 부여한 사람을 말합니다.

1.2 ‘본 소프트웨어’란 사용 허가 조건과 함께 CKD 니키덴소 주식회사의 웹 사이트에서 다운로드하는 방식으로 배포되어, 사용자 측 컴퓨터에서 동작하는 아래의 소프트웨어를 말합니다.

품명: 서보 드라이버 VPH 시리즈용 시스템 지원 툴

VPH Data Editing Software

형식: NPS-VPHDESN3

1.3 ‘본 소프트웨어 전체’란 1.2항의 본 소프트웨어와 이에 부속된 매뉴얼 등 모든 저작물(PDF 등에 의한 전자 문서를 포함)을 포함한 것을 말합니다.

1.4 ‘라이선스’란 1.1항의 사용자에 대해 CKD 니키덴소 주식회사가 별도로 정하는 방법 및 수속에 의해 부여한 본 소프트웨어의 사용 권한을 말합니다.

2. 사용자 등록

2.1 사용자는 본 소프트웨어 다운로드 시에 CKD 니키덴소 주식회사에 사용자 등록 신청을 해야 합니다. 사용자 등록은 CKD 니키덴소 주식회사 웹 사이트에서 회원 등록 또는 고객 정보 입력을 통해서 하며 필요 항목과 기타 자세한 내용은 CKD 니키덴소 주식회사가 정하는 것으로 합니다.

2.2 CKD 니키덴소 주식회사는 2.1항의 사용자 등록 정보를 확인하고 사용자 등록을 합니다. 또한 CKD 니키덴소 주식회사는 사용자 등록 정보 외에 필요에 따라 서보 드라이버 VPH 시리즈 구매 이력 등의 사용자 정보를 참조할 수 있습니다.

2.3 사용자는 사용자 등록 사항에 변경이 있는 경우에는 신속하게 CKD 니키덴소 주식회사에 알려야 합니다.

2.4 CKD 니키덴소 주식회사는 사용자에 의한 사용 조건 위반이 있었을 경우 및 해킹 등 기타 부득이한 사정으로 인해 본 소프트웨어의 통상적인 가동이 어렵다고 판단한 경우에는 예고 없이 사용자 등록 삭제, 라이선스 정지를 할 수 있습니다.

3. 사용 허가의 범위

3.1 CKD 니키덴소 주식회사는 사용자가 본 계약에 기재된 사용 조건에 동의하고 준수하는 것을 조건으로 본 소프트웨어 전체에 관해 라이선스를 부여하여 사용(다운로드 및 컴퓨터에 설치하는 것을 포함)을 허가하는 것으로 합니다.

3.2 전항의 허가에 대한 대가는 무상으로 합니다.

3.3 사용자는 제삼자에 대해 본 소프트웨어의 재사용을 허가할 수 없습니다.

3.4 사용자는 백업 목적에 한해서 본 소프트웨어 등의 복제물을 1부만 작성할 수 있는 것으로 합니다.

4. 저작권의 귀속

본 소프트웨어 전체에 관한 저작권은 CKD 니키덴소 주식회사에 귀속됩니다. 본 소프트웨어가 기록된 매체 및 이에 부속된 매뉴얼 등의 양도는 본 소프트웨어 전체의 저작권을 양도하는 것은 아닙니다.

5. 양도, 대여, 배포 등의 금지

본 소프트웨어 전체 및 라이선스는 상기 목적 이외로 사용하는 것 및 제삼자에게 양도, 배포, 대여, 송신 기타 사용을 할 수 없습니다.

6. 분석ㆍ개조 등의 금지

사용자는 본 소프트웨어 전체의 전부 또는 일부에 대해 역컴파일, 리버스 엔지니어링, 역어셈블, 수정, 개조(소스 코드의 개조도 포함), 번안 또는 이차적 저작물의 창작을 할 수 없습니다.

7. 책임의 제한

7.1 CKD 니키덴소 주식회사는 본 소프트웨어 전체의 품질, 성능이 사용자의 사용 목적에 부합하는 것을 보증하지 않습니다.

7.2 본 소프트웨어 전체에 대해 제삼자와의 사이에서 제조물 책임에 관한 분쟁 및 저작권 등 기타 지적 재산권에 관련된 분쟁이 발생한 경우에도 CKD 니키덴소 주식회사는 책임을 지지 않습니다.

7.3 CKD 니키덴소 주식회사가 본 소프트웨어 전체를 개량(버그 수정)했을 때는 필요에 따라 사용자에 대해 수정 후의 본 소프트웨어 전체 및 수정에 관한 정보를 제공합니다. 단, 제공 시기, 방법 등 기타 자세한 내용은 CKD 니키덴소 주식회사의 재량에 의해 결정하는 것으로 합니다. 또한 수정 후의 본 소프트웨어 전체에도 이 사용 허가 조건이 적용되는 것으로 합니다.

7.4 7.1항 내지 7.3항에 규정한 것 외에 CKD 니키덴소 주식회사는 법률이 금지하지 않는 범위에서 본 소프트웨어 전체의 사용 또는 사용 불가에 기인하거나 또는 관련된 기계ㆍ설비ㆍ제품ㆍ반제품 등의 손상, 일실 이익, 데이터의 소실, 업무의 중단 또는 기타 재산적 손해 또는 손실, 생명ㆍ신체적 손해 또는 손실 등을 포함한 모든 손해 등에 대해 어떠한 책임도 지지 않습니다.

7.5 7.1항 내지 7.4항 기타 이 사용 허가 조건의 규정에 의해서도 CKD 니키덴소 주식회사의 면책이 인정되지 않는 경우, 사용자에게 발생한 모든 손해에 관한 CKD 니키덴소 주식회사의 배상 책임 총액은 본 소프트웨어 전체의 금액을 상한으로 합니다.

8. 계약의 해제

사용자가 본 사용 허가 조항의 규정 중 어느 하나를 위반한 경우, CKD 니키덴소 주식회사는 즉시 본 소프트웨어 전체의 사용 허가를 해제할 수 있습니다. 이 경우, 사용자는 그 비용을 부담하여 본 소프트웨어 전체 및 그 복제물을 신속하게 반환하거나 또는 회복 불가능한 방법으로 파기해야 합니다.

9. 계약의 분리성

어떠한 이유로 인해 본 사용 허가 조항 중 어느 하나의 조항 또는 그 일부에 대해 효력이 없는 것으로 간주된 경우에도 본 계약의 다른 조항 또는 부분은 여전히 완전한 효력을 가지는 것으로 합니다.

10. 준거법

본 사용 허가 조항은 일본법에 준거하며 일본법에 따라 해석되는 것으로 합니다.

11. 분쟁 해결

11.1 본 소프트웨어 전체 및 이 사용 허가 조건에 관한 CKD 니키덴소 주식회사와 사용자 간의 소송은 프로그램 저작권에 관련된 것에 대해서는 도쿄 지방 법원을 제1심 전속적 합의 관할 법원으로 하고, 기타 소송에 대해서는 치바 지방 법원을 제1심 전속적 합의 관할 법원으로 합니다.

11.2 11.1항의 규정에도 불구하고 사용자가 일본국 외에 소재하는 경우에는 본 사용 허가 조항에서 또는 본 사용 허가 조항에 관련해서 CKD 니키덴소 주식회사와 사용자 사이에 발생할 수 있는 모든 분쟁, 논쟁 또는 의견 차이는 일반사단법인 일본상사중재협회의 상사중재규칙에 따라 일본국 도쿄도에서 중재에 의해 최종적으로 해결되는 것으로 합니다.


1.4. 개요

본 소프트웨어는 PC에서 VPH 장치의

① 파라미터 편집, 프로그램 편집, 간접 데이터 편집

② 오실로 데이터/주파수 스펙트럼 데이터/주파수 응답 데이터의 측정과 표시

③ 원격 운전, 운전 상태 표시

④ 오토 튜닝, 실시간 서보 조정, 테스트 운전

⑤ 자기 진단/내부 제어 정보의 모니터링

등을 하기 위한 소프트웨어입니다.


1.5. 시스템 환경

본 소프트웨어를 사용하려면 아래와 같은 시스템 구성이 필요합니다.

또한 VPH 장치와 데이터 통신(파라미터 전송 등)을 하는 경우에는 PC 이외에 USB 케이블(시판품)이 필요합니다.

※당사에서는 USB 케이블을 옵션으로 제공하고 있지 않습니다.

PC | PC/AT 호환기(USB 커넥터를 이용할 수 있을 것)
OS | Windows7 32bit/64bit(Ultimate, Professional,Enterprise, Home Premium) Windows 8/8.1 32bit/64bit(표시 없음, Pro, Enterprise) Windows 10 32bit/64bit(Home, Pro, Enterprise)
CPU | 1GHz 이상의 프로세서
메모리 | 1GB(32bit) 또는 2GB(64bit)의 RAM 이상
하드 디스크 | 1GB 이상
디스플레이 | XGA(1024×768 pixel) 이상
지원언어 | Japanese, English, Chinese(simplified), Chinese(traditional), Korean
기타 | .NET Framework 4.0 이상 Visual C++ 2010 런타임


1.6. 수출 관리에 대해

본 제품과 제공하려고 하는 기술의 용도 및 수요자가 대량 파괴 병기 등의 개발 등이나 통상 병기의 개발 등에 사용될 우려가 있는 경우에는 ‘외환 및 외국무역법’이 정하는 수출 규제의 대상이 될 수 있으므로 수출 시에는 충분한 심사 및 필요한 수출 수속을 밟으십시오.


2. 설치/제거

2.1. 본 소프트웨어의 설치

1) [Setup.exe 파일을 두 번 클릭하여 소프트웨어 설치를 시작합니다.

2) USB 드라이버가 설치되어 있지 않은 경우.

USB 드라이버의 설치 화면이 표시되므로 화면을 따라 설치하십시오.

USB 드라이버의 설치 방법은 ‘2.3. USB 드라이버의 설치’를 참조하십시오.

3) .NET Framework 4.0이 설치되어 있지 않은 경우.

다음과 같은 화면이 표시됩니다. [동의] 버튼을 클릭하십시오.

4) .Net Framework 4.0의 설치가 시작됩니다.

설치 완료 시에 본 대화 상자는 자동으로 닫힙니다.

5) Visual C++ 2010 런타임 라이브러리가 설치되어 있지 않은 경우.

다음과 같은 화면이 표시됩니다. [설치] 버튼을 클릭하여 다음과 같이 설치하십시오.

6) [동의] 확인란에 체크를 넣고 [설치] 버튼을 클릭합니다.

7) Visual C++ 2010 런타임 라이브러리의 설치가 완료되면 다음과 같은 화면이 표시됩니다.

[마침] 버튼을 클릭하여 본 소프트웨어의 설치로 이동합니다.

8) 필수 구성 요소가 설치되어 있는 경우.

다음과 같은 화면이 표시됩니다. [다음] 버튼을 클릭하십시오.

9) 소프트웨어 사용 허락에 동의하는 경우.

[소프트웨어 사용 허락 계약서에 동의합니다]를 선택한 후 [다음] 버튼을 클릭하십시오.

[동의 안 함]의 경우 본 소프트웨어를 설치할 수 없습니다.

10) 설치 디렉터리를 변경하는 경우.

[변경] 버튼을 클릭하여 변경하십시오. 그런 후 [다음] 버튼을 클릭하십시오.

11) 설치 확인.

지금까지 입력한 내용으로 설치하는 경우, [설치] 버튼을 클릭하십시오.

12) 설치 프로그램의 실행 경과가 표시됩니다.

13) 설치가 완료되면 다음과 같은 화면이 표시됩니다.

[마침] 버튼을 클릭하십시오.


2.2. 본 소프트웨어의 제거

1) Windows 작업 표시줄의 [시작]-[제어판]-[프로그램 및 기능]을 클릭하여 [프로그램 및 기능] 창을 표시하십시오.

2) 목록 상자에서 [VPH Data Editing Software]를 선택한 후 [제거] 버튼을 클릭하십시오.

3) [예] 버튼을 클릭하십시오.

4) 다음 화면이 표시되고 제거가 완료됩니다.


2.3. USB 드라이버의 설치

[USB_Driver 폴더를 더블 클릭합니다.

사용 PC의 OS가 32bit인 경우 dpinst32.exe를, 64bit인 경우 dpinst64.exe를 실행하여 아래의 마법사를 따라 설치하십시오.

1) 시작 화면에서 [다음(N)] 버튼을 클릭하십시오.

2) 아래 화면에서 [설치(I)]를 클릭합니다.

3) USB 드라이버의 설치가 시작됩니다.

4) 다음과 같은 화면이 표시되고 USB 드라이버의 설치가 완료됩니다.

5) VPH 장치를 USB 포트에 연결합니다.

다음과 같은 팝업이 표시되고 소프트웨어의 설치가 완료됩니다.


2.4. USB 드라이버의 제거

1) Windows 작업 표시줄의 [시작]-[제어판]-[프로그램 및 기능]을 클릭하여 [프로그램 및 기능] 창을 표시하십시오.

2) 목록 상자에서 [Windows 드라이버 패키지 - CKD NIKKI DENSO CO.,LTD.(WinUSB)CKD NIKKI DENSO VPH USB Device]를 선택한 후 [제거/변경] 버튼을 클릭하십시오.

3) [예] 버튼을 클릭하십시오.


3. 기능과 조작

3.1. 본 소프트웨어의 기동

본 소프트웨어를 기동하려면 Windows의 작업 표시줄에서

[시작]→[프로그램(P)]→

[NikkiDenso]→[VPH Data Editing Software]→[Nikki VPH DES]

를 선택하거나 바탕 화면에 생성된 [Nikki VPH DES] 바로 가기를 통해 실행하십시오.

다음과 같은 로고 마크가 표시된 후, 장치ㆍ모터 선택 창이 표시됩니다.


3.2. 장치 모터 선택 창

사용할 장치 모터를 선택합니다.


3.2.1. VPH 장치에서 장치 정보를 읽어 장치 모터 선택하기

1) 본 소프트웨어와 VPH 장치가 연결되어 있고 동시에 장치의 전원이 ON인 경우에는 [장치에서 설정을 취득] 버튼을 클릭하여 장치 내에 등록되어 있는 정보를 읽습니다.

※화면 기동 시에 VPH 장치가 연결되어 있는 경우, 자동으로 장치 내에 등록되어 있는 정보를 읽습니다

2) 읽은 정보를 바탕으로 장치 정보, 모터 정보가 선택된 상태로 화면에 표시됩니다.

3) [결정] 버튼을 클릭하여 메인 툴 바로 이행합니다.

본 소프트웨어와 VPH 장치가 USB 통신을 할 수 없는 경우

표시된 메시지의 내용을 확인하십시오.

본 소프트웨어에서 사용할 수 없는 VPH 장치가 연결되어 있는 경우

이 메시지가 표시된 경우, 연결되어 있는 VPH 장치에 맞는 소프트웨어로 업데이트해야 합니다.

당사 영업 담당자에게 연락하십시오.

본 소프트웨어에서 사용할 수 없는 모터 정보가 VPH 장치에 설정되어 있는 경우

사용할 모터가 모터란에 있는지 확인하십시오.

사용하고자 하는 모터가 없는 경우, 소프트웨어의 업데이트가 필요합니다.

당사 영업 담당자에게 연락하십시오.


3.2.2. 수동으로 장치 모터 선택하기

본 소프트웨어와 VPH 장치가 USB 통신을 할 수 없는 경우, 사용할 VPH 장치와 모터를 직접 선택합니다.

1) 장치 선택

장치란의 콤보 상자를 위에서부터 차례로 선택합니다.

2) 모터 선택

모터란의 콤보 상자를 위에서부터 차례로 선택합니다.

제품 분류에 따라서는 값 입력을 요구하는 경우가 있습니다.

3) [결정] 버튼을 클릭하여 메인 툴 바로 이행합니다.


3.2.3. 파일 드롭으로 장치 모터 선택하기

본 화면에 파일을 드롭하면 자동으로 장치 모터를 선택하여 파라미터 파일을 엽니다.

※드롭 가능한 파일은 [6.2. 파일 드롭에 대해]를 참조

1) 열고자 하는 파라미터 파일을 드래그하여 본 화면에 드롭합니다.

2) 본 화면이 닫히고 메인 툴 바가 표시됩니다.

3) 드롭한 파라미터 파일이 표시됩니다.


3.2.4. 장치 모터 선택의 메시지

장치 모터 선택 화면에서 메인 툴 바로 이행하기 전에 다음과 같은 메시지가 표시되는 경우가 있습니다.

이 경우 메시지를 따라 조작하십시오.

장치 선택은 맞지만, VPH 장치 내의 모터 정보가 미설정인 경우

장치 선택은 맞지만, 모터 선택이 VPH 장치 내의 정보와 다른 경우

※모터를 변경한 경우 반드시 표시됩니다

재기동이 필요한 파라미터가 변경된 경우

선택되어 있는 장치 선택과 VPH 장치의 정보가 다른 경우

완전히 일치하는 장치 정보를 찾을 수 없는 경우

모터 엔코더 관련 파라미터를 장치에 송신했을 때 네트워크 통신 중인 경우

장치의 자동 재기동을 실행하려고 했을 때 네트워크 통신 중인 경우

엔코더 타입을 BiSS 엔코더로 변경한 경우

엔코더 타입을 하이덴하인 ABS 엔코더로 변경한 경우


3.2.5. 표시 언어 전환

본 소프트웨어의 표시 언어를 전환합니다.

1) 언어 선택 콤보 상자(Display language choice)를 변경합니다.

2) 언어를 변경한 경우 재기동 확인 메시지가 표시됩니다.

3) ‘확인’을 클릭하면 선택한 언어로 본 소프트웨어가 기동됩니다.


3.3. 메인 툴 바 창

본 소프트웨어의 메인 화면에서 각 기능의 화면을 기동합니다.

메뉴 바

본 소프트웨어의 기능을 선택하는 메뉴가 표시됩니다.

메인 툴 바

본 소프트웨어의 기능을 선택하는 버튼이 표시됩니다.

스테이터스 바

장치의 USB 연결 상태, 파라미터의 반영 상태, 지령 단위, 설정 단위, 장치 형식, 모터 형식이 표시됩니다.

① USB 연결 상태:

장치와 통신할 수 있습니다.

장치와 통신할 수 없습니다.

주기

설정과 다른 장치가 연결된 경우, 다음과 같은 메시지가 표시됩니다.

장치ㆍ모터 선택 화면으로 돌아가 재설정하십시오.

② 파라미터의 반영 상태:

표시 없음 | 파라미터값은 최신 상태입니다.
restart | 파라미터값을 반영하기 위해 전원 재투입이 필요합니다. 클릭하면 전원을 재투입합니다.
reset | 파라미터값을 반영하기 위해 RST 신호의 입력이 필요합니다. 클릭하면 RST 신호를 입력합니다.

③ 알람, 경고 상태:

표시 없음 | 알람, 경고의 발생은 없습니다.
 | 알람 발생 시에 표시합니다.
 | 경고 발생 시에 표시합니다.

④ 네트워크 통신 상태:

표시 없음 | 네트워크 미사용 장치입니다.
 | 장치가 유지 보수 모드입니다. 클릭하면 기능 모드 전환 화면을 표시합니다.
 | 장치가 유지 보수 모드입니다. MODE 스위치가 ON이거나 MTON 신호가 ON 상태이므로 통신 모드로 전환할 수 없습니다.
 | 장치가 통신 모드입니다. 클릭하면 기능 모드 전환 화면을 표시합니다.
 | 장치가 통신 모드입니다. 네트워크 연결 중이므로 유지 보수 모드로 전환할 수 없습니다.

⑤ 단위:

선택 중인 위치 단위와 위치 소수 단위를 표시합니다.

⑥ 장치 형식:

선택 중인 장치 형식을 표시합니다.

⑦ 모터 형식

선택 중인 모터 형식을 표시합니다.

장치ㆍ모터 선택 창으로 돌아가기

본 소프트웨어가 기동되었을 때 또는 임의의 시점에 장치 모터 선택을 실행할 수 있습니다.

메뉴 바에서

[파일(F)]→[장치ㆍ모터 선택(D)]

을 선택하면 현재 열려 있는 화면 전체를 닫습니다.

주기

편집 도중인 화면이 있는 경우, 화면을 닫을지를 확인합니다.

모든 화면을 닫는 경우에는 장치 모터 선택으로 돌아갑니다.

닫지 않은 화면이 남아 있는 경우에는 장치 모터 선택으로 돌아가지 않습니다.

다음 기능이 실행 중인 경우, 장치 모터 선택으로 돌아갈 수 없습니다.

파라미터, 프로그램, 간접 데이터, 일괄 데이터 송수신 중

오실로 측정, 주파수 스펙트럼 측정 중

주파수 응답, 자기 진단, 테스트 운전, 오토 튜닝 실행 중


3.3.1. 전원 재투입, RST 신호 입력

1) 전원 재투입

스테이터스 바(상태 표시줄)의 전원 재투입 아이콘 restart 을 클릭하면 아래와 같은 확인 메시지가 표시됩니다.

장치를 재기동하는 경우에는 [확인]을 클릭하고, 중지하는 경우에는 [취소]를 클릭하십시오.

주기

MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다.

서보 OFF 후 다시 전원 재투입 아이콘 restart 을 클릭하십시오.

장치가 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다.

수동으로 전원을 재투입하십시오.

2) RST 신호 입력

스테이터스 바(상태 표시줄)의 RST 신호 입력 아이콘 reset 을 클릭하면 아래와 같은 확인 메시지가 표시됩니다.

RST 신호를 입력하는 경우에는 [확인]을 클릭하고, 중지하는 경우에는 [취소]를 클릭하십시오.

주기

MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다.

서보 OFF 후 RST 신호 입력의 아이콘 reset 을 클릭하십시오.

장치가 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다.

수동으로 전원을 재투입하십시오.


3.3.2. 기능 모드 전환

스테이터스 바(상태 표시줄)의 네트워크 통신 상태 아이콘( [image] 또는 [image] )을 클릭하면 기능 모드 전환 창이 표시됩니다.

통신 모드의 경우

유지 보수 모드의 경우

주기

MODE 스위치가 ON인 경우, 다음과 같은 메시지가 표시됩니다.

MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다.

서보 OFF 후 다시 아이콘을 클릭하십시오.

장치가 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다.

네트워크와 분리한 후 다시 아이콘을 클릭하십시오.

1) 표시되어 있는 전환 코드를 입력한 후 [Enter] 키를 누릅니다.

2) 기능 모드 전환 버튼을 클릭할 수 있게 됩니다.

통신 모드의 경우

유지 보수 모드의 경우

3) 기능 모드 전환 버튼을 클릭하면 아래와 같은 확인 메시지가 표시됩니다.

통신 모드의 경우

유지 보수 모드의 경우

모드를 전환하는 경우에는 [확인]을 클릭하고, 중지하는 경우에는 [취소]를 클릭하십시오.

주기

MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다.

서보 OFF 후 [기능 모드 전환] 버튼을 클릭하십시오.

장치가 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다.

네트워크와 분리한 후 다시 [기능 모드 전환] 버튼을 클릭하십시오.

주기

본 화면에 대응하는 파일을 드롭하여 파일을 열 수도 있습니다.

※대응하는 파일은 [6.2. 파일 드롭에 대해]를 참조


3.4. 본 소프트웨어의 종료

본 소프트웨어는 장치 모터 선택 화면의 [×] 버튼, 메인 툴 바의 메뉴 바 선택 또는 [×] 버튼으로 종료합니다.

① 장치 모터 선택 화면의 [×] 버튼

1) 장치 모터 선택 화면 오른쪽 위의 [×] 버튼을 클릭합니다.

2) 종료 확인 메시지의 [확인] 버튼을 클릭합니다.

② 메인 툴 바의 메뉴

1) 메인 툴 바의 메뉴 바에서

[파일(F)]→[종료(X)]

를 클릭합니다.

2) 종료 확인 메시지의 [확인] 버튼을 클릭합니다.

③ 메인 툴 바의 [×] 버튼

1) 메인 툴 바 오른쪽 위의 [×] 버튼을 클릭합니다.

2) 종료 확인 메시지의 [확인] 버튼을 클릭합니다.


3.5. 파라미터 편집 창

VPH 장치용 파라미터를 편집합니다.


3.5.1. 창의 표시

메뉴 바에서

[파일(F)]→[신규 작성(N)]→[파라미터(P)]

또는

[파일(F)]→[열기(O)]→[파라미터(P)]

또는

[파일(F)]→[파라미터 파일 변환]

메인 툴 바의

[데이터 편집] 탭→[파라미터]→[파라미터 메뉴 선택]


3.5.2. 파라미터의 편집

① 파라미터 직접 편집

1) 마우스 또는 키보드를 사용하여 파라미터를 선택합니다.

2) 선택한 파라미터를 마우스로 클릭, [Enter], [F2] 키를 눌러 파라미터를 편집 상태로 만듭니다.

ㆍ수치 입력 항목의 경우: 키보드로 데이터를 직접 입력합니다.

ㆍ선택 항목의 경우: 리스트에서 항목을 선택합니다.

3) 포커스를 해제, [Enter], [Tab], [F2] 키를 눌러 파라미터를 확정합니다.

※그레이 아웃되어 있는 파라미터는 편집할 수 없습니다.

② 파라미터의 복사 및 붙여넣기

파라미터 편집 창 간의 복사/붙여넣기

여러 개의 파라미터 창이 표시되어 있을 때 특정 범위의 파라미터 데이터를 다른 창에 복사하는 데 편리한 기능입니다.

1) 파라미터 데이터 복사

파라미터 데이터를 복사하는 경우에는 복사 범위를 키보드의 [Shift]+[↑], [Shift]+[↓]를 눌러 지정하거나 또는 마우스로 드래그한 후 마우스 오른쪽 클릭으로 [복사]를 선택하거나 또는 Ctrl+C로 복사합니다.

2) 파라미터 데이터 붙여넣기

파라미터 데이터를 붙여 넣을 위치를 커서로 지정하여, 마우스 오른쪽 클릭으로 [붙여넣기]를 선택하거나 또는 Ctrl+V로 붙여 넣습니다.


3.5.3. 파라미터 명칭 검색

파라미터를 선택한 상태에서 [Ctrl]+ [F]를 누르면

파라미터 명칭 검색 화면이 표시됩니다.

①검색 문자열을 입력한 후 [다음] 또는 [이전] 버튼을 클릭하면

  검색 문자열과 일치하는 파라미터를 선택합니다.

[다음] 버튼의 동작은 [Enter] 또는 [F3] 키를 눌러도 동일한 동작을 합니다.

[이전] 버튼의 동작은 [Shift] + [F3] 키를 눌러도 동일한 동작을 합니다.

주기

일치하는 파라미터가 없는 경우, 다음과 같은 메시지가 표시됩니다.

②[닫기] 버튼을 클릭하면 검색 화면을 종료합니다.

  [ESC] 또는 [×] 키를 눌러도 동일한 동작을 합니다.


3.5.4. 단위ㆍ전자 기어 설정

단위, 전자 기어 관련 파라미터를 설정합니다.

3.5.4.1. 창의 표시

파라미터 편집 창에서

[단위, 전자 기어 설정]을 선택하거나

  또는

    대상 파라미터를 더블 클릭

하면 본 창이 표시됩니다.

주기

①이미 [자동 설정]이 설정되어 있는 상태에서 본 창을 열 때, 다음과 같은 메시지가 표시되는 경우가 있습니다.

본 메시지는 [자동 설정]에서는 파라미터 편집 창에서 설정한 위치 단위를 선택할 수 없는 경우에 표시됩니다.

②본 창에서 ‘설정 모드’를 [자동 설정]으로 변경할 때, 다음과 같은 메시지가 표시되는 경우가 있습니다.

본 메시지는 [자동 설정]에서는 현재 선택되어 있는 위치 단위를 선택할 수 없는 경우에 표시됩니다.

[확인]: 위치 단위를 적절한 값으로 변경하고 자동 설정으로 이행합니다.

[취소]: 설정 모드의 변경을 취소합니다.

주기

③본 창에서 ‘설정 모드’를 [자동 설정]으로 변경할 때, 다음과 같은 메시지가 표시되는 경우가 있습니다.

본 메시지는 현재 선택되어 있는 위치 소수 단위가 잘못되어 정상적으로 기계 이동량ㆍ회전체 위치 범위를 자동 설정할 수 없는 경우에 표시됩니다.

위치 소수 단위를 표시되어 있는 값으로 변경하고 자동 설정으로 이행합니다.

④본 창에서 ‘설정 모드’를 [자동 설정]으로 변경할 때, 다음과 같은 메시지가 표시되는 경우가 있습니다.

본 메시지는 현재 설정되어 있는 기계 이동량, 전자 기어비 분자, 전자 기어비 분모, 회전체 위치 범위, 회전체 위치 범위 부호 전환 위치 안에 자동 설정할 수 없는 값이 설정되어 있는 경우에 표시됩니다.

[확인]: 기계 이동량, 전자 기어비 분자, 전자 기어비 분모, 회전체 위치 범위, 회전체 위치 범위 부호 전환 위치에 자동 설정 가능한 값을 설정합니다.

[취소]: 자동 설정을 중단합니다.

3.5.4.2. 단위, 전자 기어의 편집

설정 모드의 선택

본 창을 열면 설정 모드를 [자동 설정], [수동 설정] 중에서 선택할 수 있습니다.

자동 설정

선택된 위치 단위와 위치 소수 단위로부터 기계 이동량/전자 기어비 분자/전자 기어비 분모/회전체 위치 범위/회전체 위치 범위 부호 전환 위치를 자동 계산하여 설정합니다.

수동 설정

위치 단위와 위치 소수 단위를 선택한 후에 기계 이동량/전자 기어비 분자/전자 기어비 분모/회전체 위치 범위/회전체 위치 범위 부호 전환 위치를 직접 입력하여 설정합니다.

① ‘설정 모드’를 [자동 설정]으로 한 경우

본 창이 아래 그림과 같이 표시됩니다.

‘설정 모드’를 [자동 설정]으로 한 경우에는 다음과 같은 항목을 편집할 수 있습니다.

① 위치 단위

② 위치 소수 단위

③ 회전체 위치 범위

①~③의 선택을 통해 기계 이동량/전자 기어비 분자/전자 기어비 분모/회전체 위치 범위/회전체 위치 범위 부호 전환 위치를 자동 계산하여 설정됩니다.

각 항목의 설정 방법은 다음을 참조하십시오.

① 위치 단위 선택

위치 단위를 선택합니다.

본 소프트웨어 기동 시에 설정한 모터 제품 분류(3.2. 을 참조)에 따라 선택할 수 있는 위치 단위가 다릅니다.

모터 제품 종류 | 선택 가능한 위치 단위
τDISC | deg, pulse, kpulse
τ 리니어 | m, mm, um, inch, pulse, kpulse

② 위치 소수 단위 선택

위치 소수 단위를 선택합니다.

주기

본 동작에 의해 다음과 같은 메시지가 표시되는 경우가 있습니다.

본 메시지는 ①에서 선택한 위치 단위에 대해 잘못된 위치 소수 단위가 선택되어 정상적으로 기계 이동량ㆍ회전체 위치 범위를 자동 설정할 수 없는 경우에 표시됩니다.

③ 회전체 위치 범위 설정

회전체 위치 범위/회전체 위치 범위 부호 전환 위치를 설정합니다.

※모터 제품 종류가 ‘τ 리니어’인 경우, 본 파라미터는 설정할 수 없습니다.

체크를 넣으면 회전체 위치 범위/회전체 위치 범위 부호 전환 위치를 자동으로 적절한 값으로 설정합니다.

체크를 해제하면 회전체 위치 범위/회전체 위치 범위 부호 전환 위치는 0으로 설정됩니다.

주기

본 동작에 의해 다음과 같은 메시지가 표시되는 경우가 있습니다.

본 메시지는 위치 단위와 위치 소수 단위의 조합이 잘못되어 정상적으로 회전체 위치 범위를 자동 설정할 수 없는 경우에 표시됩니다.

② ‘설정 모드’를 [수동 설정]으로 한 경우

본 창이 아래 그림과 같이 표시됩니다.

‘설정 모드’를 [수동 설정]으로 한 경우에는 다음과 같은 항목을 편집할 수 있습니다.

① 위치 단위 설정

② 위치 소수 단위 설정

③ 기계 이동량 설정

④ 전자 기어 설정

⑤ 회전체 위치 범위

각 항목의 설정 방법은 다음을 참조하십시오.

① 위치 단위 선택

위치 단위를 선택합니다.

② 위치 소수 단위 선택

위치 소수 단위를 선택합니다.

③ 기계 이동량 설정

기계 이동량을 직접 입력합니다.

④ 전자 기어 설정

전자 기어비 분자, 전자 기어비 분모를 직접 입력합니다.

⑤ 회전체 위치 범위 설정

회전체 위치 범위/회전체 위치 범위 부호 전환 위치를 직접 입력합니다.

※모터 제품 종류가 ‘τ 리니어’인 경우, 본 파라미터는 설정할 수 없습니다.

3.5.4.3. 파라미터의 설정

본 창의 [설정]을 클릭하면 본 창이 닫히고, 본 창에서 편집한 파라미터가 파라미터 편집 창에 설정됩니다.

위치 단위와 위치 소수 단위가 변경되어 있는 경우, 다음과 같은 메시지가 표시됩니다.

주의

위치 단위와 위치 소수 단위를 변경한 경우, 모터를 작동하기 전에 다음 설정값을 반드시 재검토하십시오.

① 속도 및 이동량의 파라미터값

② 프로그램 데이터의 설정값

③ 간접 데이터의 설정값

설정값을 재검토하지 않고 모터를 동작시킨 경우, 의도하지 않은 동작을 할 가능성이 있으므로 주의하십시오.

3.5.4.4. 창 닫기

본 창의 [닫기]를 클릭하여 본 창을 닫습니다.

파라미터 변경 후 [설정]을 클릭하지 않고 [닫기]를 클릭한 경우, 다음과 같은 메시지가 표시됩니다.

[예]를 클릭하면 본 창에서 변경한 파라미터를 적용하지 않고 본 창을 닫습니다.

[아니요]를 클릭하면 닫기를 중지합니다.


3.5.5. 그룹의 선택

파라미터 그룹 선택 버튼을 클릭하면 그룹 단위로 파라미터를 편집할 수 있습니다. 다음 창은 [지령 설정] 그룹을 선택했을 때의 표시 내용입니다.

[모든 항목 표시]를 선택하고 있을 때, 지정 파라미터로 이동하는 점프 스위치(콤보 상자)를 클릭하여 파라미터 번호를 설정하면 지정한 파라미터로 커서가 이동합니다.

[P100]을 선택하면 화면에 P100의 내용이 표시되고 커서가 이동합니다.


3.5.6. 파라미터 쓰기

1) 파라미터 편집 창의 파라미터를 장치에 쓰는 경우에는 [장치에 쓰기] 버튼을 클릭합니다.

2) 쓰기 여부 확인 메시지가 표시되므로 쓰는 경우에는 [확인] 버튼을, 중지하는 경우에는 [취소] 버튼을 클릭합니다.

주기

Version 2.2.0부터 본 소프트웨어에서 유지하고 있던 FB 필터 설정 방법 선택의 값이 장치에 유지되게 되었으며 파라미터 쓰기 시에 FB 필터 설정 방법 선택의 설정값을 체크하게 되었습니다.

쓰기를 하는 파라미터와 장치 내의 FB 필터 설정 방법 선택이 다른 경우, 다음과 같은 메시지가 표시됩니다.

기본적으로는 ‘예’를 선택하고 필요에 따라 ‘실시간 서보 조정 화면’에서 FB 필터 설정 방법 선택을 재설정하십시오.

또한 재조정을 위해 오토 튜닝을 실행한 경우에도 마찬가지로 FB 필터 설정 방법 선택이 재설정됩니다.

설정 변경 후에는 파라미터를 읽어 파일에 저장함으로써 FB 필터 설정 방법 선택의 값을 유지할 수 있으며, 다음번 파라미터 쓰기 시에 저장된 값이 장치에 설정됩니다.

단, Version 2.1.0 이전의 VPH Data Editing Software에서 저장된 파일을 기록하는 경우에는 FB 필터 설정 방법 선택의 값이 파일에 저장되지 않으므로 본 메시지는 표시되지 않고, FB 필터 설정 방법 선택값도 장치에 설정되지 않습니다.

Version 4.0.0부터 절대 위치 보정 데이터의 설정에 대해 ‘절대 위치 보정 보정 동작 지정’이 ‘무효’일 때, 다음과 같은 경우에 파라미터를 쓰기 전에 메시지가 표시되게 됩니다.

ㆍ엔코더 타입이 ‘S-ABS2’, ‘S-ABS3’, ‘S-ABS4’ 중 어느 하나이고, 엔코더에 절대 위치 보정 데이터가 등록되어 있는 경우

ㆍ엔코더 타입이 ‘S-ABS2’, ‘S-ABS3’, ‘S-ABS4’ 이외이고, VPH 장치에 절대 위치 보정 데이터가 등록되어 있는 경우

‘예’를 클릭하면 ‘보정 유효’로 하여 송신합니다.

‘아니요’를 클릭한 경우에는 ‘무효’인 상태로 송신합니다.

테스트 운전 파라미터가 장치 내와 다른 경우, 파라미터를 쓰기 전에 다음과 같은 메시지가 표시됩니다.

‘확인’을 클릭하면 테스트 운전의 동작 파라미터를 파라미터 파일의 값으로 덮어쓰기합니다.

‘취소’를 클릭하면 쓰기가 취소됩니다.

3) 바 표시가 오른쪽 끝까지 도달하면 쓰기 종료입니다.

4) 쓸 때 타이틀에 표시되어 있는 파일 이름을 장치에 씁니다.

5) 전원 재투입 또는 RST 신호 입력이 필요한 파라미터가 송신된 경우에는 다음과 같은 메시지가 표시됩니다.

전원 재투입이 필요한 파라미터가 송신된 경우

RST 신호 입력이 필요한 파라미터가 송신된 경우

전원 재투입 또는 RST 신호를 입력하는 경우에는 [확인]을 클릭하고, 중지하는 경우에는 [취소]를 클릭하십시오.

주기 | 전원 재투입이 필요한 파라미터가 송신되었을 때 MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다. 서보 OFF 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 전원을 재투입하십시오.
 | 장치의 전원 재투입을 실행하려고 했을 때 MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다. 서보 OFF 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 전원을 재투입하십시오.
 | 전원 재투입이 필요한 파라미터가 송신되었을 때 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다. 네트워크와 분리한 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 전원을 재투입하십시오.
 | 장치의 전원 재투입을 실행하려고 했을 때 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다. 네트워크와 분리한 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 전원을 재투입하십시오.
 | RST 신호 입력이 필요한 파라미터가 송신되었을 때 MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다. 서보 OFF 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 RST 신호를 입력하십시오.
 | RST 신호 입력을 실행하려고 했을 때 MTON 신호가 ON인 경우, 다음과 같은 메시지가 표시됩니다. 서보 OFF 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 RST 신호를 입력하십시오.
 | RST 신호 입력이 필요한 파라미터가 송신되었을 때 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다. 네트워크와 분리한 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 RST 신호를 입력하십시오.
 | RST 신호 입력을 실행하려고 했을 때 네트워크 통신 중인 경우, 다음과 같은 메시지가 표시됩니다. 네트워크와 분리한 후 수동으로 전원을 재투입하거나 메인 툴 바를 통해 RST 신호를 입력하십시오.


3.5.7. 파라미터 읽기

1) 장치 내의 파라미터를 읽는 경우에는 [장치로부터 읽기] 버튼을 클릭합니다.

2) 읽기 여부 확인 메시지가 표시됩니다. 읽는 경우에는 [확인] 버튼을, 중지하는 경우에는 [취소] 버튼을 클릭합니다.

3) 바 표시가 오른쪽 끝까지 도달하면 읽기 종료입니다.

4) 읽을 때 장치에 기록되어 있는 파라미터명을 화면에 표시합니다.

표시된 이름은 저장 시의 초기 파일 이름입니다.

5) 파라미터 읽기 중에 다음과 같은 메시지가 표시되는 경우가 있습니다.

본 메시지가 표시된 경우, 장치에 설정되어 있는 파라미터가 현재 본 소프트웨어에서 편집하고 있는 파라미터의 설정 범위를 초과한 것이라고 생각할 수 있습니다.

① [예]를 클릭하면 읽기를 계속합니다.

‘P008(1)=4/P008(2)=3/P028(3-1)=101/P210=-1’은 장치에 설정되어 있는 범위 밖의 파라미터값입니다. (　) 안은 파라미터의 자리 범위를 나타냅니다.

단, 범위 밖의 파라미터는 강제로 초기값을 설정합니다.

본 메시지가 표시된 경우 다음과 같은 것을 생각할 수 있습니다.

내용 | 대책
사용하고 있는 파라미터 파일이 오래된 버전에서 작성되었다 | 신규 작성 파라미터로 다시 파라미터 읽기를 하십시오
장치의 버전과 본 소프트웨어의 버전이 맞지 않는다(본 소프트웨어의 버전이 오래되었다) | 본 소프트웨어의 버전 업이 필요합니다. 당사 담당 영업 부문에 문의하십시오.
장치에 설정된 파라미터값이 범위 밖으로 되어 있다(상위 기기에서 파라미터를 범위 밖의 값으로 변경했다 등) | 범위 밖의 파라미터값을 설정한 곳을 수정하십시오.

② [아니요]를 클릭하면 읽기를 중지합니다.

주기

파라미터 범위 밖으로 인해 파라미터 읽기를 중지한 경우, 범위 밖으로 된 파라미터의 하나 앞 파라미터까지는 읽기가 완료되어 있습니다.


3.5.8. 파라미터의 비교

파라미터 편집 화면의 [비교] 버튼을 클릭하면 파라미터의 데이터 비교 화면이 열립니다.

비교의 종류는 [초기값과 비교], [장치 내와 비교], [파일과 비교], [ROM과 RAM을 비교]입니다.

비교를 실행하면 차이점의 건수, 차이점의 일람이 표시됩니다.

비교 결과: 차이점의 확인

차이점 없음

차이점 있음

비교 결과: 차이의 일람

차이의 일람은 왼쪽에서부터 파라미터 번호, 파라미터의 항목명, 비교 원본 설정값, 비교 대상 설정값, 비교 원본 단위의 순으로 표시됩니다.

주기

비교 대상값에 범위 밖의 값이 설정되어 있는 경우, 붉은색 글씨로 ‘(　)’로 묶어진 값이 표시됩니다.

초기값과 비교

1) 파라미터 초기값과 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[초기값과 비교] 버튼을 클릭합니다.

2) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※P161: 위치 소수 단위 선택의 값을 참조하는 파라미터가 비교 대상인 경우

비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 초기값으로 저장되어 있는 위치 소수 단위 를 반영한 값을 표시합니다.

장치 내와 비교

1) 장치 내의 파라미터와 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[장치 내와 비교] 버튼을 클릭합니다.

2) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※P161: 위치 소수 단위 선택의 값을 참조하는 파라미터가 비교 대상인 경우

비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 장치 내에 설정되어 있는 위치 소수 단위 를 반영한 값을 표시합니다.

파일과 비교

1) 지정 파일과 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[파일과 비교] 버튼을 클릭합니다.

2) [파일 열기] 창이 표시됩니다.

3) 비교하는 파일을 선택한 후 [열기(O)] 버튼을 클릭합니다.

4) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※P161: 위치 소수 단위 선택의 값을 참조하는 파라미터가 비교 대상인 경우

비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 파일에 저장되어 있는 위치 소수 단위 를 반영한 값을 표시합니다.

ROM과 RAM을 비교

1) 장치 내의 RAM 영역과 ROM 영역의 내용을 비교하는 경우에는

[비교]→[ROM과 RAM을 비교] 버튼을 클릭합니다.

2) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※P161: 위치 소수 단위 선택의 값을 참조하는 파라미터가 비교 대상인 경우

비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

※ROM 영역과 RAM 영역에 대해

ROM 영역은 장치의 전원을 꺼도 데이터가 지워지지 않는 영역입니다. 변경 가능 횟수 10억 회의 제한이 있습니다.

RAM 영역은 장치의 전원을 끄면 데이터가 소실되는 영역입니다. 장치의 전원 투입 시 또는 ROM 영역의 데이터가 변경되면 ROM 영역의 데이터가 RAM 영역에 복사됩니다. 주로 본 영역의 데이터를 사용하여 장치가 동작합니다. 변경 횟수에 제한은 없습니다.

비교 결과의 출력

① 파일에 출력하기

[CSV 출력] 버튼을 클릭하면 차이점을 CSV 파일에 출력할 수 있습니다.

② 인쇄

차이점이 있는 상태에서 [인쇄] 버튼을 클릭하면 차이점을 인쇄할 수 있습니다.


3.5.9. 파일 열기

저장된 파라미터를 여는 경우

① 메인 툴 바에서 열기

1) 메인 툴 바의 [파일(F)]→[열기]→[파라미터]를 클릭

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 파라미터 파일을 선택한 후 [열기] 버튼을 클릭합니다.

② 파라미터 편집 화면에서 열기

1) 파라미터 편집 창의 [열기]를 클릭합니다.

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 파라미터 파일을 선택한 후 [열기] 버튼을 클릭합니다.

주기

파일의 종류에서 선택할 수 있는 확장자는 장치, 모터에 따라 다릅니다.

※자세한 내용은 [6.1. 파일 확장자 일람]을 참조

본 화면에 파라미터 파일을 드롭하여 파라미터 파일을 열 수도 있습니다.

※대응하는 파일은 [6.2. 파일 드롭에 대해]를 참조


3.5.10. 파일에 저장하기

파라미터 편집 창의 파라미터를 파일에 저장하는 경우에는 같은 파일 이름으로 저장할지 새로운 파일 이름을 지정하여 저장할지 선택할 수 있습니다.

① 같은 파일 이름으로 저장하는 경우에는 메뉴 바에서
[저장] 버튼을 클릭합니다.

② 새로운 파일 이름을 지정하여 저장하는 경우에는 메뉴 바에서

[다른 이름으로 저장] 버튼을 클릭합니다.

주기

Version 2.2.0부터 본 소프트웨어에서 유지하고 있던 FB 필터 설정 방법 선택의 값이 장치에 유지되게 되었으며 파라미터에도 저장되게 되었습니다.

저장되는 FB 필터 설정 방법 선택값은 장치에서 읽기를 한 시점의 값입니다.


3.5.11. 인쇄

파라미터 편집 창의 파라미터를 인쇄하는 경우에는 메뉴 바에서

[인쇄] 버튼을 클릭합니다.

① 파라미터가 선택 상태로 되어 있는 경우, 다음과 같은 메시지가 표시됩니다.

1) 인쇄 범위를 지정합니다.

① 전체 범위를 인쇄하는 경우

1) [전체를 인쇄]를 선택합니다.

2) [확인] 버튼을 클릭합니다.

② 인쇄 범위를 지정하여 인쇄하는 경우

1) [선택 범위를 인쇄]를 선택합니다.

2) [확인] 버튼을 클릭합니다.

2) 인쇄 창이 표시됩니다.

① 인쇄를 하는 경우, 각 항목을 설정하여 [인쇄] 버튼을 클릭합니다.

② 인쇄를 중단하는 경우에는 [취소] 버튼을 클릭합니다.

② 파라미터가 선택 상태로 되어 있지 않은 경우, 전체를 인쇄합니다.


3.5.12. 창 닫기

표시되어 있는 파라미터 편집 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.

파라미터가 변경된 채로 위의 처리를 하면 아래와 같은 확인 메시지가 표시됩니다.

창을 닫는 경우에는 [확인]을 클릭하고, 중지하는 경우에는 [취소]를 클릭하십시오.

※파라미터를 [저장] 또는 [다른 이름으로 저장]한 경우 확인 메시지는 표시되지 않습니다


3.6. 간접 데이터 편집 창

간접 데이터를 편집합니다.


3.6.1. 창의 표시

메뉴 바에서

[파일(F)]→[신규 작성(N)]→[간접 데이터(I)]

또는

[파일(F)]→[파일 열기(O)]→[간접 데이터(I)]

메인 툴 바의

[데이터 편집] 탭→[간접 데이터]→[간접 데이터 메뉴 선택]

을 선택하면 본 창이 표시됩니다.


3.6.2. 간접 데이터의 편집

① 간접 데이터의 직접 편집

1) 마우스 또는 키보드를 사용하여 간접 데이터를 선택합니다.

2) 선택한 간접 데이터를 마우스로 클릭, [Enter], [F2] 키를 눌러 간접 데이터를 편집 상태로 만듭니다.

ㆍ수치를 입력하는 경우: 키보드로 직접 입력합니다.

ㆍ선택 항목의 경우: 리스트에서 항목을 선택합니다.

3) 포커스를 해제, [Enter], [Tab], [F2] 키를 눌러 간접 데이터를 확정합니다.

② 간접 데이터의 복사 및 붙여넣기

간접 데이터 편집 창 간의 복사/붙여넣기
여러 개의 간접 데이터 편집 창이 표시되어 있을 때 특정 범위의 간접 데이터를 다른 창에 복사하는 데 편리한 기능입니다.

1) 간접 데이터의 복사

복사 범위를 키보드의 [Shift]+[↑], [Shift]+[↓]를 눌러 지정하거나 또는 마우스로 드래그한 후 마우스 오른쪽으로 클릭 [복사]를 선택하거나 또는 Ctrl+C로 복사합니다.

2) 간접 데이터의 붙여넣기

간접 데이터를 붙여 넣을 위치를 커서로 지정하여, 마우스 오른쪽 클릭으로 [붙여넣기]를 선택하거나 또는 Ctrl+V로 붙여 넣습니다.


3.6.3. 간접 데이터 쓰기

1) 간접 데이터 편집 창의 간접 데이터를 장치에 쓰는 경우에는 [장치에 쓰기] 버튼을 클릭합니다.

2) 쓰기 여부 확인 메시지가 표시되므로 쓰는 경우에는 [확인] 버튼을, 중지하는 경우에는 [취소] 버튼을 클릭합니다.

3) 바 표시가 오른쪽 끝까지 도달하면 쓰기 종료입니다.

4) 쓸 때 타이틀에 표시되어 있는 파일 이름을 장치에 씁니다.

주기

간접 데이터 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위와 장치에 설정되어 있는 위치 단위, 위치 소수 단위가 일치하지 않는 경우에는 간접 데이터를 송신할 수 없습니다.

간접 데이터 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위 또는 장치에 설정되어 있는 위치 단위, 위치 소수 단위를 다시 설정하십시오.

간접 데이터 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위는 단위 변환 버튼을 눌러서 합니다.

간접 데이터 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위를 장치에 설정되어 있는 단위로 변환합니다.


3.6.4. 간접 데이터의 읽기

1) 장치 내의 파라미터를 읽는 경우에는 [장치로부터 읽기] 버튼을 클릭합니다.

2) 읽기 여부 확인 메시지가 표시되므로 읽는 경우에는 [확인] 버튼을, 중지하는 경우에는 [취소] 버튼을 클릭합니다.

3) 바 표시가 오른쪽 끝까지 도달하면 읽기 종료입니다.

4) 읽을 때 장치에 기록되어 있는 간접 데이터명을 화면에 표시합니다.

표시된 이름은 저장 시의 초기 파일 이름입니다.

주기

기능 종류가 본 소프트웨어와 장치에서 서로 다른 경우에는 간접 데이터를 송수신할 수 없습니다. 본 소프트웨어의 장치 모터 선택을 다시 설정하십시오.


3.6.5. 간접 데이터의 비교

간접 데이터 편집 창의 [비교] 버튼을 클릭하면 간접 데이터의 데이터 비교 화면이 열립니다.

비교의 종류는 [초기값과 비교], [장치 내와 비교], [파일과 비교]입니다.

비교를 실행하면 차이점의 건수, 차이점의 일람이 표시됩니다.

비교 결과: 차이점의 확인

차이점 없음

차이점 있음

비교 결과: 차이점의 일람

차이점의 일람은 왼쪽에서부터 간접 데이터 번호, 간접 데이터의 항목명, 비교 원본 설정값, 비교 대상 설정값, 비교 원본 단위, 비교 원본 코멘트의 순으로 표시됩니다.

주기

비교 대상값에 범위 밖의 값이 설정되어 있는 경우, 붉은색 글씨로 ‘(　)’로 묶어진 값이 표시됩니다.

초기값과 비교

1) 간접 데이터 초기값과 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[초기값과 비교] 버튼을 클릭합니다.

2) 비교 결과는 ‘비교 결과: 차이점의 일람’ 형식으로 표시됩니다.

※비교 원본 설정값, 비교 대상 설정값 모두 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

장치 내와 비교

1) 장치 내의 간접 데이터와 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[장치 내와 비교] 버튼을 클릭합니다.

2) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 장치 내에 설정되어 있는 위치 소수 단위 를 반영한 값을 표시합니다.

파일과 비교

1) 지정 파일과 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[파일과 비교] 버튼을 클릭합니다.

2) [파일 열기] 창이 표시됩니다.

3) 비교하는 파일을 선택한 후 [열기(O)] 버튼을 클릭합니다.

4) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 파일에 저장되어 있는 위치 소수 단위 를 반영한 값을 표시합니다.

비교 결과의 출력

① 파일에 출력하기

[CSV 출력] 버튼을 클릭하면 차이점을 CSV 파일에 출력할 수 있습니다.

② 인쇄

차이점이 있는 상태에서 [인쇄] 버튼을 클릭하면 차이점을 인쇄할 수 있습니다.


3.6.6. 파일 열기

① 메인 툴 바에서 열기

1) 메인 툴 바의 [파일(F)]→[열기]→[간접 데이터]를 클릭

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 간접 데이터 파일을 선택한 후 [열기] 버튼을 클릭합니다.

② 간접 데이터 편집 화면에서 열기

1) 간접 데이터 편집 창의 [열기]를 클릭

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 간접 데이터 파일을 선택한 후 [열기] 버튼을 클릭합니다.

주기

① 파일의 종류에서 선택할 수 있는 확장자는 장치에 따라 다릅니다.

※자세한 내용은 [6.1. 파일 확장자 일람]을 참조

② 본 화면에 간접 데이터 파일을 드롭하여 간접 데이터 파일을 열 수도 있습니다.

※대응하는 파일은 [6.2. 파일 드롭에 대해]를 참조


3.6.7. 파일에 저장하기

간접 데이터 편집 창의 간접 데이터를 파일에 저장하는 경우에는 같은 파일 이름으로 저장할지 새로운 파일 이름을 지정하여 저장할지 선택할 수 있습니다.

① 같은 파일 이름으로 저장하는 경우에는 메뉴 바에서

[저장] 버튼을 클릭합니다.

② 새로운 파일 이름을 지정하여 저장하는 경우에는 메뉴 바에서

[다른 이름으로 저장] 버튼을 클릭합니다.


3.6.8. 인쇄

간접 데이터 편집 창의 파라미터를 인쇄하는 경우에는 메뉴 바에서
[인쇄] 버튼을 클릭합니다.

① 간접 데이터가 선택 상태로 되어 있는 경우, 다음과 같은 메시지가 표시됩니다.

1) 인쇄 범위를 지정합니다.

① 전체 범위를 인쇄하는 경우

1) [전체를 인쇄]를 선택합니다.

2) [확인] 버튼을 클릭합니다.

② 인쇄 범위를 지정하여 인쇄하는 경우

1) [선택 범위를 인쇄]를 선택합니다.

2) [확인] 버튼을 클릭합니다.

2) 인쇄 창이 표시됩니다.

① 인쇄하는 경우, 각 항목을 선택한 후 [인쇄] 버튼을 클릭합니다.

② 인쇄를 중단하는 경우에는 [취소] 버튼을 클릭합니다.

② 간접 데이터가 선택 상태로 되어 있지 않은 경우, 전체를 인쇄합니다.


3.6.9. 창 닫기

표시되어 있는 간접 데이터 편집 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.

간접 데이터가 변경된 채로 위의 처리를 하면 아래와 같은 확인 메시지가 표시됩니다.

창을 닫는 경우에는 [확인]을 클릭하고, 중지하는 경우에는 [취소]를 클릭하십시오.

※간접 데이터를 [저장] 또는 [다른 이름으로 저장]한 경우 확인 메시지는 표시되지 않습니다


3.7. 프로그램 편집 창

VPH 장치용 프로그램을 편집합니다.


3.7.1. 창의 표시

메뉴 바에서

[파일(F)]→[신규 작성(N)]→[프로그램(R)]

또는

[파일(F)]→[파일 열기(O)]→[프로그램(R)]

메인 툴 바의

[데이터 편집] 탭→[프로그램]→[프로그램 메뉴 선택]

을 선택하면 본 창이 표시됩니다.


3.7.2. 프로그램의 편집

① 프로그램의 직접 편집

1) 편집 항목의 지정은 목적하는 프로그램 스텝을 마우스로 클릭합니다.

2) 프로그램을 입력하는 경우에는 다음 순서로 데이터를 입력합니다.

ㆍ편집 항목의 CMD를 클릭하면 ▼가 표시됩니다.

ㆍ▼를 클릭하면 항목을 선택할 수 있게 됩니다.

ㆍCMD를 선택한 후에 편집 부분의 콤보 상자를 선택하거나 키보드로 데이터를 직접 입력합니다.

또한 CMD의 내용에 따라 후속하는 입력 항목이 다릅니다. (화면의 지시를 따르십시오.)

② 프로그램의 복사 및 붙여넣기

프로그램 편집 창 간의 복사/붙여넣기
여러 개의 프로그램 편집 창이 표시되어 있을 때 특정 범위의 프로그램 데이터를 다른 창에 복사하는 데 편리한 기능입니다.

1) 프로그램 데이터의 복사

프로그램 데이터를 복사하는 경우에는 복사 범위를 키보드의 [Shift]+[↑], [Shift]+[↓]를 눌러 지정하거나 또는 마우스로 드래그한 후에 마우스 오른쪽 클릭으로 [복사]를 선택하거나 또는 Ctrl+C로 복사합니다.

2) 프로그램 데이터의 붙여넣기

프로그램 데이터를 붙여 넣을 위치를 커서로 지정한 후 마우스 오른쪽 클릭으로 [붙여넣기]를 선택하거나 또는 Ctrl+V로 붙여 넣습니다.

프로그램 스텝이 다음과 같이 붙여 넣어집니다.

③ 행 삽입

1) 커서를 임의의 행에 설정합니다.

2) [행 삽입] 버튼을 클릭하면 다음과 같이 새로운 행이 삽입되어 [NOP] 명령이 등록됩니다.

마우스를 오른쪽 클릭하면 표시되는 콘텍스트 메뉴 내에서도 마찬가지로 행 삽입을 할 수 있습니다.

마지막 행이 [NOP] 명령 이외의 경우, 다음과 같은 메시지가 표시되어 행 삽입을 할 수 없습니다.

행 삽입을 하는 경우에는 마지막 행을 [NOP] 이외의 커맨드로 설정하십시오.

④ 행 삭제

1) 커서를 임의의 행에 설정합니다.

2) [행 삭제] 버튼을 클릭하면 다음과 같이 지정된 행이 삭제되어 후속 스텝이 앞으로 당겨집니다.

행 삭제를 하면 마지막 행에 [NOP] 명령이 추가됩니다.

마우스를 오른쪽 클릭하면 표시되는 콘텍스트 메뉴 내에서도 마찬가지로 행 삭제를 할 수 있습니다.


3.7.3. 프로그램의 쓰기

1) 프로그램 편집 창의 프로그램을 장치에 쓰는 경우에는 [장치에 쓰기] 버튼을 클릭합니다.

2) 쓰기 여부 확인 메시지가 표시되므로 쓰는 경우에는 [확인] 버튼을, 중지하는 경우에는 [취소] 버튼을 클릭합니다. [확인] 버튼을 클릭하면 쓰기 처리의 실행 경과가 바에 표시됩니다.

3) 바 표시가 오른쪽 끝까지 도달하면 쓰기 종료입니다.

4) 쓸 때 타이틀에 표시되어 있는 파일 이름을 장치에 씁니다.

주기

프로그램 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위와 장치에 설정되어 있는 위치 단위, 위치 소수 단위가 일치하지 않는 경우에는 프로그램을 송신할 수 없습니다.

프로그램 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위 또는 장치에 설정되어 있는 위치 단위, 위치 소수 단위를 다시 설정하십시오.

프로그램 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위는 단위 변환 버튼을 눌러서 합니다.

프로그램 편집 화면에 설정되어 있는 위치 단위, 위치 소수 단위를 장치에 설정되어 있는 단위로 변환합니다.

주의

프로그램 운전 중에 프로그램을 쓰면 운전 도중에 새 프로그램 데이터에 의한 운전으로 전환되므로 주의하십시오.

통상적으로는 운전 중인 프로그램을 종료한 후에 쓰십시오.


3.7.4. 프로그램의 읽기

1) 장치 내의 프로그램을 읽는 경우에는 [장치로부터 읽기] 버튼을 클릭합니다.

2) 읽기 여부 확인 메시지가 표시되므로 읽는 경우에는 [확인] 버튼을, 중지하는 경우에는 [취소] 버튼을 클릭합니다. [확인] 버튼을 클릭하면 읽기 처리의 실행 경과가 바에 표시됩니다.

3) 바 표시가 오른쪽 끝까지 도달하면 읽기 종료입니다.

  4) 읽을 때 장치에 기록되어 있는 프로그램명을 화면에 표시합니다.

표시된 이름은 저장 시의 초기 파일 이름입니다.


3.7.5. 프로그램 데이터의 비교

프로그램 편집 화면의 [비교] 버튼을 클릭하면 프로그램의 데이터 비교 화면이 열립니다.

비교의 종류는 [초기값과 비교], [장치 내와 비교], [파일과 비교]입니다.

비교를 실행하면 차이점의 건수, 차이점의 일람이 표시됩니다.

비교 결과: 차이점의 확인

차이점 없음

차이점 있음

비교 결과: 차이의 일람

차이의 일람은 왼쪽에서부터 프로그램의 어드레스, 비교 원본 커맨드, 비교 원본 설정값 0~7, 비교 원본 코멘트, 비교 대상 커맨드, 비교 대상 설정값 0~7, 비교 대상 코멘트의 순으로 표시됩니다.

주기

비교 대상값에 범위 밖의 값이 설정되어 있는 경우, 붉은색 글씨로 ‘(　)’로 묶어진 값이 표시됩니다.

초기값과 비교

1) 프로그램 초기값과 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[초기값과 비교] 버튼을 클릭합니다.

2) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※P161: 위치 소수 단위 선택의 값을 참조하는 설정값이 비교 대상인 경우

비교 원본 설정값, 비교 대상 설정값 모두 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

장치 내와 비교

1) 장치 내의 프로그램과 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[장치 내와 비교] 버튼을 클릭합니다.

2) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 장치 내에 설정되어 있는 위치 소수 단위 를 반영한 값을 표시합니다.

파일과 비교

1) 지정 파일과 현재 편집 중인 내용을 비교하는 경우에는

[비교]→[파일과 비교] 버튼을 클릭합니다.

2) [파일 열기] 창이 표시됩니다.

3) 비교하는 파일을 선택한 후 [열기(O)] 버튼을 클릭합니다.

4) 비교 결과는 ‘비교 결과: 차이의 일람’ 형식으로 표시됩니다.

※P161: 위치 소수 단위 선택의 값을 참조하는 프로그램이 비교 대상인 경우

비교 원본 설정값은 비교를 실행했을 때 설정되어 있는 위치 소수 단위를 반영한 값을 표시합니다.

비교 대상 설정값은 파일에 저장되어 있는 위치 소수 단위 를 반영한 값을 표시합니다.

비교 결과의 출력

① 파일에 출력하기

[CSV 출력] 버튼을 클릭하면 차이점을 CSV 파일에 출력할 수 있습니다.

② 인쇄

차이점이 있는 상태에서 [인쇄] 버튼을 클릭하면 차이점을 인쇄할 수 있습니다.


3.7.6. 파일 열기

저장된 프로그램을 여는 경우

① 메인 툴 바에서 열기

1) 메인 툴 바의 [파일(F)]→[열기]→[프로그램]을 클릭

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 프로그램 파일을 선택한 후 [열기] 버튼을 클릭합니다.

② 프로그램 편집 화면에서 열기

1) 프로그램 편집 창의 [열기]를 클릭

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 프로그램 파일을 선택한 후 [열기] 버튼을 클릭합니다.

주기

파일의 종류에서 선택할 수 있는 확장자는 장치에 따라 다릅니다.

※자세한 내용은 [6.1. 파일 확장자 일람]을 참조

본 화면에 프로그램 데이터 파일을 드롭하여 프로그램 데이터 파일을 열 수도 있습니다.

※대응하는 파일은 [6.2. 파일 드롭에 대해]를 참조


3.7.7. 파일에 저장하기

프로그램 편집 창의 프로그램을 파일에 저장하는 경우에는 같은 파일 이름으로 저장할지 새로운 파일 이름을 지정하여 저장할지 선택할 수 있습니다.

① 같은 파일 이름으로 저장하는 경우에는 메뉴 바에서

[저장] 버튼을 클릭합니다.

② 새로운 파일 이름을 지정하여 저장하는 경우에는 메뉴 바에서

[다른 이름으로 저장] 버튼을 클릭합니다.


3.7.8. 인쇄

프로그램 편집 창의 프로그램을 인쇄하는 경우에는 메뉴 바에서

[인쇄] 버튼을 클릭합니다.

① 프로그램이 선택 상태로 되어 있는 경우, 다음과 같은 메시지가 표시됩니다.

1) 인쇄 범위를 지정합니다.

① 전체 범위를 인쇄하는 경우

1) [전체를 인쇄]를 선택합니다.

2) [확인] 버튼을 클릭합니다.

② 인쇄 범위를 지정하여 인쇄하는 경우

1) [선택 범위를 인쇄]를 선택합니다.

2) [확인] 버튼을 클릭합니다.

2) 인쇄 창이 표시됩니다.

① 인쇄를 하는 경우, 각 항목을 설정하여 [인쇄] 버튼을 클릭합니다.

② 인쇄를 중단하는 경우에는 [취소] 버튼을 클릭합니다.

② 프로그램이 선택되어 있지 않은 경우, 전체를 인쇄합니다.


3.7.9. 창 닫기

표시되어 있는 프로그램 편집 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.

프로그램이 변경된 채로 위의 처리를 하면 아래와 같은 확인 메시지가 표시됩니다.

창을 닫는 경우에는 [확인]을 클릭하고, 중지하는 경우에는 [취소]를 클릭하십시오.

※프로그램을 [저장] 또는 [다른 이름으로 저장]한 경우 확인 메시지는 표시되지 않습니다


3.8. 일괄 데이터 송수신

파라미터, 간접 데이터, 프로그램 데이터를 일괄적으로 장치에 송신 또는 장치로부터 수신하여 일괄 데이터로 저장합니다.

① 송신하는 경우에는 메뉴 바에서

[파일(F)]→[일괄 데이터]→[송신]

을 선택합니다.

② 수신하는 경우에는 메뉴 바에서

[파일(F)]→[일괄 데이터]→[수신]

을 선택합니다.

송수신 파일 확장자는 [*.c*adb]입니다.

자세한 내용은 [6.1. 파일 확장자 일람]을 참조.

주기

①파라미터, 프로그램, 간접 데이터 송수신 중에는 일괄 데이터를 송수신할 수 없습니다.

②메인 툴 바의 상태 표시, 분석 기능, 조정 기능, 리모트 조작 탭의 창이 표시되어 있는 경우에는 일괄 데이터를 송수신할 수 없습니다.

③모터가 미설정인 경우, 일괄 데이터를 수신할 수 없습니다.

장치 모터 선택 화면에서 모터를 재설정한 후 일괄 데이터를 다시 수신하십시오.

④Version 2.2.0부터 FB 필터 설정 방법 선택의 값이 송수신되게 되었습니다.

따라서 수신한 데이터를 저장한 경우, 저장한 파일에는 FB 필터 설정 방법 선택의 값이 유지되어 일괄 데이터 송신 시에 장치에 설정됩니다.


3.9. 오실로스코프 창

선택한 장치 데이터를 실시간으로 그래프 표시합니다.


3.9.1. 창의 표시

오실로그래프를 측정하는 경우에는 아래의 순서로 오실로스코프 창을 표시합니다.

메인 툴 바의

[분석 기능] 탭→[오실로스코프]

를 선택하면 본 창이 표시됩니다.


3.9.2. 장치의 상태 표시

다음과 같은 장치 상태를 항상 표시합니다.

No | 항목
C012 | 모터 서멀 트립률
C014 | 장치 서멀 트립률
C018 | 회생 과부하율

색으로 상태를 나타냅니다.

색 | 상태
초록 | 정상
노랑 | 주의
빨강 | 위험


3.9.3. 오실로 설정

오실로스코프 창의 [오실로 설정]을 클릭하면 오실로 설정 창이 표시됩니다.

오실로 설정 창에서는 표시 대상 채널의 선택ㆍ표시 대상의 설정ㆍ측정 설정ㆍ트리거 설정을 할 수 있습니다.

① 표시 대상 채널의 선택

[CH 유효 선택(CH1~4)] 확인란에 표시하고자 하는 채널을 체크합니다.

주기

CH의 체크를 해제하고 측정한 데이터는 모두 0이 설정됩니다.

② 제어 정보(속도 지령, 토크 지령, 위치 편차 펄스 등) 표시 시의 데이터 설정

1) [CH1 설정]~[CH3 설정] 프레임 내의 [표시 항목] 콤보 상자에서 표시하고자 하는 제어 정보(속도 지령, 토크 지령, 위치 편차 펄스 등) 항목을 선택합니다.

2) [표시 최댓값]의 데이터 입력 영역에 그래프 표시할 때의 Y축 메모리 최댓값을 설정합니다.

3) [CH1 설정]~[CH3 설정] 프레임 내의 [표시 항목] 콤보 상자에서 [속도 피드백], [속도 지령], [아날로그 속도 지령 입력], [위치 지령 목표 속도]가 선택되어 있는 경우, 속도 단위의 전환이 가능합니다. [단위] 콤보 상자에서　%⇔속도⇔rpm　으로 전환합니다.

4) [CH1 설정]~[CH3 설정] 프레임 내의 [표시 항목] 콤보 상자에서 [실토크 지령], [아날로그 토크 지령 입력]이 선택되어 있는 경우, 토크 단위의 전환이 가능합니다. [단위] 콤보 상자에서　%⇔Nm(N)　으로 전환합니다.

③ 롱/워드 디바이스 모니터 시의 데이터 설정

1) [CH1 선택]~[CH3 선택] 프레임 내의 [표시 항목] 콤보 상자에서 롱 디바이스 모니터 또는 워드 디바이스 모니터를 선택합니다.

2) [장치 번호] 콤보 상자에서 대상 장치를 선택합니다.

3) 대상 장치는 D, R로 합니다.

4) [장치 번호]의 데이터 입력 영역에 장치 번호를 설정합니다.

5) [표시 최댓값]의 데이터 입력 영역에 그래프 표시할 때의 Y축 메모리 최댓값을 설정합니다.

6) [장치 이름]의 데이터 입력 영역에 자유롭게 장치 이름을 설정할 수 있습니다.

  설정한 장치 이름은 그래프의 범례, 인쇄 화면에 표시됩니다.

④ 상태 표시 시의 데이터 설정

1) [CH1 선택]~[CH3 선택] 프레임 내의 [표시 항목] 콤보 상자에서 표시하고자 하는 상태의 종류를 선택합니다.

2) [상태 항목] 콤보 상자에서 표시하고자 하는 신호를 선택합니다.

⑤ 입출력 신호 상태 표시 시의 데이터 설정

1) [CH1 선택]~[CH4 선택] 프레임 내의 [표시 항목] 콤보 상자에서 표시하고자 하는 신호의 종류를 선택합니다.

2) [신호 항목] 콤보 상자에서 표시하고자 하는 신호를 선택합니다.

⑥ 데이터 분해능의 설정

1) [데이터 분해능] 콤보 상자에서 시간축(X축)의 1데이터당 샘플링 시간을 선택합니다.

2) 데이터 분해능(msec)은 장치와 파라미터 설정에 따라 다음과 같은 범위에서 변동합니다.

최소 측정 간격 | 0.2 | 0.4 | 0.8 | 1.6 | 3.2
최대 측정 간격 | 0.4 | 0.8 | 1.6 | 3.2 | 6.4

⑦ 측정 시간의 설정

1) [측정 시간] 콤보 상자에서 오실로스코프의 측정 시간을 선택합니다.

2) 대상 시간은 1, 2, 5, 10, 20, 50, 100초 및 Infinity로 합니다.

⑧ 로깅의 설정

1) [로깅 유효]에 체크를 넣습니다.

2) 파일을 저장하는 대화 상자가 표시되므로 로깅 파일의 저장 위치와 파일 이름을 설정합니다.

3) [로깅 유효]가 ON인 경우, [로그 파일 이름란], [로그 파일 설정] 버튼으로 로그 파일을 변경할 수 있습니다.

4) 로그 파일의 파일 확장자는 [*.cxlog]입니다. 파일은 60초마다 파일이 생성되고, 파일 이름에 일련번호가 매겨집니다.

⑨ 트리거 설정

[측정 시간] 콤보 상자에서 Inifinity 이외를 선택한 경우, 트리거 설정이 가능합니다.

1) 트리거 설정을 유효로 하려면 [트리거 유효]에 체크를 넣습니다.

2) 연속적으로 트리거를 거는 경우에는 [노멀 트리거]를 선택합니다.

   한 번만 트리거를 거는 경우에는 [싱글 트리거]를 선택합니다.

   [노멀 트리거]를 선택하면 트리거가 걸릴 때마다 측정 시간분 데이터를 취득하여 그래프를 재표시합니다.

   단, 트리거 발생 후부터 측정 시간 내의 트리거는 무효가 됩니다.

3) 트리거 대상으로 하는 채널을 [트리거 대상]에서 선택합니다.

4) 입출력 신호 이외의 채널을 트리거 대상으로 한 경우, [트리거 역치]에 트리거가 되는 역치를 설정합니다.

5) 트리거가 발생한 후의 지연 시간(트리거 타이밍 이후의 파형을 표시하는 길이)을 [트리거 지연 시간]에서 설정합니다.

[트리거 지연 시간]을 설정했을 때의 측정 데이터 표시 범위는 다음과 같습니다.

예 1) [측정 시간]을 10sec, [트리거 지연 시간]을 2sec로 했을 때

트리거 타이밍에서 2sec 후의 측정 시간분 측정 데이터(음영 부분)가 표시됩니다.

예 2) [측정 시간]을 10sec, [트리거 지연 시간]을 -2sec로 했을 때

트리거 타이밍에서 2sec 전의 측정 시간분 측정 데이터(음영 부분)가 표시됩니다.

6) [ON] 또는 [OFF]의 선택을 통해 트리거 검출 에지(edge)를 설정합니다.

⑩ 오실로 설정의 설정

[설정] 버튼을 클릭하면 설정한 각 정보를 등록한 후 오실로스코프 창으로 돌아갑니다.

오실로 설정에서 설정한 내용은 오실로스코프 창 하단 스테이터스 바(상태 표시줄)에 표시합니다.

주기

연결된 장치에서 사용할 수 없는 표시 항목이 설정되어 있는 경우, 다음과 같은 메시지가 표시됩니다.

표시 항목을 변경하십시오.

장치로부터 수신한 데이터는 16bit 데이터이므로 표시 최댓값에 32767을 초과하는 값을 설정한 경우, 표시 데이터가 계단 모양으로 표시되는 경우가 있습니다.

예 1)

표시 항목: 위치 편차

표시 최댓값: 16,000,000[pulse]

로 한 경우의 1 데이터 분해능은

16,000,000/32767≒488[pulse]

가 되고, 장치가 1,000,000[pulse]의 위치 편차를 가지고 있었을 경우, 1,000,031[pulse]로 표시합니다.

예 2)

표시 항목: 속도 피드백

표시 최댓값: 1,800.000[deg/sec]

로 한 경우의 1 데이터 분해능은

1,800,000/32767≒55[pulse/sec]

가 되고, 장치가 360.000[deg/sec]로 동작하고 있었을 경우, 359.978[deg/sec]로 표시합니다.


3.9.4. 표시 항목

오실로 설정에서 설정하는 표시 항목은 다음과 같습니다.

표시 항목명 | 설명
속도 피드백 | 모터 실동작 속도를 표시합니다.
실토크 지령 | 실토크 지령값을 표시합니다.
위치 편차 | 위치 편차 펄스를 표시합니다.
속도 지령 | 속도 지령값을 표시합니다. 속도 지령 모드, 펄스열 지령 모드, 내장 지령 모드, 네트워크로부터의 속도 지령과 위치 지령에서 유효합니다. S자나 편차를 포함하는 속도계 마지막 지령값이 됩니다.
아날로그 속도 지령 | 아날로그 속도 지령값을 표시합니다. VPH-HA 장치만 항목이 표시됩니다. 아날로그 옵션이 없는 장치는 값이 0으로 고정이 됩니다.
아날로그 토크 지령 | 아날로그 토크 지령값을 표시합니다. 모터 정격 토크 시에 100%로 됩니다. VPH-HA 장치만 항목이 표시됩니다. 아날로그 옵션이 없는 장치는 값이 0으로 고정이 됩니다.
위치 지령 목표 속도 | 위치 지령에서의 목표 속도를 표시합니다. 펄스열 지령 모드, 내장 지령 모드, 네트워크로부터의 위치 지령에서 유효합니다. S자나 편차를 포함하지 않는 지령값이 됩니다.
모터 실효값 | 모터 실효값(부하율)을 표시합니다.
모터 서멀 트립률 | 모터 서멀 트립률을 표시합니다. 100%가 되면 ‘모터 과부하 이상’을 검출합니다.
펄스열 지령 속도 | 펄스열 지령 속도를 표시합니다. 펄스열 지령 모드, 네트워크로부터의 위치 지령에서 유효합니다. 1ms 간격의 미가공값(raw value)을 표시합니다. S자나 편차를 포함하지 않는 지령값이 됩니다. ※VPH 장치의 버전에 따라 측정을 할 수 없는 경우가 있습니다
롱 디바이스 모니터 | 지정한 디바이스값을 롱 디바이스로 표시합니다.
워드 디바이스 모니터 | 지정한 디바이스값을 워드 디바이스로 표시합니다.
상태 표시 선택 | 선택한 상태 표시 항목을 표시합니다.
입력 신호 선택 | 선택한 입력 신호 상태를 표시합니다.
출력 신호 선택 | 선택한 출력 신호 상태를 표시합니다.


3.9.5. 표시 스케일의 설정

① 시간(X)축의 설정

1) 1화면에 표시할 표시 시간을 [시간 스케일] 콤보 상자에서 선택합니다.

2) 시간 스케일은 0.05, 0.1, 0.2, 0.5, 1, 2, 5, 10, 20, 50초로 합니다.

② 표시 데이터 범위(Y)축의 설정

1) 수치 표시 항목의 경우는 1화면에 표시할 수치 데이터 범위를 [스케일] 콤보 상자에서 선택합니다. 100%일 때의 수치는 오실로스코프 설정 창에서 설정한 표시 최댓값입니다.

2) 신호 표시 항목의 경우는 신호 OFF 시의 표시 위치를 [오프셋] 콤보 상자에서 선택합니다. 오프셋 0%의 표시 위치는 Y축의 중앙을 의미합니다.

3) 스케일은 0.1, 0.5, 1, 5, 10, 25, 50, 100%로 합니다.

4) 오프셋은 -80, -60, -40, -20, 0, 20, 40, 60, 80%로 합니다.


3.9.6. 실시간 표시의 시작/정지

1) 오실로스코프의 실시간 표시를 시작하는 경우에는 [시작] 버튼을 클릭합니다. 표시 중에는 [시작] 버튼이 [정지] 버튼으로 됩니다.

2) [정지] 버튼을 클릭하면 표시를 정지합니다.

3) 표시를 정지하면 다음과 같이 측정 파형이 표시됩니다.


3.9.7. 그래프 설정

오실로스코프 창의 [스케일], [오프셋] 설정 영역 내에서 오른쪽 클릭하면 그래프 설정 창이 표시됩니다.

그래프 설정 창에서는 표시 대상 채널의 색 선택ㆍ표시 대상 묘화순ㆍ커서색 설정ㆍ트리거 역치 선색 설정을 할 수 있습니다.

① 측정 그래프 선색 설정

각 채널의 측정 그래프 선색은 [선색 CH1]~[선색 CH4] 콤보 상자에서 선택한 색으로 각각 표시됩니다.

② 묘화순 설정

채널 선택의 리스트에서 묘화순을 변경하고자 하는 채널을 선택한 후 [앞면으로 이동], [뒷면으로 이동]으로 순서를 변경합니다.

③ 커서색 설정

[커서 A색] 콤보 상자, [커서 B색] 콤보 상자에서 선택한 색으로 각각 표시됩니다.

④ 트리거 역치 선색 설정

[Trigger] 콤보 상자에서 선택한 색으로 표시됩니다.


3.9.8. 커서의 설정

① 커서의 설정

1) 버튼 [A] 또는 [B]를 클릭합니다. 선택한 커서(A/B)에 대응하는 정보 표시란의 표시 문자가 굵게 표시됩니다. [A] 또는 [B]는 배타적으로 선택됩니다.

2) 커서 A가 선택되어 있는 상태에서 다시 버튼 [A]를 클릭하면 커서 A의 선택이 해제됩니다. 커서 B에 대해서도 마찬가지입니다.

② 채널의 설정

1) 버튼 [CH1]~[CH4]를 선택합니다. 선택한 채널에 커서선이 매핑됩니다.

2) 현재 선택되어 있는 채널은 버튼색이 변경됩니다.

③ 커서 정보의 표시

1) 현재 커서 A 또는 B가 표시되어 있는 위치의 시간 및 CH1~CH4의 정보가 커서에 대응하는 정보 표시란에 표시됩니다.

2) [차이]란에는 [A]점과 [B]점 값의 차이를 표시합니다.

3) [A-B Min], [A-B Max]란에는 [A]점과 [B]점 사이의 최솟값ㆍ최댓값을 표시합니다.

④ 커서의 이동

1) 화면 상의 임의의 점을 클릭하면 그 점에 십자 커서가 표시됩니다.

2) LeftButton 또는 RightButton 를 클릭하면 커서 위치의 미세 조정이 가능합니다. 마우스를 계속 누르면 커서가 자동으로 이동합니다.

3) 커서 A 및 커서 B가 표시되어 있는 상태에서 paraMoveButton 를 클릭하면 paraMoveButtonPushed 로 전환됩니다. 이 상태에서 LeftButton 또는 RightButton 를 클릭하면 커서 A 및 커서 B가 동시에 평행 이동합니다.

주기

시작 버튼 클릭 시에 연결된 장치에서 사용할 수 없는 표시 항목이 설정되어 있는 경우, 다음과 같은 메시지가 표시됩니다.

[확인] 버튼을 클릭하면 오실로 설정 화면이 표시되므로 표시 항목을 변경하십시오.


3.9.9. 부하율 계산

부하율을 표시하는 경우에는 ‘토크 지령’을 측정합니다. 커서 A, B를 지정합니다. 그리고 ‘부하율 계산’ 버튼을 클릭합니다.

주기

커서 A 또는 B가 지정되어 있지 않은 경우, 다음과 같은 메시지가 표시됩니다.

토크 데이터가 계측되지 않은 경우, 다음과 같은 메시지가 표시됩니다.

여러 채널에서 ‘토크 지령’을 측정한 경우, 가장 번호가 작은 채널의 부하율을 계산합니다.

(예: CH1~3을 모두 ‘실토크 지령’으로 한 경우, CH1 ‘실토크 지령’의 부하율을 계산)


3.9.10. 오실로스코프 표시 항목의 재설정

표시 항목을 변경하는 경우에는 [오실로 설정]을 클릭하여 채널을 설정합니다.


3.9.11. 파일 열기

본 소프트웨어의 오실로스코프 기능에서 저장한 오실로 데이터를 표시합니다.

① 메인 툴 바에서 열기

1) 메인 툴 바의 [파일(F)]→[파일 열기(O)]→[오실로 데이터(O)]를 클릭

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 오실로 데이터 파일을 선택한 후 [열기] 버튼을 클릭합니다.

3) 읽기 중에는 다음과 같은 화면이 표시됩니다.

주기

파일의 종류에서 선택할 수 있는 확장자는 장치에 따라 다릅니다.

※자세한 내용은 [6.1. 파일 확장자 일람]을 참조

본 화면에 오실로 데이터 파일을 드롭하여 오실로 데이터 파일을 열 수도 있습니다.

※대응하는 파일은 [6.2. 파일 드롭에 대해]를 참조

그래프는 저장되어 있는 시간축으로 표시됩니다.

Version 2.2.0 이후에서 저장한 파일에는 커서 위치와 스크롤 위치가 저장되어 파일을 열면 커서 위치와 스크롤 위치가 복원됩니다.

Version 2.1.0 이전의 VPH Data Editing Software에서 저장한 파일을 연 경우에는 커서 위치와 스크롤 위치는 복원되지 않습니다.

기능 제한에 대해

저장한 오실로 데이터를 표시한 경우에는 다음과 같은 기능이 무효가 됩니다.

1. 오실로 계측

2. 오실로 설정의 CH 유효 선택과 단위 변환 이외의 기능


3.9.12. 파일에 저장하기

본 창에서 표시하고 있는 오실로 데이터를 파일에 저장하는 경우에는 메뉴 바에서

① [다른 이름으로 저장] 버튼을 클릭합니다.

② A와 B의 커서가 표시되어 있는 경우, 저장 방법을 선택할 수 있습니다.

주기

저장할 수 있는 데이터는 300[sec]까지입니다.

csv 형식으로 데이터를 저장한 경우, 현재 표시되어 있는 단위계의 데이터를 출력합니다.

표시 최대값의 설정이나 계산 오차로 인해 정수 데이터가 소수점이 있는 데이터가 되는 경우가 있습니다.


3.9.13. 인쇄

표시되어 있는 오실로 데이터를 인쇄하는 경우에는 메뉴 바에서

[인쇄] 버튼을 클릭합니다.

인쇄 창이 표시되므로 각 항목을 설정한 후 [확인] 버튼을 클릭합니다.

주기

용지 크기는 [A4, A3], 인쇄 방향은 [세로, 가로]를 지정할 수 있습니다만, 실제 출력은 [A4], [세로] 형식으로 이루어집니다.


3.9.14. 창 닫기

표시되어 있는 오실로스코프 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.


3.10. 주파수 스펙트럼 창

주파수 스펙트럼을 측정하여 실시간으로 그래프로 표시합니다.


3.10.1. 측정 창의 표시

메인 툴 바의

[분석 기능] 탭→[주파수 스펙트럼 측정]을 클릭하면 본 창이 표시됩니다.


3.10.2. 측정 설정

① 측정 대상의 설정

1) [측정 대상] 콤보 상자에서 측정 대상을 선택합니다.

2) 측정 대상은 속도, 토크로 합니다.

② 주파수의 설정

1) [주파수] 콤보 상자에서 측정 주파수를 선택합니다.

2) 측정 주파수(Hz)는 장치와 파라미터 설정에 따라 다음과 같은 범위에서 변동합니다.

최대 측정 간격 | 10000 | 5000 | 3333 | 2500 | 2000
최소 측정 간격 | 2500 | 1250 | 833 | 625 | 500

주기

사용 PC의 동작 성능(OS 및 처리 시간)에 따라서는 설정한 주파수로 측정할 수 없는 경우가 있습니다. 이 경우에는 측정 주파수를 낮추십시오.

[주파수] 콤보 상자 변경 시에 연결된 장치와 주파수가 다른 경우, 다음과 같은 메시지가 표시됩니다.

[확인] 버튼을 클릭하면 그래프와 주파수가 리셋됩니다.

[취소] 버튼을 클릭하면 그래프와 주파수는 그대로 유지됩니다.


3.10.3. 화면 표시 제어의 설정

① 진폭의 설정

1) Y축의 측정 대상(속도/토크) 진폭의 표시 스케일을 [진폭] 콤보 상자에서 선택합니다.

2) 스케일은 자동, 1, 2, 3, 4, 5, 10, 20, 50%(또는 dB)로 합니다.

② 선색, 배경색, 선폭의 설정

1) 선색, 배경색, 선폭을 [선색], [배경색], [선폭] 콤보 상자에서 선택합니다.

2) 선색은 [빨강], [초록], [파랑], [주황], [시안], [마젠타]로 합니다.

3) 배경색은 [백], [흑]으로 합니다.

4) 선폭은 [가는 선], [굵은 선], [매우 굵은 선]으로 합니다.

③ 표시 대상의 설정

1) 측정 결과의 표시 방법을 [화면 전환] 콤보 상자에서 선택합니다.

2) 표시 방법은 [리니어] 및 [로그]로 합니다.

3) 리니어의 경우는 정격 속도 또는 정격 토크를 [100%]에 대응시킨 형태로 % 표시됩니다.

4) 로그의 경우는 정격 속도 또는 정격 토크를 [1]에 정규화한 형태로 데시벨 표시됩니다.

[화면 전환]을 [로그]로 한 경우, 다음과 같은 화면이 표시됩니다.


3.10.4. 주파수 스펙트럼의 측정 시작/정지

1) 주파수 스펙트럼의 측정을 시작하는 경우에는 [시작] 버튼을 클릭합니다. 측정 중에는 [시작] 버튼이 [정지] 버튼으로 됩니다.

2) [정지] 버튼을 클릭하면 측정을 정지합니다.

3) 측정이 정지되면 다음과 같이 측정 파형이 표시됩니다. 동시에 [노치 필터 하한 주파수] 이상의 주파수 영역에서 진폭이 최고가 되는 점에 커서 A가 자동 설정됩니다.


3.10.5. 커서의 설정

① 커서의 설정

1) 버튼 [A] 또는 [B]를 클릭합니다. 선택한 커서(A/B)에 대응하는 정보 표시란의 표시 문자가 굵게 표시됩니다. [A] 또는 [B]는 배타적으로 선택됩니다.

2) 커서 A가 선택되어 있는 상태에서 다시 버튼 [A]를 클릭하면 커서 A의 선택이 해제됩니다. 커서 B에 대해서도 마찬가지입니다.

3) 커서 설정 방법을 [image] 로 설정한 경우, 클릭 위치 전후의 주파수에 오렌지색 선이 표시됩니다. 이 오렌지색 선의 범위 내에서 가장 높은 주파수에 커서가 설정됩니다.

커서가 설정된 경우의 화면은 다음과 같습니다.

4) 커서 설정 방법을 [image] 로 설정한 경우, 클릭한 주파수에 커서가 설정됩니다.

커서가 설정된 경우의 화면은 다음과 같습니다.

② 커서의 이동

1) 화면 상의 임의의 점을 클릭하면 그 점에 십자 커서가 표시됩니다. 커서 A의 경우는 [초록], 커서 B의 경우는 [시안]으로 표시됩니다. (단, 커서가 서로 겹치거나 표시 파형, 축선 등과 겹치면 일시적으로 색이 바뀝니다.)

2) LeftButton 또는 RightButton 를 클릭하면 커서 위치의 미세 조정이 가능합니다. 마우스를 계속 누르면 커서가 자동으로 이동합니다.

③ 커서 정보의 표시

1) 현재 커서 A 또는 B가 표시되어 있는 위치의 주파수 및 속도 또는 토크의 정보가 커서에 대응하는 정보 표시란에 표시됩니다.

2) [차이]란에는 [A]점과 [B]점 값의 차이를 표시합니다.

커서가 설정된 경우의 화면은 다음과 같습니다.


3.10.6. 노치 필터의 설정

본 창에서의 노치 필터 설정은 앞 절의 커서 설정과 연동되어 있습니다.

① 노치 필터의 설정값 읽기

1) 본 창이 표시된 시점에서 연결되어 있는 장치 내에 설정되어 있는 노치 필터의 정보가 표시됩니다.

2) 노치 필터 프레임 내의 [수신] 버튼을 클릭하면 연결되어 있는 장치 내에 설정되어 있는 노치 필터의 정보를 읽어 표시합니다.

② 노치 필터의 산출

노치 필터 산출에는 다음 2가지 방식이 있습니다.

1) 커서 A 또는 커서 B만 설정한 경우

중심 주파수: 커서 위치의 주파수를 중심 주파수로 설정합니다.

밴드 폭 비율: 노치 필터 밴드 폭 비율에 설정된 값을 밴드 폭 비율로 설정합니다.

2) 커서 A 및 커서 B를 설정한 경우

중심 주파수: [A] 및 [B]에 표시되어 있는 주파수의 곱의 제곱근( [image] )이 중심 주파수로 설정됩니다.

밴드 폭 비율: 밴드 폭을 중심 주파수로 나누었을 때의 몫을 백분율로 변환한 값을 설정합니다.

※100%를 초과하는 경우에는 100%로 클램프합니다.

커서 A, B 설정 시의 중심 주파수, 밴드 폭 비율 설정 예

커서 | A | B | 차이
주파수[Hz] | 500 | 1000 | -500

계산식 | 예
중심 주파수 = | 707 [Hz] =
밴드 폭 = ABS(A-B) | 500 [Hz] =
밴드 폭 비율 = 밴드 폭 ÷ 중심 주파수 | 0.707107 = 500÷707.1068
밴드 폭 비율[%] = 밴드 폭 비율 × 100 | 70 [%] = 0.707107×100

③ 노치 필터의 설정

1) 커서 A, B를 설정합니다.

2) 필터링 대상 파라미터에 대응하는 [설정] 버튼을 클릭합니다.

3) 커서의 설정을 통해 산출한 결과를 중심 주파수, 밴드 폭 비율에 설정합니다.

4) 설정과 동시에 해당 설정값이 장치 내에도 쓰여집니다.

5) 깊이에 대응한 장치에서는 값을 설정한 상태에서 [설정] 버튼을 클릭하면 깊이를 설정할 수 있습니다.

주의

이때 설정된 내용이 시스템과 일치하지 않으면 모터가 심하게 진동합니다. 노치 필터를 설정한 위치에 대응하는 [클리어] 버튼을 눌러 노치 필터의 설정을 즉시 해제하십시오.

6) [노치 필터 하한 주파수]에 설정한 값 이하의 주파수 영역으로 노치 필터를 설정하려고 한 경우에는 다음과 같은 메시지가 표시됩니다.

[예]를 클릭한 경우, 설정을 강행합니다.

※본 판단은 고객님이 합니다. 고객님 장치의 안전성을 충분히 확인한 후에 판단하십시오.

[아니요]를 클릭한 경우, 설정을 중지합니다.

통상적으로는 이쪽을 선택합니다.

7) [노치 필터 하한 주파수], [노치 필터 밴드 폭 비율]은 키보드로 [수치+Enter]를 입력하여 설정할 수 있습니다.

(예 1) 커서 A를 아래 그림의 위치에 맞춰 각 중심 주파수의 [설정] 버튼을 클릭하면 아래 그림과 같이 노치 필터가 설정됩니다.

(예 2) 커서 A 및 커서 B를 아래 그림의 위치에 맞춰 각 중심 주파수의 [설정] 버튼을 클릭하면 아래 그림과 같이 노치 필터가 설정됩니다.


3.10.7. 파일 열기

메인 툴 바에서 열기

1) 메인 툴 바의 [파일(F)]→[파일 열기(O)]→[주파수 스펙트럼(S)]을 클릭합니다.

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 주파수 스펙트럼 데이터 파일을 선택한 후 [열기] 버튼을 클릭합니다.

주기

파일의 종류에서 선택할 수 있는 확장자는 장치에 따라 다릅니다.

※자세한 내용은 [6.1. 파일 확장자 일람]을 참조

본 화면에 주파수 스펙트럼 데이터 파일을 드롭하여 주파수 스펙트럼 데이터 파일을 열 수도 있습니다.

※대응하는 파일은 [6.2. 파일 드롭에 대해]를 참조

기능 제한에 대해

저장한 주파수 스펙트럼 데이터를 표시한 경우에는 다음과 같은 기능이 무효가 됩니다.

1. 주파수 스펙트럼 계측

2. 노치 필터의 설정

3. 측정 설정의 변경


3.10.8. 파일에 저장하기

본 창에서 표시하고 있는 주파수 스펙트럼 데이터를 파일에 저장하는 경우에는 메뉴 바에서

[다른 이름으로 저장] 을 선택합니다.


3.10.9. 인쇄

표시되어 있는 주파수 스펙트럼 데이터를 인쇄하는 경우에는 메뉴 바에서

[인쇄] 버튼을 클릭합니다.

인쇄 창이 표시되므로 각 항목을 설정한 후 [확인(A)] 버튼을 클릭합니다.

주기

용지 크기는 [A4, A3], 인쇄 방향은 [세로, 가로]를 지정할 수 있습니다만, 실제 출력은 [A4], [세로] 형식으로 이루어집니다.


3.10.10. 창 닫기

표시되어 있는 주파수 스펙트럼 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.


3.10.11. 가이드 메시지

주파수 스펙트럼 측정 시에 다음과 같은 메시지가 표시됩니다. 지시에 따르십시오.

오실로스코프 실행 중에는 주파수 스펙트럼의 측정은 할 수 없습니다.

[시작] 버튼을 클릭했을 때, 연결된 장치와 주파수가 다른 경우 표시됩니다.

노치 필터 하한 주파수 이하(위 화면에서는 100Hz)의 영역으로 노치 필터를 설정하려고 했을 때 표시됩니다.

본 판단은 고객님이 합니다. 고객님 장치의 안전성을 충분히 확인한 후에 판단하십시오.

노치 필터 깊이에 대응하지 않는 장치에 대해 깊이를 설정하려고 했을 때에 표시됩니다.

주파수 스펙트럼 데이터를 장치로부터 수신하고 있는 경우에 데이터 불러오기가 늦었을 때 표시됩니다.

측정 주파수와 사용 PC의 동작 성능(OS 및 처리 시간)에 의존합니다. 같은 PC를 사용하는 경우에는 측정 주파수를 낮춰 측정하십시오.


3.11. 주파수 응답 창

장치의 주파수 응답을 측정하여 표시하고, 저장한 주파수 응답 데이터를 표시합니다.


3.11.1. 측정 창의 표시

메인 툴 바의

[분석 기능] 탭→[주파수 응답]을 클릭하면 본 창이 표시됩니다.


3.11.2. 측정 설정

① 측정 게인 번호의 설정

측정 게인 번호를 선택합니다.

② 측정 주파수의 설정

1) [측정 주파수] 콤보 상자에서 측정 주파수를 선택합니다.

2) 측정 주파수(Hz)는 장치와 파라미터 설정에 따라 다음과 같은 범위에서 변동합니다.

최대 측정 간격 | 10000 | 5000 | 3333 | 2500 | 2000
최소 측정 간격 | 2500 | 1250 | 833 | 625 | 500

주기

사용 PC의 동작 성능(OS 및 처리 시간)에 따라서는 설정한 주파수로 측정할 수 없는 경우가 있습니다. 이 경우에는 측정 주파수를 낮추십시오.

[측정 주파수] 콤보 상자 변경 시에 연결된 장치와 측정 주파수가 다른 경우, 다음과 같은 메시지가 표시됩니다.

[확인] 버튼을 클릭하면 그래프와 측정 주파수가 리셋됩니다.

[취소] 버튼을 클릭하면 그래프와 측정 주파수는 그대로 유지됩니다.

③ 가진 폭(속도 지령량/오프셋량)의 설정

1) 가진 시의 가진 폭을 키보드로 직접 입력합니다.

2) [%] 부분을 오른쪽 클릭하면 입력 가능한 데이터 영역이 표시됩니다.

주의

고객님의 장치에 맞춰 안전한 범위 내에서 설정하십시오.

④ 가진 시간의 설정

가진할 시간을 키보드로 직접 입력합니다. 1Hz부터 위에서 설정한 측정 주파수까지의 범위로 설정합니다.

⑤ 허용 최대 진동량의 설정

허용 최대 진동량을 키보드로 직접 입력합니다.

주의

고객님의 장치에 맞춰 안전한 범위 내에서 설정하십시오.

특히 τ 리니어 모터의 경우는 유효 스트로크를 오버하지 않도록 주의하십시오.

⑥ 계측 횟수의 설정

1Hz부터 위에서 설정한 측정 주파수까지의 가진을 1회로 하여 총 계측 횟수를 키보드로 직접 입력합니다.


3.11.3. 표시 설정

① 진폭의 설정

1) Y축의 진폭 표시 스케일을 [진폭] 콤보 상자에서 선택합니다.

2) 스케일은 자동, 1, 2, 3, 4, 5, 10, 20, 50dB로 합니다.

3) 측정 직후에는 [자동]이 설정되어 화면 전체에 파형이 표시될 수 있도록 하고 있습니다.

② 위상 설정

1) Y축의 위상 표시 스케일을 [위상] 콤보 상자에서 선택합니다.

2) 스케일은 자동, 15, 30, 45, 60, 75, 90deg로 합니다.

3) 측정 직후에는 [자동]이 설정되어 화면 전체에 파형이 표시될 수 있도록 하고 있습니다.

③ 선색, 배경색, 선폭의 설정

1) 선색, 배경색, 선폭을 [선색], [배경색], [선폭] 콤보 상자에서 선택합니다.

2) 선색은 [빨강], [초록], [파랑], [주황], [시안], [마젠타]로 합니다.

3) 배경색은 [백], [흑]으로 합니다.

4) 선폭은 [가는 선], [굵은 선], [매우 굵은 선]으로 합니다.

④ 표시 대상의 설정

1) 측정 결과의 표시 방법을 [화면 전환] 콤보 상자에서 선택합니다.

2) 표시 방법은 [진폭 위상] 및 [진폭]으로 합니다.

3) 진폭 위상의 경우는 표시 영역 상반부에 진폭을, 하반부에 위상을 표시합니다.

4) 진폭의 경우는 진폭의 화면이 표시 영역 전체에 표시됩니다.


3.11.4. 주파수 응답의 측정 시작/정지

1) 주파수 응답의 측정을 시작하는 경우에는 [시작] 버튼을 클릭합니다. 측정 중에는 [시작] 버튼이 [정지] 버튼으로 됩니다.

→

2) 다음과 같은 화면이 표시됩니다.

3) 설정된 계측 횟수분의 측정이 진행되어 종료되면 자동으로 측정을 완료하고 [정지] 버튼이 [시작] 버튼으로 돌아갑니다.

4) 측정이 완료됨과 동시에 [노치 필터 하한 주파수] 이상의 주파수 영역에서 이전 포인트와 현재 포인트에서의 진폭 변화량이 최고가 되는 점에 커서 A가 자동 설정됩니다.

5) 측정 중에 긴급히 동작을 정지시키고자 하는 경우에는 다시 [정지] 버튼을 클릭합니다. 측정이 긴급 정지됩니다.

6) 측정 완료 시에는 다음과 같은 화면이 됩니다.


3.11.5. 커서의 설정

① 커서의 설정

1) 버튼 [A] 또는 [B]를 클릭합니다. 선택한 커서(A/B)에 대응하는 정보 표시란의 표시 문자가 붉은색이 됩니다. [A] 또는 [B]는 배타적으로 선택됩니다.

2) 커서 A가 선택되어 있는 상태에서 다시 버튼 [A]를 클릭하면 커서 A의 선택이 해제됩니다. 커서 B에 대해서도 마찬가지입니다.

3) 커서 설정 방법을 [image] 로 설정한 경우, 클릭 위치 전후의 주파수에 오렌지색 선이 표시됩니다. 이 오렌지색 선의 범위 내에서 가장 높은 주파수에 커서가 설정됩니다.

커서가 설정된 경우의 화면은 다음과 같습니다.

4) 커서 설정 방법을 [image] 로 설정한 경우, 클릭한 주파수에 커서가 설정됩니다.

커서가 설정된 경우의 화면은 다음과 같습니다.

② 커서의 이동

1) 화면 상의 임의의 점을 클릭하면 그 점에 십자 커서가 표시됩니다. 커서 A의 경우는 [초록], 커서 B의 경우는 [시안]으로 표시됩니다. (단, 커서가 겹치거나 표시 파형, 축선 등과 겹치면 일시적으로 색이 바뀝니다.)

2) LeftButton 또는 RightButton 를 클릭하면 커서 위치의 미세 조정이 가능합니다. 마우스를 계속 누르면 커서가 자동으로 이동합니다.

③ 커서 정보의 표시

1) 현재 커서 A 또는 B가 표시되어 있는 위치의 주파수 및 진폭 또는 위상의 정보가 커서에 대응하는 정보 표시란에 표시됩니다.

2) [차이]란에는 [A]점과 [B]점 값의 차이를 표시합니다.

커서가 설정된 경우의 화면은 다음과 같습니다.


3.11.6. 노치 필터의 설정

본 창에서의 노치 필터 설정은 앞 절의 커서 설정과 연동되어 있습니다.

① 노치 필터의 설정값 읽기

1) 본 창이 표시된 시점에서 연결되어 있는 장치 내에 설정되어 있는 노치 필터의 정보가 표시됩니다.

2) 노치 필터 프레임 내의 [수신] 버튼을 클릭하면 연결되어 있는 장치 내에 설정되어 있는 노치 필터의 정보를 읽어 표시합니다.

② 노치 필터의 산출

노치 필터 산출에는 다음 2가지 방식이 있습니다.

① 커서 A 또는 커서 B만 설정한 경우

중심 주파수: 커서 위치의 주파수를 중심 주파수로 설정합니다.

밴드 폭 비율: 노치 필터 밴드 폭 비율에 설정된 값을 밴드 폭 비율로 설정합니다.

② 커서 A 및 커서 B를 설정한 경우

중심 주파수: [A] 및 [B]에 표시되어 있는 주파수의 곱의 제곱근( [image] )이 중심 주파수로 설정됩니다.

밴드 폭 비율: 밴드 폭을 중심 주파수로 나누었을 때의 몫을 백분율로 변환한 값을 설정합니다.

※100%를 초과하는 경우에는 100%로 클램프합니다.

커서 A, B 설정 시의 중심 주파수, 밴드 폭 비율 설정 예

커서 | A | B | 차이
주파수[Hz] | 500 | 1000 | -500

계산식 | 예
중심 주파수 = | 707 [Hz] =
밴드 폭 = ABS(A-B) | 500[Hz] =
밴드 폭 비율 = 밴드 폭 ÷ 중심 주파수 | 0.707107 = 500÷707.1068
밴드 폭 비율[%] = 밴드 폭 비율 × 100 | 70 [%] = 0.707107×100

③ 노치 필터의 설정

1) 커서 A, B를 설정합니다.

2) 필터링 대상 파라미터에 대응하는 [설정] 버튼을 클릭합니다.

3) 커서의 설정을 통해 산출한 결과를 중심 주파수, 밴드 폭 비율에 설정합니다.

4) 설정과 동시에 해당 설정값이 장치 내에도 쓰여집니다.

5) 깊이에 대응한 장치에서는 값을 설정한 상태에서 [설정] 버튼을 클릭하면 깊이를 설정할 수 있습니다.

주의

이때 설정된 내용이 시스템과 일치하지 않으면 모터가 심하게 진동합니다. 노치 필터를 설정한 위치에 대응하는 [클리어] 버튼을 눌러 노치 필터의 설정을 즉시 해제하십시오.

6) [노치 필터 하한 주파수]에 설정한 값 이하의 주파수 영역으로 노치 필터를 설정하려고 한 경우에는 다음과 같은 메시지가 표시됩니다.

[예]를 클릭한 경우, 설정을 강행합니다.

※본 판단은 고객님이 합니다. 고객님 장치의 안전성을 충분히 확인한 후에 판단하십시오.

[아니요]를 클릭한 경우, 설정을 중지합니다.

통상적으로는 이쪽을 선택합니다.

7) [노치 필터 하한 주파수], [노치 필터 밴드 폭 비율]은 키보드로 [수치+Enter]를 입력하여 설정할 수 있습니다.

(예 1) 커서 A를 아래 그림의 위치에 맞춰 각 중심 주파수의 [설정] 버튼을 클릭하면 아래 그림과 같이 노치 필터가 설정됩니다.

(예 2) 커서 A 및 커서 B를 오른쪽 그림의 위치에 맞춰 각 중심 주파수의 [설정] 버튼을 클릭하면 아래 그림과 같이 노치 필터가 설정됩니다.


3.11.7. 파일 열기

메인 툴 바에서 열기

1) 메인 툴 바의 [파일(F)]→[파일 열기(O)]→[주파수 응답(R)]을 클릭합니다.

2) 파일 열기 대화 상자가 표시되므로 열고자 하는 주파수 응답 데이터 파일을 선택한 후 [열기] 버튼을 클릭합니다.

주기

파일의 종류에서 선택할 수 있는 확장자는 장치에 따라 다릅니다.

※자세한 내용은 [6.1. 파일 확장자 일람]을 참조

본 화면에 주파수 응답 데이터 파일을 드롭하여 주파수 응답 데이터 파일을 열 수도 있습니다.

※대응하는 파일은 [6.2. 파일 드롭에 대해]를 참조

기능 제한에 대해

저장한 주파수 응답 데이터를 표시한 경우에는 다음과 같은 기능이 무효가 됩니다.

1. 주파수 응답 계측

2. 노치 필터의 설정

3. 측정 조건의 변경


3.11.8. 파일에 저장하기

본 창에서 표시하고 있는 주파수 응답 데이터를 파일에 저장하는 경우에는 메뉴 바에서

[다른 이름으로 저장] 버튼을 클릭합니다.


3.11.9. 인쇄

1) 표시되어 있는 주파수 응답 데이터를 인쇄하는 경우에는 메뉴 바에서

` [인쇄] 버튼을 클릭합니다.

2) 인쇄 창이 표시되므로 각 항목을 설정한 후 [인쇄] 버튼을 클릭합니다.

주기

용지 크기는 [A4, A3], 인쇄 방향은 [세로, 가로]를 지정할 수 있습니다만, 실제 출력은 [A4], [세로] 형식으로 이루어집니다.


3.11.10. 창 닫기

표시되어 있는 주파수 응답 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.

이때 다음과 같은 화면이 표시되는 경우가 있습니다.


3.11.11. 가이드 메시지

주파수 응답 측정 시에 다음과 같은 메시지가 표시됩니다. 지시에 따르십시오.

주파수 응답 데이터를 장치로부터 수신하고 있는 경우에 데이터 불러오기가 늦었을 때 표시됩니다.

사용 PC의 동작 성능(OS 및 처리 시간)에 따라서는 설정한 주파수로 측정할 수 없는 경우가 있습니다. 이 경우에는 측정 주파수를 낮추십시오.

장치 내에서 가진을 실행하고 있는 경우에 에러가 발생했을 때 표시됩니다.

가진 폭, 허용 최대 진동량 등을 변경한 후 재측정하십시오.

[시작] 버튼을 클릭했을 때, 연결된 장치와 측정 주파수가 다른 경우에 표시됩니다.

장치로부터 노치 필터의 값을 수신하는 경우에 이상이 발생했을 때 표시됩니다.

USB 통신을 할 수 있는 상태로 되어 있는지 확인하십시오.

커서가 설정되어 있지 않은 상태에서 노치 필터를 설정하려고 했을 때 표시됩니다. 커서를 설정하십시오.

노치 필터 깊이에 대응하지 않는 장치에 대해 깊이를 설정하려고 했을 때에 표시됩니다.


3.12. 상태 표시 창

알람 이력, 장치 상태, 장치 정보, 엔코더 정보, 모터 정보 등을 표시합니다.


3.12.1. 상태 표시 창의 표시

메인 툴 바의

[상태 표시] 탭→[상태 표시]를 클릭하면 본 창이 표시됩니다.


3.12.2. 상태 정보

① 상태 표시 탭을 선택하면 운전 정보가 표시됩니다.

② 항목의 현재값이 [데이터] 표시란에 표시됩니다.

③ 항목의 현재 단위가 [단위] 표시란에 표시됩니다.

④ 클리어 버튼을 클릭한 경우, 다음과 같은 확인 메시지가 표시됩니다.

[확인] 버튼을 클릭하면 대상 항목의 데이터가 클리어됩니다.

[취소] 버튼을 클릭하면 클리어를 중지하고 원래 화면으로 돌아갑니다.

⑤ 상태 그룹 선택 버튼을 클릭하면 그룹 단위로 상태를 표시할 수 있습니다.

다음 창은 [위치] 그룹을 선택했을 때의 표시 내용입니다.

⑥ [사용자 지정] 그룹을 선택하면 표시 항목의 순서를 바꾸거나 불필요한 항목을 비표시로 할 수 있습니다.

항목을 아래로 이동할 때는 이동하고자 하는 항목을 선택한 후 [ [image] ] 버튼을 클릭합니다.

항목을 위로 이동할 때는 이동하고자 하는 항목을 선택한 후 [ [image]] 버튼을 클릭합니다.

항목을 비표시로 하려면 비표시로 하고자 하는 항목을 선택한 후 [비표시] 버튼을 클릭합니다.

초기 상태로 되돌릴 때는 [초기 표시] 버튼을 클릭합니다.


3.12.3. 알람 정보

① 알람 탭을 선택하면 알람 정보가 표시됩니다.

② 각 항목의 현재값이 [Data] 표시란에 표시됩니다.

③ [일람 표시] 버튼을 클릭하면 알람 경고 일람 화면이 표시됩니다.

표시되어 있는 알람을 오른쪽 클릭하면 알람 경고 일람 화면에서 알람의 상세 내용이 표시됩니다.

④ [알람 클리어] 버튼을 클릭하면 다음과 같은 확인 메시지가 표시됩니다.

[확인] 버튼을 클릭하면 알람 정보가 클리어됩니다.

[취소] 버튼을 클릭하면 클리어를 중지하고 원래 화면으로 돌아갑니다.


3.12.4. 장치 정보 표시

① 장치 정보 탭을 선택하면 장치 정보가 표시됩니다.

② 항목의 현재값이 [Data] 표시란에 표시됩니다.

③ 항목의 현재 단위가 [단위] 표시란에 표시됩니다.


3.12.5. 엔코더 정보 표시

① 엔코더 정보 탭을 선택하면 엔코더 정보가 표시됩니다.

② 항목의 현재값이 [Data] 표시란에 표시됩니다.

③ 항목의 현재 단위가 [단위] 표시란에 표시됩니다.

주기

엔코더 정보 표시에 대응하지 않는 장치를 연결한 경우, 다음과 같은 메시지가 표시되고 엔코더 정보 탭이 비표시가 됩니다.

엔코더 정보에 대응하는 장치를 연결한 경우, 다음과 같은 메시지가 표시되고 엔코더 정보 탭이 표시됩니다.


3.12.6. 모터 정보 표시

  ① 모터 정보 탭을 선택하면 모터 정보가 표시됩니다.

  ② 항목의 현재값이 [Data] 표시란에 표시됩니다.

③ 항목의 현재 단위가 [단위] 표시란에 표시됩니다.

※모터에 따라서는 정보가 없으므로 모터 정보 탭에 항목이 표시되지 않는 경우가 있습니다.

주기

모터 정보 표시에 대응하지 않는 장치를 연결한 경우, 다음과 같은 메시지가 표시되어 모터 정보 탭이 비표시로 됩니다.

모터 정보에 대응하는 장치를 연결한 경우, 다음과 같은 메시지가 표시되어 모터 정보 탭이 표시됩니다.


3.12.7. 창 닫기

표시되어 있는 상태 표시 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.


3.13. 입출력 신호 상태 표시 창

입출력 신호 상태를 표시합니다.


3.13.1. 입출력 신호 상태 표시 창의 표시

메인 툴 바의

[상태 표시] 탭→[입출력 표시]를 클릭하면 본 창이 표시됩니다.


3.13.2. 입출력 신호 상태 표시

① 입출력 신호의 현재 상태가 표시됩니다.

② 신호가 [ON]인 상태에서 파란색으로 표시됩니다.

③ 신호 기호에 마우스 커서를 이동하면 신호명이 표시됩니다.


3.13.3. 창 닫기

표시되어 있는 상태 표시 창을 닫는 경우에는 [×] 버튼을 클릭합니다.


3.14. 리모트 운전 창

본 소프트웨어상에서 입출력 신호를 조작하여 리모트 운전을 합니다.


3.14.1. 스위치 BOX 창의 표시

메인 툴 바의

[리모트 조작] 탭→[스위치 박스]를 클릭하면 본 창이 표시됩니다.

창의 각 신호 내용은 장치의 취급 설명서를 참조하십시오.


3.14.2. 출력 신호 상태의 표시

출력 신호의 상태를 실시간으로 표시합니다.

(신호 ON 시: 초록, 빨강 / 신호 OFF 시: 배경색)


3.14.3. 입력 신호의 ON/OFF 조작

입력 신호를 ON/OFF하는 경우에는 각 버튼, 탭(속도 제어 모드 등), 목록 상자(SS1-3)를 조작합니다.

① 통상 입력 신호 버튼

SwitchBoxButton | 표시 | 일반 글꼴
 | 동작 | 클릭: ON/OFF 전환 오른쪽 클릭: ON/OFF 전환

② 모멘터리 입력 신호 버튼

SwitchBoxButton | 표시 | 기울임 글꼴
 | 동작 | 버튼 프레스 상태: ON 버튼 릴리스 상태: OFF 오른쪽 클릭: ON/OFF 전환

주의

입력 신호의 조작에 따라서는 모터가 동작하므로 충분히 안전을 확인한 후에 하십시오.


3.14.4. 창 닫기

표시되어 있는 리모트 운전 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.


3.15. 실시간 서보 조정 창

오토 튜닝 후의 레벨 조정과 속도/위치 루프 게인 및 서보 조정 파라미터를 실시간으로 변경합니다.


3.15.1. 실시간 서보 조정 창의 표시

메인 툴 바의

[조정 기능] 탭→[실시간 서보 조정]을 클릭하면 본 창이 표시됩니다.

주기

Version 2.2.0부터 본 소프트웨어에서 유지하고 있던 FB 필터 설정 방법 선택값이 장치에 유지되게 되었습니다.

본 화면 기동 시에 장치 내의 FB 필터 설정 방법 선택이 미설정인 경우, 다음과 같은 메시지가 표시됩니다.

또한 USB 연결 시에도 FB 필터 설정 방법 선택을 체크하여 미설정인 경우에는 본 메시지가 표시됩니다.


3.15.2. 조정 대상 게인의 선택

1) 조정 대상 항목을 [조정 게인 선택] 콤보 상자에서 선택합니다.

2) 선택된 조정 대상 항목과 관련된 파라미터가 관련 파라미터 표시/설정 영역에 표시됩니다.


3.15.3. 파라미터 조정

① 버튼에 의한 조정

1) 관련 파라미터 표시/설정 영역에서 각 항목의 조정 버튼 [▲], [▼]를 클릭합니다.

2) [▲]를 클릭하면 파라미터의 설정값이 증가되어 실시간으로 업데이트됩니다.

3) [▼]를 클릭하면 파라미터의 설정값이 감소되어 실시간으로 업데이트됩니다.

4) 증가량 조정 라디오 버튼으로 [▲], [▼]를 클릭했을 때의 증가/감소량을 변경할 수 있습니다.

② 키보드에 의한 조정

키보드로 직접 값을 설정합니다.

설정값은 [Enter] 키를 눌렀을 때 확정됩니다.

설정값에 잘못된 값을 입력한 경우, 메시지를 표시하고 설정값을 직전의 값으로 되돌립니다.

범위 밖의 값을 입력한 경우

수치 이외의 값을 입력한 경우

주기

게인 조정 버튼 [▲], [▼]를 계속 누르고 있는 동안에는 계속 증가 또는 감소합니다.

설정값이 확정되지 않은 상태에서는 붉은색 문자로 표시됩니다.

설정값을 확정하려면 [Enter] 키를 누릅니다.

③ 저속 게인(Step 3)과 연동

① 저속 게인(Step 3)과 연동 확인란에 체크를 넣습니다.

② Step 1(연동 원본 파라미터)을 확정하면 Step 3(연동 대상 파라미터)을 변경합니다.

Step1 | Step3
속도 루프 비례 게인 | 속도 루프 비례 게인/저속 게인
속도 루프 적분 시정수 | 속도 루프 적분 시정수/저속 게인
속도 루프 미분 시정수 | 속도 루프 미분 시정수/저속 게인
속도 루프 비례 게인 분배율 | 속도 루프 비례 게인 분배율/저속 게인
위치 루프 게인 | 위치 루프 게인/저속 게인
위치 루프 미분 시정수 | 위치 루프 미분 시정수/저속 게인


3.15.4. 이너셔의 설정

[이너셔]의 값을 변경하면 다음과 같은 확인 메시지가 표시됩니다.

[확인]을 클릭하면 현재의 이너셔 설정값을 장치 내의 파라미터에 설정합니다.

[취소]를 클릭하면 파라미터의 설정을 중지합니다.


3.15.5. 점성 마찰의 설정

[점성 마찰]의 값을 변경하면 다음과 같은 확인 메시지가 표시됩니다.

[확인]을 클릭하면 현재의 점성 마찰값을 장치 내의 파라미터에 설정합니다.

[취소]를 클릭하면 파라미터의 설정을 중지합니다.


3.15.6. FB 필터 설정

1) 본 창 표시 시, USB 연결 시 또는 [ [image] ]를 눌렀을 때 장치 내의 FB 필터 설정 방법 선택의 값을 수신하여 FB 필터 설정 방법 선택에 반영합니다.

2) [FB 필터 설정 방법 선택] 콤보 상자를 [수동]으로 설정하면 [FB 필터 차수], [FB 필터 주파수]를 수동으로 설정할 수 있게 됩니다.

3) [FB 필터 설정 방법 선택] 콤보 상자를 [수동] 이외로 설정하면 FB 필터 처리를 하고, [FB 필터 차수], [FB 필터 주파수]가 자동으로 업데이트됩니다.

또한 이 상태에서 오토 튜닝 레벨 조정을 하는 경우에도 마찬가지로 업데이트됩니다.

4) [업데이트] 버튼을 클릭하면 FB 필터 설정 방법 선택의 값을 장치에 송신합니다.


3.15.7. 조정 전의 파라미터로 되돌리기

[ [image] ]를 클릭하면 다음과 같은 확인 메시지가 표시됩니다.

[예]를 클릭하면 파라미터를 조정 전의 설정으로 되돌립니다.

[예]를 클릭하면 파라미터와 FB 필터 설정 방법 선택을 조정 전의 설정으로 되돌립니다.

[아니요]를 클릭하면 파라미터를 원래대로 되돌리는 것을 중지합니다.


3.15.8. 파라미터의 업데이트

[업데이트] 버튼을 클릭하면 다음과 같은 확인 메시지가 표시됩니다.

모든 설정값이 확정되어 있는 경우

[확인]을 클릭하면 현재의 게인 설정값을 장치 내의 파라미터에 설정합니다.

[확인]을 클릭하면 현재의 게인 설정값과 FB 필터 설정 방법 선택값을 장치에 송신합니다.

[취소]를 클릭하면 파라미터의 설정을 중지합니다.

미확정(붉은색 글씨) 설정값이 있는 경우

붉은색 글씨의 설정값을 확정(Enter 키)한 후 다시 [업데이트] 버튼을 클릭합니다.


3.15.9. 창 닫기

표시되어 있는 실시간 게인 조정 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.

화면을 닫을 때 [업데이트]가 실행되어 있지 않은 경우, 다음과 같은 메시지가 표시됩니다.

※[업데이트] 버튼을 클릭하지 않고 닫아도 장치의 RAM 영역에 기록되어 있으므로 장치의 전원을 끌 때까지 본 창 표시 시에 편집 상태가 유지됩니다.


3.16. 오토 튜닝 창

오토 튜닝을 하여 게인 파라미터를 설정합니다.


3.16.1. 창의 표시

메인 툴 바에서 [조정 기능] 탭→[오토 튜닝]을 클릭하면 본 창이 표시됩니다.

주기

Version 2.2.0부터 본 소프트웨어에서 유지하고 있던 FB 필터 설정 방법 선택값이 장치에 유지되게 되었습니다.

본 화면 기동 시에 장치 내의 FB 필터 설정 방법 선택이 미설정인 경우, 다음과 같은 메시지가 표시됩니다.

또한 USB 연결 시에도 FB 필터 설정 방법 선택을 체크하여 미설정인 경우에는 본 메시지가 표시됩니다.


3.16.2. 동작 파라미터의 수신

동작 파라미터 수신 버튼을 클릭하면 장치의 동작 파라미터를 수신하여 동작 파라미터 설정 항목에 그 값을 반영합니다.

주기

Version 2.2.0부터 본 소프트웨어에서 유지하고 있던 FB 필터 설정 방법 선택값이 장치에 유지되게 되었습니다.

동작 파라미터 수신 시에 장치 내의 FB 필터 설정 방법 선택이 미설정인 경우, 다음과 같은 메시지가 표시됩니다.

또한 USB 연결 시에도 FB 필터 설정 방법 선택을 체크하여 미설정인 경우에는 본 메시지가 표시됩니다.


3.16.3. 동작 파라미터의 설정

튜닝 게인, 동작 방향, 운전 비율, 최대 토크, 이너셔 배율을 설정합니다.


3.16.4. FB 필터의 설정

FB 필터 설정 방법 선택이 [수동]인 경우, FB 필터 차수, FB 필터 주파수에 설정한 값으로 FB 필터 처리를 합니다.

FB 필터 설정 방법 선택이 [수동] 이외의 경우, 자동으로 FB 필터 처리를 합니다.


3.16.5. 오토 튜닝의 시작

시작 버튼을 클릭하면 동작 파라미터에 설정한 파라미터로 오토 튜닝을 시작합니다.

오토 튜닝의 결과는 스테이터스에 표시됩니다.


3.16.6. 상세 표시

창 오른쪽 위에 있는 [image] 를 클릭하면 모터 동작 예상값과 오토 튜닝 결과를 표시합니다.

VPH-HB 장치ㆍVPH-HD 장치ㆍVPH-HE 장치의 경우, deg 단위 또는 mm 단위의 모터 동작 예상값이 추가 표시됩니다.

VPH 장치와 통신할 수 없는 경우, 모터 동작 예상값은 ‘---’가 됩니다.

VPH-HA 장치ㆍVPH-HC 장치

VPH-HB 장치ㆍVPH-HD 장치ㆍVPH-HE 장치


3.16.7. 창 닫기

표시되어 있는 위치 결정 오토 튜닝 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.

오토 튜닝 실행 후의 경우, 다음과 같은 메시지를 표시합니다.


3.17. 테스트 운전 창

테스트 운전을 합니다.


3.17.1. 테스트 운전 창의 표시

메인 툴 바에서 [조정 기능] 탭→[테스트 운전]을 선택하면 본 창이 표시됩니다.


3.17.2. 동작의 설정

항목명 | 설정 범위 | 설명
시작 위치 지정 | 무효, ABS, INC | 동작 시작 위치의 방법을 선택할 수 있습니다.
HCP 제한 | HCP 제한, 제한 없음 | [시작 위치 지정]이 ‘ABS’인 경우에만 표시됩니다. ‘HCP 제한’의 경우, 원점 복귀가 완료되지 않은 상태에서는 테스트 운전을 실행할 수 없습니다. ‘제한 없음’의 경우, 원점 복귀가 완료되지 않은 상태에서도 테스트 운전을 실행합니다.
동작 시작 위치 | -2147483648~2147483647 [P161] | 모터의 동작 시작 위치를 지정합니다. 단위와 소수점 위치는 P161의 설정값에 따릅니다.
시작 위치 이동 속도 | 0~300000000[P161/sec] | 동작 시작 위치까지의 모터 이동 속도를 설정합니다. 단위와 소수점 위치는 P161의 설정값에 따릅니다.
동작 방향 | + 방향, － 방향, 왕복 | 모터의 동작 방향을 선택할 수 있습니다.
이동량 | -2147483648~2147483647 [P161] | 모터의 이동량을 설정합니다. 단위와 소수점 위치는 P161의 설정값에 따릅니다.
속도 | 0~300000000[P161/sec] | 모터의 동작 속도를 설정합니다. 단위와 소수점 위치는 P161의 설정값에 따릅니다.
정지 시간 | 0.000~999.999[s] | 위치 결정 완료 후부터 다음 위치 결정 시작까지의 정지 시간을 설정합니다.
SEL 선택 | SEL.0, SEL.1, SEL.2, SEL.3, SEL.4, SEL.5, SEL.6, SEL.7 | 선택한 SEL의 가감속 시간으로 모터가 동작합니다.
가속 시간 | -9.9~99999.9[ms] | 선택한 SEL의 모터 가속 시간을 설정합니다.
감속 시간 | -9.9~99999.9[ms] | 선택한 SEL의 모터 감속 시간을 설정합니다.
S자 시간 1 | -9.9~1000.0[ms] | 선택한 SEL의 모터 S자 시간 1을 설정합니다. 확인란에 체크를 넣으면 펄스열 지령의 S자 시간 1에 동일한 값을 설정합니다.
S자 시간 2 | -9.9~1000.0[ms] | 모터 가감속 시간 및 S자 시간 1에 다시 S자 시간 2를 설정합니다.

주기

S자 시간 1의 동시 설정 확인란이 OFF인 상태에서 테스트 운전을 실행하고 있었을 경우, SEL 선택을 변경하면 다음과 같은 메시지가 표시됩니다.

‘예’ 버튼을 클릭하면 S자 시간 1의 값을 장치에 설정합니다.

‘아니요’ 버튼을 클릭하면 SEL 선택을 변경합니다.

[시작 위치 지정]이 ‘ABS’, [HCP 제한]이 ‘HCP 제한’이고, 원점 복귀가 완료되지 않은 상태에서 테스트 운전을 실행하면 다음과 같은 메시지가 표시됩니다.


3.17.3. 정지 설정

항목명 | ON/OFF | 설명
USB 통신 끊김 시 모터 정지 | ON | 테스트 운전 동작 중에 USB 통신을 끊은 경우에도 테스트 운전 동작을 계속합니다.
 | OFF | 테스트 운전 동작 중에 USB 통신을 끊은 경우, 테스트 운전 동작을 정지합니다.
사이클 정지 | ON | 동작 시작 위치로 돌아가 테스트 운전 동작을 종료합니다.
 | OFF | 현재 위치에서 테스트 운전 동작을 종료합니다.


3.17.4. 테스트 운전의 시작/정지

주의

본 기능을 실행하면 모터가 동작하므로 충분히 안전을 확인한 후에 하십시오.

1) [시작] 버튼을 클릭하면 다음과 같은 메시지를 표시합니다.

2) 동작 중에는 일정 간격으로 스테이터스를 업데이트합니다.

동작 중의 상태는 스테이터스에 표시됩니다.

스테이터스 | 상태
RUNNING[실행 횟수] | 실행 중
CYCLE STOP RUNNING[실행 횟수] | 사이클 정지 실행 중
STOP[실행 횟수] | 도중 정지
ALARM STOP[실행 횟수] 알람명 | 알람 정지 알람의 명칭
WARNING STOP[실행 횟수] | 경고 정지
FORCED STOP[실행 횟수] | 강제 정지
USB CLOSE | 장치와 USB 통신을 할 수 없다

3) 운전을 정지하는 경우

① [사이클 정지] 버튼을 클릭한 경우, 테스트 운전을 사이클 정지로 정지합니다. ([정지 설정]의 [사이클 정지]가 ON인 경우에만)

② [감속 정지] 버튼을 클릭한 경우, 테스트 운전을 감속 정지로 정지합니다.

③ [급정지] 버튼을 클릭한 경우, 테스트 운전을 급정지로 정지합니다.

④ [Esc] 키를 누른 경우, 테스트 운전을 급정지로 정지합니다.


3.17.5. 동작 상태의 표시

창 오른쪽 위에 있는 [image] 를 클릭하면 동작 상태를 표시합니다.

를 클릭하면 동작 상태를 비표시로 할 수 있습니다.

동작 상태의 표시 내용은 다음과 같습니다.

항목명 | 설명
현재 위치 | 모터의 현재 위치(C021)를 표시합니다.
위치 결정 목표 위치 1 | 다음 위치 결정 목표 위치를 표시합니다.
위치 결정 목표 위치 2 | 위치 결정 목표 위치 1의 다음 위치 결정 목표 위치를 표시합니다.
속도 | 모터의 실동작 속도(C001)를 표시합니다.

동작 방향은 모터의 동작 방향에 맞춰 노란색 화살표가 표시됩니다.

상태 | τDISC |  |  | τ 리니어
 | 왕복 | ＋ 방향 | － 방향 | 왕복 | ＋ 방향 | － 방향
미실행 |  |  |  |
정지 중 |  |  |  |  |  |
＋ 방향 동작 중 |  |  |  |  |  |
－ 방향 동작 중 |  |  |  |  |  |

주기

모터 동작 중, 정지 중의 판단은 SZ 신호로 판단합니다.

모터 동작 중임에도 불구하고 노란색 화살표가 표시되지 않는 경우, SZ 신호 속도 범위(P651)를 모터 동작 속도 미만으로 설정하십시오.

동작 방향의 표시는 다음 설정에서 역방향으로 할 수 있습니다.

항목명 | 설명
일반 설정 | 모터의 동작 방향을 표시합니다.
특수 설정 | 모터의 동작 방향을 반전 표시합니다.


3.17.6. VPH 장치에 의한 추가 표시

VPH-HB 장치ㆍVPH-HD 장치ㆍVPH-HE 장치의 경우, 단위가 ‘deg’ 또는 ‘mm’로 환산된 항목이 추가 표시됩니다.

추가 표시 부분에 대해 VPH 장치와 통신할 수 없는 경우, 동작 파라미터 설정은 공백이 되고, 동작 상태는 ‘0.00’이 됩니다.

환산되어 추가 표시되는 항목은 다음과 같습니다.

동작 파라미터 설정 | 동작 표시
동작 시작 위치 | 현재 위치
시작 위치 이동 속도 | 위치 결정 목표 위치 1
이동량 | 위치 결정 목표 위치 2
속도 | 속도


3.17.7. 창 닫기

표시되어 있는 위치 결정 테스트 운전 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.

테스트 운전 실행 후인 경우, 다음과 같은 메시지를 표시합니다.

주기

S자 시간 1의 동시 설정 확인란이 OFF인 상태에서 테스트 운전을 실행하고 있었을 경우, 다음과 같은 메시지가 표시됩니다.

‘예’ 버튼을 클릭하면 S자 시간 1의 값을 장치에 설정합니다.

‘아니요’ 버튼을 클릭하면 그대로 화면을 종료합니다.


3.18. 자기 진단 창

PC 상에서 장치의 자기 진단을 실행합니다.

주의

자기 진단의 항목 내용에 따라 서보 동작을 수반하므로 충분히 안전을 확인한 후에 하십시오.


3.18.1. 창의 표시

메인 툴 바에서

[조정 기능] 탭→[자기 진단]을 클릭하면 본 창이 표시됩니다.


3.18.2. 자기 진단 항목의 선택

[진단 항목 선택(DG No.)] 콤보 상자에서 자기 진단 항목을 선택합니다.


3.18.3. 자기 진단의 시작/종료

① 자기 진단을 시작하는 경우에는 [진단 시작] 버튼을 클릭합니다.
진단을 시작하면 [진단 시작] 버튼이 [진단 종료] 버튼으로 바뀝니다.

② 자기 진단을 종료하는 경우에는 [진단 종료] 버튼을 클릭합니다.
진단을 종료하면 [진단 종료] 버튼이 [진단 시작] 버튼으로 바뀝니다.


3.18.4. 진단 결과의 표시

자기 진단 중/진단 종료 시의 진단 결과는 [진단 내용의 설정/표시] 상자 내에 표시됩니다.


3.18.5. 창 닫기

표시되어 있는 자기 진단 창을 닫는 경우에는 [×] 버튼을 클릭합니다.

자기 진단 실행 후인 경우, 다음과 같은 메시지가 표시됩니다.


3.19. 장치 모니터 창

장치 내의 장치 내용을 모니터링합니다.


3.19.1. 창의 표시

메인 툴 바에서

[상태 표시] 탭→[장치 모니터]를 클릭하면 본 창이 표시됩니다.

창의 개요

① [Bit] 항목: Bit 단위(0/1)의 읽기/쓰기를 할 수 있습니다.

② [Word] 항목: Word 단위(-32768~32767)의 읽기/쓰기를 할 수 있습니다.

③ [Long] 항목: Long 단위(-2147483648~2147483647)의 읽기/쓰기를 할 수 있습니다.

④ [IX Device], [R Device], [D Device], [X Device]의 경우는 해당하는 프레임 내에서 직접 데이터를 조작할 수 있습니다.

⑤ 기타 장치(X/R/D/IX)의 경우는 [Device], [Word]/[Long] 프레임 내에서 장치의 종류를 지정하여 데이터를 조작할 수 있습니다.

⑥ [R] 버튼으로 장치의 데이터 읽기를 할 수 있습니다.

⑦ [W] 버튼으로 장치에 데이터 쓰기를 할 수 있습니다.


3.19.2. 데이터 읽기

1) 각 프레임 내의 장치 번호 입력 영역(①)에 장치 번호를 입력합니다.

장치 번호는 [▲], [▼] 버튼(②)을 클릭해도 증감합니다.

증감량은 증가량 조정 콤보 상자(③)에서 지정할 수 있습니다.

2) [R] 버튼(④)을 클릭합니다.

3) 읽은 데이터는 각 프레임 내의 데이터 영역(⑤)에 표시됩니다.

부동 소수 위치 표시 영역(⑥)은 읽은 32bit 데이터를 플로트 표시합니다.

4) 읽었을 때의 처리 결과는 상태 표시 상자(⑦)에 표시합니다.

(정상 종료 시: OK/이상 종료 시: NG가 표시됩니다.)


3.19.3. 데이터의 쓰기 조작

1) 각 프레임 내의 장치 번호 입력 영역(①)에 장치 번호를 입력합니다.

장치 번호는 [▲], [▼] 버튼(②)을 클릭해도 증감합니다.

증감량은 증가량 조정 콤보 상자(③)에서 지정할 수 있습니다.

2) 데이터 영역(④)에 쓸 값을 입력합니다.

3) [W] 버튼(⑤)을 클릭합니다.

4) 썼을 때의 처리 결과는 상태 표시 상자(⑥)에 표시합니다.

정상 종료 시: OK/이상 종료 시: NG가 표시됩니다.)


3.19.4. 실시간 업데이트

1) [실시간 업데이트] 확인란을 ON으로 합니다.

2) [R], [W] 버튼이 무효가 됩니다.

3) 지정된 장치 번호의 데이터를 데이터 영역에 표시하여 실시간으로 업데이트됩니다.


3.19.5. 창 닫기

표시되어 있는 자기 진단 창을 닫는 경우에는 [닫기] 버튼을 클릭하거나 또는 [×] 버튼을 클릭합니다.


3.20. 버전 창

본 소프트웨어의 버전 정보가 표시됩니다.

메뉴 바에서

[도움말(H)]→[버전 정보(V)]를 클릭합니다.


4. 통신 에러

4.1. 에러 내용

USB 통신을 실행하고 있을 때 다음과 같은 메시지가 표시된 경우 메시지에 표시된 내용을 확인하십시오.


5. 데이터 임포트

5.1. 데이터 임포트에 대해

본 기능은 장치 모터 정보를 임포트하여 새로 추가된 장치 및 모터를 소프트웨어의 버전 업 없이 사용할 수 있도록 하는 기능입니다.

주기

데이터 임포트 기능은 VPH Data Editing Software Version 1.0.0부터 지원합니다.


5.2. 데이터 임포트 방법

1) 장치ㆍ모터 선택 창의 [데이터 임포트] 버튼을 클릭합니다.

2) 소프트웨어를 재기동한다는 메시지가 표시되므로 [확인]을 클릭합니다.

3) UAC(사용자 계정 컨트롤)의 확인 메시지가 표시되면 [예]를 클릭하십시오.

4) 재기동된 장치ㆍ모터 선택 창의 [데이터 임포트] 버튼을 클릭합니다.

5) 파일 열기 대화 상자가 표시되므로 임포트 파일을 선택한 후 [열기] 버튼을 클릭합니다.

6) 임포트 처리 중에는 진척 상황을 나타내는 바가 표시됩니다.

7) 다음과 같은 메시지가 표시되어 데이터 임포트가 완료됩니다.

주기

데이터 임포트가 정상적으로 종료되지 않은 경우, 다음과 같은 메시지가 표시됩니다.


6. 부록

6.1. 파일 확장자 일람

본 소프트웨어에서 사용하는 파일 확장자는 다음과 같습니다.

명칭 | 장치 종류 | 모터 종류 | 확장자 | 열기 | 저장
파라미터 | VPH-HA | τDISC | *.c0pa0 | ○ | ○
 | VPH-HA | τ 리니어 | *.c0pa1 | ○ | ○
 | VPH-HB | τDISC | *.c1pa0 | ○ | ○
 | VPH-HB | τ 리니어 | *.c1pa1 | ○ | ○
 | VPH-HC | τDISC | *.c2pa0 | ○ | ○
 | VPH-HC | τ 리니어 | *.c2pa1 | ○ | ○
 | VPH-HD | τDISC | *.c3pa0 | ○ | ○
 | VPH-HD | τ 리니어 | *.c3pa1 | ○ | ○
 | VPH-HE | τDISC | *.c4pa0 | ○ | ○
 | VPH-HE | τ 리니어 | *.c4pa1 | ○ | ○
 | ALL | ALL | *.csv | × | ○
프로그램 데이터 | VPH-HA | ALL | *.c0pro | ○ | ○
 | VPH-HB | ALL | *.c1pro | ○ | ○
 | VPH-HC | ALL | *.c2pro | ○ | ○
 | VPH-HD | ALL | *.c3pro | ○ | ○
 | VPH-HE | ALL | *.c4pro | ○ | ○
간접 데이터 | VPH-HA | ALL | *.c0ind | ○ | ○
 | VPH-HB | ALL | *.c1ind | ○ | ○
 | VPH-HC | ALL | *.c2ind | ○ | ○
 | VPH-HD | ALL | *.c3ind | ○ | ○
 | VPH-HE | ALL | *.c4ind | ○ | ○
오실로 데이터 | ALL | ALL | *.cxosc | ○ | ○
 | ALL | ALL | *.cxlog | ○ | ○
 | ALL | ALL | *.csv | × | ○
주파수 스펙트럼 데이터 | ALL | ALL | *.cxfrs | ○ | ○
주파수 응답 데이터 | ALL | ALL | *.cxfrr | ○ | ○
일괄 데이터 | VPH-HA | ALL | *.c0adb | ○ | ○
 | VPH-HB | ALL | *.c1adb | ○ | ○
 | VPH-HC | ALL | *.c2adb | ○ | ○
 | VPH-HD | ALL | *.c3adb | ○ | ○
 | VPH-HE | ALL | *.c4adb | ○ | ○

※ALL은 모든 종류에 대응


6.2. 파일 드롭에 대해

본 소프트웨어의 대응하는 창에 파일을 드롭하여 드롭한 파일을 엽니다.


6.2.1. 대응 창, 파일 일람

 |  | 대상 창
 |  | 장치 | 메인 | 파라 | 프로 | 간접 | 오실로 | 스펙 | 주응
드롭 파일 | 파라미터(*.c*pa**) | ○ | ○ | ○ | × | × | × | × | ×
 | 파라미터(*.csv) | × | × | × | × | × | × | × | ×
 | 프로그램(*.c*pro*) | ○ | ○ | × | ○ | × | × | × | ×
 | 간접 데이터(*.c*ind*) | ○ | ○ | × | × | ○ | × | × | ×
 | 오실로 데이터(*.cxosc*, *.cxlog) | ○ | ○ | × | × | × | ○ | × | ×
 | 오실로 데이터(*.csv) | × | × | × | × | × | × | × | ×
 | 주파수 스펙트럼 데이터(*.cxfrs*) | ○ | ○ | × | × | × | × | ○ | ×
 | 주파수 응답 데이터(*.cxfrr*) | ○ | ○ | × | × | × | × | × | ○
 | 주파수 응답 데이터(*.csv) | × | × | × | × | × | × | × | ×
 | 일괄 데이터(*.c*adb*) | × | × | × | × | × | × | × | ×

※창의 약칭: 정식 명칭

장치: 장치 모터 선택 창, 메인: 메인 툴 바 창, 파라: 파라미터 편집 창, 프로: 프로그램 편집 창

간접: 간접 데이터 편집 창, 오실로: 오실로스코프 창, 스펙: 주파수 스펙트럼 창, 주응: 주파수 응답 측정 창


6.2.2. 드롭 비대응 창

아래의 창은 드롭에 의한 파일 열기에 대응하지 않습니다.

창 명칭

상태 표시 창

입출력 신호 상태 표시 창

장치 모니터 창

자기 진단 창

오토 튜닝 창

실시간 서보 조정 창

테스트 운전 창

스위치 BOX 창

버전 표시 창

데이터 비교 창

인쇄 창


6.3. csv 파일의 데이터 구조

csv 파일에 데이터를 저장한 경우의 데이터 구조를 나타냅니다.

주의

csv 파일 형식으로 저장한 파일은 본 소프트웨어로 열 수 없습니다.

파라미터 데이터 csv 파일 구조

NAME | 파일 이름 |  |  |  |  |  |  |
DEF | 파라미터 번호 | 장치 번호 | 파라미터 명칭 | 단위 | 설정 범위 | 설정값 | 초기값 | 표시 상태

오실로 데이터 csv 파일 구조

NAME | 파일 이름 |  |  |  |
DEF | 15 |  |  | 채널 설정 |
DEF | 0 | CH1 표시 최댓값 | CH1 표시 오프셋량 |  | CH1: CH1의 명칭
DEF | 1 | CH2 표시 최댓값 | CH2 표시 오프셋량 |  | CH2: CH2의 명칭
DEF | 2 | CH3 표시 최댓값 | CH3 표시 오프셋량 |  | CH3: CH3의 명칭
DEF | 205 |  | CH4 표시 오프셋량 |  | CH4: CH4의 명칭
DEF | 데이터 분해능[msec] |  |  | 데이터 분해능 |
DEF | 290 |  | 2 |  | 2
DEF | 291 |  | 1 |  | 0
DEF | 292 |  | 3 |  | 0
DEF | 293 |  | 0 |  | 0
DEF | 294 |  | 7 |  | 6
DAT | 데이터 취득 시간[sec] | CH1 데이터 | CH2 데이터 | CH3 데이터 | CH4 데이터

주기

CH* 표시 오프셋량은 측정 항목에 신호가 설정되어 있는 CH만 출력됩니다.

속도계의 데이터는 표시된 단위계의 데이터를 출력합니다.

신호 데이터는 0이면 OFF, 1이면 ON입니다.

주파수 응답 데이터 csv 파일 구조

NAME | 파일 이름 |  |
 | 【측정 조건】 | 설정값 | 단위
DEF | 측정 게인 번호 | 0 |
DEF | 측정 주파수 | 4000 | [Hz]
DEF | 가진 폭(속도 지령량) | 1 | [%]
DEF | 가진 폭(오프셋량) | 0 | [%]
DEF | 가진 시간 | 3000 | [msec]
DEF | 허용 최대 편차량 | 0 | [pulse]
DEF | 계측 횟수 | 3 | 【회】
 | 【노치 필터】 | 설정값 | 단위
DEF | 중심 주파수 1 | 0 | [Hz]
DEF | 밴드 폭 비율 1 | 0 | [%]
DEF | 깊이 1 | 0 | [-dB]
DEF | 중심 주파수 2 | 0 | [Hz]
DEF | 밴드 폭 비율 2 | 0 | [%]
DEF | 깊이 2 | 0 | [-dB]
DEF | 중심 주파수 3 | 0 | [Hz]
DEF | 밴드 폭 비율 3 | 0 | [%]
DEF | 깊이 3 | 0 | [-dB]
DEF | 중심 주파수 4 | 0 | [Hz]
DEF | 밴드 폭 비율 4 | 0 | [%]
DEF | 깊이 4 | 0 | [-dB]
DEF | 중심 주파수 | 0 | [Hz]
DEF | 밴드 폭 비율 | 0 | [%]
DEF | 깊이 | 0 | [-dB]
 | 【주파수 응답】 |  |
 | 주파수[Hz] | 진폭[dB] | 위상[deg]
DAT | 0.244110826 | -0.3161 | 0
DAT | 0.488221653 | -0.3032 | -0.2199
DAT | 0.732332479 | -0.2988 | -0.1022
DAT | ～ | ～ | ～
DAT | 3999.511778 | -11.7789 | 17.4333
DAT | 3999.755889 | -11.8517 | -153.2895
DAT | 4000 | -13.3143 | 22.0282